Jump to content
Funtoo Linux
  • 0
drobbins

Python 3.4

Question

Hi everyone,

 

Python-3.4 was recently unmasked and this has resulted in it being installed on Funtoo Linux systems. It is currently part of stage3's.

 

There is nothing wrong with Python 3.4 -- but we are going to mask 3.4. The reason is because right now, we have 3 versions of python on a stage3 -- 2.7, 3.3 and 3.4. And I don't feel it's the right time to "switch" to 3.4. 3.4 is fine to use, and if you want to continue to use it, you should unmask it locally and set PYTHON_ABIS in /etc/make.conf to something like "2.7 3.3 3.4" (containing the versions of python that you want Portage to build modules for.)

 

We are going to be sticking with 2.7 and 3.3 for a while, our official versions of python, and will officially switch to 3.4+ at some point in the future. At this time, we'll update our official PYTHON_ABIS setting in our profile, which tells Portage what versions of python it should build python modules for, and deprecate 3.3, which will not be installed by default.

 

Just letting you know so you're aware of upoming changes to your Funtoo systems.

 

This work is being tracked in this bug:

 

http://bugs.funtoo.org/browse/FL-1274

 

Best Regards,

Daniel

 

 

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

I'm using Python 3.4 by now, and it works fine. I had no problems about compatibility, but I had to use some env configurations per package (PYTHON_SINGLE_ABI). But are a few. 

Share this post


Link to post
Share on other sites
  • 0

I compiled globally all Python-based packages which includes all based in Python 3. Work fine with 3.4. So i think mask is not needed anymore. BTW, it's almost one year that's masked.
The same i think about PHP 5.6.

Share this post


Link to post
Share on other sites
  • 0
I want to commend the speed in providing information from developers !!!!!

You're Great !!!! (maybe for this reason that with Gentoo I have trouble ..... My Funtoo has all I desire from the OS .... Gentoo not animore.

 

Great drobbins , oleg and alll developers. thank You for Your Works !!!!!!

Share this post


Link to post
Share on other sites
  • 0

So, which python 3.4 version does funtoo support/recommend unmasking?

I have a choise of:

dev-lang/python-3.4.0-r1000

dev-lang/python-3.4.1-r1000

dev-lang/python-3.4.2-r1000

dev-lang/python-3.4.3-r1000

dev-lang/python-3.4.4_pre20150621

dev-lang/python-3.4.4_pre20150628

dev-lang/python-3.4.4_pre20150705

dev-lang/python-3.4.4_pre20150712

 

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

One question about Python 3.4.

Do we need to have  this entry : "PYTHON_SINGLE_TARGET="python3_4"  in make.conf

I remember that was recommended earlier, after some upgrades.

Whit that in make.conf some packages , just a few, won't compile.

But if compillig-person does comment out this, then everything compile nicely,

but again, after  few updates,  a few packages appears which won't compile,

if that is actually a reason, I'm not sure.

 

So is that safely to remove "Python single target"  entry from make.conf ?

 

sorry for my english

 

Thanks

Share this post


Link to post
Share on other sites
  • 0

I've:

sandro@ci74771ht ~ $ eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.4 *

You can make:

# eselect python set python3.4
# python-updater

Then you can remove PYTHON variables in /etc/make.conf.

 

But this depends from your configuration .... if you have necessity of other versions of python different from the default (2.7 & 3.4), in this case you must continue to use your configuration that implements for example also python3.3.

 

[ot]

Remember also

# perl-cleaner --modules
# revdep-rebuild

[/ot]

Hello :)

Share this post


Link to post
Share on other sites
  • 0

Thanks for answering,

 

I'll try to keep "PYTHON_SINGLE_TARGET="python3_4"  in make.conf.

 

Commands you suggested didn't  get anything to rebuild or reinstall, system is up-to date.

So, I'll wait for further updates.

Currently,  xfce4-notifyd-0.3.0 fails to compile, that was part of recent regular updates,

and in log file I  found this:

"No rule to make target 'themes/gtk-3.0/Default/gtk.css', needed by 'all-am'.  Stop."

 

But before that , for some time , "Python Single_target 3_4" option in make.conf

was commented out, so almost whole system was built that way.

 If anything else, I'll reinstall system, :)

Share this post


Link to post
Share on other sites

×