Jump to content
funtoo forums


  • Content count

  • Joined

  • Last visited

  • Days Won


cardinal last won the day on December 8 2017

cardinal had the most liked content!


About cardinal

  • Rank
    Advanced Member

Recent Profile Visitors

471 profile views
  1. Unresolved bug report: https://bugs.funtoo.org/browse/FL-4954 This comment claims it was built successfully with sys-devel/clang-6.0.0:6::llvm-kit
  2. This file has the correct sha512sum for open-iscsi-2.0.872.tar.gz in the genkernel Manifest cd /var/cache/portage/distfiles wget http://ftp.osuosl.org/pub/funtoo/distfiles/genkernel/open-iscsi-2.0-872.tar.gz emerge -1av genkernel
  3. Sync: ego sync Update portage: funtoo /home/rj # emerge -1av portage These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] sys-apps/portage-2.3.25_beta2::core-kit USE="(ipc) native-extensions xattr -build -doc -epydoc (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_6 -pypy -python3_4 -python3_5" 0 KiB Total: 1 package (1 reinstall), Size of downloads: 0 KiB Would you like to merge these packages? [Yes/No] Update world: emerge -avuDN @world Reference: https://bugs.funtoo.org/browse/FL-4956?focusedCommentId=35149&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-35149
  4. python-kit/3.4-prime not found

    @samyg llvm-kit config file is not present in /var/git/meta-repo/repos.conf [root@funtoo:/home/rj]# cat > /var/git/meta-repo/repos.conf/llvm-kit << "EOF" [llvm-kit] location = /var/git/meta-repo/kits/llvm-kit auto-sync = no priority = 1 EOF [root@funtoo:/home/rj]# chown portage:portage /var/git/meta-repo/repos.conf/llvm-kit Reference: https://bugs.funtoo.org/browse/FL-4940?focusedCommentId=35127&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-35127
  5. [Solved]"boot-update" Error

    Open /etc/boot.conf as root user in a text editor. Change: "memtest86+" { type linux16 kernel /memtest86.bin } To: #"memtest86+" { # type linux16 # kernel /memtest86.bin #} Type this command as root user and hit Enter on keyboard: boot-update
  6. "net-dns/avahi" has unmet requirements.

    If python use is enabled you must have dbus use enabled. Emerge has detected dbus use flag disabled for avahi. Enable the avahi dbus use flag. Python 2.7 is on default python-kit/3.4-prime and python-kit/3.6-prime
  7. [Solved]New Install sys-boot/os-prober 404

    Use sudo or user root: cd /var/cache/portage/distfiles wget http://www6.frugalware.org/mirrors/linux/frugalware/frugalware-current/source/base/os-prober/os-prober_1.74.tar.xz emerge -av os-prober
  8. [Solved]New Install sys-boot/os-prober 404

    Couldn't download 'os-prober_1.74.tar.xz'

    Yes, my fault ego stopped working because I didn't review the https://www.funtoo.org/News:Python_Updater_Deprecation /Changing the Python Active Version. I failed to set the python interpreter from python-3.4 to python-3.6 funtoo /home/rj # eselect python list Available Python interpreters, in order of preference: [1] python3.4 [2] python3.6 (fallback) [3] python2.7 (fallback) funtoo /home/rj # eselect python set 2 funtoo /home/rj # eselect python list Available Python interpreters, in order of preference: [1] python3.6 [2] python3.4 [3] python2.7 (fallback) All functions of ego now work as expected. Thanks for your help Oleg.

    python-kit/3.6-prime breaks ego {query,doc,kit} rj@funtoo ~ $ emerge -pv qutebrowser These are the packages that would be merged, in order: Calculating dependencies... done! !!! The ebuild selected to satisfy ">=dev-python/PyQt5-5.7.1[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-),declarative,gui,network,opengl,printsupport,sql,webengine,widgets]" has unmet requirements. - dev-python/PyQt5-5.8.2::python-kit USE="dbus opengl svg -bluetooth -debug -declarative -designer -doc -examples -gles2 -gui -help -location -multimedia -network -positioning -printsupport -sensors -serialport -sql -testlib -webchannel -webengine -webkit -websockets -widgets -x11extras -xmlpatterns" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5" The following REQUIRED_USE flag constraints are unsatisfied: webengine? ( widgets? ( webchannel ) ) The above constraints are a subset of the following complete expression: any-of ( python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 ) bluetooth? ( gui ) declarative? ( gui network ) designer? ( widgets ) help? ( gui widgets ) location? ( positioning ) multimedia? ( gui network ) opengl? ( gui widgets ) positioning? ( gui ) printsupport? ( gui widgets ) sensors? ( gui ) serialport? ( gui ) sql? ( widgets ) svg? ( gui widgets ) testlib? ( gui widgets ) webchannel? ( network ) webengine? ( network widgets? ( webchannel ) ) webkit? ( gui network printsupport widgets ) websockets? ( network ) widgets? ( gui ) xmlpatterns? ( network ) (dependency required by "www-client/qutebrowser-1.2.0::net-kit" [ebuild]) (dependency required by "qutebrowser" [argument])
  11. unable to install unbound, unmet libsodium dependency

    File a bug report at bugs.funtoo.org
  12. unable to install unbound, unmet libsodium dependency

    Disable dnscrypt use flag for net-dns/unbound then libsodium is not required.
  13. External commands disallowed while sourcing ebuild

    Fixed and Closed https://bugs.funtoo.org/browse/FL-4831
  14. LightDM will not start XFCE

    epro show Do you have mix-ins: xfce If not # epro mix-in +xfce Verify its set: # epro show # emerge -avuDN @world Emerge xsm: emerge -av xsm Check /var/log/lightdm/lightdm.log for more hints if login still fails.
  15. LightDM will not start XFCE

    Look for significant errors in ~/.xsession of the account your trying to log into.