Jump to content
funtoo forums

cardinal

Members
  • Content Count

    336
  • Joined

  • Last visited

  • Days Won

    48

Everything posted by cardinal

  1. I can't install php-5.6.38 due to the icu problem , it should be removed from core-server-kit It's not possible on my system to install 2 versions of icu at the same time to satisfy this older version of php. If you have an older version of php installed that's trying to upgrade/downgrade to php-5.6.38 then you will have to remove it. Portage would install dev-lang/php-7.2.12 on my updated 1.3-release php free system without any conflicts: rj@funtoo ~ $ sudo emerge -pv php These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] dev-libs/oniguruma-6.9.0:0/5::dev-kit USE="-crnl-as-line-terminator -static-libs" 0 KiB [ebuild N ] dev-libs/libsodium-1.0.16-r2:0/23::dev-kit USE="asm urandom -minimal -static-libs" CPU_FLAGS_X86="-aes -sse4_1" 0 KiB [ebuild N ] dev-libs/libzip-1.3.0:0/5::dev-kit USE="bzip2 -static-libs" 0 KiB [ebuild N ] app-text/tidy-html5-5.6.0::text-kit 0 KiB [ebuild N ] app-eselect/eselect-php-0.9.5::core-kit USE="fpm -apache2" 0 KiB [ebuild N ] app-text/aspell-0.60.7_rc1::text-kit USE="nls unicode" L10N="en -af -be -bg -br -ca -cs -cy -da -de -de-1901 -el -eo -es -et -fi -fo -fr -ga -gl -he -hr -hu -hy -is -it -la -lt -nl -no -pl -pt -pt-BR -ro -ru -sk -sl -sr -sv -uk -vi" 0 KiB [ebuild N ] app-dicts/aspell-en-2017.01.22.0::text-kit 0 KiB [ebuild N ] dev-lang/php-7.2.12:7.2::core-server-kit USE="acl argon2 berkdb bzip2 cgi cli ctype curl exif fileinfo filter fpm gd gdbm hash iconv intl ipv6 json mysql mysqli nls opcache pcntl pdo phar posix readline session simplexml sockets sodium spell sqlite ssl tidy tokenizer truetype unicode webp xml xmlreader xmlrpc xmlwriter xslt zip zip-encryption zlib -apache2 -bcmath -calendar -cdb -cjk -coverage -debug -embed -enchant -firebird -flatfile -ftp -gmp -imap -inifile -iodbc -kerberos -ldap -ldap-sasl -libedit -libressl -lmdb -mhash -mssql -oci8-instant-client -odbc -phpdbg -postgres -qdbm -recode (-selinux) -session-mm -sharedmem -snmp -soap -systemd -sysvipc -test -threads -tokyocabinet -wddx -xpm" 5,010 KiB Total: 8 packages (8 new), Size of downloads: 5,010 KiB
  2. Each kit is a git repo that is set to the active branch that has it's release name. # ego kit funtoo /home/rj # ego kit /var/git/meta-repo (updated 17 hours 23 minutes ago): kit active branch default stability core-kit 1.3-release (same) prime core-hw-kit 1.3-release (same) prime core-ui-kit 1.3-release (same) prime core-server-kit 1.3-release (same) prime core-gl-kit 1.3-release (same) prime security-kit 1.3-release (same) prime xorg-kit 1.20-release (same) prime gnome-kit 3.30-prime (same) prime rust-kit 1.32-prime (same) prime xfce-kit 4.13-release (same) prime kde-kit 1.3-release (same) prime desktop-kit 1.3-release (same) prime media-kit 1.3-release (same) prime editors-kit 1.3-release (same) prime net-kit 1.3-release (same) prime text-kit 1.3-release (same) prime science-kit 1.3-release (same) prime games-kit 1.3-release (same) prime perl-kit 5.28-release (same) prime java-kit 1.3-release (same) prime ruby-kit 1.3-release (same) prime haskell-kit 1.3-release (same) prime ml-lang-kit 1.3-release (same) prime lisp-scheme-kit 1.3-release (same) prime python-kit 3.7-release (same) prime lang-kit 1.3-release (same) prime llvm-kit 1.3-release (same) prime dev-kit 1.3-release (same) prime python-modules-kit 1.3-release (same) prime nokit 1.3-release (same) prime NOTE: This information comes from /etc/ego.conf and meta-repo metadata. After making changes to ego.conf, be sure to run ego sync in so that the individual kit repositories on disk are synchronized with the kit branches shown above. Additional Information comes from /var/git/meta-repo/metadata/kit-info.json Specific revision number for each kits git repo: /var/git/meta-repo/metadata/kit-sha1.json
  3. If you have rust-bin installed then it includes cargo. /opt/rust-bin-1.32.0/bin/cargo-bin-1.32.0 You have to manually run this command to symlink the cargo-bin-1.32.0 executable to /usr/bin/cargo : # eselect rust set 1 Verify cargo: # which cargo /usr/bin/cargo # file `which cargo` /usr/bin/cargo: symbolic link to /usr/bin/cargo-bin-1.32.0 # file `which cargo-bin-1.32.0` /usr/bin/cargo-bin-1.32.0: symbolic link to ../../opt/rust-bin-1.32.0/bin/cargo-bin-1.32.0 # file /opt/rust-bin-1.32.0/bin/cargo-bin-1.32.0 /opt/rust-bin-1.32.0/bin/cargo-bin-1.32.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.9, stripped Reference: https://bugs.funtoo.org/browse/FL-5843 dev-util:cbindgen-0.8.2:20190519-154310.log
  4. Your processor doesn't support aes which is in your CPU_FLAGS_86 and CFLAGS="- march=westmere" Building nettle with aes cpu flag set on gcc when your processor doesn't support aes could be the cause of the error. Reference: https://gcc.gnu.org/onlinedocs/gcc/x86-Options.html ‘westmere’ Intel Westmere CPU with 64-bit extensions, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, POPCNT, AES and PCLMUL instruction set support. Set to native and add the proper flags to match your processor. Install cpuid2cpuflags Follow my directions here starting at Remove any gcc override settings you've made previously. After you've finished configuring gcc to match your processor rebuild nettle.
  5. @nigga-china The source code for media-kit/1.3-release media-libs/allegro-4.4.2-r1 is the vanilla version from sourceforge. To build aseprite: # mkdir -p /etc/portage/patches/media-libs/allegro-4.4.2-r1 Download the allegro_GLX_RGBA_FLOAT_BIT_fix.patch # cp allegro_GLX_RGBA_FLOAT_BIT_fix.patch /etc/portage/patches/media-libs/allegro-4.4.2-r1 Enable bundled-libs use flag for aseprit or you can't resize the window it runs in: # echo "dev-games/aseprite bundled-libs" > /etc/portage/package.use/aseprite Build aseprite: # emerge -av aseprite
  6. @nigga-china Why are you building allegro-4.4.2-r1? The patch only works for allegro-5.2.4.0 Emerge should build allegro-5.2.4.0 unless your overriding it. rj@funtoo ~ $ ego query v allegro media-libs/allegro| slot| repo -------------------+-----+---------------------- 4.4.2-r1| 0| media-kit/1.3-release -------------------+-----+---------------------- 5.0.11| 5| media-kit/1.3-release * 5.2.4.0| | media-kit/1.3-release Please always post your commands and use wgetpaste to push your failed build logs. Post the link to the pasted build logs in your reply. The screen shot doesn't show the whole log and my eye sight is bad. It's difficult for me to read the text on your prints.
  7. @nigga-china I was able to build allegro-5.2.4.0 after adding this patch to /etc/portage/patches/media-libs/allegro funtoo /home/rj # wgetpaste /var/log/portage/media-libs\:allegro-5.2.4.0\:20190514-220248.log https://bpaste.net/show/171ed7e8d8a8 Don't re-install your system, if you keep it updated you will eventually rebuild every package with the correct GCC settings. If for some reason a program doesn't work then rebuild it.
  8. Gcc sandybridge m{tune,arch} sets the aes flag that doesn't match your CPU. This is what is triggering the compile error. The GCC settings for sandybridge: ‘sandybridge’ Intel Sandy Bridge CPU with 64-bit extensions, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, POPCNT, AVX, AES and PCLMUL instruction set support. Reference: https://gcc.gnu.org/onlinedocs/gcc/x86-Options.html Remove any gcc override settings you've made previously. Set the correct subarch here: # ego profile subarch native_64 === Enabled Profiles: === arch: x86-64bit build: current subarch: native_64 flavor: desktop mix-ins: lxde >>> Set subarch to native_64. Updating profiles at /etc/portage/make.profile/parent... Set your CPU flags: # echo "*/* $(cpuid2cpuflags)" >> /etc/portage/package.use/00cpuflags Verify with "emerge --info" and grep that cpuflags are correct for your cpu: # emerge --info | grep 'CFLAGS\|CPU_FLAGS_X86' Reference: https://wiki.gentoo.org/wiki/GCC_optimization
  9. This user override only exists if booted into a debian patched kernel: /proc/sys/kernel/unprivileged_userns_clone
  10. Default setting is disabled: # cat /proc/sys/kernel/unprivileged_userns_clone 0 Enable on reboot: # echo 'kernel.unprivileged_userns_clone=1' > /etc/sysctl.d/unprivileged_userns_clone.conf Verify enabled: # cat /proc/sys/kernel/unprivileged_userns_clone 1
  11. Remove the package.use disabling pulseaudio for firefox-bin If pulseaudio has the alsa-plugins use flag enabled, then alsa-plugins becomes a depends of pulseaudio. rj@funtoo ~ $ equery depends alsa-plugins * These packages depend on alsa-plugins: media-sound/pulseaudio-12.2 (alsa-plugin ? >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,-mgorny(-)]) Disable alsa-plugin use flag for pulseaudio depends and you will not be forced into installing alsa-plugins. rj@funtoo ~ $ cat /etc/portage/package.use/pulseaudio media-sound/pulseaudio -alsa-plugin
  12. Add to package.use dev-util/itstool PYTHON_TARGETS: -* python3_6 PYTHON_SINGLE_TARGET: -* python3_6 dev-libs/libxml2 PYTHON_TARGETS: -* python3_6 I don't specify >=< and package version when overriding default USE flags in package.use Reference: https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS https://wiki.gentoo.org/wiki/Handbook:Parts/Working/USE
  13. Cuda is not supported by legacy nvidia-driver-340.107 Don't set gfxcard-nvidia mix-ins with legacy driver as it adds cuda use flag to make.defaults Cuda use flag is enabled on multiple packages on your system pulling in nvidia-cuda-toolkit which pulls in nvidia-driver-410.93 rj@funtoo ~ $ equery g nvidia-cuda-toolkit-9.2.88 * dependency graph for dev-util/nvidia-cuda-toolkit-9.2.88 `-- dev-util/nvidia-cuda-toolkit-9.2.88 NVIDIA-CUDA license(s) `-- sys-devel/gcc-7.4.1-r6 (<sys-devel/gcc-8) unknown [cxx] `-- x11-drivers/nvidia-drivers-410.93 (>=x11-drivers/nvidia-drivers-396.24) M[package.mask] [X uvm] `-- sys-libs/libtermcap-compat-2.0.8-r4 (sys-libs/libtermcap-compat) ~amd64 `-- sys-libs/ncurses-5.9-r101 (sys-libs/ncurses) amd64 [tinfo] `-- virtual/jre-1.8.0-r1 (>=virtual/jre-1.6) amd64 [ dev-util/nvidia-cuda-toolkit-9.2.88 stats: packages (6), max depth (1) ] Disable cuda use flag from every package on your system. Use this command to find the packages with cuda enabled: USE="cuda"; for PKG in $(equery -q hasuse $USE); do echo $PKG: $(equery -q uses $PKG |grep $USE); done At the minimum these 2 packages have cuda enabled: # required by dev-cpp/eigen-3.3.5-r1::dev-kit[cuda] [ebuild R ] media-libs/opencv-3.4.1-r4 USE="cuda* opencl*" I run nvidia-8400GS with nvidia-driver-340.107 with >x11-drivers/nvidia-drivers-340.107 in package.mask No issue with portage wanting to install nvidia-cuda-toolkit and upgrade nvidia-driver. All packages with cuda use option on my system have it disabled "-cuda" rj@funtoo ~ $ USE="cuda"; for PKG in $(equery -q hasuse $USE); do echo $PKG: $(equery -q uses $PKG |grep $USE); done dev-cpp/eigen-3.3.5-r1: -cuda media-libs/opencv-3.4.1-r4: -cuda media-video/mpv-0.27.2: -cuda Check and avoid user override configs made in /etc/portage/make.conf , /etc/portage/packages.{use,mask,unmask}. The Block on your system is caused by having apulse installed with pulseaudio use enabled. [blocks B ] media-plugins/alsa-plugins[pulseaudio] ("media-plugins/alsa-plugins[pulseaudio]" is hard blocking media-sound/apulse-0.1.12-r4) Remove apulse and install pulseaudio. If you configure pulseaudio as minimal unintrusive dumb pipe to alsa you don't need alsa-plugins or the pulseaudio use flag enabled. Pulse auto-spawns when needed by pre-compiled firefox-bin or any other program with a pulseaudio driver. Programs with alsa drivers work as well.
  14. python_single_target is a subset of python_targets and requires a matching version of python_targets itstool python_targets_python3_6 must be enabled for python_single_target_python3_6 rj@funtoo ~ $ emerge -pv itstool These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] dev-util/itstool-2.0.6-r1::core-kit PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_4 -python3_5 -python3_7" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7" 0 KiB Total: 1 packages (1 reinstall), Size of downloads: 0 KiB Reference: https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS The PYTHON_SINGLE_TARGET variable is used for packages that are built for a single implementation of choice only. It may contain only a single implementation. Due to technical limitations, the implementation specified as PYTHON_SINGLE_TARGET must also be included in PYTHON_TARGETS for the package in question.
  15. rj@funtoo ~ $ equery b /usr/share/sgml/docbook/xml-dtd-4.3/docbookx.dtd * Searching for /usr/share/sgml/docbook/xml-dtd-4.3/docbookx.dtd ... app-text/docbook-xml-dtd-4.3-r1 (/usr/share/sgml/docbook/xml-dtd-4.3/docbookx.dtd) My pam build log lines 359->381 My build of pam sourced http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl URI redirection references /etc/xml/catalog: <delegateURI uriStartString="http://docbook.sourceforge.net/release/xsl/" catalog="file:///etc/xml/docbook"/> From /etc/xml/docbook: http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl <rewriteURI uriStartString="http://docbook.sourceforge.net/release/xsl/current" rewritePrefix="file:///usr/share/sgml/docbook/xsl-stylesheets"/> rj@funtoo ~ $ equery b /usr/share/sgml/docbook/xsl-stylesheets * Searching for /usr/share/sgml/docbook/xsl-stylesheets ... app-text/docbook-xsl-stylesheets-1.79.1-r2 (/usr/share/sgml/docbook/xsl-stylesheets) Verify your install of app-text/docbook-xml-dtd and app-text/docbook-xsl-stylesheets .
  16. Three methods to prevent updating version: Mask greater than the specific installed version: >x11-drivers/nvidia-drivers-340.107 Use the --noreplace option emerge -av --noreplace =x11-drivers/nvidia-drivers-340.107 Use the exclude option: emerge -avuDN world --exclude=x11-drivers/nvidia-drivers
  17. The crash error from /usr/bin/glib-mkenums on line 107->113 of your log can be due to not having your locale set to UTF-8 according to: https://gitlab.gnome.org/GNOME/glib/issues/1430 On my system: rj@funtoo ~ $ locale LANG=en_US.UTF-8 LC_CTYPE="en_US.UTF-8" LC_NUMERIC="en_US.UTF-8" LC_TIME="en_US.UTF-8" LC_COLLATE=POSIX LC_MONETARY="en_US.UTF-8" LC_MESSAGES="en_US.UTF-8" LC_PAPER="en_US.UTF-8" LC_NAME="en_US.UTF-8" LC_ADDRESS="en_US.UTF-8" LC_TELEPHONE="en_US.UTF-8" LC_MEASUREMENT="en_US.UTF-8" LC_IDENTIFICATION="en_US.UTF-8" LC_ALL= rj@funtoo ~ $ locale -a C POSIX en_US.utf8 Reference: https://www.funtoo.org/Funtoo_Linux_Localization https://wiki.gentoo.org/wiki/Localization/Guide https://wiki.gentoo.org/wiki/UTF-8
  18. mousetweaks-3.12.0 emerges on my system. Push the build log with wgetpaste and provide the link in your reply so we can try to determine what is causing the compile failure on your system. emerge -av wgetpaste funtoo /home/rj # wgetpaste /var/log/portage/gnome-extra\:mousetweaks-3.12.0\:20190426-164024.log Your paste can be seen here: https://bpaste.net/show/77c00553aed3 My mousetweaks build log
  19. Set up a local overlay. Copy from master branch net-kit to local overlay: net-mail/dovecot/dovecot-2.3.4.ebuild net-mail/dovecot/files Reference: https://github.com/funtoo/net-kit/tree/master/net-mail/dovecot
  20. The problem has been reported: sys-kernel/debian-sources-lts-4.9.161_p1 tarball needs mirrored or bumped The user/password for forums.funtoo.org and bugs.funtoo.org should be the same.
  21. This is normal, just because you see an ebuild with a higher version,doesn't mean your system is broken because portage is not updating automatically to that version. Python-3.7 is masked in portage. The user has to manually override the mask with a configuration in package.unmask to install python-3.7
  22. Did you add VIDEO_CARDS="nouveau" to /etc/portage/make.conf then run emerge -avuDN @world This activates xll-base/xorg-drivers meta package which installs other required drivers automatically. nokit/sys-kernel/gentoo-sources 1.3-release branch shows gentoo-sources-4.19.1 rj@funtoo ~ $ emerge -pv gentoo-sources These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] sys-kernel/gentoo-sources-4.19.1:4.19.1::nokit USE="-build -experimental -symlink" 100,731 KiB Total: 1 package (1 new), Size of downloads: 100,731 KiB To install a specific version of gentoo-sources set a package.mask for versions greater than > funtoo /home/rj # echo ">sys-kernel/gentoo-sources-4.18.18-r1" >> /etc/portage/package.mask/gentoo-sources funtoo /home/rj # emerge -pv gentoo-sources These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] sys-kernel/gentoo-sources-4.18.18-r1:4.18.18-r1::nokit USE="-build -experimental -symlink" 99,937 KiB Total: 1 package (1 new), Size of downloads: 99,937 KiB Reference: https://wiki.gentoo.org/wiki/Nouveau
×
×
  • Create New...