Jump to content
funtoo forums
mantas

Testing 1.3

Recommended Posts

I don't know how to update the grub tho. The kernels in boot are all LTS 4.9.130, but grub.cfg says genkernel 4.14.12.

I don't remember modifying grub.cfg so I wonder if there is a tool I need to run?

 

Share this post


Link to post
Share on other sites
5 hours ago, engineer said:

I don't know how to update the grub tho. The kernels in boot are all LTS 4.9.130, but grub.cfg says genkernel 4.14.12.

I don't remember modifying grub.cfg so I wonder if there is a tool I need to run?

 

use boot-update to update the grub entries.

Share this post


Link to post
Share on other sites

My problems are these:

I can't boot because grub lists an invalid efi file, and choosing it gives an error. So I boot a LiveCD and chroot in.

When I run 'ego boot update' I get an "ERROR: couldn't find grub-probe"

Emerge grub  says "fails to validate /dev - may be a broken '/dev/fd'".

I don't know how to fix this.

Share this post


Link to post
Share on other sites

OK I fixed this.

So I got into the grub editor and changed the name of the kernels manually to get it to boot. Then I did an ego boot update which failed. I then remembered the emerge grub part and did that. When I looked up it was like the matrix on my screen as a billion lines of code went by.

Why doesn't make change the text color to shades of green when i use the --matrix option??!!?

I used etc-update to merge /etc/default/grub changes. Now "ego boot update" worked, tho with warning I must digest.

Things I notice: the search line has updated disk ID, and it found the old kernels which boot-update never did.

Oh - and KDE doesn't start. /etc/conf.d/xdm has DISPLAYMANAGER="sddm" but there's plenty of --depclean stuff yet to be done.

 

So thanks for the help, guys, I can boot again!!

 

_Eng

 

Share this post


Link to post
Share on other sites
On 12/5/2018 at 7:09 AM, drobbins said:

OK, so I am following upgrade instructions, so far so good. Currently updating system.

A couple of points:

  • I wanted to stay on perl 5.28 which was available some time ago from a kit, so had to unmask perl and ~20 perl virtuals, don't know if there is a file somewhere with such a list already
  • Had to unmerge a number of xorg proto packages which had file collisions with one updated xorg proto package.

Share this post


Link to post
Share on other sites

System update fails on the last package - gnome-base/dconf-0.30.1 with error:

Quote

No installed vala in || ( dev-lang/vala:0.40 dev-lang/vala:0.38 dev-lang/vala:0.36 dev-lang/vala:0.34 dev-lang/vala:0.32 dev-lang/vala:0.30 dev-lang/vala:0.28 dev-lang/vala:0.26 )

vala-0.42.3 is installed

Don't know if 1.3 bugs should be already reported on bug tracker.

Share this post


Link to post
Share on other sites

First, I can't report anything on bugs.funtoo.org because the login is rejecting me. 

Second, I got as far as emerge -av @preserved-rebuild, but it fails on compiling glib-2.58.1, but that fails with the complaint

Program gdbus-codegen found: NO

gio/meson.build:237:0: ERROR:  Program(s) ['gdbus-codegen'] not found or not executable

 

Share this post


Link to post
Share on other sites

I followed the instruction and typed "emerge -auDN @system --ignore-world".

Emerge wanted to upgrade xorg-proto but detected lots of collisions.

Then emerge told me that there were many preserved libs and asked me to use "emerge @preserved-rebuild" to rebuild these libs.

--12/9

Solved!

I removed llvm 5 and 6.

Share this post


Link to post
Share on other sites

 

 

Interesting behaviour for x11-libs/gtk+:

Quote

farout ~ # emerge -pv gtk+

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] x11-libs/gtk+-3.94.0:4::gnome-kit [2.24.32-r1:2::gnome-kit, 3.24.1:3::gnome-kit] USE="X vim-syntax wayland xinerama (-aqua) -broadway -cloudprint -colord -cups -docs -examples -introspection -test -vulkan" 0 KiB

Total: 1 package (1 in new slot), Size of downloads: 0 KiB

Quote

Library rt found: YES
Program wayland-scanner found: YES (/usr/bin/wayland-scanner)
Program gen-gsk-gresources-xml.py found: YES (/usr/bin/env python3 /var/tmp/portage/x11-libs/gtk+-3.94.0/work/gtk+-3.94.0/gsk/gen-gsk-gresources-xml.py)
Configuring gsk.resources.xml with command
Program gen-gtk-gresources-xml.py found: YES (/usr/bin/env python3 /var/tmp/portage/x11-libs/gtk+-3.94.0/work/gtk+-3.94.0/gtk/gen-gtk-gresources-xml.py)
Configuring gtk.gresources.xml with command
Program sassc found: NO
Program gentypefuncs.py found: YES (/usr/bin/env python3 /var/tmp/portage/x11-libs/gtk+-3.94.0/work/gtk+-3.94.0/gtk/gentypefuncs.py)
Configuring gtkversion.h using configuration
Dependency x11 found: YES (cached)
Has header "langinfo.h": YES
Header <langinfo.h> has symbol "_NL_MEASUREMENT_MEASUREMENT": YES
Header <langinfo.h> has symbol "_NL_PAPER_HEIGHT": YES
Header <langinfo.h> has symbol "_NL_PAPER_WIDTH": YES
Header <langinfo.h> has symbol "_NL_TIME_FIRST_WEEKDAY": YES
Has header "cups/cups.h": NO

modules/printbackends/meson.build:48:4: ERROR:  Problem encountered: Cannot find CUPS headers in default prefix.

A full log can be found at /var/tmp/portage/x11-libs/gtk+-3.94.0/work/gtk+-3.94.0-build/meson-logs/meson-log.txt
 * ERROR: x11-libs/gtk+-3.94.0::gnome-kit failed (configure phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line   92:  Called src_configure
 *   environment, line 4705:  Called meson_src_configure
 *   environment, line 3403:  Called die
 * The specific snippet of code:
 *       tc-env_build "$@" || die

Probably a result of this message:

Quote

The Meson build system
Version: 0.48.2
Source dir: /var/tmp/portage/x11-libs/gtk+-3.94.0/work/gtk+-3.94.0
Build dir: /var/tmp/portage/x11-libs/gtk+-3.94.0/work/gtk+-3.94.0-build
Build type: native build
WARNING: Unknown options: "CUPS_CONFIG, cloudprint-print-backend, cups-print-backend, mir-backend, modules, papi-print-backend, test-print-backend"
Project name: gtk+
Project version: 3.94.0
Appending CFLAGS from environment: '-O1 -pipe'
Appending LDFLAGS from environment: ' '
Appending CPPFLAGS from environment: ' '
Native C compiler: x86_64-pc-linux-gnu-gcc (gcc 7.3.1 "x86_64-pc-linux-gnu-gcc (Funtoo Hardened 7.3.1-r5) 7.3.1 20181104")

 

Share this post


Link to post
Share on other sites
On 12/6/2018 at 3:43 PM, mauricev said:

First, I can't report anything on bugs.funtoo.org because the login is rejecting me. 

If login is rejecting you, you will need to use authy to upgrade your account -- go to https://auth.funtoo.org/login and go through that. It should prompt you to upgrade your account. If you are not willing or able to use SMS to validate your account, you can find us on IRC and get us to manually validate your account. Oleg (angry_vincent), biberao and me will be able to help you there (other guys will have the ability to do this tomorrow)...

Share this post


Link to post
Share on other sites

Just to report, one funtoo system here (KDE desktop) succesfully updated to 1.3, big thanks to dev team for their hard work on Funtoo linux.

Quote

lithium ~ # emerge -auDNv @world                
These are the packages that would be merged, in order:
Calculating dependencies... done!
Total: 0 packages, Size of downloads: 0 KiB
Nothing to merge; quitting.


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×