Jump to content

engineer

Members
  • Content Count

    31
  • Joined

  • Last visited

Everything posted by engineer

  1. While you are there, go ahead and fix /usr/share/genkernel/defaults/config.sh /usr/share/genkernel/arch/x86/config.sh KERNEL_BINARY="arch/x86/boot/bzImage" DEFAULT_MAKEOPTS="-j5" Also in /usr/share/genkernel/gen_bootloader.sh change grub2-mkconfig -o "${GRUB_CONF}" to ego boot update
  2. sh: bad number error is fixed by changing the following code /usr/share/genkernel/defaults/linuxrc: Replace linuxrc: if [ "${USE_AUFS_NORMAL}" -eq '1' ] With linuxrc: if [ "${USE_AUFS_NORMAL}" = '1' ] There are two instances.
  3. On linux-debian-sources-5.10.28_p1 I get this error also, but it comes before initramfs. Output says: ... Hint: Use parameter scandelay... Determining boot device... Detected real_root=/dev/sda3 Mounting /dev/sda3 as root... Using mount -t ext4 -o ro sh: bad number Booting (initramfs).. INIT: version 2.95 booting etc.
  4. ty got it working and jEdit loaded. If you've never tried "elastic tabstops" you've been missing out and should try jEdit which has that option.
  5. The Rust people have removed C routines as "unsafe". C is not unsafe, lazy programmers are unsafe. Anyhow, they have screwed the python cryptography module and everyone's CI pipelines are breaking. The solution is to recompile the Rust toolchain. I notice Funtoo did a mini update to 5.10.26_p1 and that should compile whatever broke. When I am compiling toolchain stuff, I emerge @system first and then @world, which is redundant but ensures the toolchain is complete. ex: emerge -uDN --with-bdeps=y --emptytree @system Note: this takes almost two days on my iCore 5.
  6. I was trying to merge jEdit programmer's editor and got errors on javamail that took a little while to track down, so here's how to fix it. BUILD FAILED Target "-push-to-maven-init" does not exist in the project "JavaMail". It is used from target "push-to-maven-prepare". build.xml of dev-java/oracle-javamail-1.5.6 contains: <!DOCTYPE project [ <!ENTITY commonBuild SYSTEM "ant-common.xml"> ]> ... &commonBuild; And ant-common.xml contains necessary code. BUT Python xml.sax module by default does not expand external entities since Python 3.6.7, 3.7.1 and 3.8.0
  7. Edit /etc/boot.conf, add display { gfxmode 1280x1024x24, 1024x768, 800x600, auto } use numbers that make sense on your machine, obv.
  8. That worked great! Thanks for the detailed instructions, they worked first time, flawlessly. This has inspired me to try an --empty-tree which may take a couple of days on my Core i5 with 1800+ packages. I'm sure something will break and I'll be back. ;)
  9. Latest problem is net-voip/telepathy-gabble-0.18.4 and net-voip/telepathy-salute-0.8.1-r1 which are pulled in by net-in/telepathy-connection-managers-2-r2 I suspect openssl 1.1+ is messing them up, or some Apple defines that are messing up the structures. Anyone else running into this?
  10. OK, of course there's a package.mask as well. I can't delete the post, but if an admin wants to that's fine.
  11. Also, how do you block a download? I'm aware of package.unmask, is there a package.mask as well?
  12. I'm doing an emerge and it trying / failing to download dev-util/gn-63.0.3239.70 which is refused because of file size mismatch. I don't know what this is, but the gentoo page has a version 0.1463 : https://packages.gentoo.org/packages/dev-util/gn Can someone explain where this is coming from? Is this some kind of hack?
  13. That fixed it up. Took a while to compile - like 4 hours or something. Thanks for that, I was getting nowhere.
  14. message is "die 'Aborting due to serious QA concern with RUNPATH/RPATH" Has anyone run into this and solved it?
  15. Taking Python3.4 and Python3.5 out of PYTHON_TARGETS in make.conf seems to be work. Now I'm having trouble with nodejs.
  16. So I'm trying to rebuild everything using --emptytree @world and it's failing on python3_4 Preserved libs list comes up, but I don't know what it's for - heres the list tho, if it helps: dev-libs/ice-64.2, dev-libs/libevent-2.1.8, dev-libs/openssl-1.1.1b-r2, net-libs/hhtp-parser-2.9.2 What can I do?
  17. Thanks guys - I've put all three way to override python in my package.use!! # package.use # # three ways to select python version >=app-text/asciidoc-8.6.10 python_single_target_python2_7 python_targets_python2_7 dev-util/itstool PYTHON_TARGETS: -* python3_6 PYTHON_SINGLE_TARGET: -* python3_6 dev-libs/libxml2 python_targets_python*
  18. >=app-misc/pax-utils-0.1.10 >=app-text/asciidoc-8.6.10 python_single_target_python2_7 python_targets_python2_7 >=app-text/poppler-0.74.0 >=dev-libs/glib-2.44.0 >=dev-libs/liborcus-0.13 >=dev-libs/xmlsec-1.2.26 nss >=dev-libs/libxml2-2.9.9-r1 python_single_target_python3_6 python_targets_python3_6 >=dev-util/itstool-2.0.6-r1 python_single_target_python3_6 python_targets_python3_6 >=media-libs/gd-2.2.5-r1 fontconfig >=media-libs/lensfun-0.2.5 >=media-libs/mlt-6.12.0-r1 sdl frei0r >=media-video/ffmpeg-3.4.5 sdl >=sys-boot/grub-2.02-r3 mount >=virtual/ff
  19. My package.use [/etc/portage]-> cat package.use >=app-misc/pax-utils-0.1.10 >=app-text/asciidoc-8.6.10 python_single_target_python2_7 python_targets_python2_7 >=app-text/poppler-0.74.0 >=dev-libs/glib-2.44.0 >=dev-libs/liborcus-0.13 >=dev-libs/xmlsec-1.2.26 nss >=dev-libs/libxml2-2.9.9-r1 >=dev-util/itstool-2.0.6-r1 >=media-libs/gd-2.2.5-r1 fontconfig >=media-libs/lensfun-0.2.5 >=media-libs/mlt-6.12.0-r1 sdl frei0r >=media-video/ffmpeg-3.4.5 sdl >=sys-boot/grub-2.02-r3 mount >
  20. I did an emerge --depclean, then an emerge --backtrack=500 @world >>> Installing (1 of 2) dev-libs/libxml2-2.9.8-r1::core-kit >>> Emerging (2 of 2) dev-util/itstool-2.0.6-r1::core-kit * itstool-2.0.6.tar.bz2 BLAKE2B SHA512 size ;-) ... [ ok ] >>> Unpacking source... >>> Unpacking itstool-2.0.6.tar.bz2 to /var/tmp/portage/dev-util/itstool-2.0.6-r1/work >>> Source unpacked in /var/tmp/portage/dev-util/itstool-2.0.6-r1/work >>> Preparing source in /var/tmp/
  21. [/etc/portage]-> emerge --rage-clean dev-util/itstool dev-libs/libxml2 dev-util/itstool selected: 2.0.6-r1 protected: none omitted: none dev-libs/libxml2 selected: 2.9.8-r1 protected: none omitted: none All selected packages: =dev-libs/libxml2-2.9.8-r1 =dev-util/itstool-2.0.6-r1 >>> 'Selected' packages are slated for removal. >>> 'Protected' and 'omitted' packages will not be removed. >>> Unmerging (1 of 2) dev-util/itstool-2.0.6-r1...
  22. OK, got SSH working. Here's the output of emerge @world: WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-libs/libxml2:2 (dev-libs/libxml2-2.9.9-r1:2/2::core-kit, ebuild scheduled for merge) conflicts with dev-libs/libxml2[python,python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python3_6(+)] required by (dev-util/itstool-2.0.6-r1:0/0::core-kit, installed)
  23. Without my kernel working properly, I'm having trouble getting the output. Might take a picture of the screen. But, what I did to try to get a kernel is to run a 'make clean' and 'make', then I was going to just genkernel and avoid the emerge. But - I get the old: mpihelp_add_1 multiple definitions problem. Didn't this go away about a decade ago? It has something to do with 'extern' vs 'static'. Why is this still happening?!?
×
×
  • Create New...