Jump to content
funtoo forums

All Activity

This stream auto-updates     

  1. Today
  2. Cmake fails with "bus error"

    Hello all, dev-util/cmake-3.8.0::core-kit I was working on my Raspberry pi this weekend, (chroot from Rasberry linux) did ego sync, then emerge networkmanager. I had problems with use flags , did --autounmask-write and updated config file. everything goes along fine 51 packages installed. Then we get to cmake, everything seems to get started properly, applying patches etc until this one part shown below and I get "bus error" armv7a-hardfloat-linux-gnueabi-g++ -O2 -pipe -march=armv7-a -mfloat-abi=hard -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Bootstrap.cmk -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Source -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Utilities -c /var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Source/cmGlobalGenerator.cxx -o cmGlobalGenerator.o armv7a-hardfloat-linux-gnueabi-g++ -O2 -pipe -march=armv7-a -mfloat-abi=hard -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Bootstrap.cmk -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Source -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Utilities -c /var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Source/cmGlobalUnixMakefileGenerator3.cxx -o cmGlobalUnixMakefileGenerator3.o Bus error Everything is locked up for awhile but comes back - except chroot - terminal window has all of the info in it still. I did as much as i know to do - tried again - redid ego sync - rebooted and chroot with different chroot instructions - Checked that I still had disk space - tried another Pi - I reflashed my raspberry pi to clean SD with pi Linux, reinstalled funtoo and paid particularly close attention when setting up env and portage config / environment variables. i did notice at the beginning of emerge it says *unable to find kernel sources at /usr/src/linux *Was unable to determine your kernel .config Not sure where to look or what to do. suggestions requested.
  3. meta-repo: Can /usr/portage be deleted now?

    Thank you, dhudson. Would you also be so kind to post 1.) output of ls -l /etc/portage/ (-l flag is important), and 2.) content of /etc/portage/make.profile/arch/x86-64bit/parent
  4. Funtoo improves Dropbox

    Oh, and you also get the QT5-based GUI without having to emerge all of the QT5 libraries. This is very handy for GNOME users. Note that when dropbox is started in GNOME, you will have a little GNOME task icon for dropbox.... It contains dropbox settings...
  5. Hi All, I've just massively reworked the net-misc/dropbox ebuild to provide a much better experience in Funtoo and you should see this showing up in the next few hours. I couldn't get the Gentoo dropbox working reliably. Here is a list of all the changes: Updated to dropbox-39.4.49.ebuild No longer has an initscript It now sets up ~/.dropbox-dist for each user who sets up dropbox (rather than having a system dropbox install) You don't need to be in the "dropbox" group to use the dropbox nautilus (gnome file browser) extension gnome support is built-in (as long as "gnome" is set in USE, which it is if you are using the GNOME mix-in.) Reworked the python 'dropbox' script to provide a better user experience and be optimal for Funtoo: if you start "dropbox" for the first time from GNOME, it will start a GTK+ installer to set up dropbox for you. if you don't have a GUI, you can still install dropbox The above two features are existing features of dropbox that were somewhat borked in Gentoo. At the end of the setup process, you are given instructions on how to enable dropbox on startup. dropbox command-line tool is also included. Please note that if you have nautilus-dropbox installed, you will need to remove it. This should result in a really nice experience for dropbox users. Use as follows: # emerge dropbox (make sure it's 39.4.49 -- this is the new version.) (as regular user:) $ dropbox start -i This will initialize the ~/.dropbox-dist directory for the user via a command-line or GTK+ interface. Once this is done, dropbox start should be added to your .bash_login and/or .xprofile and can be run immediately to start dropbox in your current session. Since the ebuild is completely new, the possibility of bugs exist. Please report bugs at https://bugs.funtoo.org . Thanks. -Daniel
  6. [solved] lxqt-base/lxqt-panel-0.11.0 fails to emerge

    Thank you much. I just noticed that version 0.11-0-r1 was out and it indeed fixed.
  7. Yesterday
  8. Last week
  9. [solved] lxqt-base/lxqt-panel-0.11.0 fails to emerge

    fixed lxqt-panel.
  10. [solved] lxqt-base/lxqt-panel-0.11.0 fails to emerge

    this looks like a lxqt-panel problem, according to build.log. not likely your system problem.
  11. [solved] lxqt-base/lxqt-panel-0.11.0 fails to emerge

    How do I know if the problem I am having is a bug and not a problem with my system?
  12. [solved] lxqt-base/lxqt-panel-0.11.0 fails to emerge

    sorry, you can report both issues. The build failure and the forum problem, separately :)
  13. [solved] lxqt-base/lxqt-panel-0.11.0 fails to emerge

    The package or the forum behavior?
  14. [solved] lxqt-base/lxqt-panel-0.11.0 fails to emerge

    please report this on bugs.funtoo.org
  15. I'm 5 files away from having a working desktop and lxqt-panel-0.11 fails. Can anyone help WHy does the code box say im trying to pst spam? Seriously how do you post any code from the failed package when the forum blocks it? build.log
  16. ANSWERED funtoo logo ideas

    Is there a font that is preferred for the logos and wallpapers?
  17. sys-kernel/debian-sources-4.13.10-1 Test

    thank you. yes, the ebuild has no keywords, so adding them is step prior to emerge. Yes, due to many modules enabled by default, during compilation disk space consuming picks around 18Gb, so 20Gb is set so that there is plenty of space.
  18. Funtoo mascot

    I think it could work.
  19. @Oleg Vinichenko Please find the results of my tests under a Virtual Box machine: - First I had to add "amd64" to KEYWORD variable in the ebuild under: /var/git/meta-repo/core-kit/ - Then I had to expand the virtual harddisk, so that I had 20G free (from 32G to 60G) (ubuntu live cd) - Then I had to do a emerge -av ">=debian-sources-4.13.10-1" because with an ego sync && emerge -avuND world it dit not show up in the package tree, when I searched for it. It compiled without a problem, and after (manually) adapting the /boot/grub/grub.cfg, replacing 4.8.15-1 with the correct version, the Virtual Machine booted up correctly Also, KDE Plasma with virtual box guest additions booted up correctly. Kind regards, Valerie
  20. meta-repo: Can /usr/portage be deleted now?

    oh your right I got that wrong... sorry but you should have a dir /etc/portage/make.profile with a file called parent I belive make.profile was a file before the change. here is mine.. change your subaarch to reflect your hardware. ~$ cat /etc/portage/make.profile/parent core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit core-kit:funtoo/1.0/linux-gnu/build/current core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/amd64-piledriver core-kit:funtoo/1.0/linux-gnu/flavor/workstation core-kit:funtoo/1.0/linux-gnu/mix-ins/no-systemd core-kit:funtoo/1.0/linux-gnu/mix-ins/mediadevice-audio-pro xfce-kit:funtoo/kits/python-kit/3.4-prime net-kit:funtoo/kits/python-kit/3.4-prime python-kit:funtoo/kits/python-kit/3.4-prime core-hw-kit:funtoo/kits/python-kit/3.4-prime ruby-kit:funtoo/kits/python-kit/3.4-prime gnome-kit:funtoo/kits/python-kit/3.4-prime security-kit:funtoo/kits/python-kit/3.4-prime ml-lang-kit:funtoo/kits/python-kit/3.4-prime xorg-kit:funtoo/kits/python-kit/3.4-prime text-kit:funtoo/kits/python-kit/3.4-prime lisp-scheme-kit:funtoo/kits/python-kit/3.4-prime java-kit:funtoo/kits/python-kit/3.4-prime perl-kit:funtoo/kits/python-kit/3.4-prime games-kit:funtoo/kits/python-kit/3.4-prime desktop-kit:funtoo/kits/python-kit/3.4-prime haskell-kit:funtoo/kits/python-kit/3.4-prime php-kit:funtoo/kits/python-kit/3.4-prime lang-kit:funtoo/kits/python-kit/3.4-prime nokit:funtoo/kits/python-kit/3.4-prime science-kit:funtoo/kits/python-kit/3.4-prime editors-kit:funtoo/kits/python-kit/3.4-prime core-kit:funtoo/kits/python-kit/3.4-prime kde-kit:funtoo/kits/python-kit/3.4-prime media-kit:funtoo/kits/python-kit/3.4-prime dev-kit:funtoo/kits/python-kit/3.4-prime
  21. meta-repo: Can /usr/portage be deleted now?

    Thanks. i didn't ask about repos.conf but about make.profile. I read the README.rst page carefully and did what it says. Nevertheless, I ran into major troubles after removing /usr/portage. First, no profile is defined anymore: me@work# epro list ... WARNING: No arch defined. Please set. WARNING: No build defined. Please set. WARNING: No flavor defined. Please set. If i make /etc/portage/make.profile a link to /var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/ as suggested above, epro gets broken: me@work# epro arch x86-64bit Traceback (most recent call last): File "/usr/bin/epro", line 102, in <module> EgoModule.run_ego_module(action, econfig, args, VERSION) File "/usr/share/ego/python/ego/module.py", line 64, in run_ego_module ego_module(*args) File "/usr/share/ego/modules/profile.ego", line 299, in __call__ super().__call__(*args) File "/usr/share/ego/python/ego/module.py", line 49, in __call__ self.handle(**options) File "/usr/share/ego/modules/profile.ego", line 278, in handle handler(**options) File "/usr/share/ego/modules/profile.ego", line 198, in handle_single_profile_actions current_setting = list(self.tree.get_children(profile_type))[0] IndexError: list index out of range Second, tools like qsearch etc. do not work any more: me@work# qsearch base64 search: open failed: /usr/portage: No such file or directory Basically, this means that I cannot emerge anymore and my system is broken, for the first time that I'm using funtoo – and it's quite a couple of years!
  22. debian-sources-4.13.10 added some time back, currently with no keywords set. Please, give it a test nd report back the problems encountered.
  23. Funtoo mascot

    I am doing some sketches for a mascot of a honey badger. A honey badger might be a good candidate. What do you think?
  24. Can not sign into funtoo.bugs

    I can delete it for you. Send me a PM with details.
  25. Can not sign into funtoo.bugs

    That was the issue. Thank you!! Is there a way to delete the other account I made with the wrong email?
  1. Load more activity
×