Jump to content
funtoo forums
  • 0
quantum

Mask a Package

Question

Hi to all,

 

I am trying to mask the package dev-scheme/guile-2.0.11* since gnucash demand dev-scheme/guile-1.8.8.

 

Unfortently Gnucash does not support dev-scheme/guile-2.0.11* (I adapted the ebuild to check).

 

After masking the package dev-scheme/guile-2.0.11*

cat /etc/portage/package.mask 

=dev-scheme/guile-2.0.11-r1
 

Despite the mask of ev-scheme/guile-2.0.11-r, funtoo still try to merge it:

emerge -au @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-scheme/guile:0

  (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with
    dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed)
                    ^^^^^^^^                              


Nothing to merge; quitting.

How could i mask correctly the package =dev-scheme/guile-2.0.11-r1?

 

 

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Here is the result:

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-scheme/guile:0

  (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with
    dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed)

Share this post


Link to post
Share on other sites
  • 0

I'm with the "stable", and i've made an experiment installing gnucash.

 

When I try to update @world i'm in the same your situation.

 

But .... is necessary to update guile ? Which ebuilds requires strictly the 2.0.11  ? :wacko:

 

However, i've emerged gnucash; then emerge @preserved-rebuild (4 ebuilds recompiled with guile 1.8.x).

Making a revdep-rebuild only libreoffice-bin was reinstalled.

Share this post


Link to post
Share on other sites
  • 0

in general, if there is a new version of a package, then the system will try to install it, in case there is no conflict.

 

The question which is still open, is why i can't mask the package guile-2.0.11?

 

@Sandro, could you please try to mask this package like I did and see if it works?

Share this post


Link to post
Share on other sites
  • 0

1. gnucash does support guile2. however ebuild has never changed to enable it. It's possible to fix

2. as long as guile-1.8.8 installed and dev-scheme/guile-1.8.8-r99 installed, portage shouldn't try merging guile-2.0.11.  Its needed to see full emerge output, was it world update? 

3. masking this package not working, because it's unmasked in profiles (unmask overrides masks).

Share this post


Link to post
Share on other sites
  • 0

I followed the remark of @Oleg that gnucash ebuild could be adjested to guile2 and it worked.

No i do not see any more:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
 
dev-scheme/guile:0
 
  (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with
    dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed)

Before i merged my patched gnucash ebuild I run emerge -auDN --tree @world and i got the same as above.

 

I think funtoo wanted to build the latest available version of guild (which was 2.0.11-r1 in my case).

Nether the less, I still do not understand why the mask did not work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×