Jump to content

quantum

Members
  • Content Count

    29
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by quantum

  1. Hello together, in my new project I am reading all ebuilds from a given path and then I would like to split the filename (string) that i found to its components: atom base and atom version. For example: /var/git/overlay/sys-apps/portage-2.1.4_rc1 I would like to get back Atom base: portage Atom version: 2.1.4_rc1 It would be even better if atom version will be split to "major.minor.micro" and "rc". Thanks for your help
  2. @bcowan thanks for the explanation. Would it be great if your information "nvidia-kernel-modules needs to be installed separately, this is by design for container use cases." be added to NVIDIA Linux Display Drivers? Or the users should install the latest debian-sources-lts instead?
  3. In my case gfxcard-nvidia was in my mix-ins enabled, but i have VIDEO_CARDS in my make.conf as well. Do i need my VIDEO_CARDS in make.conf if i activated gfxcard-nvidia in mix-ins? What did the trick was installing x11-drivers/nvidia-kernel-modules. I did: emerge -uDva @world and the package x11-drivers/nvidia-kernel-modules was not part of it, so i guess the dependencies are not perfect or that it need to be installed separately.
  4. Hi all, unfortunately my Xorg do not work, so i needed to use another computer in order to write this post. My problem started after updating to the new Nvidia driver 435.21. This caused a not compatible API between my gentoo-sources 4.19.27. That is why I updated today to debian-sources 5.2.17-p1. After the update i validated that the selected kernel is the new debian kernel and prefomed: emerge @x11-module-rebuild The package x11-drivers/nvidia-driver-435.21 was installed as well. The problem ist that my xorg does not start. looking into Xorg.0.log reviles that no nvidia driver exists using the command find i was unable to find for this kernel files such as nvidia.ko Any idea?
  5. @cardinal does it make sense to install other version? Or this is a problem a comment problem on multiply release of mariadb?
  6. I am trying to activate my mariadb database. After installting mariadb: [ebuild R ] dev-db/mariadb-10.4.6:0/18::core-server-kit USE="server -backup -bindist -client-libs -cracklib -debug -extraengine -galera -innodb-lz4 -innodb-lzo -innodb-snappy -jdbc -jemalloc -kerberos -latin1 -libressl -mroonga -numa -odbc -oqgraph -pam -perl -profiling -rocksdb (-selinux) -sphinx -sst-mariabackup -sst-rsync -static -systemd -systemtap -tcmalloc -test -tokudb -xml -yassl" 0 KiB [ebuild R ] virtual/mysql-5.6-r12:0/18::core-server-kit USE="server -embedded -static" 0 KiB After the installtion I wrote: emerge --config =dev-db/mariadb-10.4.6 and i got: Configuring pkg... * Trying to get password for mysql 'root' user from 'mysql' section ... /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory * Trying to get password for mysql 'root' user from 'client' section ... /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory * Please provide a password for the mysql 'root'@'localhost' user now * or through the /root/.my.cnf file. * Avoid ["'\_%] characters in the password * Not entering a password defaults to UNIX authentication > * Retype the password > * Creating the mysql database and setting proper permissions on it ... * Command: usr/bin/mysql_install_db --basedir=/usr --loose-skip-grant-tables --loose-skip-host-cache --loose-skip-name-resolve --loose-skip-networking --loose-skip-slave-start --loose-skip-ssl --loose-skip-log-bin --loose-skip-relay-log --loose-skip-slow-query-log --loose-skip-external-locking --loose-skip-log-slave-updates --datadir=//var/lib/mysql --tmpdir=/ * ERROR: dev-db/mariadb-10.4.6::core-server-kit failed (config phase): * Failed to initialize mysqld. Please review /var/log/mysql/mysqld.err AND /var/tmp/portage/dev-db/mariadb-10.4.6/temp/mysql_install_db.log * * Call stack: * ebuild.sh, line 93: Called pkg_config * environment, line 4492: Called die * The specific snippet of code: * die "Failed to initialize mysqld. Please review ${EPREFIX}/var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"; * * If you need support, post the output of `emerge --info '=dev-db/mariadb-10.4.6::core-server-kit'`, * the complete build log and the output of `emerge -pqv '=dev-db/mariadb-10.4.6::core-server-kit'`. !!! When you file a bug report, please include the following information: GENTOO_VM= CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm" JAVACFLAGS="" COMPILER="" and of course, the output of emerge --info =mariadb-10.4.6 * The complete build log is located at '/var/tmp/portage/dev-db/mariadb-10.4.6/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment'. * Working directory: '/var/tmp/portage/dev-db/mariadb-10.4.6/temp' * S: '/var/tmp/portage/dev-db/mariadb-10.4.6/work/mariadb-10.4.6' The output of file /var/tmp/portage/dev-db/mariadb-10.4.6/temp/mysql_install_db.log: sh: usr/bin/mysql_install_db: No such file or directory On my computer I have the file mysql_install_db at a different directory: /usr/share/mariadb/scripts/mysql_install_db Any idea how to solve this problem?
  7. What is the difference between dev-ros and ros-meta categories? Since Funtoo support only one ROS distribution, it is to my not clear the seperation to dev-ros and ros-meta. In case of multi ROS distribution, the packages in dev-ros, the specific to a distribution need to be some how connected to the same ROS distribution. Regards
  8. meanwhile, I decided to try implementing it.
  9. Hi to all, i am using Funtoo together with ROS (Robotic Operation Systems). In ROS there are many distributions and each one is considered closed for it self. In Funtoo there is only one version available, the Melodic, which is only shortly got the status "Recommended". There exists a ros-overlay, which generate its ebuilds. From my experience it works pretty well, but it is a complete solution. I was facing missing dependencies problem as well. Would it be conceivable to create a ROS kit and to place there all the different ROS distributions? I would be more then happy to do it my self, but I would like to know in advance that is idea fits the Funtoo why of thinking. What do you think?
  10. @Oleg VinichenkoThank you for your replay. if i understand you correctly, then in my case of using python 3.6, then there is no problem. What will happen if someone else with python 2.7 only would like to install this package as well? Then configparser will be needed. What i am missing in your answer is a solution to the case that the someone else and I could use the same ebuild. Is there way to write one ebuild for both cases?
  11. Dear all, for atom-1.3.1 I would like to write an ebuild pysl-0.21.1 As i looked in setup.py, I saw: install_requires=[ 'configparser; python_version<"3.0"', 'future>=0.14.0', 'futures; python_version<"3.2"', 'jedi>=0.12', 'python-jsonrpc-server', 'pluggy' ], extras_require={ 'all': [ 'autopep8', 'mccabe', 'pycodestyle', 'pydocstyle>=2.0.0', 'pyflakes>=1.6.0', 'rope>-0.10.5', 'yapf', ], 'autopep8': ['autopep8'], 'mccabe': ['mccabe'], 'pycodestyle': ['pycodestyle'], 'pydocstyle': ['pydocstyle>=2.0.0'], 'pyflakes': ['pyflakes>=1.6.0'], 'rope': ['rope>0.10.5'], 'yapf': ['yapf'], 'test': ['tox', 'versioneer', 'pytest', 'mock', 'pytest-cov', 'coverage'], }, How could i write something like 'configparser; python_version<"3.0"' in my ebuild? Would it be correct to see all the packages below install_requires as DEPEND and all packages below extras_require as RDEPEND? Regards
  12. As part of my try to build ROS2 Bouncy distribution with Funtoo I added ros-overlay to my repository. At present i get a build error for the package ros-bouncy/ament_cmake_core-0.5.1 Since i was unable to upload the file, there here is my /var/tmp/portage/ros-bouncy/ament_cmake_core-0.5.1/temp/build.log: As i tried to investigate the problem, i found that i do have package ament_package, but at a different path: As you can see, /opt/ros/bouncy/lib64/python3.6/site-packages rather then /usr/lib64/python3.6/site-packages. My guess is that the PYTHONPATH which is set in /var/git/overlay/ros-overlay/eclass/ament-cmake.eclass is not correct.
  13. quantum

    space is full

    Problem is solved with the help of: https://btrfs.wiki.kernel.org/index.php/Problem_FAQ#I_get_.22No_space_left_on_device.22_errors.2C_but_df_says_I.27ve_got_lots_of_space I used the command: btrfs fi balance start and now it works.
  14. quantum

    space is full

    Hi all, since two days i have follwoing problem: My home partition shows allwas that it is full alought using df -h : Filesystem Size Used Avail Use% Mounted on /dev/sda7 20G 5.3G 0 100% /home I don't understand how my 5.3G occupy the all 20G... After deleting files from /home, there was some free space in /home. Unfortently, after restarting the computer, there was once again 100% used. lsof do not show any open file under /home Any ideas?
  15. quantum

    Mask a Package

    I followed the remark of @Oleg that gnucash ebuild could be adjested to guile2 and it worked. No i do not see any more: WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-scheme/guile:0 (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed) Before i merged my patched gnucash ebuild I run emerge -auDN --tree @world and i got the same as above. I think funtoo wanted to build the latest available version of guild (which was 2.0.11-r1 in my case). Nether the less, I still do not understand why the mask did not work.
  16. quantum

    Mask a Package

    how can i change my unmasked in profiles?
  17. quantum

    Mask a Package

    Is this a bug? If yes, then where could i submit it?
  18. quantum

    Mask a Package

    in general, if there is a new version of a package, then the system will try to install it, in case there is no conflict. The question which is still open, is why i can't mask the package guile-2.0.11? @Sandro, could you please try to mask this package like I did and see if it works?
  19. quantum

    Mask a Package

    Here is the result: These are the packages that would be merged, in order: Calculating dependencies... done! Total: 0 packages, Size of downloads: 0 KiB WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-scheme/guile:0 (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed)
  20. quantum

    Mask a Package

    Hi to all, I am trying to mask the package dev-scheme/guile-2.0.11* since gnucash demand dev-scheme/guile-1.8.8. Unfortently Gnucash does not support dev-scheme/guile-2.0.11* (I adapted the ebuild to check). After masking the package dev-scheme/guile-2.0.11* cat /etc/portage/package.mask =dev-scheme/guile-2.0.11-r1 Despite the mask of ev-scheme/guile-2.0.11-r, funtoo still try to merge it: emerge -au @world These are the packages that would be merged, in order: Calculating dependencies... done! Total: 0 packages, Size of downloads: 0 KiB WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-scheme/guile:0 (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed) ^^^^^^^^ Nothing to merge; quitting. How could i mask correctly the package =dev-scheme/guile-2.0.11-r1?
  21. I don't really know what it did that made it work, but it works. The last steps i did were: starting eclipse from root (worked after small modification of the file /usr/bin/eclipse-bin-4.3) adding -XX:-UseBiasedLocking to the last line which now looks like: exec "${ECLIPSE_BIN}" -vm $(java-config --java) "$@" "${ECLIPSE_USER_ARGS}" -vmargs ${VM_ARGS} -XX:-UseBiasedLocking 2. remove ~/.eclipse directory 3. java-config --set-user-vm=oracle-jdk-bin-1.8 4. java-config-2 --set-user-vm=oracle-jdk-bin-1.8 5. start eclipse
  22. unfortunately not. I think my problem is somewhere in my java.library.path. java-config-2 -l [ant-core] Java-based build tool similar to 'make' that uses XML configuration files (/usr/share/ant-core/package.env) [swt-4.2] GTK based SWT Library (/usr/share/swt-4.2/package.env) [eclipse-ecj-4.5] Eclipse Compiler for Java (/usr/share/eclipse-ecj-4.5/package.env) [vuze] BitTorrent client in Java, formerly called Azureus (/usr/share/vuze/package.env) [javacc] Java Compiler Compiler - The Java Parser Generator (/usr/share/javacc/package.env) [junit] Simple framework to write repeatable tests (/usr/share/junit/package.env) [ant-eclipse-ecj-4.5] Ant Compiler Adapter for Eclipse Java Compiler (/usr/share/ant-eclipse-ecj-4.5/package.env) [commons-lang-2.1] Commons components to manipulate core java classes (/usr/share/commons-lang-2.1/package.env) [json-simple] Simple Java toolkit for JSON (/usr/share/json-simple/package.env) [swt-3.8] GTK based SWT Library (/usr/share/swt-3.8/package.env) [commons-cli-1] A Java library for working with the command line arguments and options (/usr/share/commons-cli-1/package.env) [log4j] A low-overhead robust logging package for Java (/usr/share/log4j/package.env) but if i try to set my default java CLASSPATH i get following error: java-config-2 --set-system-classpath=log4j,swt-4.2,eclipse-ecj-4.5 !!! WARNING: Setting a user and system classpath is deprecated, this option will be removed from future versions. !!! ERROR: Package log4j was not found! !!! ERROR: Package swt-4.2 was not found! !!! ERROR: Package eclipse-ecj-4.5 was not found! >>> Regenerating /etc/ld.so.cache... !!! ALERT: If you want the changes too take effect in your current session, you should update your environment by running: source /etc/profile althought the packages log4j, swt-4.2 and eclipse-ecj-4.5 are installed.
  23. I was able to make netbeans to work. There was a difference between my root java config and user. After choosing the correct JDK it sarted to work. java-config --list-available-vms The following VMs are available for generation-2: *) Oracle JDK 1.8.0.92 [oracle-jdk-bin-1.8] 2) Oracle JRE 1.8.0.92 [oracle-jre-bin-1.8]
  24. I just tried to start NetBeans IDE 8.1 and i got following message: The JDK is missing and is required to run some NetBeans modules Please use the --jdkhome command line option to specify a JDK How could i test in Funtoo if my Java path are correctly set? Since it seems that all is connected together
×
×
  • Create New...