Jump to content
funtoo forums

quantum

Members
  • Content Count

    19
  • Joined

  • Last visited

1 Follower

About quantum

  • Rank
    Member

Recent Profile Visitors

190 profile views
  1. quantum

    [Solved] ebuild for pysl package

    @Oleg VinichenkoThank you for your replay. if i understand you correctly, then in my case of using python 3.6, then there is no problem. What will happen if someone else with python 2.7 only would like to install this package as well? Then configparser will be needed. What i am missing in your answer is a solution to the case that the someone else and I could use the same ebuild. Is there way to write one ebuild for both cases?
  2. quantum

    [Solved] ebuild for pysl package

    Dear all, for atom-1.3.1 I would like to write an ebuild pysl-0.21.1 As i looked in setup.py, I saw: install_requires=[ 'configparser; python_version<"3.0"', 'future>=0.14.0', 'futures; python_version<"3.2"', 'jedi>=0.12', 'python-jsonrpc-server', 'pluggy' ], extras_require={ 'all': [ 'autopep8', 'mccabe', 'pycodestyle', 'pydocstyle>=2.0.0', 'pyflakes>=1.6.0', 'rope>-0.10.5', 'yapf', ], 'autopep8': ['autopep8'], 'mccabe': ['mccabe'], 'pycodestyle': ['pycodestyle'], 'pydocstyle': ['pydocstyle>=2.0.0'], 'pyflakes': ['pyflakes>=1.6.0'], 'rope': ['rope>0.10.5'], 'yapf': ['yapf'], 'test': ['tox', 'versioneer', 'pytest', 'mock', 'pytest-cov', 'coverage'], }, How could i write something like 'configparser; python_version<"3.0"' in my ebuild? Would it be correct to see all the packages below install_requires as DEPEND and all packages below extras_require as RDEPEND? Regards
  3. As part of my try to build ROS2 Bouncy distribution with Funtoo I added ros-overlay to my repository. At present i get a build error for the package ros-bouncy/ament_cmake_core-0.5.1 Since i was unable to upload the file, there here is my /var/tmp/portage/ros-bouncy/ament_cmake_core-0.5.1/temp/build.log: As i tried to investigate the problem, i found that i do have package ament_package, but at a different path: As you can see, /opt/ros/bouncy/lib64/python3.6/site-packages rather then /usr/lib64/python3.6/site-packages. My guess is that the PYTHONPATH which is set in /var/git/overlay/ros-overlay/eclass/ament-cmake.eclass is not correct.
  4. quantum

    space is full

    Problem is solved with the help of: https://btrfs.wiki.kernel.org/index.php/Problem_FAQ#I_get_.22No_space_left_on_device.22_errors.2C_but_df_says_I.27ve_got_lots_of_space I used the command: btrfs fi balance start and now it works.
  5. quantum

    space is full

    Hi all, since two days i have follwoing problem: My home partition shows allwas that it is full alought using df -h : Filesystem Size Used Avail Use% Mounted on /dev/sda7 20G 5.3G 0 100% /home I don't understand how my 5.3G occupy the all 20G... After deleting files from /home, there was some free space in /home. Unfortently, after restarting the computer, there was once again 100% used. lsof do not show any open file under /home Any ideas?
  6. quantum

    Mask a Package

    I followed the remark of @Oleg that gnucash ebuild could be adjested to guile2 and it worked. No i do not see any more: WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-scheme/guile:0 (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed) Before i merged my patched gnucash ebuild I run emerge -auDN --tree @world and i got the same as above. I think funtoo wanted to build the latest available version of guild (which was 2.0.11-r1 in my case). Nether the less, I still do not understand why the mask did not work.
  7. quantum

    Mask a Package

    how can i change my unmasked in profiles?
  8. quantum

    Mask a Package

    Is this a bug? If yes, then where could i submit it?
  9. quantum

    Mask a Package

    in general, if there is a new version of a package, then the system will try to install it, in case there is no conflict. The question which is still open, is why i can't mask the package guile-2.0.11? @Sandro, could you please try to mask this package like I did and see if it works?
  10. quantum

    Mask a Package

    Here is the result: These are the packages that would be merged, in order: Calculating dependencies... done! Total: 0 packages, Size of downloads: 0 KiB WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-scheme/guile:0 (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed)
  11. quantum

    Mask a Package

    Hi to all, I am trying to mask the package dev-scheme/guile-2.0.11* since gnucash demand dev-scheme/guile-1.8.8. Unfortently Gnucash does not support dev-scheme/guile-2.0.11* (I adapted the ebuild to check). After masking the package dev-scheme/guile-2.0.11* cat /etc/portage/package.mask =dev-scheme/guile-2.0.11-r1 Despite the mask of ev-scheme/guile-2.0.11-r, funtoo still try to merge it: emerge -au @world These are the packages that would be merged, in order: Calculating dependencies... done! Total: 0 packages, Size of downloads: 0 KiB WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-scheme/guile:0 (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed) ^^^^^^^^ Nothing to merge; quitting. How could i mask correctly the package =dev-scheme/guile-2.0.11-r1?
  12. I don't really know what it did that made it work, but it works. The last steps i did were: starting eclipse from root (worked after small modification of the file /usr/bin/eclipse-bin-4.3) adding -XX:-UseBiasedLocking to the last line which now looks like: exec "${ECLIPSE_BIN}" -vm $(java-config --java) "$@" "${ECLIPSE_USER_ARGS}" -vmargs ${VM_ARGS} -XX:-UseBiasedLocking 2. remove ~/.eclipse directory 3. java-config --set-user-vm=oracle-jdk-bin-1.8 4. java-config-2 --set-user-vm=oracle-jdk-bin-1.8 5. start eclipse
  13. unfortunately not. I think my problem is somewhere in my java.library.path. java-config-2 -l [ant-core] Java-based build tool similar to 'make' that uses XML configuration files (/usr/share/ant-core/package.env) [swt-4.2] GTK based SWT Library (/usr/share/swt-4.2/package.env) [eclipse-ecj-4.5] Eclipse Compiler for Java (/usr/share/eclipse-ecj-4.5/package.env) [vuze] BitTorrent client in Java, formerly called Azureus (/usr/share/vuze/package.env) [javacc] Java Compiler Compiler - The Java Parser Generator (/usr/share/javacc/package.env) [junit] Simple framework to write repeatable tests (/usr/share/junit/package.env) [ant-eclipse-ecj-4.5] Ant Compiler Adapter for Eclipse Java Compiler (/usr/share/ant-eclipse-ecj-4.5/package.env) [commons-lang-2.1] Commons components to manipulate core java classes (/usr/share/commons-lang-2.1/package.env) [json-simple] Simple Java toolkit for JSON (/usr/share/json-simple/package.env) [swt-3.8] GTK based SWT Library (/usr/share/swt-3.8/package.env) [commons-cli-1] A Java library for working with the command line arguments and options (/usr/share/commons-cli-1/package.env) [log4j] A low-overhead robust logging package for Java (/usr/share/log4j/package.env) but if i try to set my default java CLASSPATH i get following error: java-config-2 --set-system-classpath=log4j,swt-4.2,eclipse-ecj-4.5 !!! WARNING: Setting a user and system classpath is deprecated, this option will be removed from future versions. !!! ERROR: Package log4j was not found! !!! ERROR: Package swt-4.2 was not found! !!! ERROR: Package eclipse-ecj-4.5 was not found! >>> Regenerating /etc/ld.so.cache... !!! ALERT: If you want the changes too take effect in your current session, you should update your environment by running: source /etc/profile althought the packages log4j, swt-4.2 and eclipse-ecj-4.5 are installed.
  14. I was able to make netbeans to work. There was a difference between my root java config and user. After choosing the correct JDK it sarted to work. java-config --list-available-vms The following VMs are available for generation-2: *) Oracle JDK 1.8.0.92 [oracle-jdk-bin-1.8] 2) Oracle JRE 1.8.0.92 [oracle-jre-bin-1.8]
  15. I just tried to start NetBeans IDE 8.1 and i got following message: The JDK is missing and is required to run some NetBeans modules Please use the --jdkhome command line option to specify a JDK How could i test in Funtoo if my Java path are correctly set? Since it seems that all is connected together
×