Jump to content
  • 0
yungstorm

error when updating

Question

I keep getting this error because my terminal emulator of choice termite is in the portage overlays, but it depends on x11-libs/gnome-pty-helper-0.40.2. I tried fixing this by adding the gentoo overlay, but that just borked everything then I removed it and reverted my portage to what I was before. I'm fresh out of ideas help please?

 

emerge: there are no ebuilds to satisfy ">=x11-libs/gnome-pty-helper-0.40.2".
(dependency required by "x11-libs/vte-0.40.2::nightmare" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I run current lxde x86_64
Emerge layman,add nightmare overlay.
Add nightmare overlay to /etc/portage/package.mask to stop override of matching funtoo packages which would create version conflict.

*/*::nightmare

Add the package I want from nightmare overlay to /etc/portage/package.unmask

x11-terms/termite::nightmare
funtoo rj # emerge -pv x11-terms/termite

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   #] x11-libs/vte-0.38.3:2.91::nightmare [0.28.2-r207:0::gentoo] USE="termite-patch -debug -glade -introspection -vala" 0 kB
[ebuild  N    #] x11-terms/termite-9999::nightmare  0 kB

Total: 2 packages (1 new, 1 in new slot), Size of downloads: 0 kB

!!! The following update has been skipped due to unsatisfied dependencies:

x11-libs/vte:2.91

emerge: there are no ebuilds to satisfy ">=x11-libs/gnome-pty-helper-0.40.2".
(dependency required by "x11-libs/vte-0.40.2::nightmare" [ebuild])


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by x11-terms/termite-9999::nightmare
# required by x11-terms/termite (argument)
# /etc/portage/package.mask:
=x11-libs/vte-0.38.3

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-terms/termite-9999::nightmare
# required by x11-terms/termite (argument)
=x11-libs/vte-0.38.3 termite-patch

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

I ignore this

x11-libs/vte:2.91

emerge: there are no ebuilds to satisfy ">=x11-libs/gnome-pty-helper-0.40.2".
(dependency required by "x11-libs/vte-0.40.2::nightmare" [ebuild])

and follow package.unmask and package.use instructions.
 
Add to /etc/portage/package.unmask

=x11-libs/vte-0.38.3

Add to /etc/portage/package.use

=x11-libs/vte-0.38.3 termite-patch

funtoo rj # emerge -av x11-terms/termite

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   #] x11-libs/vte-0.38.3:2.91::nightmare [0.28.2-r207:0::gentoo] USE="termite-patch -debug -glade -introspection -vala" 0 kB
[ebuild  N    #] x11-terms/termite-9999::nightmare  0 kB

Total: 2 packages (1 new, 1 in new slot), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] 

Emerge completes without error.

funtoo rj # eix -J
[I] x11-libs/vte
     Available versions:  
     (0)    0.28.2-r207
     (2.90) 0.36.3
     (2.91) 0.38.2 0.38.3 (~)0.38.3[1] [m](~)0.40.2[1]
       {+crypt debug glade +introspection python termite-patch vala PYTHON_ABIS="2.6 2.7"}
     Installed versions:  0.28.2-r207(05:15:26 PM 07/04/2015)(python -debug -introspection PYTHON_ABIS="2.7 -2.6") 0.38.3(2.91)[1](01:04:46 AM 08/22/2015)(termite-patch -debug -glade -introspection -vala)
     Homepage:            https://wiki.gnome.org/action/show/Apps/Terminal/VTE
     Description:         Library providing a virtual terminal emulator widget

[I] x11-terms/termite [1]
     Available versions:  (~)7 (~)8 (~)9 (~)10 (~)9999
     Installed versions:  9999(01:05:06 AM 08/22/2015)
     Homepage:            https://github.com/thestinger/termite
     Description:         A keyboard-centric VTE-based terminal

[1] "nightmare" /var/lib/layman/nightmare

Found 2 matches.

Share this post


Link to post
Share on other sites
  • 0

You're on "stable" or current ?

caause in my system (Stable) compiles successfully).

 

You can paste the stdout/stderr (/var/tmp/portage/x11-libs/gnome-pty-helper-0.4.2/tmp/build.log)

Share this post


Link to post
Share on other sites
  • 0

You're on "stable" or current ?

caause in my system (Stable) compiles successfully).

 

You can paste the stdout/stderr (/var/tmp/portage/x11-libs/gnome-pty-helper-0.4.2/tmp/build.log)

It's saying that isn't a valid directory :( and i'm on current

Share this post


Link to post
Share on other sites
  • 0

Funtoo has dev-scheme/termite-0.15 in the current tree, and it depends on gnome-pty-helper-0.38.3

 

Maybe you haven't really removed the gentoo overlay version of termite?

 

EDIT:  Disregard, wrong termite.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...