Jump to content

overkill

Members
  • Content Count

    129
  • Joined

  • Last visited

  • Days Won

    11

Everything posted by overkill

  1. Did you follow this guide? https://www.funtoo.org/LXD I think it's the one I used originally. I could only find it again via a google search. Couldn't find it via the menus on www.funtoo.org.
  2. I'm not sure about exim, but it think it's common for <> to be used for forwarding. Because of this, some servers will not accept forwarded mail because of the null sender address. Is that what you are running into? One should be able to check the logs to see what indeed is being used as the sender address on forwarded messages.
  3. The Funtoo Install Guide says it should be a symlink. I think I may have seen a emerge message mentioning to set the timezone with tzselect. So I did. LOL! Changing the file to a symlink fixed the Time/Date Display. Thanks!!!
  4. As a symlink?, no. Forgot how I set it, but it is in the /etc/localtime file. I remember the old way was to symlink it. Then it change in funtoo some time ago (years?). I'll have to browse the install guide to see if it is there. # date Sun Dec 16 12:31:54 CST 2018 CST is Central Standard Time in the U.S., which is set by America Chicago.
  5. I deleted my new overlay, and used /etc/portage/repos.conf/overkill.conf to define my existing /usr/local/portage overlay. All is good again
  6. I've just upgraded to Funtoo 1.3. My overlay seems to be broken. It's still in the old /usr/local/portage directory. Before the upgrade, it did work. But equery always shows the O even if there isn't an overlay ebuild for that package. [--O] [ ] www-client/chromium-70.0.3538.67:0 [--O] [ ] www-client/chromium-70.0.3538.67-r1:0 [--O] [ ] www-client/chromium-71.0.3578.10:0 [I-O] [ ] www-client/chromium-71.0.3578.30:0 [--O] [M ] www-client/chromium-72.0.3595.2:0 I've followed the new overlay guide (https://www.funtoo.org/Local_Overlay) and made a new overlay in /var/git/
  7. Just upgraded to Gnome 3.30. The time/date display in the middle of the top bar is always UTC. My system clock is using local time America/Chicago for Central Standard Time. Using the settings utility in gnome, it shows the correct time zone, but it says UTC America/Chicago. No matter what I change it to, it will still show UTC time. If I manually change the time with the gnome settings date / time control, it will change the system time to UTC, but the time/date will be correct. How do I force gnome to NOT BE STUCK in UTC?
  8. Looks like you are trying to run the command as a non-root user. Did you try running as root?
  9. I was planning on migrating to a different CPU in the short term. Yes, here it is # cat /etc/ego.conf # This is the ego.conf file [global] release = 1.3 Here it is, but I'm having a problem with empathy, not enchant. Are they related? # emerge enchant -av These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] app-text/enchant-2.2.1-r1:0/2::text-kit USE="hunspell -aspell -static-libs -test" 0 KiB Total: 1 package (1 reinstall), Size of downloads: 0 KiB Would you like to merge these packages? [Yes/No]
  10. I do use gnome, so the mix in is enabled. # epro show === Enabled Profiles: === arch: x86-64bit build: current subarch: (not set) flavor: desktop mix-ins: gnome === Python kit: === branch: 3.7-release === All inherited flavor from desktop flavor: === workstation (from desktop flavor) core (from workstation flavor) minimal (from core flavor) === All inherited mix-ins from desktop flavor: === X (from workstation flavor)
  11. Can't finish `emerge @preserved-rebuild`. Empathy fails everytime. go keeps being included in the list, just like it says in the guide. I did uninstall it and reinstall it. # emerge @preserved-rebuild -av These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] dev-lang/go-1.11.2:0/1.11.2::lang-kit USE="-gccgo" 0 KiB [ebuild U ] net-im/empathy-3.12.14::gnome-kit [3.12.12::gentoo] USE="geolocation gnome gnome-online-accounts map spell v4l -debug -test" 0 KiB Total: 2 packages (1 upgrade, 1 reinstall), Size of downloads: 0 KiB Wou
  12. Couldn't wait. Had to uninstall 3 packages to proceed. # emerge -C =compiler-rt-sanitizers-6.0.0 -a # emerge -C =webkit-gtk-2.4.11-r2 -a # emerge -C =grilo-plugins-0.2.17 Now `emege @preserved-rebuild works! # emerge @preserved-rebuild -av These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] dev-lang/go-1.11.2:0/1.11.2::lang-kit USE="-gccgo" 0 KiB [ebuild R ] dev-scheme/guile-2.0.11-r1:0/2.0.11::core-kit USE="deprecated nls regex threads -debug -debug-malloc -emacs -networking -static" 0 KiB [ebuild UD ] dev-libs/pro
  13. Good news, bad news. I was able to complete `emerge world -uDNav`, but cannot do a `emerge @preserved-rebuild -a`. # emerge @preserved-rebuild -av These are the packages that would be merged, in order: Calculating dependencies... done! emerge: there are no ebuilds to satisfy "sys-libs/compiler-rt-sanitizers:6.0.0". (dependency required by "@preserved-rebuild" [argument]) Checking the tree with equery shows: # equery l -po compiler-rt-sanitizers * Searching for compiler-rt-sanitizers ... [--O] [ ] sys-libs/compiler-rt-sanitizers-4.0.1:4.0.1 [--O] [ ] sys-libs/compiler-rt-s
  14. I did remove xorg-server as instructed in the guide. I also cut and pasted the sed commands. My major fault I believe was that I had done a partial 1.2 upgrade back around May. By partial I mean not all of the kits moved to 1.2, only a selection of kits were specified as 1.2-prime. I followed those instructions and successfully upgraded. I believe I posted my ego.conf file in my first post of this thread. I didn't upgrade (ego sync & emerge world -uDNav) that installation, I just jumped right into the 1.3 upgrade guide. So yes, my mistake, but I did follow the guides, I just fa
  15. I had to fix some issues -- don't remember what exactly the error was -- about too many versions trying to be installed. It suggested to use --verbose-conflicts but that didn't work. Basically I had to reinstall any [installed] package(s) with a lower version dependency. After I got those cleaned up, I attacked the errors like in my last post. In the last post, I would have run `emerge libcanberra --ignore-world -1av`. After sucessfully installing, then I would `emerge world -uDNav` again and deal with the next problem. Had to uninstall gparted. I couldn't fix that one. I also got desp
  16. It merged, but now other programs show up. I'm afraid it will just keep continuing until I've emerge 1256 packages manually ? I've run `emerge world -uDNav` several times and the output changes but the "there are no ebuilds to satisfy ">=dev-libs/glib-2.32:2[abi_x86_64(-)]" " remains. # emerge world -uDNav These are the packages that would be merged, in order: Calculating dependencies... done! emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.32:2[abi_x86_64(-)]". (dependency required by "media-libs/libcanberra-0.30-r5::gentoo" [installed]) (dependency required by "
  17. Still stuck at this point. # emerge world -uDNav These are the packages that would be merged, in order: Calculating dependencies... done! emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.34.3:2[abi_x86_64(-)]". (dependency required by "net-libs/libnice-0.1.13::gentoo" [installed]) (dependency required by "media-plugins/gst-plugins-libnice-0.1.13-r100::gentoo" [installed]) (dependency required by "net-libs/farstream-0.2.8-r1::gentoo" [installed]) (dependency required by "net-im/pidgin-2.13.0::net-kit[gstreamer]" [installed]) (dependency required by "@selected" [set]) (depend
  18. OK. Done. Looks good. # emerge -1av glib gdbus-codegen at-spi2-core gtk+ atk qtcore colord qtgui libgusb --ignore-world These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] dev-util/gdbus-codegen-2.58.1::gnome-kit PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7" 0 KiB [ebuild R ] dev-libs/glib-2.58.1:2::gnome-kit USE="dbus mime xattr (-fam) (-selinux) -static-libs -systemtap -test -utils" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7" 0 KiB [ebuild R ] dev-qt/qtcore-5.11.2-r1:5/
  19. I added python_single_target_python2_7 and that eliminated the unmet requirements. Now I have a new snag # emerge world -uDNav These are the packages that would be merged, in order: Calculating dependencies... done! emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.34.3:2[abi_x86_64(-)]". (dependency required by "media-libs/libquvi-0.9.4-r1::gentoo" [installed]) (dependency required by "dev-libs/totem-pl-parser-3.26.1::gnome-kit[quvi]" [ebuild]) (dependency required by "media-libs/grilo-0.3.6::gnome-kit[playlist]" [ebuild]) (dependency required by "gnome-base/gnome-control-
  20. Got pass `emerge system -uDNav --ignore-world`. I had to remove nearly all the x11-proto/ packages due to file collisions with xorg-proto. Now I'm attempting to run `emerge world -uDNav` as per the 1.3 upgrade guide. I'm hitting a snag with "unmet requirements". I know how to add the requirement to my package.use file, but I am unsure of the correct selection. # emerge world -uDNav These are the packages that would be merged, in order: Calculating dependencies \ !!! Problem resolving dependencies for gnome-extra/chrome-gnome-shell from @selected ... done! !!! The ebuild selecte
  21. Anything that helps automatically solves conflicts I support 100%. Ever time I see them I just glaze over and don't know where to start. Making the wrong choice can make things even worse. Thanks for helping me out. I don't think I would have made it without. But as usual with funtoo and gentoo, I learned a great deal.
  22. I think it took me some practice to understand your tip about the "installed" packages. Running `emerge system -uDNav --ignore-world` would almost work. There were two "installed" files -- qtcore-4.8.7-r4 and qtgui-4.8.7. I update those to current versions using `emerge qtcore qtgui --ignore-world -av` and then ran `emerge system -uDNav --ignore-world again and it still failed. I used quickpkg to back all the qtcore and qtqui versions up, then removed the old 4.8.7 versions. Ran the `emerge system -uDNav --ignore-world` command again and the output changed, wanting to add # required
  23. Got a blocker with this one: # emerge dev-libs/glib gtk+ gobject-introspection glib-utils gtk-update-icon-cache qtgui qtcore -av --ignore-world These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] dev-python/setuptools-40.0.0::python-modules-kit [36.4.0::python-modules-kit] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7%" 830 KiB [ebuild U ] dev-python/certifi-2018.8.24::python-modules-kit [2018.4.16::python-modules-kit] PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -p
  24. It was there. No matter what, it seems dev-libs/glib is the stickler. There is no glib-2.48.2 and no gdbus-codegen-2.48.2 in the tree: # equery l -po dev-libs/glib * Searching for glib in dev-libs ... [I--] [??] dev-libs/glib-2.48.2:2 [--O] [ ] dev-libs/glib-2.58.1:2 # equery l -po gdbus-codegen * Searching for gdbus-codegen ... [I--] [??] dev-util/gdbus-codegen-2.48.2:0 [--O] [ ] dev-util/gdbus-codegen-2.58.1:0 Should I just emerge both with --nodeps?
  25. Still hangs up on dev-libs/glib. # emerge -1av glib at-spi2-core gtk+ atk qtcore colord qtgui libgusb --ignore-world These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] dev-python/setuptools-40.0.0::python-modules-kit [36.4.0::python-modules-kit] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7%" 830 KiB [ebuild U ] dev-python/certifi-2018.8.24::python-modules-kit [2018.4.16::python-modules-kit] PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7" 144 K
×
×
  • Create New...