Jump to content
  • 0

I don't get grub on reboot


rekena

Question

Hi, I have been using gentoo for a long time and wanted to try funtoo, I installed it recently but the grub does not load me when rebooting the system.
This is my configuration.
Thanks a lot!
  •       FSTAB

 

# == IMPORTANT ==============================================================
# The 3 lines below need to be *uncommented* and adjusted for your system
# ===========================================================================

 /dev/nvme0n1p7        /boot        ext2        noauto,noatime        1 2
 /dev/nvme0n1p8        none        swap       sw                      0 0
 /dev/nvme0n1p5        /root        ext4        noatime               0 1

 

  •     GRUB
set timeout=3

if [ -s $prefix/grubenv ]; then
    load_env
fi

function savedefault {
    if [ -z "{boot_once}" ]; then
        saved_entry="${chosen}"
        save_env saved_entry
    fi
}

  insmod part_msdos
  insmod ext2
  set root=(hostdisk//dev/nvme0n1,msdos7)
  search --no-floppy --fs-uuid --set 471ee74b-e33d-4b60-ad6b-119b7e92e6fd
if loadfont /grub/fonts/unicode.pf2; then
   set gfxmode=text
   insmod all_video
   terminal_output gfxterm
fi

set menu_color_normal=cyan/blue
set menu_color_highlight=blue/cyan

menuentry "Funtoo Linux genkernel - kernel-debian-sources-x86_64-5.9.6_p1" {
  insmod part_msdos
  insmod ext2
  set root=(hostdisk//dev/nvme0n1,msdos7)
  search --no-floppy --fs-uuid --set 471ee74b-e33d-4b60-ad6b-119b7e92e6fd
  linux /kernel-debian-sources-x86_64-5.9.6_p1 nomodeset real_root=/dev/nvme0n1p5 rootfstype=ext4 rand_id=TG3W8IBB
  initrd /initramfs-debian-sources-x86_64-5.9.6_p1
  set gfxpayload=keep
}

if [ ! "${next_entry}" = "" ] ; then
    set default="${next_entry}"
    set next_entry=
    save_env next_entry
    set boot_once=true
elif [ ! "${saved_entry}" = "" ]; then
    set default="${saved_entry}"
else
    set default=0
fi
  •     BOOT.CONF

 

boot {
    generate grub
    default "Funtoo Linux genkernel"
    timeout 3
}

"Funtoo Linux" {
    kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
    kernel kernel[-v]
    initrd initramfs[-v]

    # IMPORTANT: Most users will want to remove "nomodeset", below!
    #
    # It is included in the initial install to ensure that virtually all
    # systems boot up with a readable initial console.

    # But all graphics drivers (with the one exception of the proprietary
    # NVIDIA drivers) REQUIRE mode setting to be enabled, and thus the
    # nomodeset option must be REMOVED prior to setting up a graphical
    # environment or X will not start. Remember to run "ego boot update" after
    # removing the option, and then reboot prior to configuring X.

    # Also note that if you are using a 4K or higher resolution display, your
    # console text may become very small after enabling kernel mode setting
    # since it will display your console at the native resolution of your
    # display.

    params += real_root=auto rootfstype=auto nomodeset
}

 

 

Edited by rekena
simple
Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
On 11/30/2020 at 3:43 PM, rekena said:

but the grub does not load me

What does it mean? What error message or what behaviour do you see?

 

 

On 11/30/2020 at 3:43 PM, rekena said:

linux /kernel-debian-sources-x86_64-5.9.6_p1

On 11/30/2020 at 3:43 PM, rekena said:

initrd /initramfs-debian-sources-x86_64-5.9.6_p1

Do you really have kernel and initramfs in the fs root(instead of /boot)?

 

Link to post
Share on other sites
  • 0

try this in fstab ext2 needs to be "vfat" if you are using UEFI. And you storage device name is "nvme0n1" you need to install grub using this name if you have already done that then with successfull boot you can remove just remove "nomodeset" parameter from /etc/boot.conf the regenerate "ego boot update"

/dev/nvme0n1p7        /boot        ext2        noauto,noatime        1 2
Edited by sacviper
more useful information
Link to post
Share on other sites
  • 0
  • Funtoo Linux BDFL
19 hours ago, pnoecker said:

where do i start.  /dev/nvme is a direct device name and can change, use either labels, partlabels, uuid, or partuuid persistent naming because udev can load the drive as nvme0n0p5 or n2p5

This is probably not the problem and shouldn't be the first advice to try to address the issue.

Link to post
Share on other sites
  • 0
  • Funtoo Linux BDFL

@rekena I am not seeing anything obvious from what you posted indicating a problem. As @lego12239 asked, what specifically are you seeing? Based on what you originally said, it sounds like GRUB is not even loading for you? If this is the case, then we want to make sure grub bootloader has been installed, so....

Make sure you have run the "grub-install (with arguments from install docs)" command from the install instructions. This will install the boot loader. Then run "ego boot update" in chroot. Then when you reboot grub should load.

If grub is loading, but the kernel can't find the root filesystem, then this is a *different* issue related to partition naming and what I assume @pnoecker was thinking. But you are saying that grub isn't starting. So I don't think we should look here.

In any case, please clarify exactly what you are seeing 🙂

Link to post
Share on other sites
  • 0
On 12/1/2020 at 4:30 PM, sacviper said:

sacviper try this in fstab ext2 needs to be "vfat" if you are using UEFI. And you storage device name is "nvme0n1" you need to install grub using this name if you have already done that then with successfull boot you can remove just remove "nomodeset" parameter from /etc/boot.conf the regenerate "ego boot update"



 

Hello thank you all for answering.

I am running ext2 to use dual boot corri win on uefi and mrb linux always

Edited by rekena
eclipse
Link to post
Share on other sites
  • 0
18 hours ago, drobbins said:

@rekena I am not seeing anything obvious from what you posted indicating a problem. As @lego12239 asked, what specifically are you seeing? Based on what you originally said, it sounds like GRUB is not even loading for you? If this is the case, then we want to make sure grub bootloader has been installed, so....

Make sure you have run the "grub-install (with arguments from install docs)" command from the install instructions. This will install the boot loader. Then run "ego boot update" in chroot. Then when you reboot grub should load.

If grub is loading, but the kernel can't find the root filesystem, then this is a *different* issue related to partition naming and what I assume @pnoecker was thinking. But you are saying that grub isn't starting. So I don't think we should look here.

In any case, please clarify exactly what you are seeing 🙂

I have installed grub and kernel, recompiled them and got these messages 

I will expose the procedures that I used

 

>>> Installing (1 of 1) sys-kernel/debian-sources-lts-4.19.152_p1::core-kit
*
* To avoid automounting and auto(un)installing with /boot,
* just export the DONT_MOUNT_BOOT variable.
*
* You are chrooted. Not touching /boot -- assuming you have it mounted if you have one.
*
* To avoid automounting and auto(un)installing with /boot,
* just export the DONT_MOUNT_BOOT variable.
*
* You are chrooted. Not touching /boot -- assuming you have it mounted if you have one.
* With binary use flag enabled /usr/src/linux
* symlink automatically set to debian kernel
* If you have external modules, don't forget to rebuild them with:
*
* emerge @module-rebuild
*
depmod: ERROR: could not open directory /lib/modules/4.14.70-std531-amd64: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
* Generating config for grub...


* NOTE: Intel microcode will be loaded at boot-time.
* NOTE: Detected MBR boot. Configuring for Legacy MBR booting.
* ERROR: (root=auto) - / entry in /etc/fstab not recognized ().
* ERROR: No matching kernels or boot entries found in /etc/boot.conf.
* ERROR: Did not complete successfully.

 

chroot) sysresccd /usr/src # ego boot update
* Generating config for grub...


* WARN: No CPU microcode available for non-Intel systems.
* NOTE: Detected MBR boot. Configuring for Legacy MBR booting.
* ERROR: (root=auto) - / entry in /etc/fstab not recognized ().
* ERROR: No matching kernels or boot entries found in /etc/boot.conf.
* ERROR: Did not complete successfully.



(chroot) sysresccd /usr/src # eix -I microcode
[I] sys-firmware/intel-microcode [1]


(chroot) sysresccd /usr/src # eix -I grub
[I] app-admin/grubconfig
Available versions: 1.28-r2
Installed versions: 1.28-r2(09:57:12 02/12/20)
Description: Simple Tool to configure Grub-Bootloader

[I] sys-boot/grub
Installed versions: 2.02-r3(2/2.02-r3)^st(16:51:10 02/12/20)(fonts nls themes -debug -device-mapper -doc -efiemu -libzfs -mount -multislot -sdl -static -
Description: GNU GRUB boot loader

I recompile kernel, boot,microcode and grub, but I keep getting these message😅

image.png

Edited by rekena
eclipse
Link to post
Share on other sites
  • 0

Am I missing something or do you not have '/' set in /etc/fstab?  I've never had an entry "/root" and the first error boot update seems to be having is this:

* ERROR: (root=auto) - / entry in /etc/fstab not recognized ().

which seems to imply that your fstab is at fault.  Shouldn't this line:

/dev/nvme0n1p5        /root        ext4        noatime               0 1

look like this:

/dev/nvme0n1p5        /		        ext4        noatime               0 1

instead?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...