Jump to content

drobbins

Funtoo Linux BDFL
  • Posts

    448
  • Joined

  • Last visited

  • Days Won

    226

Community Answers

  1. drobbins's post in Missing package sys-apps/iucode_tool was marked as the answer   
    I would ask that you open bugs for any missing packages that were in nokit but are now missing in next-release. We are trying to get rid of nokit and move anything we want to maintain to the other kits. This is part of our "beard trimming" initiative.
  2. drobbins's post in [Solved] Is it possible to change the email used for auth.funtoo? was marked as the answer   
    I do not have the UI built out for this yet, but you can contact me via PM on the forums and I can change it for you.
  3. drobbins's post in Gvim depends on non-existent version of vim-core? was marked as the answer   
    @cardinal that isn't really a fix for the issue, just a workaround.
    @kundor yes, this is a bug. A couple of weeks ago, our upstream vim had issues, so I forked vim and vim-core. But I did not grab gvim. It should be reported to bugs.funtoo.org and we'll get it fixed. Thanks ?
  4. drobbins's post in Error emerging libglvnd in Funtoo 1.3 -> 1.4 upgrade was marked as the answer   
    I just committed a fixed git-r3.eclass -- added 'PROPERTIES='live'' to the eclass. In my opinion, this is a silly new feature of Portage that was not necessary, as git-r3.eclass is not a wonderful idea in the first place and didn't need a new 'feature' to prevent it from breaking with the network-sandbox feature. Over-engineering.
    Full fix should appear in meta-repo in 15 minutes.
  5. drobbins's post in [solved] lxd/lxc no .config in the kernel source directory was marked as the answer   
    LXD GPU-accelerated containers requires Funtoo Linux 1.4. It looks like you may be using Funtoo Linux 1.3?
    The nvidia-drivers in 1.4 has been significantly modified to work properly inside containers and not require a kernel. The 1.3 one hasn't.
  6. drobbins's post in Are there Funtoo AWS images or a cloud build system ? was marked as the answer   
    We finally have an answer to this question: official Funtoo AWS images: https://aws.amazon.com/marketplace/pp/B07KT3VN7Q?qid=1548635103743&sr=0-1&ref_=srh_res_product_title
  7. drobbins's post in Explicit setting CPU_FLAGS_X86 for Skylake Xeon E3 v5 was marked as the answer   
    Hey, so I think no one is really telling you the obvious -- you found a small bug, and I'm going to fix it with a commit to the profiles so that pclmul is added to CPU_FLAGS_X86 for skylake and skylake-avx512. ?
  8. drobbins's post in Detached HEAD state for some kit branches was marked as the answer   
    There is nothing wrong with some branches having "detached head". You will see this when there has been a recent update to our 1.3 development branch.
    If you see this at the end:
    Sync successful and kits in alignment! :) Then it means things are OK.
  9. drobbins's post in Meltdown patches was marked as the answer   
    We are currently deploying our 2nd-generation compute infrastructure which runs on LXD and debian-sources-4.14.12-2, which provides some mitigation for the recent exploits. We are also running the latest Intel microcode and will continually update as new fixes become available.
  10. drobbins's post in How to update world with new CFLAGS: -O3 ? was marked as the answer   
    Also, just a note, I don't recommend -O3 and it is not always faster. -O2 contains all the 'almost always good' optimizations, and -O3 contains some questionable ones.
  11. drobbins's post in Are there any plans to make genkernel-next more funtoo-friendly? was marked as the answer   
    Yes, I am working with robbat2 on a genkernel rewrite and a modular system to integrate initramfs like dracut, etc. We are just getting started and the holidays are keeping me from diving in right now. The project is/will be hosted here: https://github.com/funtoo/xkernel . You can see that robbat2 has contributed a host of issues/todos that I will be whittling away on soon.
  12. drobbins's post in Dropbox changes was marked as the answer   
    Yes, sorry for the inconvenience of this change -- dropbox is supposed to be set up under each user's home directory rather than installed centrally. While this fixes quite a few other complications it does make things more complicated for you. Fortunately there is a pretty good way to get dropbox working the way you want -- using /etc/local.d. See if this works for your needs. Try creating an /etc/local.d/dropbox.start script that will start dropbox as the user of your choice when the system boots:
    #!/bin/bash su username -c "/usr/bin/dropbox start" Then...
    # chmod +x /etc/local.d/dropbox.start This will run dropbox as user "username" when the system starts.
  13. drobbins's post in Is https://www.funtoo.org/Keychain deprecated? was marked as the answer   
    Everything has been updated, and we have a new release out.
  14. drobbins's post in Can not sign into funtoo.bugs was marked as the answer   
    Make sure you enter your username in *lowercase*. See if that helps.
  15. drobbins's post in Trouble updating after migration to meta-repo was marked as the answer   
    I believe I've identified and fixed the bug in ego's git master. Try this:
    # cd /var/tmp # git clone https://github.com/funtoo/ego # cd ego # ./ego profile update This should result in the profiles being properly updated with python-kit references. This code was lost in the migration to the new profiles API in ego 2.3.0. I'm going to roll this out as ego-2.3.1.
  16. drobbins's post in [solved] Could not clone kit 'lang-kit' into '/var/git/meta-repo/kits/lang-kit' was marked as the answer   
    This has been hit by a few users and is fixed in ego-2.3.0, which is available for testing. The workaround is to type something like cd /tmp before running the command (ego drops permissions to run as the Portage user and git freaks out if it can't read the current working directory.)
  17. drobbins's post in Error syncing meta-repo was marked as the answer   
    And it does appear that this was the issue - and it's fixed in our git version of ego and should be fixed in our next release. Until then, if you have the issue, type "cd /tmp" and re-run the command and it should work :)
  18. drobbins's post in Same account for forums and bugs? was marked as the answer   
    Try using 'monkeymonkey' to log in to the bug tracker. For some reason, the code in the forums is allowing you to sign in with your full name, but really you should have used your username. I can sync the accounts if you are ok being 'monkeymonkey' in both places.
  19. drobbins's post in New spam prevention technology preventing me from posting a message was marked as the answer   
    I whitelisted you, so in about 5 minutes you should be able to post what you were posting.
  20. drobbins's post in Evaluating Funtoo - questions was marked as the answer   
    I think the answer will vary depending on the person, but I can tell you about how I set up my workstation (laptop, Thinkpad W541). Generally, I want to set things up and have a stable, productive system since I need to be able to potentially leave my home office at a moment's notice and go somewhere... and my laptop needs to work. So I use the standard kits along with gnome-3.20, and now I have xorg 1.19-prime and 3.6-prime of python-kit running. I use debian-sources because it just plan works and I have no time to play with kernels (or need to).

    I might reinstall every 3-6 months, just to test the installation process, but this is generally not necessary unless you really *want* to. The apps I use the most are google chrome, hangouts, JetBrains pycharm (Java IDE), git. I have cups set up so I can print. I have a small set of python modules installed from packages to support my development work.
  21. drobbins's post in unfinished merge was marked as the answer   
    # cd /var/git/meta-repo # git reset --hard # git clean -fd
  22. drobbins's post in perl woes was marked as the answer   
    Type "epro" and look at the "build" setting. Funtoo-stable has been deprecated and we recommend reinstall to migrate to kits.
  23. drobbins's post in Forum search broken? was marked as the answer   
    This is now fixed :)
  24. drobbins's post in sys-kernel/openvz-rhel6-stable-2.6.32.042.120.18: linux/compiler-gcc5.h: No such file or directory was marked as the answer   
    This was imported into the bug tracker: https://bugs.funtoo.org/browse/FL-3636
     
    The temporary workaround is to use gcc-config to set your compiler to 4.8.5 so you can emerge the ebuild, and then set it back to 5.x afterwards. We're working on fixing it so this is not necessary.
  25. drobbins's post in Metro - What happened to ./metro/subarch/ ? was marked as the answer   
    Sorry for not catching this sooner. This info has been migrated into the funtoo profiles themselves, so it is no longer needed in metro.
×
×
  • Create New...