Jump to content

rekena

Members
  • Posts

    4
  • Joined

  • Last visited

rekena's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. I have installed grub and kernel, recompiled them and got these messages I will expose the procedures that I used >>> Installing (1 of 1) sys-kernel/debian-sources-lts-4.19.152_p1::core-kit * * To avoid automounting and auto(un)installing with /boot, * just export the DONT_MOUNT_BOOT variable. * * You are chrooted. Not touching /boot -- assuming you have it mounted if you have one. * * To avoid automounting and auto(un)installing with /boot, * just export the DONT_MOUNT_BOOT variable. * * You are chrooted. Not touching /boot -- assuming you have it mounted if you have one. * With binary use flag enabled /usr/src/linux * symlink automatically set to debian kernel * If you have external modules, don't forget to rebuild them with: * * emerge @module-rebuild * depmod: ERROR: could not open directory /lib/modules/4.14.70-std531-amd64: No such file or directory depmod: FATAL: could not search modules: No such file or directory * Generating config for grub... * NOTE: Intel microcode will be loaded at boot-time. * NOTE: Detected MBR boot. Configuring for Legacy MBR booting. * ERROR: (root=auto) - / entry in /etc/fstab not recognized (). * ERROR: No matching kernels or boot entries found in /etc/boot.conf. * ERROR: Did not complete successfully. chroot) sysresccd /usr/src # ego boot update * Generating config for grub... * WARN: No CPU microcode available for non-Intel systems. * NOTE: Detected MBR boot. Configuring for Legacy MBR booting. * ERROR: (root=auto) - / entry in /etc/fstab not recognized (). * ERROR: No matching kernels or boot entries found in /etc/boot.conf. * ERROR: Did not complete successfully. (chroot) sysresccd /usr/src # eix -I microcode [I] sys-firmware/intel-microcode [1] (chroot) sysresccd /usr/src # eix -I grub [I] app-admin/grubconfig Available versions: 1.28-r2 Installed versions: 1.28-r2(09:57:12 02/12/20) Description: Simple Tool to configure Grub-Bootloader [I] sys-boot/grub Installed versions: 2.02-r3(2/2.02-r3)^st(16:51:10 02/12/20)(fonts nls themes -debug -device-mapper -doc -efiemu -libzfs -mount -multislot -sdl -static - Description: GNU GRUB boot loader I recompile kernel, boot,microcode and grub, but I keep getting these message?
  2. Hello thank you all for answering. I am running ext2 to use dual boot corri win on uefi and mrb linux always
  3. Hi, I have been using gentoo for a long time and wanted to try funtoo, I installed it recently but the grub does not load me when rebooting the system. This is my configuration. Thanks a lot! FSTAB # == IMPORTANT ============================================================== # The 3 lines below need to be *uncommented* and adjusted for your system # =========================================================================== /dev/nvme0n1p7 /boot ext2 noauto,noatime 1 2 /dev/nvme0n1p8 none swap sw 0 0 /dev/nvme0n1p5 /root ext4 noatime 0 1 GRUB set timeout=3 if [ -s $prefix/grubenv ]; then load_env fi function savedefault { if [ -z "{boot_once}" ]; then saved_entry="${chosen}" save_env saved_entry fi } insmod part_msdos insmod ext2 set root=(hostdisk//dev/nvme0n1,msdos7) search --no-floppy --fs-uuid --set 471ee74b-e33d-4b60-ad6b-119b7e92e6fd if loadfont /grub/fonts/unicode.pf2; then set gfxmode=text insmod all_video terminal_output gfxterm fi set menu_color_normal=cyan/blue set menu_color_highlight=blue/cyan menuentry "Funtoo Linux genkernel - kernel-debian-sources-x86_64-5.9.6_p1" { insmod part_msdos insmod ext2 set root=(hostdisk//dev/nvme0n1,msdos7) search --no-floppy --fs-uuid --set 471ee74b-e33d-4b60-ad6b-119b7e92e6fd linux /kernel-debian-sources-x86_64-5.9.6_p1 nomodeset real_root=/dev/nvme0n1p5 rootfstype=ext4 rand_id=TG3W8IBB initrd /initramfs-debian-sources-x86_64-5.9.6_p1 set gfxpayload=keep } if [ ! "${next_entry}" = "" ] ; then set default="${next_entry}" set next_entry= save_env next_entry set boot_once=true elif [ ! "${saved_entry}" = "" ]; then set default="${saved_entry}" else set default=0 fi BOOT.CONF boot { generate grub default "Funtoo Linux genkernel" timeout 3 } "Funtoo Linux" { kernel bzImage[-v] } "Funtoo Linux genkernel" { kernel kernel[-v] initrd initramfs[-v] # IMPORTANT: Most users will want to remove "nomodeset", below! # # It is included in the initial install to ensure that virtually all # systems boot up with a readable initial console. # But all graphics drivers (with the one exception of the proprietary # NVIDIA drivers) REQUIRE mode setting to be enabled, and thus the # nomodeset option must be REMOVED prior to setting up a graphical # environment or X will not start. Remember to run "ego boot update" after # removing the option, and then reboot prior to configuring X. # Also note that if you are using a 4K or higher resolution display, your # console text may become very small after enabling kernel mode setting # since it will display your console at the native resolution of your # display. params += real_root=auto rootfstype=auto nomodeset }
×
×
  • Create New...