Jump to content
funtoo forums
  • 0
NikosAlexandris

Java version 7 (for web apps)

Question

The USGS Global Visualization Viewer requires Java 7 or higher. In my Funtoo box I have:

java -version

java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode

Isn't this already version 7?  How do I get past this obstacle?  I currently use Firefox which features (the plugin) IcedTea-Web ver. 1.3.2.  I have also been through http://www.funtoo.org/Funtoo_Linux_Web_Browsers#Oracle_Java_Runtime_Environment to ensure it was not a "Security" misconfiguration.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

None of the above helped me further. Searching more for available packages, showed icedtea-web-1.4.2. Emerging it like

USE="jamvm javascript" emerge -av icedtea-web

hinted, among others, a magic message after installation completion saying The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin. Listing options and current setting revealed the "problem"

eselect java-nsplugin list
Available 32-bit Java browser plugins
Available 64-bit Java browser plugins
  [1]   icedtea-7
  [2]   icedtea-bin-6  current
  [3]   icedtea-web@icedtea-7
  [4]   icedtea-web@icedtea-bin-6
  [5]   oracle-jre-bin-1.7

Setting it to "7", like

eselect java-nsplugin set 64bit 1

fixed it and http://glovis.usgs.gov/ runs fine.  I don't know, of course, if installing icedtea-web-1.4.2 was necessary at all.

Share this post


Link to post
Share on other sites
  • 0

I am able to run the USGS Global Visualization Viewer in Chromium. I set up Java and Chromium as described on the wiki page you linked to.

 

Make sure use set the "nsplugin" USE variable when you emerged oracle-jvm/jdk.

 

I had to perform one extra trick in Chromium to get it to work, because when I went to the USGS site, it displayed the Java logo but underneath said "Java not allowed."

 

To fix this, I went to the page "chrome://plugins" and then checked "Always allowed" checkbox next to:

 

Java™ Version: 10.45.2

Next Generation Java Plug-in 10.45.2 for Mozilla browsers
 
Then I reloaded the page and the Java applet loaded automatically :)
 
So, to review:
 
1) ensure "nsplugin" is In USE.
2) It's working in Chromium.
 
I do not have FireFox emerged on this machine to test.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×