Jump to content
funtoo forums
  • 0
sibok

qtwebkit wants to install ruby but it breaks emerge

Question

Hi,

i'm trying to update @world but i'm suffering the following error:

emerge -avuUDNt @world --keep-going                                       

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

Oops! Conflicts have been encountered:

>>> media-libs/phonon-vlc-0.9.1-r1:0/0::media-kit, installed, wants media-video/vlc:0/5-8=

My candidates are:

>>> media-video/vlc-3.0.2-r1:0/5-9::media-kit, ebuild scheduled for merge has SLOT 0/5-9
>>> media-video/vlc-2.2.8-r1:0/5-8::media-kit, ebuild scheduled for merge has SLOT 0/5-8

>>> sys-libs/ldb-1.1.29-r1:0/1.1.29::gentoo, installed, wants >=sys-libs/tevent-0.9.31[]

My candidates are:

>>> sys-libs/tevent-0.9.31-r1:0/0::core-kit, ebuild scheduled for merge has SLOT 0/0
>>> sys-libs/tevent-0.9.31-r1:0/0::gentoo, installed has SLOT 0/0

>>> net-print/cups-filters-1.17.9:0/0::net-kit, installed, wants app-text/poppler:0/66=
>>> media-gfx/gimp-2.8.22:2/2::media-kit, installed, wants >=app-text/poppler-0.12.4[cairo]

My candidates are:

>>> app-text/poppler-0.45.0:0/62::gnome-kit, ebuild scheduled for merge has SLOT 0/62 and IUSE cairo
>>> app-text/poppler-0.52.0-r2:0/66::gnome-kit, installed has SLOT 0/66 and IUSE cairo

>>> dev-lang/ruby-2.3.6:2.3/2.3::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.2.1[ruby_targets_ruby23]
>>> dev-lang/ruby-2.4.4:2.4/2.4::libressl, ebuild scheduled for merge, wants >=dev-ruby/rdoc-5.1.0[ruby_targets_ruby24]
>>> dev-lang/ruby-2.2.9:2.2/2.2::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.0.1[ruby_targets_ruby22]

My candidates are:

>>> dev-ruby/rdoc-5.1.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 but not IUSE ruby_targets_ruby22
>>> dev-ruby/rdoc-4.2.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 and IUSE ruby_targets_ruby22



We hope this informational output has been useful in identifying the
problem. We are continually working to reduce conflicts. Do not
hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)


emerge: there are no ebuilds to satisfy ">=dev-ruby/rubygems-2.5.1[ruby_targets_ruby23]".
(dependency required by "virtual/rubygems-13::ruby-kit[ruby_targets_ruby23]" [ebuild])
(dependency required by "dev-ruby/kpeg-1.1.0::ruby-kit" [ebuild])
(dependency required by "dev-ruby/rdoc-5.1.0::ruby-kit[ruby_targets_ruby24]" [ebuild])
(dependency required by "dev-lang/ruby-2.4.4::libressl[rdoc]" [ebuild])
(dependency required by "dev-ruby/racc-1.4.14::ruby-kit[ruby_targets_ruby24]" [ebuild])
(dependency required by "dev-ruby/rdoc-4.2.0::ruby-kit[ruby_targets_ruby22]" [ebuild])
(dependency required by "dev-lang/ruby-2.2.9::ruby-kit[rdoc]" [ebuild])
(dependency required by "dev-ruby/minitest-5.10.3::ruby-kit[ruby_targets_ruby22]" [ebuild])
(dependency required by "dev-lang/ruby-2.3.6::ruby-kit" [ebuild])
(dependency required by "dev-ruby/test-unit-3.2.6::ruby-kit[ruby_targets_ruby23]" [ebuild])

 

While digging it up just found qtwebkit seems to cause the error:

emerge -va qtwebkit

These are the packages that would be merged, in order:

Calculating dependencies... done!

Oops! Conflicts have been encountered:

>>> dev-lang/ruby-2.3.6:2.3/2.3::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.2.1[ruby_targets_ruby23]
>>> dev-lang/ruby-2.4.4:2.4/2.4::libressl, ebuild scheduled for merge, wants >=dev-ruby/rdoc-5.1.0[ruby_targets_ruby24]
>>> dev-lang/ruby-2.2.9:2.2/2.2::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.0.1[ruby_targets_ruby22]

My candidates are:

>>> dev-ruby/rdoc-5.1.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 but not IUSE ruby_targets_ruby22
>>> dev-ruby/rdoc-4.2.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 and IUSE ruby_targets_ruby22



We hope this informational output has been useful in identifying the
problem. We are continually working to reduce conflicts. Do not
hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)


emerge: there are no ebuilds to satisfy ">=dev-ruby/rubygems-2.5.1[ruby_targets_ruby23]".
(dependency required by "virtual/rubygems-13::ruby-kit[ruby_targets_ruby23]" [ebuild])
(dependency required by "dev-ruby/json-2.1.0::ruby-kit" [ebuild])
(dependency required by "dev-ruby/rdoc-5.1.0::ruby-kit[ruby_targets_ruby23]" [ebuild])
(dependency required by "dev-lang/ruby-2.4.4::libressl[rdoc]" [ebuild])
(dependency required by "dev-ruby/did_you_mean-1.1.2::ruby-kit[ruby_targets_ruby24]" [ebuild])

 

Also, when running equery command i can see the following warnings:

equery u telnet
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/pentoo/metadata/layout.conf'
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/zugaina/metadata/layout.conf'
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/java/metadata/layout.conf'
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/bitcoin/metadata/layout.conf'
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/miramir/metadata/layout.conf'
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/libressl/metadata/layout.conf'
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/aegypius/metadata/layout.conf'
Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/vmware/metadata/layout.conf'

 

Also i wonder if the content of /etc/portage/repos.conf/ is right, i mean should all these ego* files be inside /etc/portage/repos.conf/?

ls -la /etc/portage/repos.conf/
total 31
drwxr-xr-x  2 root root 1024 May 23 23:02 .
drwxr-xr-x 15 root root 1024 Jun  2 14:19 ..
-rw-r--r--  1 root root   89 Jun  2 13:54 ego-core-hw-kit
-rw-r--r--  1 root root  115 Jun  2 13:54 ego-core-kit
-rw-r--r--  1 root root   89 Jun  2 13:54 ego-desktop-kit
-rw-r--r--  1 root root   81 Jun  2 13:54 ego-dev-kit
-rw-r--r--  1 root root   89 Jun  2 13:54 ego-editors-kit
-rw-r--r--  1 root root   85 Jun  2 13:54 ego-games-kit
-rw-r--r--  1 root root   85 Jun  2 13:54 ego-gnome-kit
-rw-r--r--  1 root root   89 Jun  2 13:54 ego-haskell-kit
-rw-r--r--  1 root root   83 Jun  2 13:54 ego-java-kit
-rw-r--r--  1 root root   81 Jun  2 13:54 ego-kde-kit
-rw-r--r--  1 root root   83 Jun  2 13:54 ego-lang-kit
-rw-r--r--  1 root root   97 Jun  2 13:54 ego-lisp-scheme-kit
-rw-r--r--  1 root root   83 Jun  2 13:54 ego-llvm-kit
-rw-r--r--  1 root root   85 Jun  2 13:54 ego-media-kit
-rw-r--r--  1 root root   89 Jun  2 13:54 ego-ml-lang-kit
-rw-r--r--  1 root root   81 Jun  2 13:54 ego-net-kit
-rw-r--r--  1 root root   80 Jun  2 13:54 ego-nokit
-rw-r--r--  1 root root   83 Jun  2 13:54 ego-perl-kit
-rw-r--r--  1 root root   81 Jun  2 13:54 ego-php-kit
-rw-r--r--  1 root root   87 Jun  2 13:54 ego-python-kit
-rw-r--r--  1 root root  103 Jun  2 13:54 ego-python-modules-kit
-rw-r--r--  1 root root   83 Jun  2 13:54 ego-ruby-kit
-rw-r--r--  1 root root   89 Jun  2 13:54 ego-science-kit
-rw-r--r--  1 root root   91 Jun  2 13:54 ego-security-kit
-rw-r--r--  1 root root   83 Jun  2 13:54 ego-text-kit
-rw-r--r--  1 root root   83 Jun  2 13:54 ego-xfce-kit
-rw-r--r--  1 root root   83 Jun  2 13:54 ego-xorg-kit
lrwxrwxrwx  1 root root   29 Oct  8  2017 funtoo -> /var/git/meta-repo/repos.conf
-rw-r--r--  1 root root  740 Dec 25 12:55 layman.conf
-rw-r--r--  1 root root  106 Jun  1 19:09 local-overlay.conf

Hope someone can help me cause i'm unable to update @world the system.

 

Thanks in advanced :)

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
>>> net-print/cups-filters-1.17.9:0/0::net-kit, installed, wants app-text/poppler:0/66=
>>> media-gfx/gimp-2.8.22:2/2::media-kit, installed, wants >=app-text/poppler-0.12.4[cairo]

My candidates are:

>>> app-text/poppler-0.45.0:0/62::gnome-kit, ebuild scheduled for merge has SLOT 0/62 and IUSE cairo
>>> app-text/poppler-0.52.0-r2:0/66::gnome-kit, installed has SLOT 0/66 and IUSE cairo

It seems that the old gimp version is pulling in the old poppler version. In such cases it often helps to emerge the conflicting packages together. In this case e.g. 

emerge -pv cups-filters gimp

The rest of the messages seem to have the same problem.  Try to make the updates in steps.

I would try to get a list of available updates at first. For that I would exclude problematic packages from emerge with --exclude until I have a list and then go through them manually. This helps to get the system up to date, especially if it hasn't been updated for a while.

 

 

Share this post


Link to post
Share on other sites
  • 0

Thanks a lot for the answer jhan, i sometimes already do what you propose but it's a pain in the ass. It would be nice if someone could post a real fix for the issue.

Thanks in advanced.

Share this post


Link to post
Share on other sites
  • 0

Yes, it is tedious but so far the only way I know for solving those conflicts.

I agree that it would be ideal if emerge would do these things alone but so far I haven't experienced that. Although, if I read bug https://bugs.funtoo.org/browse/FL-3491 correctly, it seems to already do that. Not sure if it is true or not though.

Share this post


Link to post
Share on other sites
  • 0

Hi, by now updating my GNU/Linux Funtoo OS is a WIP.

 

What i've done is to get a list of packages to be updated and then run emerge =pkg-version for each one of he packages. The following is the script i've used to update the packages:

#!/bin/bash

file=$1
lines=`cat $file|wc -l`

for (( n=1; n<=$lines; n++ )); do
       pkg=`cat $file|head -n$n|tail -n1`
       emerge -1 --ask n =$pkg --keep-going --nodeps
done

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×