Jump to content
funtoo forums

sibok

Members
  • Content Count

    12
  • Joined

  • Last visited

  1. Yes, you're right, sometimes I'm a bit rude. I'm really sorry for my attitude. I got the impression you were the kind of troll who does not carefully read the posts and answer with whatever feels like. My apologies 🙂 The problem about switching to a branch is that one first has to know that branch exists. I was wondering if Funtoo got the right portage/kits/system package tools to deal with packages and these kind of things. In reallity I'm missing a way to check/list for available/existing sources/branches for kits. Also, get some info like a description to understand why multiple branches exists and which is the one that interests me. Last, I fell useless having a stability column when there's no simple/easy way to understand the meaning of these stability values through system tools or man pages. Back to topic, AFAIK and as I observed on your answers I assume such tools does not exist on Funtoo. I really thank you for your time and dedication to expose a workaround or a way to achieve what I was looking for eventhough it may look a unordinary. Also I was wondering how can I know about the existence of the different releases? Would be cool to be able to get this kind of information through reliable sources or system tools. In short, is it safe to move to 1.3 release? Also, you're saying it would be unsafe to switch to kde-kit 1.3-release as long as it is not show by ego kit -v list? Thanks
  2. I'm not losing my time anymore with you. As said, you didn't read or understood the genuine post. Also you just copied and pasted the command I proposed on the first post which obviously doesn't answer any of the questions set out. By moving to any kit git repo locally one can git ls-remote (or fetch all branches and check them out) and see what branches exists. But What I would like to know if there's any command to see how many or which branches exists for a given kit repo. Also I would like to query a description/definition for the stability associated to those branches. Unfortunately none of these can be achieved by ego, AFAIK. ego kit -v list|status doesn't show all the existing branches for a given kit repository. Neither describes it's stability. As example, you should be able to comprehend kde-kit has 3 git branches which are not shown by ego kit, nor a description for its stability: ego kit -v list /var/git/meta-repo (updated 5 hours 42 minutes ago): kit is active? branch stability kde-kit active 5.12-prime prime So my questions persists. Is there any way to get this kind of information through system utilities or one should dig into with git commands and then decide which branch suits best reading untrusted sources? Kind regards,
  3. Hi Palica, thanks for your time and your answer. Also note if you carefully read the post you'll see I exposed the 3 existing branches for kde-kit which doesn't are not shown by running ego kit -v list|status. Also there's no description about the stability value's meanings. In short, the command yo proposed - which is the same I exposed on the first post - does not resolve any of the exposed questions. I really appreciate your time but I would like ask for skipping unrelated, nonsense or misguiding replies. Cheers 🙂
  4. Looking at github or playing with git locally one can see kde-kit has the following branches: master 1.3-release 5.12-prime I wonder if it's possible to get that info through ego or any other specific GNU/Funtoo Linux command? Also I would like to be able to get a description about the existing branches. Right now I'm on kde-kit 5.12 which I think is a bit outdated. Last, I also wonder how can one know the difference about prime, current and dev stability? Should one be able to understand it through the command's arguments, man page or cmd help? I mean, i run ego kit -v list and it shows a table with a stability column but there's no description about the stability values meaning. Does anyone know about the right tools or commands to get that kind of info? Thanks in advanced! 🙂
  5. sibok

    Properly configuring MTRR

    Hi, while reading about plymouth and nvidia drivers I came around MTRR kernel settings. Quickly I run the following command which states uncachable for 3 MTRR registers: cat /proc/mtrr cat /proc/mtrr reg00: base=0x000000000 ( 0MB), size=16384MB, count=1: write-back reg01: base=0x400000000 (16384MB), size= 1024MB, count=1: write-back reg02: base=0x0c0000000 ( 3072MB), size= 1024MB, count=1: uncachable reg03: base=0x0bf700000 ( 3063MB), size= 1MB, count=1: uncachable reg04: base=0x0bf800000 ( 3064MB), size= 8MB, count=1: uncachable I went to make menuconfig -> Processor Type and Features -> MTRR support I've found MTRR cleanup support (which was disabled) so I enabled it. -*- MTRR (Memory Type Range Register) support │ │ │ │ [*] MTRR cleanup support │ │ │ │ (0) MTRR cleanup enable value (0-1) (NEW) │ │ │ │ (1) MTRR cleanup spare reg num (0-7) (NEW) │ │ │ │ [ ] Intel MPX (Memory Protection Extensions) │ │ │ │ [*] Intel Memory Protection Keys After reading /home/sys/usr/src/linux-4.19.5-gentoo/Documentation/x86/mtrr.txt I still don't know which values to place to MTRR cleanup enable value (0-1) (NEW) & MTRR cleanup spare reg num (0-7) (NEW) kernel config. By now just placed value 1 to both options and compiled the kernel. It now shows the following in dmesg: [ 0.001933] MTRR default type: uncachable [ 0.001933] MTRR fixed ranges enabled: [ 0.001934] 00000-9FFFF write-back [ 0.001935] A0000-BFFFF uncachable [ 0.001935] C0000-E3FFF write-protect [ 0.001936] E4000-EBFFF write-through [ 0.001936] EC000-FFFFF write-protect [ 0.001936] MTRR variable ranges enabled: [ 0.001937] 0 base 000000000 mask C00000000 write-back [ 0.001938] 1 base 400000000 mask FC0000000 write-back [ 0.001939] 2 base 0C0000000 mask FC0000000 uncachable [ 0.001940] 3 base 0BF700000 mask FFFF00000 uncachable [ 0.001940] 4 base 0BF800000 mask FFF800000 uncachable [ 0.001941] 5 disabled [ 0.001941] 6 disabled [ 0.001941] 7 disabled [ 0.002540] x86/PAT: Configuration [0-7]: WB WC UC- UC WB WP UC- WT [ 0.002611] total RAM covered: 16375M [ 0.002928] Found optimal setting for mtrr clean up [ 0.002929] gran_size: 64K chunk_size: 16M num_reg: 7 lose cover RAM: 0G [ 0.003394] e820: update [mem 0xbf700000-0xffffffff] usable ==> reserved [ 0.003397] last_pfn = 0xbf680 max_arch_pfn = 0x400000000 [ 0.003407] Scanning 1 areas for low memory corruption [ 0.003409] Base memory trampoline at [(____ptrval____)] 91000 size 24576 [ 0.003414] BRK [0x02401000, 0x02401fff] PGTABLE [ 0.003415] BRK [0x02402000, 0x02402fff] PGTABLE [ 0.003416] BRK [0x02403000, 0x02403fff] PGTABLE [ 0.003451] BRK [0x02404000, 0x02404fff] PGTABLE [ 0.003596] BRK [0x02405000, 0x02405fff] PGTABLE [ 0.003602] BRK [0x02406000, 0x02406fff] PGTABLE After compiling cat /proc/mtrr shows as follows: reg00: base=0x000000000 ( 0MB), size= 2048MB, count=1: write-back reg01: base=0x080000000 ( 2048MB), size= 1024MB, count=1: write-back reg02: base=0x0bf700000 ( 3063MB), size= 1MB, count=1: uncachable reg03: base=0x0bf800000 ( 3064MB), size= 8MB, count=1: uncachable reg04: base=0x100000000 ( 4096MB), size= 4096MB, count=1: write-back reg05: base=0x200000000 ( 8192MB), size= 8192MB, count=1: write-back reg06: base=0x400000000 (16384MB), size= 1024MB, count=1: write-back To me it looks like there are 2 registers unused (reg02 and reg03). My system: Is running Gentoo-sources 4.19.5. i7-920 on an Asus P6T Deluxe. 16GB RAM (12GB on triple channel). Nvidia GTX-260 VGA (nvidia driver v340.107) Looking into the BIOS I cannot find any MTR/MSR setting to switch from continuous to discrete. Looking into my CPU flags it looks like it supports MTRR and PAT: flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_ts c arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm pti t pr_shadow vnmi flexpriority ept vpid dtherm ida lspci -v shows 3 "Memory at" lines but don't know how to identify which mtrr reg belongs to the VGA to setup MTRR in the kernel: 02:00.0 VGA compatible controller: NVIDIA Corporation GT200 [GeForce GTX 260] (rev a1) (prog-if 00 [VGA controller]) Subsystem: ASUSTeK Computer Inc. GT200 [GeForce GTX 260] Flags: bus master, fast devsel, latency 0, IRQ 30 Memory at fa000000 (32-bit, non-prefetchable) [size=16M] Memory at d0000000 (64-bit, prefetchable) [size=256M] Memory at f8000000 (64-bit, non-prefetchable) [size=32M] I/O ports at bc00 [size=128] [virtual] Expansion ROM at 000c0000 [disabled] [size=128K] Capabilities: [60] Power Management version 3 Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+ Capabilities: [78] Express Endpoint, MSI 00 Capabilities: [100] Virtual Channel Capabilities: [128] Power Budgeting <?> Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?> Kernel driver in use: nvidia Kernel modules: nvidia The following test throws 2 errors, maybe related to the 2 uncached registers: fwts mtrr - Results generated by fwts: Version V17.02.00 (2017-02-16 02:00:35). Some of this work - Copyright (c) 1999 - 2017, Intel Corp. All rights reserved. Some of this work - Copyright (c) 2010 - 2017, Canonical. Some of this work - Copyright (c) 2016 - 2017, IBM. This test run on 02/12/18 at 02:31:29 on host Linux PauPC 4.19.5-gentoo #2 SMP Sat Dec 1 13:49:26 CET 2018 x86_64. Command: "fwts mtrr -". Running tests: mtrr. mtrr: MTRR tests. ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- MTRR overview ------------- Reg 0: 0x0000000000000000 - 0x000000007fffffff ( 2048 MB) Write-Back Reg 1: 0x0000000080000000 - 0x00000000bfffffff ( 1024 MB) Write-Back Reg 2: 0x00000000bf700000 - 0x00000000bf7fffff ( 1 MB) Uncached Reg 3: 0x00000000bf800000 - 0x00000000bfffffff ( 8 MB) Uncached Reg 4: 0x0000000100000000 - 0x00000001ffffffff ( 4096 MB) Write-Back Reg 5: 0x0000000200000000 - 0x00000003ffffffff ( 8192 MB) Write-Back Reg 6: 0x0000000400000000 - 0x000000043fffffff ( 1024 MB) Write-Back Test 1 of 3: Validate the kernel MTRR IOMEM setup. FAILED [MEDIUM] MTRRIncorrectAttr: Test 1, Memory range 0x100000 to 0xbf67ffff (System RAM) has incorrect attribute Default (Most probably Uncached). FAILED [MEDIUM] MTRRIncorrectAttr: Test 1, Memory range 0x100000000 to 0x43fffffff (System RAM) has incorrect attribute Default (Most probably Uncached). Test 2 of 3: Validate the MTRR setup across all processors. PASSED: Test 2, All processors have the a consistent MTRR setup. Test 3 of 3: Test for AMD MtrrFixDramModEn being cleared by the BIOS. SKIPPED: Test 3, CPU is not an AMD, cannot test. =================================================================================================================================================================================== 1 passed, 2 failed, 0 warning, 0 aborted, 1 skipped, 0 info only. =================================================================================================================================================================================== 1 passed, 2 failed, 0 warning, 0 aborted, 1 skipped, 0 info only. Test Failure Summary =================================================================================================================================================================================== Critical failures: NONE High failures: NONE Medium failures: 2 mtrr: Memory range 0x100000 to 0xbf67ffff (System RAM) has incorrect attribute Default (Most probably Uncached). mtrr: Memory range 0x100000000 to 0x43fffffff (System RAM) has incorrect attribute Default (Most probably Uncached). Low failures: NONE Other failures: NONE Test |Pass |Fail |Abort|Warn |Skip |Info | ---------------+-----+-----+-----+-----+-----+-----+ mtrr | 1| 2| | | 1| | ---------------+-----+-----+-----+-----+-----+-----+ Total: | 1| 2| 0| 0| 1| 0| ---------------+-----+-----+-----+-----+-----+-----+ I wonder: Why I can not see PAT enabled in dmesg? How can I make sure PAT is enabled? How should I configure MTRR to make use of the 7 registers? Why MTRR default type is uncachable? Whats does MTRR cleanup enable value mean at kernel config? I mean, what does the 0 and 1 value means? Setting enable_mtrr_cleanup mtrr_spare_reg_nr=1at cmdline (kernel line at grub.cfg) throughs a bunch of errors on dmesg. Also should I place mtrr_spare_reg_nr=2 (as cat /proc/mtrr shows) or mtrr_spare_reg_nr=2 (as dmesg states)? Thanks in advanced! 🙂
  6. Hi, by now updating my GNU/Linux Funtoo OS is a WIP. What i've done is to get a list of packages to be updated and then run emerge =pkg-version for each one of he packages. The following is the script i've used to update the packages: #!/bin/bash file=$1 lines=`cat $file|wc -l` for (( n=1; n<=$lines; n++ )); do pkg=`cat $file|head -n$n|tail -n1` emerge -1 --ask n =$pkg --keep-going --nodeps done
  7. Thanks a lot for the answer jhan, i sometimes already do what you propose but it's a pain in the ass. It would be nice if someone could post a real fix for the issue. Thanks in advanced.
  8. Hi, i'm trying to update @world but i'm suffering the following error: emerge -avuUDNt @world --keep-going These are the packages that would be merged, in reverse order: Calculating dependencies... done! Oops! Conflicts have been encountered: >>> media-libs/phonon-vlc-0.9.1-r1:0/0::media-kit, installed, wants media-video/vlc:0/5-8= My candidates are: >>> media-video/vlc-3.0.2-r1:0/5-9::media-kit, ebuild scheduled for merge has SLOT 0/5-9 >>> media-video/vlc-2.2.8-r1:0/5-8::media-kit, ebuild scheduled for merge has SLOT 0/5-8 >>> sys-libs/ldb-1.1.29-r1:0/1.1.29::gentoo, installed, wants >=sys-libs/tevent-0.9.31[] My candidates are: >>> sys-libs/tevent-0.9.31-r1:0/0::core-kit, ebuild scheduled for merge has SLOT 0/0 >>> sys-libs/tevent-0.9.31-r1:0/0::gentoo, installed has SLOT 0/0 >>> net-print/cups-filters-1.17.9:0/0::net-kit, installed, wants app-text/poppler:0/66= >>> media-gfx/gimp-2.8.22:2/2::media-kit, installed, wants >=app-text/poppler-0.12.4[cairo] My candidates are: >>> app-text/poppler-0.45.0:0/62::gnome-kit, ebuild scheduled for merge has SLOT 0/62 and IUSE cairo >>> app-text/poppler-0.52.0-r2:0/66::gnome-kit, installed has SLOT 0/66 and IUSE cairo >>> dev-lang/ruby-2.3.6:2.3/2.3::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.2.1[ruby_targets_ruby23] >>> dev-lang/ruby-2.4.4:2.4/2.4::libressl, ebuild scheduled for merge, wants >=dev-ruby/rdoc-5.1.0[ruby_targets_ruby24] >>> dev-lang/ruby-2.2.9:2.2/2.2::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.0.1[ruby_targets_ruby22] My candidates are: >>> dev-ruby/rdoc-5.1.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 but not IUSE ruby_targets_ruby22 >>> dev-ruby/rdoc-4.2.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 and IUSE ruby_targets_ruby22 We hope this informational output has been useful in identifying the problem. We are continually working to reduce conflicts. Do not hesitate to report a bug at https://bugs.funtoo.org. Thank you! :) emerge: there are no ebuilds to satisfy ">=dev-ruby/rubygems-2.5.1[ruby_targets_ruby23]". (dependency required by "virtual/rubygems-13::ruby-kit[ruby_targets_ruby23]" [ebuild]) (dependency required by "dev-ruby/kpeg-1.1.0::ruby-kit" [ebuild]) (dependency required by "dev-ruby/rdoc-5.1.0::ruby-kit[ruby_targets_ruby24]" [ebuild]) (dependency required by "dev-lang/ruby-2.4.4::libressl[rdoc]" [ebuild]) (dependency required by "dev-ruby/racc-1.4.14::ruby-kit[ruby_targets_ruby24]" [ebuild]) (dependency required by "dev-ruby/rdoc-4.2.0::ruby-kit[ruby_targets_ruby22]" [ebuild]) (dependency required by "dev-lang/ruby-2.2.9::ruby-kit[rdoc]" [ebuild]) (dependency required by "dev-ruby/minitest-5.10.3::ruby-kit[ruby_targets_ruby22]" [ebuild]) (dependency required by "dev-lang/ruby-2.3.6::ruby-kit" [ebuild]) (dependency required by "dev-ruby/test-unit-3.2.6::ruby-kit[ruby_targets_ruby23]" [ebuild]) While digging it up just found qtwebkit seems to cause the error: emerge -va qtwebkit These are the packages that would be merged, in order: Calculating dependencies... done! Oops! Conflicts have been encountered: >>> dev-lang/ruby-2.3.6:2.3/2.3::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.2.1[ruby_targets_ruby23] >>> dev-lang/ruby-2.4.4:2.4/2.4::libressl, ebuild scheduled for merge, wants >=dev-ruby/rdoc-5.1.0[ruby_targets_ruby24] >>> dev-lang/ruby-2.2.9:2.2/2.2::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.0.1[ruby_targets_ruby22] My candidates are: >>> dev-ruby/rdoc-5.1.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 but not IUSE ruby_targets_ruby22 >>> dev-ruby/rdoc-4.2.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 and IUSE ruby_targets_ruby22 We hope this informational output has been useful in identifying the problem. We are continually working to reduce conflicts. Do not hesitate to report a bug at https://bugs.funtoo.org. Thank you! :) emerge: there are no ebuilds to satisfy ">=dev-ruby/rubygems-2.5.1[ruby_targets_ruby23]". (dependency required by "virtual/rubygems-13::ruby-kit[ruby_targets_ruby23]" [ebuild]) (dependency required by "dev-ruby/json-2.1.0::ruby-kit" [ebuild]) (dependency required by "dev-ruby/rdoc-5.1.0::ruby-kit[ruby_targets_ruby23]" [ebuild]) (dependency required by "dev-lang/ruby-2.4.4::libressl[rdoc]" [ebuild]) (dependency required by "dev-ruby/did_you_mean-1.1.2::ruby-kit[ruby_targets_ruby24]" [ebuild]) Also, when running equery command i can see the following warnings: equery u telnet Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/pentoo/metadata/layout.conf' Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/zugaina/metadata/layout.conf' Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/java/metadata/layout.conf' Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/bitcoin/metadata/layout.conf' Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/miramir/metadata/layout.conf' Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/libressl/metadata/layout.conf' Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/aegypius/metadata/layout.conf' Unavailable repository 'gentoo' referenced by masters entry in '/var/lib/layman/vmware/metadata/layout.conf' Also i wonder if the content of /etc/portage/repos.conf/ is right, i mean should all these ego* files be inside /etc/portage/repos.conf/? ls -la /etc/portage/repos.conf/ total 31 drwxr-xr-x 2 root root 1024 May 23 23:02 . drwxr-xr-x 15 root root 1024 Jun 2 14:19 .. -rw-r--r-- 1 root root 89 Jun 2 13:54 ego-core-hw-kit -rw-r--r-- 1 root root 115 Jun 2 13:54 ego-core-kit -rw-r--r-- 1 root root 89 Jun 2 13:54 ego-desktop-kit -rw-r--r-- 1 root root 81 Jun 2 13:54 ego-dev-kit -rw-r--r-- 1 root root 89 Jun 2 13:54 ego-editors-kit -rw-r--r-- 1 root root 85 Jun 2 13:54 ego-games-kit -rw-r--r-- 1 root root 85 Jun 2 13:54 ego-gnome-kit -rw-r--r-- 1 root root 89 Jun 2 13:54 ego-haskell-kit -rw-r--r-- 1 root root 83 Jun 2 13:54 ego-java-kit -rw-r--r-- 1 root root 81 Jun 2 13:54 ego-kde-kit -rw-r--r-- 1 root root 83 Jun 2 13:54 ego-lang-kit -rw-r--r-- 1 root root 97 Jun 2 13:54 ego-lisp-scheme-kit -rw-r--r-- 1 root root 83 Jun 2 13:54 ego-llvm-kit -rw-r--r-- 1 root root 85 Jun 2 13:54 ego-media-kit -rw-r--r-- 1 root root 89 Jun 2 13:54 ego-ml-lang-kit -rw-r--r-- 1 root root 81 Jun 2 13:54 ego-net-kit -rw-r--r-- 1 root root 80 Jun 2 13:54 ego-nokit -rw-r--r-- 1 root root 83 Jun 2 13:54 ego-perl-kit -rw-r--r-- 1 root root 81 Jun 2 13:54 ego-php-kit -rw-r--r-- 1 root root 87 Jun 2 13:54 ego-python-kit -rw-r--r-- 1 root root 103 Jun 2 13:54 ego-python-modules-kit -rw-r--r-- 1 root root 83 Jun 2 13:54 ego-ruby-kit -rw-r--r-- 1 root root 89 Jun 2 13:54 ego-science-kit -rw-r--r-- 1 root root 91 Jun 2 13:54 ego-security-kit -rw-r--r-- 1 root root 83 Jun 2 13:54 ego-text-kit -rw-r--r-- 1 root root 83 Jun 2 13:54 ego-xfce-kit -rw-r--r-- 1 root root 83 Jun 2 13:54 ego-xorg-kit lrwxrwxrwx 1 root root 29 Oct 8 2017 funtoo -> /var/git/meta-repo/repos.conf -rw-r--r-- 1 root root 740 Dec 25 12:55 layman.conf -rw-r--r-- 1 root root 106 Jun 1 19:09 local-overlay.conf Hope someone can help me cause i'm unable to update @world the system. Thanks in advanced :)
  9. Compiling VLC media player 2.2.2 Weatherwax (revision 2.2.1-282-g863a425) solved the issue
  10. I'm also suffering this annoying issue. Also when running eix-sync it gets frozen for some minutes on funtoo-kde-overlay and then it keeps on with its work.
  11. Hi, I'm on a clean Funtoo install and after setting up ALSA i've just tried to play some movies through VLC but it doesn't seem to be able to detect/choose the default output audio device. If i go to Audio -> Audio Device and there i choose the proper audio device then it seems to work fine. Does anyone knows how to fix this issue? This is the emerged VLC version VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42 When i call vlc from console i can see this output, i'm on KDE Plasma 5 [00000000012741f8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface. [0000000001386528] qt4 interface error: Unable to load extensions module These are the used USE flags to compile vlc [ebuild R ] media-video/vlc-2.2.1-r1:0/5-8::gentoo USE="X a52 alsa avcodec avformat bluray cdda cddb dbus directfb dts dvbpsi dvd encode faad ffmpeg flac fontconfig gcrypt ieee1394 jpeg libass libsamplerate live matroska mp3 mpeg mtp ncurses ogg opengl png postproc qt5 run-as-root samba sdl svg swscale taglib theora truetype twolame udev upnp v4l vorbis vpx x264 x265 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -bidi -chromaprint -dc1394 -debug (-directx) -dvb (-dxva2) -fdk -fluidsynth -gme -gnome -gnutls -growl -httpd -jack -kate -kde (-libav) -libcaca -libnotify -libtar -libtiger -linsys -lirc -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-media-library) -modplug -musepack (-neon) -omxil -opencv -optimisememory -opus -projectm -pulseaudio -qt4 (-rdp) -rtsp -schroedinger -sdl-image -sftp -shout -sid -skins -speex {-test} -tremor -vaapi -vcdx -vdpau -vlm -vnc -wma-fixed -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse" 20,450 KiB Running speaker-test -t wav -c 2from console through my user on the system works fine. aplay -l and aplay -L output PauPC ~ # aplay -l **** List of PLAYBACK Hardware Devices **** card 0: Intel [HDA Intel], device 0: ALC1200 Analog [ALC1200 Analog] Subdevices: 0/1 Subdevice #0: subdevice #0 card 0: Intel [HDA Intel], device 1: ALC1200 Digital [ALC1200 Digital] Subdevices: 1/1 Subdevice #0: subdevice #0 PauPC ~ # aplay -L null Discard all samples (playback) or generate zero samples (capture) default:CARD=Intel HDA Intel, ALC1200 Analog Default Audio Device sysdefault:CARD=Intel HDA Intel, ALC1200 Analog Default Audio Device front:CARD=Intel,DEV=0 HDA Intel, ALC1200 Analog Front speakers surround21:CARD=Intel,DEV=0 HDA Intel, ALC1200 Analog 2.1 Surround output to Front and Subwoofer speakers surround40:CARD=Intel,DEV=0 HDA Intel, ALC1200 Analog 4.0 Surround output to Front and Rear speakers surround41:CARD=Intel,DEV=0 HDA Intel, ALC1200 Analog 4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=Intel,DEV=0 HDA Intel, ALC1200 Analog 5.0 Surround output to Front, Center and Rear speakers surround51:CARD=Intel,DEV=0 HDA Intel, ALC1200 Analog 5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=Intel,DEV=0 HDA Intel, ALC1200 Analog 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=Intel,DEV=0 HDA Intel, ALC1200 Digital IEC958 (S/PDIF) Digital Audio Output This is my alsa.conf cat /etc/modprobe.d/alsa.conf # Alsa kernel modules' configuration file. # ALSA portion alias char-major-116 snd # OSS/Free portion alias char-major-14 soundcore ## ## IMPORTANT: ## You need to customise this section for your specific sound card(s) ## and then run `update-modules' command. ## Read alsa-driver's INSTALL file in /usr/share/doc for more info. ## ## ALSA portion ## alias snd-card-0 snd-interwave ## alias snd-card-1 snd-ens1371 ## OSS/Free portion ## alias sound-slot-0 snd-card-0 ## alias sound-slot-1 snd-card-1 ## alias snd-card-0 snd-hda-intel alias sound-slot-0 snd-card-0 # OSS/Free portion - card #1 alias sound-service-0-0 snd-mixer-oss alias sound-service-0-1 snd-seq-oss alias sound-service-0-3 snd-pcm-oss alias sound-service-0-8 snd-seq-oss alias sound-service-0-12 snd-pcm-oss ## OSS/Free portion - card #2 ## alias sound-service-1-0 snd-mixer-oss ## alias sound-service-1-3 snd-pcm-oss ## alias sound-service-1-12 snd-pcm-oss alias /dev/mixer snd-mixer-oss alias /dev/dsp snd-pcm-oss alias /dev/midi snd-seq-oss # Set this to the correct number of cards. options snd cards_limit=1 options snd-hda-intel id=Intel index=0 This is an unneeded ~/.asoundrc i've created just in case $ cat .asoundrc defaults.pcm.!card Intel defaults.pcm.!device 0 defaults.pcm.!ctl Intel pcm.hda-intel { type hw card 0 device 0 } ctl.hda-intel { type hw card 0 device 0 } My motherboard is an Asus P6T and this lspci |grep -i audio output lspci |grep -i audio 00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller cat /sys/class/sound/card*/id Intel Hope someone can help me to fix this annoying issue. Thx!
×