Jump to content

Search the Community

Showing results for tags 'emerge'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

  • drobbins' Blog
  • It's a Bear's life
  • haxmeister's Blog
  • psychopatch's Blog
  • 666threesixes666's Blog
  • decision theory
  • Chris Kurlinski's Blog
  • Sandro's Blog
  • danielv's Blog
  • Not So Stupid Admin Tricks
  • maldoror's Blog
  • andreawilson's Blog
  • Simple Step-by-Step Server Setup
  • saraedward's Blog
  • eusanpe
  • Linux Container Club - LXD/LXC's Blog
  • Funtoo Perl Hackers's Perl on Funtoo

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

  1. PHP:7.4 (dev-lang/php-7.4.11:7.4::core-server-kit) won't compile 😕 It looks like mysql_pdo is causing the build to fail. Should I fill a bug? There's anything I can do to fix it? Thanks in advanced! 🙂 emerge --update --newuse --deep --with-bdeps=y @world --backtrack=30 --verbose-conflicts --keep-going * Mounting 9000M of memory to /var/tmp/portage ... [ ok ] * emerging --update --newuse --deep --with-bdeps=y @world --backtrack=30 --verbose-conflicts --keep-goin
  2. Hi, I just added Official KDE TEAM git repo to my Funtoo system through layman repositories.xml <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE repositories SYSTEM "/dtd/repositories.dtd"> <repositories xmlns="" version="1.0"> <repo priority="50" quality="experimental" status="unofficial"> <name>Gentoo KDE Team Git Overlay</name> <description>Official Gentoo KDE Team Git Overlay</description> <homepage>https://wiki.gentoo.org/wiki/KDE/Ebuild_repository</homepage> <owner> <ema
  3. I try to install kde-plasma-5-new but when I update my system with <emerge -auvDN --with-bdeps=y @world> The command emerge a lot of packages but block at sidermonkey packages (I already retry in case of bad luck) In attached files you will the log of the build (emerge-build.log), the environement info (emerge-info.log) and an image of the error I found (but maybe there are more). Thanks for any help. emerge-build.log emerge-info.log
  4. During my upgrade from 1.3 to 1.4 I got an error while running the command: # emerge -auDN @world --jobs=3 --exclude dev-lang/perl So i got the error "Package 'dev-db/mysql-connector-c-8.0.16' NOT merged due to file collisions." The detected file is /usr/lib64/pkgconfig/mysqlclient.pc I checked with "portageq" who's the owner and looks like it's dev-db/mysql-5.7.23 Not sure if it's an human mistake (me) or if it's a portage bug...
  5. Hello I have been trying to install but it fails I have attached build log please have a look. And one more thing when it was compiling it got stuck with this line "virtual memory exhausted: Cannot allocate memory" but after few mins compilation starts again and it fails it is in the log. Thanks in advance for your help teamviewer.txt
  6. So I'm trying to rebuild everything using --emptytree @world and it's failing on python3_4 Preserved libs list comes up, but I don't know what it's for - heres the list tho, if it helps: dev-libs/ice-64.2, dev-libs/libevent-2.1.8, dev-libs/openssl-1.1.1b-r2, net-libs/hhtp-parser-2.9.2 What can I do?
  7. One or more updates skipped due to dependency conflict: dev-libs/libxml2-2.9.9-r1 conflicts with dev-util/itstool-2.0.6-r1 This was on 'emerge @system' Anyone know the steps to resolve? Tried --backtrack=500 and even removing both. Also tried --emptytree
  8. Well, a time ago I knew about Gentoo and Funtoo and I liked the philosophy and how it works, then I decided to install Funtoo on my notebook (that I'm using right now). Someday I tried to install VLC and in the middle of the installation, when compiling QtGui, my notebook stopped being hot and noisy (what is normal when it's compiling packages). So I checked the processor cores with htop and it seemed like the compilation process just was dead. I waited some more minutes and nothing... I decided to cancel the installation. Later I tried to install Aseprite and the Allegro package has need
  9. Trying to install pulseaudio but emerge fails please have a look [32;01m * [39;49;00mPackage: dev-cpp/eigen-3.3.5-r1 [32;01m * [39;49;00mRepository: dev-kit [32;01m * [39;49;00mUSE: amd64 elibc_glibc kernel_linux openmp userland_GNU [32;01m * [39;49;00mFEATURES: preserve-libs sandbox userpriv usersandbox >>> Unpacking source... >>> Unpacking eigen-3.3.5.tar.bz2 to /var/tmp/portage/dev-cpp/eigen-3.3.5-r1/work >>> Source unpacked in /var/tmp/portage/dev-cpp/eigen-3.3.5-r1/work >>> Preparing source in /var/tmp/portage/dev-cpp/eige
  10. Hello, I was going finally to update my ego profile to 1.3 following this guide: https://www.funtoo.org/Upgrade_Instructions/1.3-release I've followed every step and checked that it worked as intended. I've just done the this step now (succesfully): emerge -auDN @system --ignore-world Now, the next step would to to run emerge -auDN @world But this one, it fails spectacularly... These are the packages that would be merged, in order: Calculating dependencies .. ....... ...... ...... done! [ebuild U ] x11-misc/util-macros-1.19.2-r1 [1.19.1] [ebuild
  11. whenever I finish doing something in emerge such as installing a package or updating my system I get the message config file 'etc/portage/package.use' needs updating however when I look for the file I can't find it and I am not sure how to update it as I can't find it, my guess was to do emerge -auDN etc/portage/package.use but it says it's not a valid package atom, I've looked on the wiki and have prodded around for a few days but have been unable to find a solution. Thank you for the help in advance, and best regards!
  12. Hi i got the following error in a KDE fresh install emerging calligra. # emerge -av app-office/calligra These are the packages that would be merged, in order: Calculating dependencies... done! emerge: there are no ebuilds built with USE flags to satisfy "app-crypt/qca:2[qt5]". !!! One of the following packages is required to complete your request: - app-crypt/qca-2.2.0_pre20180606::nokit (Missing IUSE: qt5) - app-crypt/qca-2.1.3-r2::nokit (Missing IUSE: qt5) (dependency required by "app-office/calligra-3.1.0-r1::kde-kit[crypt]" [ebuild]) (dependency requi
  13. Necktwi@funtoo:~ $ emerge --info '=sys-devel/clang-6.0.0-r1::llvm-kit' | wgetpaste Your paste can be seen here: https://paste.pound-python.org/show/K3BiPPKqiB7o7YFV0Ki8/ Necktwi@funtoo:~ $ emerge -pqv '=sys-devel/clang-6.0.0-r1::llvm-kit' | wgetpaste Your paste can be seen here: https://paste.pound-python.org/show/HCAX7yC6n9jYb5R1bBBp/ Necktwi@funtoo:~ $ sudo cat /var/tmp/portage/sys-devel/clang-6.0.0-r1/temp/build.log| wgetpaste Your paste can be seen here: https://paste.pound-python.org/show/FCQgLsrdBL7uCqO3ykDR/ Necktwi@funtoo:~ $ sudo cat /var/tmp/portage/sys-
  14. # emerge --info '=app-crypt/p11-kit-0.23.9::gnome-kit' | wgetpaste Your paste can be seen here: https://paste.pound-python.org/show/73ovlmBBmHd6fNoYJN9U/ # emerge -pqv '=app-crypt/p11-kit-0.23.9::gnome-kit' [ebuild N ] app-crypt/p11-kit-0.23.9 USE="asn1 libffi trust -debug" ABI_X86="(64) -32 (-x32)" # cat /var/tmp/portage/app-crypt/p11-kit-0.23.9/temp/build.log | wgetpaste Your paste can be seen here: https://paste.pound-python.org/show/Y156AZf6AJb79f3bcL7a/ # cat /var/tmp/portage/app-crypt/p11-kit-0.23.9/temp/environment | wgetpaste Your paste can be seen here: https://pa
  15. I did not update my system for a long time and also missed the announcement for the meta-repo thing. I decided to update, read a lot of links from the forums etc. and ended up screwing up my build system. (for example this post ) # epro === Enabled Profiles: === arch: base build: (not set) subarch: (not set) flavor: (not set) mix-ins: (not set) === Python kit: === branch: 3.4-prime # emerge -vpuD --newuse @world !!! /etc/portage/make.profile is not a symlink and will probably prevent most merges. !!! It should point into a profile within
  16. libharu is a requirement of freecad... The Output from emerge libharu is: * ERROR: media-libs/libharu-2.3.0-r2::media-kit failed (prepare phase): * patch -p1 failed with /var/tmp/portage/media-libs/libharu-2.3.0-r2/files/libharu-2.3.0-1-Included-necessary-char-widths-in-generated-PDF.patch * * Call stack: * ebuild.sh, line 92: Called src_prepare * environment, line 3662: Called cmake-utils_src_prepare * environment, line 870: Called _cmake_execute_optionally 'src_prepare' * environment, line 306: Called en
  17. I am attempting to update my systems and for whatever reason, when running: emerge --newuse -uD world -vp mips-sources is complaining of eapi7-ver: EAPI=5 not supported. I don't have mips-sources installed and I'm on an x86/64 system. Calculating dependencies / * ERROR: sys-kernel/mips-sources-4.13.16::nokit failed (depend phase): * eapi7-ver: EAPI=5 not supported * * Call stack: * ebuild.sh, line 603: Called source '/var/git/meta-repo/kits/nokit/sys-kernel/mips-sources/mips-sources-4.13.16.ebuild' * mips-sources-4.13.16.ebuild
  18. Hi, i'm trying to update @world but i'm suffering the following error: emerge -avuUDNt @world --keep-going These are the packages that would be merged, in reverse order: Calculating dependencies... done! Oops! Conflicts have been encountered: >>> media-libs/phonon-vlc-0.9.1-r1:0/0::media-kit, installed, wants media-video/vlc:0/5-8= My candidates are: >>> media-video/vlc-3.0.2-r1:0/5-9::media-kit, ebuild scheduled for merge has SLOT 0/5-9 >>> media-video/vlc-2.2.8-r1:0/5-8::media-kit, ebuild scheduled for merge has
  19. Hallo. I got an error during the installation of gimp with emerge -atv gimp. Output: - media-libs/gexiv2-0.10.6::media-kit USE="python -introspection -static-libs -test" PYTHON_TARGETS="python2_7 python3_4 -python3_5" The following REQUIRED_USE flag constraints are unsatisfied: python? ( introspection ) The above constraints are a subset of the following complete expression: python? ( introspection any-of ( python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 ) ) test? ( python ) (dependency required by "media-gfx/gimp-2.9.6::
  20. Hallo. emerge -atv scipy failed with the following message: >>> Failed to emerge sci-libs/scipy-0.19.1-r1, Log file: >>> '/var/tmp/portage/sci-libs/scipy-0.19.1-r1/temp/build.log' * Messages for package sci-libs/scipy-0.19.1-r1: * ERROR: sci-libs/scipy-0.19.1-r1::science-kit failed (compile phase): * (no error message) * * Call stack: * ebuild.sh, line 92: Called src_compile * environment, line 4389: Called distutils-r1_src_compile * environment, line 1317: Called _distutils-r1_run_foreach_impl 'python_compile'
  21. Hello, I am trying to install Funtoo and have been having a tone of blocks, and desided to start fresh and os-prober has been a reacuring ofender. Here is the message "ownloading 'http://ftp.bg.debian.org/debian/pool/main/o/os-prober/os-prober_1.74.tar.xz' --2018-03-19 13:43:49-- http://ftp.bg.debian.org/debian/pool/main/o/os-prober/os-prober_1.74.tar.xz Resolving ftp.bg.debian.org... 212.50.0.19, 2a01:288:4000:6::2 Connecting to ftp.bg.debian.org|212.50.0.19|:80... connected. HTTP request sent, awaiting response... 404 Not Found 2018-03-19 13:43:50 ERROR 404: Not Found." If someone
  22. Hello, Funtoo users! I want to know how to update world when a dependepcy package could not be downloaded by Portage (error 404 Not found or timeout reason). # emerge -avuDN --with-bdeps=y --newrepo @world .... --2018-02-17 18:24:05-- ftp://oss.sgi.com/projects/xfs/cmd_tars/xfsprogs-4.5.0.tar.gz (try: 3) => ‘/var/cache/portage/distfiles/xfsprogs-4.5.0.tar.gz’ Connecting to oss.sgi.com|192.48.178.134|:21... failed: Connection timed out. Giving up. !!! Couldn't download 'xfsprogs-4.5.0.tar.gz'. Aborting. * Fetch failed for 'sys-fs/xfsprogs-4.5.0', Log file: * '/var/tmp/portage/sys-
  23. I am completely new to installing Gentoo/Funtoo and have had no problems up until updating my @world set. This is giving me an issue and seems like nothing is working. I have done some research on the Gentoo and Funtoo forums with no luck. I tried to just follow the install from the handbook and ran "emerge -auDN @world" and then got this. Code can be found here: https://pastebin.com/z9jbJDHG From there I am at a loss and do not know how to proceed. If anyone has any insight on what I can try to do to fix it or some other commands that I can run to get more info it would be greatly a
  24. hello, i notice the conflicts messages have changed and now i cannot interpret them anymore: # emerge -uDN world --backtrack=1000 These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] dev-libs/protobuf-3.4.1:0/14::dev-kit [3.3.0:0/13::dev-kit] USE="zlib -emacs -examples -static-libs {-test} (-java%) (-python%*)" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="(-python2_7%*) (-python3_4%*) (-python3_5%) (-python3_6%)" 4,385 KiB [ebuild R ] dev-libs/protobuf-c-1.3.0:0/1.0.0::dev-kit USE="-static-libs {-test}" ABI_X86="(64) -32 (-x32)" 4
  25. Hello everybody, Could somebody give me some hints finding a detailed howto /eventually the git page about the algorithm used by Funtoo/Gentoo. I'd like to understand the way it calculates the dependency resolution. As far as i can understand, this is made during the emerge -(p)vDuna @world option. Am i right if i am saying this is done through the root/trunk/leave node dependency calculation (written in python?).
×
×
  • Create New...