Jump to content

Photo

Mask a Package

- - - - - portage mask

10 replies to this topic

#1
quantum

quantum

    Member

  • Members
  • PipPip
  • 16 posts

Hi to all,

 

I am trying to mask the package dev-scheme/guile-2.0.11* since gnucash demand dev-scheme/guile-1.8.8.

 

Unfortently Gnucash does not support dev-scheme/guile-2.0.11* (I adapted the ebuild to check).

 

After masking the package dev-scheme/guile-2.0.11*

cat /etc/portage/package.mask 

=dev-scheme/guile-2.0.11-r1
 

Despite the mask of ev-scheme/guile-2.0.11-r, funtoo still try to merge it:

emerge -au @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-scheme/guile:0

  (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with
    dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed)
                    ^^^^^^^^                              


Nothing to merge; quitting.

How could i mask correctly the package =dev-scheme/guile-2.0.11-r1?

 

 



#2
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 305 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

And if You use:

# emerge -DNupv world --with-bdeps=y

 

How is the output ?



#3
quantum

quantum

    Member

  • Members
  • PipPip
  • 16 posts

Here is the result:

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-scheme/guile:0

  (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with
    dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed)



#4
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 305 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

I'm with the "stable", and i've made an experiment installing gnucash.

 

When I try to update @world i'm in the same your situation.

 

But .... is necessary to update guile ? Which ebuilds requires strictly the 2.0.11  ? :wacko:

 

However, i've emerged gnucash; then emerge @preserved-rebuild (4 ebuilds recompiled with guile 1.8.x).

Making a revdep-rebuild only libreoffice-bin was reinstalled.



#5
quantum

quantum

    Member

  • Members
  • PipPip
  • 16 posts

in general, if there is a new version of a package, then the system will try to install it, in case there is no conflict.

 

The question which is still open, is why i can't mask the package guile-2.0.11?

 

@Sandro, could you please try to mask this package like I did and see if it works?



#6
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 305 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

@quantum: nothing to do; the error compares also with my system.



#7
quantum

quantum

    Member

  • Members
  • PipPip
  • 16 posts

Is this a bug?

 

If yes, then where could i submit it?



#8
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 336 posts

1. gnucash does support guile2. however ebuild has never changed to enable it. It's possible to fix

2. as long as guile-1.8.8 installed and dev-scheme/guile-1.8.8-r99 installed, portage shouldn't try merging guile-2.0.11.  Its needed to see full emerge output, was it world update? 

3. masking this package not working, because it's unmasked in profiles (unmask overrides masks).


www.funtoo.org

#9
quantum

quantum

    Member

  • Members
  • PipPip
  • 16 posts

how can i change my unmasked in profiles?



#10
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 336 posts

i need to get full emerge output of world update after you did following:

emerge -1 guile:12 guile:0/1.8.8

emerge -auDN --tree @world


www.funtoo.org

#11
quantum

quantum

    Member

  • Members
  • PipPip
  • 16 posts

I followed the remark of @Oleg that gnucash ebuild could be adjested to guile2 and it worked.

No i do not see any more:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
 
dev-scheme/guile:0
 
  (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, ebuild scheduled for merge) conflicts with
    dev-scheme/guile:0/1.8.8[deprecated,nls,regex,threads] required by (dev-scheme/guile-1.8.8-r99:12/12::gentoo, installed)

Before i merged my patched gnucash ebuild I run emerge -auDN --tree @world and i got the same as above.

 

I think funtoo wanted to build the latest available version of guild (which was 2.0.11-r1 in my case).

Nether the less, I still do not understand why the mask did not work.





Reply to this topic



  



Also tagged with one or more of these keywords: portage, mask

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users