Jump to content
Read the Funtoo Newsletter: Summer 2023 ×

ping insanity

Recommended Posts

im experiencing periodic packet loss...  something changed within the last month that is causing this....  (at least im pretty sure it just started, ive been able to get clean clean signals to my local counter strike servers before)


tested old kernel 3.13.7 problem still present

ruled out networkmanager, same versions been installed the entire time net-misc/networkmanager-

almost ruled out wpa_supplicant net-wireless/wpa_supplicant-2.1-r1 (original install) (net-wireless/wpa_supplicant-2.2-r1 now) 

glib-networking is getting dirty looks from me....


Ethernet controller: Qualcomm Atheros AR5212/AR5213 Wireless Network Adapter (rev 01)

mkultra@spaceball-1 ~ $ ping google.com
PING google.com ( 56(84) bytes of data.
64 bytes from ord08s07-in-f8.1e100.net ( icmp_seq=1 ttl=54 time=22.4 ms
64 bytes from ord08s07-in-f8.1e100.net ( icmp_seq=2 ttl=54 time=14.6 ms
64 bytes from ord08s07-in-f8.1e100.net ( icmp_seq=3 ttl=54 time=316 ms
64 bytes from ord08s07-in-f8.1e100.net ( icmp_seq=4 ttl=54 time=159 ms
64 bytes from ord08s07-in-f8.1e100.net ( icmp_seq=5 ttl=54 time=22.7 ms

ok i lost half the post....  anything past the code....


anyways im not sure if its the packages, the kernel or kernel modules, what packages etc....

mkultra@spaceball-1 ~ $ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=2 ttl=64 time=170 ms
64 bytes from icmp_seq=3 ttl=64 time=0.858 ms
64 bytes from icmp_seq=4 ttl=64 time=0.841 ms
--- ping statistics ---
5 packets transmitted, 3 received, 40% packet loss, time 4001ms
rtt min/avg/max/mdev = 0.841/57.426/170.581/80.012 ms

forums bug....  anything past code blocks is wiped out on the forums....


i can ping my self @ with 0% loss and excellent pings....  any loss to the router is unacceptable, any 170 pings to the router are unacceptable.   i can youtube and internet rather well still, but the jitter is insane for trying to game.

Link to comment
Share on other sites

ath5k wireless 802.11g


Ethernet controller: Qualcomm Atheros AR5212/AR5213 Wireless Network Adapter (rev 01)


my laptop ath9k adaptor gets less signal and is half the processor and ram, its ping spikes are 1/2 of these on the desktop.


(notice laptop is gentoo, not funtoo)


(im going to test masking latest glib-networking)


testing masking glib-networking shows what happened.  latest world update changed libsoup-gnome from 2.44.2 to 2.46.0


rolling back libsoup & libsoup gnome


--- ping statistics ---

24 packets transmitted, 24 received, 0% packet loss, time 23021ms
rtt min/avg/max/mdev = 0.799/1.707/7.295/1.413 ms
testing more.....  still not fixed....  (i moved the box around and woke up to it working properly)
Link to comment
Share on other sites

wait wait, fixed by rolling back libsoup & libsoup-gnome...  though i remerged them and its back....


ill do that right now nrc.....


(thanks guys)


current libsoup libsoup-gnome ala funtoo


--- ping statistics ---
25 packets transmitted, 19 received, 24% packet loss, time 24016ms
rtt min/avg/max/mdev = 0.812/20.884/257.794/57.684 ms
ala xubuntu
--- ping statistics ---
25 packets transmitted, 25 received, 0% packet loss, time 24017ms
rtt min/avg/max/mdev = 0.803/4.644/86.164/16.646 ms
xubuntu maxes out at 87ms ping(and that was only 1 packet,) funtoo maxes out at 258ms ping (with multiple 100+ms packets and loss on top of that)
xubuntu 0% loss, funtoo 24% loss
this is over 25 packets transmitted to ensure that its got enough time to let the issue present its self.
xubuntu is
libsoup 2.38.1-1
libsoup-gnome 2.38.1-1
glib-networking 2.32.1-1ubuntu2
broken funtoo is
libsoup 2.46.0-r1
libsoup-gnome 2.46.0
glib-networking 2.40.1-r1 (im pretty sure glib-networking is just an accessory to the crime, not the prime suspect)
working funtoo is
libsoup 2.44.2
libsoup-gnome 2.44.2
--- ping statistics ---
25 packets transmitted, 25 received, 0% packet loss, time 24020ms
rtt min/avg/max/mdev = 0.780/8.179/133.931/26.464 ms
more specific, libsoup roll back alone i get excellent pings but still 20% loss...  both rolled back still 20% loss...  reloading networkmanager loss goes to 0%
Link to comment
Share on other sites

I run a Wireless Internet Server Provider in rural Texas.  Deal with wireless issues on a daily basis.  Looks like interference or poor signal strength to me.  Do you have neighbors close by?, running on the same or overlapping your channel?.  I'd try switching channels and see if your packet loss improves.


What your signal level and your noise level when you are experiencing packet loss?  Are you far from your router?  Try moving closer.  Still have high latency/packet loss?


When consumer grade wireless routers begin to die, they exhibit strange, inconsistent behavior.  You could try a different router at least.  Stay away from Netgear and Belkin.  They are the shittiest routers on the market.  If you want a good wireless router that runs linux, try a Mikrotik.  www.routerboard.com and www.mikrotik.com


A wired connection is ALWAYS better than wireless.  Use wired when you can.  In fact, try a cabled connection to your router.  Still have high latency and packet loss?  I highly doubt it has anything to do with software unless you are doing something unusual in make.conf.  Are you an extreme ricer? ;)


Forgot to mention, if your wireless connection is being maxed out by another device on your network, that can also cause high latency and packet loss.  Are you running a torrent on another wireless device?

Link to comment
Share on other sites

only me, only this box


Link Quality=30/70  Signal level=-80 dBm or better and issue comes up... xubuntu was same hardware (its my funtoo install media)


no channel clashing issues.


ive noted something strange....  its good for 3 seconds then bad loss / bad ping.....

mkultra@spaceball-1 ~ $ ping -c 25
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=1.08 ms
64 bytes from icmp_seq=3 ttl=64 time=4.48 ms
64 bytes from icmp_seq=4 ttl=64 time=3.07 ms
64 bytes from icmp_seq=5 ttl=64 time=1.64 ms
64 bytes from icmp_seq=6 ttl=64 time=294 ms
64 bytes from icmp_seq=7 ttl=64 time=1.34 ms
64 bytes from icmp_seq=8 ttl=64 time=0.803 ms
64 bytes from icmp_seq=9 ttl=64 time=1.60 ms
64 bytes from icmp_seq=10 ttl=64 time=220 ms
64 bytes from icmp_seq=11 ttl=64 time=0.951 ms
64 bytes from icmp_seq=12 ttl=64 time=0.796 ms
64 bytes from icmp_seq=13 ttl=64 time=0.810 ms
64 bytes from icmp_seq=14 ttl=64 time=110 ms
64 bytes from icmp_seq=15 ttl=64 time=1.15 ms
64 bytes from icmp_seq=16 ttl=64 time=0.786 ms
64 bytes from icmp_seq=17 ttl=64 time=2.32 ms
64 bytes from icmp_seq=19 ttl=64 time=4.57 ms
64 bytes from icmp_seq=20 ttl=64 time=4.10 ms
64 bytes from icmp_seq=21 ttl=64 time=1.16 ms
64 bytes from icmp_seq=22 ttl=64 time=192 ms
64 bytes from icmp_seq=23 ttl=64 time=1.10 ms
64 bytes from icmp_seq=24 ttl=64 time=2.74 ms
64 bytes from icmp_seq=25 ttl=64 time=1.49 ms

this is happening under 3.15.5 & 3.13.7 (which was running cs GREAT for a long time)

Link to comment
Share on other sites

thanks overkill...  resolved...  802.11e qos/wmm disabled & channel changed from 8 to 10 did the trick.  i disabled everything not necessary and was still getting the problems.  tried pings from laptop and noted lag every 4 seconds tried pings from laptop usb noted lag every 4 seconds tried live media noted lag every 4 seconds......  lol NO BUGS just bad configs...  thanks again for putting up with this garbage on the forums....

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...