Jump to content
funtoo forums
  • 0
storkk

First update in a while, slot conflicts ahoy. (python-related?)

Question

Last time I updated @world was probably 6 months ago... and now I'm running into issues I don't seem to be able to solve, possibly partly python-related:

# emerge -v --info | wgetpaste

Your paste can be seen here: https://bpaste.net/show/4dcc37d656ac

# emerge --ask --update --newuse --deep --with-bdeps=y @world | wgetpaste

.... std err is at https://bpaste.net/show/3b353d5588b6 ...
Your paste can be seen here: https://bpaste.net/show/4deeb418e791

# python-updater | wgetpaste
emerge: there are no ebuilds to satisfy "dev-python/PyQt4:0/QtCore-1".


Your paste can be seen here: https://bpaste.net/show/0a030c9c47b4

... removing/unversioning all the packages that complain (not sure that's the best idea, but just trying to get something to work), I get:

# emerge -Dv1 --keep-going app-admin/syslog-ng:0 app-portage/gentoolkit:0 app-text/calibre:0 dev-java/javatoolkit:0 dev-libs/boost:0/1.56.0 dev-libs/libxml2:2 dev-libs/libxslt:0 dev-python/Babel:0 dev-python/apsw:0 dev-python/beautifulsoup:python-2 dev-python/cffi dev-python/cryptography:0 dev-python/cython:0 dev-python/decorator:0 dev-python/enum34:0 dev-python/eyeD3:0.7 dev-python/httplib2:0 dev-python/idna:0 dev-python/ipaddress:0 dev-python/lxml:0 dev-python/notify-python:0 dev-python/numpy:0 dev-python/packaging:0 dev-python/paver:0 dev-python/ply dev-python/pycparser:0 dev-python/pyelftools:0 dev-python/pygments:0 dev-python/pygobject:3 dev-python/pygtk:2 dev-python/pyopenssl:0 dev-python/python-dateutil:0 dev-python/python-gflags:0 dev-python/pytz:0 dev-python/pyxattr:0 dev-python/pyzmq:0 dev-python/setuptools:0 dev-python/simplejson:0 dev-python/sip:0/11 dev-python/six:0 dev-python/twisted-core:0 dev-python/twisted-web:0 dev-util/boost-build:0 dev-util/gdbus-codegen:0 dev-util/scons:0 net-p2p/deluge:0 sys-apps/file:0 sys-libs/cracklib:0 sys-libs/libcap-ng:0 x11-libs/vte:0 | wgetpaste


Your paste can be seen here: https://bpaste.net/show/145345d5d5bf

 

Trying to oneshot icu and what pulls it in:

# emerge -1 icu libxml2 calibre --backtrack=50 | wgetpaste
... std err is at https://bpaste.net/show/734ffceb3e2d ...
Your paste can be seen here: https://bpaste.net/show/21c89c124f17

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Versions of eselect-python, python,python-exec that should be masked keep trying to install on your system because you have them in /etc/portage/package.unmask
There could be package versions we need to install that are masked in your /etc/portage/package.mask
I realize now that to update a stale system you must remove stale /etc/portage/package.mask and /etc/portage/package.unmask overrides if they exist or they cause conflicts with the update. 
Remove /etc/portage/package.mask and /etc/portage/package.unmask and maybe we can make some progress.

# emerge --sync
# emerge --pretend --update --newuse --deep --with-bdeps=y @world | wgetpaste
emerge -v -info | wgetpaste

Share this post


Link to post
Share on other sites
  • 0

Thanks for taking a look!

# epro list

=== arch: ===

    arm-32bit, pure64, x86-32bit, (x86-64bit*)

=== subarch: ===

    amd64-bulldozer, amd64-jaguar, amd64-k10, amd64-k8, amd64-k8+sse3
    amd64-piledriver, amd64-steamroller, atom_64, btver1_64, core-avx-i
    core2_64, corei7, generic_64, intel64-broadwell, intel64-haswell
    intel64-ivybridge, intel64-nehalem, intel64-sandybridge, intel64-silvermont
    intel64-westmere, native_64, nocona, opteron_64, xen-pentium4+sse3_64

=== build: ===

    (current*), experimental, stable

=== flavor: ===

    core, desktop*, hardened, minimal, server, workstation

=== mix-ins: ===

    X*, audio*, cinnamon, console-extras, dvd*, gnome, gnome-3.16-fixups
    hardened, kde, kde-plasma-5, lxde, lxqt, mate, media*, media-pro
    mediadevice-audio-consumer, mediadevice-audio-pro, mediadevice-base
    mediadevice-video-consumer, mediadevice-video-pro, mediaformat-audio-common
    mediaformat-audio-extra, mediaformat-gfx-common, mediaformat-gfx-extra
    mediaformat-video-common, mediaformat-video-extra, no-emul-linux-x86
    no-systemd, openvz-host, print, python3-only, vmware-guest
    xfce*

# cat /etc/portage/make.conf | wgetpaste 
Your paste can be seen here: https://bpaste.net/show/2a79f63a7021

https://bpaste.net/show/2a79f63a7021 because links don't seem to work in code blocks.

Share this post


Link to post
Share on other sites
  • 0

Ok... one "step" at once.

In Your epro list and make.conf i can see that you're using "multib".

Add to your make.conf:

ABI_X86="64 32"

The retry to take a look with emerge -DNupv world --with-bdeps=y (and paste it if there is some news :))

 

And about VIDEO_CARDS there is an error .... change with

VIDEO_CARDS="radeon"

Also Insert:

 

INPUT_DEVICES="mouse keyboard evdev".

 

Another idea: if you want to use your videocard with opengl for desktop effects remove the "no-emul-linux-x86" cause for graphical Opengl softwares can be necessary the opengl 32-bits compatible.

 

(if You use a laptop add also "synaptics" to the INPUT_DEVICES declaration :)

 

About Python, review Your declaration in make.conf.

If You use Python 2_7 and 3_3 you can delete the declarations about python.

 

You cpu is an Intel "Sandy Bridge" or "Ivy-bridge" ?

Share this post


Link to post
Share on other sites
  • 0

Thanks again, Sandro!

 

  • Not sure why I need multilib, and it's not in my make.conf AFAICT. I'll add ABI_X86="64 32" for now, but perhaps that's something else I need to fix. I don't think I need any 32-bit libraries. (except ogengl maybe??)
  • I've also changed VIDEO_CARDS... but that information came from the "VIDEO_CARDS" column at https://wiki.gentoo.org/wiki/Radeon#Feature_support (Evergreen chipset) - is that an error?
  • Added INPUT_DEVICES... I also have a wacom - should that go in here as well?
  • Could you explain a bit more about the no-emul-linux-x86 mix-in relating to opengl? How does this relate to multilib and ABI_X86 ?
  • I added the python lines after portage prompted me to (packages with REQUIRED_USE flags "at least one of" ...), after removing them emerge -uDnv fails immediately:
    !!! Problem resolving dependencies for sys-boot/boot-update from @selected
    
    !!! The ebuild selected to satisfy "sys-boot/boot-update" has unmet requirements.
    - sys-boot/boot-update-1.7.3-r1::gentoo USE="" PYTHON_SINGLE_TARGET="python2_7 python3_3" PYTHON_TARGETS="python2_7 python3_3"
    
      The following REQUIRED_USE flag constraints are unsatisfied:
        exactly-one-of ( python_single_target_python2_7 python_single_target_python3_3 )
    
      The above constraints are a subset of the following complete expression:
        exactly-one-of ( python_single_target_python2_7 python_single_target_python3_3 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_3? ( python_targets_python3_3 )
    
    (dependency required by "@selected" [set])
    (dependency required by "@world" [argument])
    
    

    I could set it in package.use, but it seems to be many packages.

  • CPU:

  • # cat /proc/cpuinfo | grep ridg
    # cat /proc/cpuinfo | grep name
    model name	: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
    ... x 8 ...
    
    

    After re-adding the python lines, but doing everything else above, I have stderr:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-haskell/hashable:0

  (dev-haskell/hashable-1.2.4.0:0/1.2.4.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/hashable-1.2.3.3:0/1.2.3.3::gentoo, installed) pulled in by
    >=dev-haskell/hashable-1.0:0/1.2.3.3= required by (dev-haskell/case-insensitive-1.2.0.4:0/1.2.0.4::gentoo, installed)
                              ^^^^^^^^^^^                                                                                 
    (and 9 more with the same problem)

dev-haskell/unordered-containers:0

  (dev-haskell/unordered-containers-0.2.6.0:0/0.2.6.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/unordered-containers-0.2.5.1:0/0.2.5.1::gentoo, installed) pulled in by
    <dev-haskell/unordered-containers-0.3:0/0.2.5.1= required by (dev-haskell/semigroups-0.16.2.2:0/0.16.2.2::gentoo, installed)
                                         ^^^^^^^^^^^                                                                             
    (and 5 more with the same problem)

dev-haskell/scientific:0

  (dev-haskell/scientific-0.3.4.4:0/0.3.4.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/scientific-0.3.3.8:0/0.3.3.8::gentoo, installed) pulled in by
    >=dev-haskell/scientific-0.3.1:0/0.3.3.8= required by (dev-haskell/attoparsec-0.13.0.1:0/0.13.0.1::gentoo, installed)
                                  ^^^^^^^^^^^                                                                             
    (and 4 more with the same problem)

dev-haskell/pandoc-types:0

  (dev-haskell/pandoc-types-1.12.4.7:0/1.12.4.7::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/pandoc-types-1.12.4.5:0/1.12.4.5::gentoo, installed) pulled in by
    <dev-haskell/pandoc-types-1.13:0/1.12.4.5= required by (app-text/pandoc-1.15.0.6:0/1.15.0.6::gentoo, installed)
                                  ^^^^^^^^^^^^                                                                      
    (and 3 more with the same problem)

dev-haskell/yaml:0

  (dev-haskell/yaml-0.8.15.2:0/0.8.15.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/yaml-0.8.12:0/0.8.12::gentoo, installed) pulled in by
    >=dev-haskell/yaml-0.8.8.2:0/0.8.12= required by (app-text/pandoc-1.15.0.6:0/1.15.0.6::gentoo, installed)
                              ^^^^^^^^^^                                                                      
    (and 1 more with the same problem)

dev-haskell/blaze-html:0

  (dev-haskell/blaze-html-0.8.1.1:0/0.8.1.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/blaze-html-0.8.1.0:0/0.8.1.0::gentoo, installed) pulled in by
    >=dev-haskell/blaze-html-0.5:0/0.8.1.0= required by (app-text/pandoc-1.15.0.6:0/1.15.0.6::gentoo, installed)
                                ^^^^^^^^^^^                                                                      
    (and 3 more with the same problem)

dev-haskell/tagsoup:0

  (dev-haskell/tagsoup-0.13.8:0/0.13.8::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/tagsoup-0.13.3-r1:0/0.13.3::gentoo, installed) pulled in by
    >=dev-haskell/tagsoup-0.13.1:0/0.13.3= required by (app-text/pandoc-1.15.0.6:0/1.15.0.6::gentoo, installed)
                                ^^^^^^^^^^                                                                      
    (and 1 more with the same problem)

dev-haskell/blaze-markup:0

  (dev-haskell/blaze-markup-0.7.0.3:0/0.7.0.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/blaze-markup-0.7.0.2:0/0.7.0.2::gentoo, installed) pulled in by
    <dev-haskell/blaze-markup-0.8:0/0.7.0.2= required by (app-text/pandoc-1.15.0.6:0/1.15.0.6::gentoo, installed)
                                 ^^^^^^^^^^^                                                                      
    (and 3 more with the same problem)

dev-haskell/streaming-commons:0

  (dev-haskell/streaming-commons-0.1.15:0/0.1.15::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/streaming-commons-0.1.12.1:0/0.1.12.1::gentoo, installed) pulled in by
    >=dev-haskell/streaming-commons-0.1.0.2:0/0.1.12.1= required by (dev-haskell/http-client-0.4.18.1:0/0.4.18.1::gentoo, installed)
                                           ^^^^^^^^^^^^                                                                              
    (and 1 more with the same problem)

dev-haskell/resourcet:0

  (dev-haskell/resourcet-1.1.7:0/1.1.7::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/resourcet-1.1.6:0/1.1.6::gentoo, installed) pulled in by
    <dev-haskell/resourcet-1.2:0/1.1.6= required by (dev-haskell/conduit-1.2.5:0/1.2.5::gentoo, installed)
                              ^^^^^^^^^                                                                    
    (and 3 more with the same problem)

dev-haskell/conduit:0

  (dev-haskell/conduit-1.2.6.1:0/1.2.6.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/conduit-1.2.5:0/1.2.5::gentoo, installed) pulled in by
    >=dev-haskell/conduit-1.1.0:0/1.2.5= required by (dev-haskell/yaml-0.8.12:0/0.8.12::gentoo, installed)
                               ^^^^^^^^^                                                                   
    (and 1 more with the same problem)

dev-haskell/void:0

  (dev-haskell/void-0.7.1:0/0.7.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/void-0.7:0/0.7::gentoo, installed) pulled in by
    >=dev-haskell/void-0.5.5:0/0.7= required by (dev-haskell/conduit-1.2.5:0/1.2.5::gentoo, installed)
                            ^^^^^^^                                                                    

dev-haskell/mmorph:0

  (dev-haskell/mmorph-1.0.5:0/1.0.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-haskell/mmorph-1.0.4:0/1.0.4::gentoo, installed) pulled in by
    dev-haskell/mmorph:0/1.0.4= required by (dev-haskell/resourcet-1.1.6:0/1.1.6::gentoo, installed)
                      ^^^^^^^^^                                                                      
    (and 1 more with the same problem)

media-video/avidemux:2.6

  (media-video/avidemux-2.6.8:2.6/2.6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-video/avidemux-2.6.8:2.6/2.6::gentoo, installed) pulled in by
    ~media-video/avidemux-2.6.8:2.6[opengl?,qt4?] required by (media-libs/avidemux-plugins-2.6.8:2.6/2.6::gentoo, installed)
                                            ^^^^                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-python-20151117-r3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, ebuild scheduled for merge)

  (sys-libs/ncurses-5.9-r101:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2 required by (sys-kernel/gentoo-sources-4.1.4:4.1.4/4.1.4::gentoo, installed)
    sys-libs/ncurses required by (sys-libs/slang-2.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_32(-),abi_x86_64(-)]) required by (sys-libs/readline-6.3_p8-r2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2:5/5= required by (sys-devel/bc-1.06.95-r2:0/0::gentoo, installed)
    sys-libs/ncurses:5/5=[unicode] required by (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, installed)
    sys-libs/ncurses:5/5= required by (sci-mathematics/octave-4.0.0:0/4.0.0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by (sys-apps/gptfdisk-1.0.0:0/0::gentoo, installed)
    sys-libs/ncurses:=[unicode] required by (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, installed)
    sys-libs/ncurses required by (app-text/hunspell-1.3.3:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:= required by (sys-devel/bc-1.06.95-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.4.5:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7 required by (sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_32(-),abi_x86_64(-)]) required by (dev-db/unixODBC-2.3.2-r2:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses required by @system
    >=sys-libs/ncurses-5.2-r2 required by (app-editors/vim-7.4.712:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2 required by (sys-kernel/gentoo-sources-4.4.1:4.4.1/4.4.1::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:=[unicode?] (>=sys-libs/ncurses-5.7-r7:=[unicode]) required by (sys-process/procps-3.3.11-r3:0/5::gentoo, ebuild scheduled for merge)

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/greenlet-0.4.9:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxdg-0.25-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/characteristic-14.3.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pyzmq-15.2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (dev-python/html5lib-0.9999999:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/simplejson-3.8.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (sys-libs/tdb-1.3.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/enum34-1.1.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (dev-java/javatoolkit-0.3.0-r9:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pypy-4.0.1:0/4.0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-print/cups-2.1.2-r2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cffi-1.4.2:0/1.4.2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/send2trash-1.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/beautifulsoup-3.2.1-r1:python-2/python-2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/ipykernel-4.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libixion-0.9.1:0/0.10::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.7.0-r2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[ncurses] required by (app-portage/elogv-0.7.6.6:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/eyeD3-0.7.5:0.7/0.7::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/chardet-2.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/jinja-2.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/file-5.25:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/sip-4.17-r1:0/11::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/libgpod-0.8.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/ipyparallel-4.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (gnome-base/gconf-3.2.6-r4:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/Babel-2.2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/cryptography-1.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/netifaces-0.10.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[readline,sqlite,threads(+)] required by (dev-python/ipython-4.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ipython_genutils-0.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ipaddress-1.0.16:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/protobuf-2.6.1-r3:0/9::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyasn1-0.1.9:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cddb-py-1.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/gobject-introspection-1.44.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-libs/libproxy-0.4.11-r2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-text/gnome-doc-utils-0.20.10-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/gexiv2-0.10.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyaudio-0.2.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (app-editors/vim-7.4.712:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-wireless/lorcon-0.0_p20150109:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/newt-0.52.18:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/idna-2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/avidemux-plugins-2.6.8:2.6/2.6::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/lxml-3.5.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sci-libs/gdal-2.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/psutil-3.3.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libpeas-1.14.0-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[tk?,threads(+)] (>=dev-lang/python-2.7.5-r2:2.7[threads(+)]) required by (dev-python/pillow-3.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pickleshare-0.6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-greenlet-1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/path-py-8.1.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycrypto-2.6.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cssselect-0.9.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyelftools-0.23-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[ssl(+),threads(+)] required by (dev-python/gevent-1.1_beta6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/py-1.4.31:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyside-1.2.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/alsa-lib-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/PyQt4-4.11.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numpy-1.10.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pyopenssl-0.15.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pexpect-4.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/traitlets-4.1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-util/anjuta-3.16.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-pda/libimobiledevice-1.1.6-r1:0/4::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libclc-0.2.0_pre20151006:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/decorator-4.0.6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygments-2.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-pda/libplist-1.11-r1:0/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-admin/syslog-ng-3.7.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-gfx/gimp-2.9.2:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-util/itstool-2.0.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/vte-0.28.2-r207:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (dev-lang/spidermonkey-1.8.5-r4:0/mozjs185::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/twisted-web-15.2.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads,sqlite] required by (www-client/firefox-44.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pymountboot-0.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (games-fps/doomsday-1.15.7:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxslt-1.1.28-r5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[ssl(+)] required by (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-p2p/deluge-1.3.12:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/service_identity-14.0.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-lang/yasm-1.3.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/PyQt5-5.5.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/cython-0.23.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-3.16.2:3/3::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[sqlite,ssl] required by (app-text/calibre-2.47.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ply-3.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-16.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-libs/webkit-gtk-2.4.9:3/25::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-wireless/aircrack-ng-1.2_rc3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-dnspython-1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/python-gflags-2.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pycparser-2.14:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/markupsafe-0.23:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/google-apputils-0.4.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[ncurses] required by (dev-python/urwid-1.3.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/jupyter_client-4.1.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/shiboken-1.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/httplib2-0.9.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[ncurses?,xml] (>=dev-lang/python-2.7.5-r2:2.7[ncurses,xml]) required by (net-misc/wicd-1.7.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/mechanize-0.2.5-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:2.7 required by (media-libs/vigra-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyasn1-modules-0.0.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/jupyter_core-4.0.6:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-admin/eclean-kernel-0.4.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/keybinder-0.3.1-r200:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/simplegeneric-0.8.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[sqlite] required by (app-misc/anki-2.0.33:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/dnspython-1.12.0-r200:py2/py2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyparsing-2.0.7:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/twisted-core-15.2.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (media-gfx/inkscape-0.91-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads,xml] required by (media-libs/vigra-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cssutils-1.0.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/usbutils-007:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-ipaddress-1.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pytz-2015.7:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (sys-libs/tdb-1.3.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ptyprocess-0.5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/kmod-19:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-boot/boot-update-1.7.3-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-qt/qtwebkit-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (net-libs/rb_libtorrent-1.0.8:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/paver-1.2.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/mutagen-1.31:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (www-client/chromium-48.0.2564.82:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-java/java-config-2.2.0:2/2::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/apsw-3.8.11.1_p1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/six-1.10.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/python-dateutil-2.4.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/beautifulsoup-4.4.1:4/4::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/zope-interface-4.1.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libnl-3.2.27:3/3::gentoo, ebuild scheduled for merge)

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.7-r7:0= required by (dev-libs/libcdio-0.93:0/15::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (games-roguelike/nethack-3.6.0-r1:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (dev-lang/ruby-2.2.4:2.2/2.2::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2-r5 required by (sys-boot/grub-2.02_beta2-r3:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (app-misc/screen-4.2.1-r2:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (app-crypt/pinentry-0.9.7:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:0= required by (media-sound/alsa-utils-1.1.0:0.9/0.9::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-),abi_x86_64(-)]) required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (dev-util/cmake-3.4.3:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (net-wireless/wpa_supplicant-2.5-r1:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (sys-devel/gettext-0.19.6:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (dev-lang/ruby-2.0.0_p648:2.0/2.0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (sci-mathematics/octave-4.0.0:0/4.0.0::gentoo, installed)
    sys-libs/ncurses:0= required by (app-editors/nano-2.5.0:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:0= required by (media-sound/lame-3.99.5-r1:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses required by @system
    >=sys-libs/ncurses-5.2:0= required by (dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (x11-libs/vte-0.28.2-r207:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2:0 required by (www-client/elinks-0.12_pre6-r2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2-r2:0= required by (sys-apps/texinfo-6.0:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r1:0=[unicode?] (>=sys-libs/ncurses-5.9-r1:0=[unicode]) required by (app-editors/nano-2.5.0:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.18.3-r1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2-r2:0= required by (app-shells/bash-4.3_p42:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (dev-python/pypy-4.0.1:0/4.0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2:0= required by (sys-apps/less-481:0/0::gentoo, installed)
    sys-libs/ncurses:0/5=[unicode] required by (sys-process/htop-1.0.3-r1:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (media-video/mplayer-1.2.1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2 required by (app-admin/testdisk-7.0-r3:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (gnome-extra/libgda-5.2.4-r1:5/4::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0=[unicode] required by (media-video/vlc-2.2.1-r1:0/5-8::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0=[unicode?] (sys-libs/ncurses:0=[unicode]) required by (sys-process/htop-1.0.3-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (sys-block/parted-3.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:0= required by (x11-terms/xterm-322:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (dev-lang/ruby-2.1.8:2.1/2.1::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2-r2:0=[unicode?] (>=sys-libs/ncurses-5.2-r2:0=[unicode]) required by (sys-apps/util-linux-2.27.1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2:0 required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

and out:

Your paste can be seen here: https://bpaste.net/show/a26d7608ed21
 
Thanks again for your time and help!

Share this post


Link to post
Share on other sites
  • 0

Try to make :

# perl-cleaner --allmodules
# python-updater

Then

# emerge -DNu @system

If You wnt i can enter in Your system .... with teamviewer or sshd.

My references:

Facebook: alcerb1972

Skype: alessandro.ceriani (Saronno, IT)

 

Cause i mu st see "under my litle eyes Your real situation.

 

It isn't the first time that i make similar work ..... :)

I'n not "cracker" .... your privacy will be respected totally :)

And If you want with teamviever ... you can use my PC from remote .......

 

I must have all under my eyes to make something .....

Share this post


Link to post
Share on other sites
  • 0

Python3_4 requires app-eselect/eselect-python-20151117-r3 conflicts with python2_7 and python3_3
>=python-3.4.3-r2 and >=eselect-python-20151117-r3 are masked to prevent this.
http://git.funtoo.org/ports-2012/tree/profiles/package.mask/funtoo-python#n9
http://git.funtoo.org/ports-2012/tree/profiles/package.mask/funtoo-python#n12
User override adding python3_4 to PYTHON_TARGETS and PYTHON_SINGLE_TARGET to make.conf or using a package.unmask re-creates conflict. 
Remove this from /etc/portage/make.conf :

USE_PYTHON="2.7 3.4"
PYTHON_TARGETS="python2_7 python3_4"
PYTHON_SINGLE_TARGET="python3_4"

The -p or --pretend option is used on the commands below to check for conflicts.
Update eselect-python,python2_7,and python3_3 to the current versions

# emerge -pv1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2

If there are no conflicts and merge succeeds run python-updater
 
Output on my updated system:

funtoo rj # emerge -pv1  =app-eselect/eselect-python-20140125 python:2.7 python:3.3

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-eselect/eselect-python-20140125::gentoo  71 KiB
[ebuild   R    ] dev-lang/python-2.7.10-r1:2.7::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -tk -wininst" 0 KiB
[ebuild   R    ] dev-lang/python-3.3.5-r2:3.3::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened -tk -wininst" 0 KiB

Total: 3 packages (3 reinstalls), Size of downloads: 71 KiB
# emerge -pvDNu --with-bdeps=y @system 

From my updated pure64 current system
I have EMERGE_DEFAULT_OPTS="--with-bdeps=y" in my make.conf
 

funtoo rj # emerge -pv  @system | wgetpaste 

Your paste can be seen here: https://bpaste.net/show/83aa913ae656

funtoo rj # emerge -v --info | wgetpaste 

Your paste can be seen here: https://bpaste.net/show/da6d0140c022
 

Share this post


Link to post
Share on other sites
  • 0

@cardinal... Thanks for helping. It looks like we may be getting somewhere, but:

# emerge -pv1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-arch/bzip2-1.0.6-r7::gentoo  USE="-static -static-libs" ABI_X86="32* (64) (-x32)" 764 KiB
[ebuild   R    ] dev-libs/expat-2.1.0-r5::gentoo  USE="unicode -examples -static-libs" ABI_X86="32* (64) (-x32)" 550 KiB
[ebuild   R    ] dev-libs/libffi-3.2.1::gentoo  USE="-debug -pax_kernel -static-libs {-test}" ABI_X86="32* (64) (-x32)" 919 KiB
[ebuild   R    ] virtual/libffi-3.0.13-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] dev-libs/gmp-6.1.0:0/10.4::gentoo [6.0.0a:0/0::gentoo] USE="asm%* cxx -doc -pgo -static-libs" ABI_X86="(64) -32 (-x32)" 1,905 KiB
[ebuild   R    ] sys-libs/zlib-1.2.8-r1::gentoo  USE="minizip -static-libs" ABI_X86="32* (64) (-x32)" 558 KiB
[ebuild     U  ] dev-libs/icu-56.1:0/56::gentoo [55.1:0/55::gentoo] USE="-debug -doc -examples -static-libs" ABI_X86="32* (64) (-x32)" 25,120 KiB
[ebuild     U  ] media-libs/libpng-1.6.21:0/16::gentoo [1.6.18:0/16::gentoo] USE="apng (-neon) -static-libs" ABI_X86="32* (64) (-x32)" 932 KiB
[ebuild     U  ] media-libs/freetype-2.6.2:2::gentoo [2.6:2::gentoo] USE="X adobe-cff bzip2 png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32* (64) (-x32)" 1,727 KiB
[ebuild     UD ] media-libs/fontconfig-2.11.1-r2:1.0::gentoo [2.11.94:1.0::gentoo] USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 1,481 KiB
[ebuild     U  ] dev-libs/libxml2-2.9.3:2::gentoo [2.9.2-r1001:2::gentoo] USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test} (-python_abis_2.6%) (-python_abis_2.7%*) (-python_abis_3.1%) (-python_abis_3.2%) (-python_abis_3.3%*) (-python_abis_3.4%) (-python_abis_3.5%)" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7%* python3_3%* -python3_4% -python3_5%" 5,349 KiB
[ebuild   R    ] sys-libs/gpm-1.20.7-r2::gentoo  USE="(-selinux) -static-libs" ABI_X86="32* (64) (-x32)" 772 KiB
[ebuild     U  ] sys-libs/ncurses-6.0-r1:0/6::gentoo [5.9-r5:0/5::gentoo] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs {-test%} -threads% -tinfo -trace" ABI_X86="32* (64) (-x32)" 3,059 KiB
[ebuild     UD ] dev-lang/python-2.7.10-r1:2.7::gentoo [2.7.10-r1000:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened% -tk -wininst" 11,964 KiB
[ebuild     UD ] dev-lang/python-3.3.5-r2:3.3::gentoo [3.3.6-r1000:3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened% -tk -wininst" 11,845 KiB
[ebuild  rR    ] sys-devel/bc-1.06.95-r2::gentoo  USE="readline -libedit -static" 284 KiB
[ebuild  rR    ] dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo  USE="gmp -binary -doc -ghcbootstrap -ghcmakebinary" 0 KiB
[ebuild  r  U  ] gnome-extra/libgda-5.2.4-r1:5/4::gentoo [5.2.4:5/4::gentoo] USE="berkdb gtk introspection* java ssl -canvas -debug (-firebird) -gnome-keyring -graphviz -http -json -ldap -mdb -mysql -oci8 -postgres -reports -sourceview -vala" PYTHON_TARGETS="python2_7" 12,032 KiB
[ebuild  rR    ] sci-mathematics/octave-4.0.0:0/4.0.0::gentoo  USE="X glpk imagemagick java opengl qhull qrupdate readline sparse zlib -curl -doc -fftw -gnuplot -gui -hdf5 -jit -postscript -static-libs" 15,390 KiB
[ebuild  r  U  ] sys-devel/llvm-3.7.1:0/3.7.1::gentoo [3.6.2:0/3.6::gentoo] USE="clang libffi ncurses python static-analyzer xml -debug -doc -gold -libedit -lldb% -multitarget -ocaml {-test}" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7 (-pypy%)" VIDEO_CARDS="radeon" 24,610 KiB
[ebuild     U  ] sys-devel/clang-3.7.1-r100:0/3.7::gentoo [3.6.2-r100:0/3.6::gentoo] USE="python static-analyzer -debug -multitarget" ABI_X86="32* (64) (-x32)" 0 KiB
[blocks B      ] >=sys-devel/llvm-3.7 (">=sys-devel/llvm-3.7" is blocking media-libs/mesa-10.5.2)
[blocks B      ] <=sys-devel/clang-3.7.1-r99 ("<=sys-devel/clang-3.7.1-r99" is blocking sys-devel/llvm-3.7.1)

Total: 21 packages (9 upgrades, 3 downgrades, 9 reinstalls), Size of downloads: 119,254 KiB
Conflict: 2 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/ncurses:0

  (sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, installed) pulled in by
    sys-libs/ncurses:0/5[ada?,cxx?,gpm?,static-libs?,tinfo?,unicode?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/ncurses-5.9-r99:5/5::gentoo, installed)
                    ^^^^                                                                                                                                                                                                                                                                                                              
    sys-libs/ncurses:0/5= required by (dev-python/pypy-2.6.0:0/2.6::gentoo, installed)
                    ^^^^^                                                                                                 
    (and 6 more with the same problems)

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                          

  (dev-libs/icu-55.1:0/55::gentoo, installed) pulled in by
    >=dev-libs/icu-4.8.1.1:0/55= required by (app-office/libreoffice-5.0.2.2:0/0::gentoo, installed)
                          ^^^^^^                                                                                                        
    (and 18 more with the same problem)

sys-devel/clang:0

  (sys-devel/clang-3.7.1-r100:0/3.7::gentoo, ebuild scheduled for merge) pulled in by
    =sys-devel/clang-3.7.1-r100 required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
    ^                ^^^^^^^^^^                                                                                                                                      

  (sys-devel/clang-3.6.2-r100:0/3.6::gentoo, installed) pulled in by
    =sys-devel/clang-3.6.2-r100 required by (sys-devel/llvm-3.6.2:0/3.6::gentoo, installed)
    ^                ^^^^^^^^^^                                                                                                                   
    <sys-devel/clang-3.7 required by (dev-libs/libclc-0.1.0_pre20150305:0/0::gentoo, installed)
    ^                ^^^                                                                                                                              

sys-devel/llvm:0

  (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge) pulled in by
    ~sys-devel/llvm-3.7.1[clang(-),debug=,multitarget?,python?,static-analyzer?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/clang-3.7.1-r100:0/3.7::gentoo, ebuild scheduled for merge)
    ^               ^^^^^                                                                                                                                                                                                                                                                                                                                                                

  (sys-devel/llvm-3.6.2:0/3.6::gentoo, installed) pulled in by
    <sys-devel/llvm-3.7:0/3.6=[abi_x86_64(-)] required by (media-libs/mesa-10.5.2:0/0::gentoo, installed)
    ^               ^^^^^^^^^^                                                                                                                                                     
    ~sys-devel/llvm-3.6.2[clang(-),debug=,multitarget?,python?,static-analyzer,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/clang-3.6.2-r100:0/3.6::gentoo, installed)
    ^               ^^^^^                                                                                                                                                                                                                                                                                                                                              
    (and 1 more with the same problems)

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2[python,python_targets_python2_7(-)?,-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_jython2_7(-),python_single_target_python2_7(+)] required by (dev-util/itstool-2.0.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                 
    dev-libs/libxml2:2=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                       
    >=dev-libs/libxml2-2.6.12[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (app-text/gnome-doc-utils-0.20.10-r1:0/0::gentoo, installed)
                                                                                                                                                                                               

  (dev-libs/libxml2-2.9.2-r1001:2/2::gentoo, installed) pulled in by
    >=dev-libs/libxml2-2.8.0:2[python,python_abis_2.7] required by (dev-libs/libxslt-1.1.28-r1002:0/0::gentoo, installed)
                                      ^^^^^^^^^^^^^^^                                                                                                        


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/mesa-10.5.2:0/0::gentoo, installed) pulled in by
    >=media-libs/mesa-10.3.4-r1[egl,gbm] required by (x11-base/xorg-server-1.16.4-r1:0/1.16.1::gentoo, installed)
    >=media-libs/mesa-9.1.6[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[egl,abi_x86_64(-)]) required by (x11-libs/cairo-1.14.2:0/0::gentoo, installed)
    >=media-libs/mesa-10.2:* required by (www-client/firefox-41.0-r1:0/0::gentoo, installed)
    media-libs/mesa required by @selected
    >=media-libs/mesa-9.1.6[opencl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[opencl,abi_x86_64(-)]) required by (virtual/opencl-0-r4:0/0::gentoo, installed)
    >=media-libs/mesa-10.3.4-r1[nptl] required by (x11-base/xorg-server-1.16.4-r1:0/1.16.1::gentoo, installed)
    media-libs/mesa[egl] required by (net-libs/webkit-gtk-2.4.9:3/25::gentoo, installed)
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[abi_x86_64(-)]) required by (virtual/opengl-7.0-r1:0/0::gentoo, installed)
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[abi_x86_64(-)]) required by (media-libs/gst-plugins-bad-1.4.5:1.0/1.0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, ebuild scheduled for merge)

My make.conf now looks like https://bpaste.net/show/017adc3330b5

 

@Sandro: Thanks... perlcleaner fails with clang and llvm blocks; icu, ncurses and a bunch of python slot conflicts. I'm not quite ready for a remote control session, but thanks for the offer!

Share this post


Link to post
Share on other sites
  • 0

whoa... 

# emerge -upNv1 mesa

These are the packages that would be merged, in order:

Calculating dependencies... done!
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.3/emerge", line 50, in <module>
    retval = emerge_main()
  File "/usr/lib64/python3.3/site-packages/_emerge/main.py", line 1154, in emerge_main
    return run_action(emerge_config)
  File "/usr/lib64/python3.3/site-packages/_emerge/actions.py", line 3191, in run_action
    emerge_config.args, spinner)
  File "/usr/lib64/python3.3/site-packages/_emerge/actions.py", line 321, in action_build
    settings, trees, myopts, myparams, myaction, myfiles, spinner)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 9117, in backtrack_depgraph
    myaction, myfiles, spinner)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 9154, in _backtrack_depgraph
    success, favorites = mydepgraph.select_files(myfiles)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 3580, in select_files
    return self._select_files(args)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 3919, in _select_files
    return self._resolve(myfavorites)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 4070, in _resolve
    if not self._create_graph():
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 2382, in _create_graph
    if not self._pop_disjunction(allow_unsatisfied):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 3495, in _pop_disjunction
    pkg, dep_root, dep_priority, dep_struct, allow_unsatisfied):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 3102, in _add_pkg_dep_string
    allow_unsatisfied)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 3162, in _wrapped_add_pkg_dep_string
    strict=strict, priority=dep_priority)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 4362, in _select_atoms_highest_available
    myroot=root, trees=trees)
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 704, in dep_check
    use_binaries=use_binaries, myroot=myroot, trees=trees)
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 63, in _expand_new_virtuals
    use_force=use_force, **kwargs))
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 113, in _expand_new_virtuals
    matches = portdb.match_pkgs(x.without_use)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 8866, in match_pkgs
    if pkg is not None and self._visible(pkg, atom_set):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 8965, in _visible
    pkg, ignore_use=True):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 4482, in _virt_deps_visible
    parent=pkg, priority=self._priority(runtime=True))
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 4362, in _select_atoms_highest_available
    myroot=root, trees=trees)
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 704, in dep_check
    use_binaries=use_binaries, myroot=myroot, trees=trees)
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 63, in _expand_new_virtuals
    use_force=use_force, **kwargs))
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 113, in _expand_new_virtuals
    matches = portdb.match_pkgs(x.without_use)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 8866, in match_pkgs
    if pkg is not None and self._visible(pkg, atom_set):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 8969, in _visible
    self._have_virt_update(pkg, atom_set):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 9028, in _have_virt_update
    for new_child in self._iter_virt_update(pkg, atom_set):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 9010, in _iter_virt_update
    self._depgraph._select_atoms_parent, pkg):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 5356, in _want_update_pkg
    not (deep is not True and depth > deep))
TypeError: unorderable types: object() > int()
 

Trying to oneshot or update portage gives the same llvm and clang blocks with ncurses and python slot conflicts

Share this post


Link to post
Share on other sites
  • 0

[blocks B ] >=sys-devel/llvm-3.7 (">=sys-devel/llvm-3.7" is blocking media-libs/mesa-10.5.2)

[blocks B ] <=sys-devel/clang-3.7.1-r99 ("<=sys-devel/clang-3.7.1-r99" is blocking sys-devel/llvm-3.7.1)

 

Anytime you change USE or configurations portage wants to rebuild the packages such as mesa because Sandro had you change

VIDEO_CARDS="radeon r600" to VIDEO_CARDS="radeon" and add ABI_X86="64 32" which rebuild lib packages to compile the 32-bit libs.

VIDEO_CARDS variable determines what drivers mesa builds.If mesa builds drivers that don't match your hardware it causes no harm.

I would remove or comment out ABI_X86="64 32" and change back to VIDEO_CARDS="radeon r600" in make.conf

sys-devel/llvm-3.7.1 and media-libs/mesa-11.1.1 are current versions on my system.

No sys-devel/clang installed on my system so it appears clang is not a required dependency of llvm.

 

The last thing you want on a stale system is to trigger rebuilds with configuration changes on top of updating issues.

Try again:

# emerge -pv1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2
I will be away from the keyboard until tomorrow. My advice is to back up your system before experimenting or removing packages. It is very easy to brick a stale system trying to update it.

Share this post


Link to post
Share on other sites
  • 0

@cardinal Thanks for your further insight and help.

 

clang depends on llvm, and I agree, it shouldn't be the other way around.  Anyway, with my make.conf at https://bpaste.net/show/c123aa09e478 I have

# emerge -pv1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-arch/bzip2-1.0.6-r7::gentoo  USE="-static -static-libs" ABI_X86="32* (64) (-x32)" 764 KiB
[ebuild   R    ] dev-libs/expat-2.1.0-r5::gentoo  USE="unicode -examples -static-libs" ABI_X86="32* (64) (-x32)" 550 KiB
[ebuild   R    ] dev-libs/libffi-3.2.1::gentoo  USE="-debug -pax_kernel -static-libs {-test}" ABI_X86="32* (64) (-x32)" 919 KiB
[ebuild   R    ] virtual/libffi-3.0.13-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] dev-libs/gmp-6.1.0:0/10.4::gentoo [6.0.0a:0/0::gentoo] USE="asm%* cxx -doc -pgo -static-libs" ABI_X86="(64) -32 (-x32)" 1,905 KiB
[ebuild   R    ] sys-libs/zlib-1.2.8-r1::gentoo  USE="minizip -static-libs" ABI_X86="32* (64) (-x32)" 558 KiB
[ebuild     U  ] dev-libs/icu-56.1:0/56::gentoo [55.1:0/55::gentoo] USE="-debug -doc -examples -static-libs" ABI_X86="32* (64) (-x32)" 25,120 KiB
[ebuild     U  ] media-libs/libpng-1.6.21:0/16::gentoo [1.6.18:0/16::gentoo] USE="apng (-neon) -static-libs" ABI_X86="32* (64) (-x32)" 932 KiB
[ebuild     U  ] media-libs/freetype-2.6.2:2::gentoo [2.6:2::gentoo] USE="X adobe-cff bzip2 png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32* (64) (-x32)" 1,727 KiB
[ebuild     UD ] media-libs/fontconfig-2.11.1-r2:1.0::gentoo [2.11.94:1.0::gentoo] USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 1,481 KiB
[ebuild     U  ] dev-libs/libxml2-2.9.3:2::gentoo [2.9.2-r1001:2::gentoo] USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test} (-python_abis_2.6%) (-python_abis_2.7%*) (-python_abis_3.1%) (-python_abis_3.2%) (-python_abis_3.3%*) (-python_abis_3.4%) (-python_abis_3.5%)" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7%* python3_3%* -python3_4% -python3_5%" 5,349 KiB
[ebuild   R    ] app-eselect/eselect-python-20140125::gentoo  71 KiB
[ebuild   R    ] sys-libs/gpm-1.20.7-r2::gentoo  USE="(-selinux) -static-libs" ABI_X86="32* (64) (-x32)" 772 KiB
[ebuild     U  ] sys-libs/ncurses-6.0-r1:0/6::gentoo [5.9-r5:0/5::gentoo] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs {-test%} -threads% -tinfo -trace" ABI_X86="32* (64) (-x32)" 3,059 KiB
[ebuild     UD ] dev-lang/python-2.7.10-r1:2.7::gentoo [2.7.10-r1000:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened% -tk -wininst" 11,964 KiB
[ebuild     UD ] dev-lang/python-3.3.5-r2:3.3::gentoo [3.3.6-r1000:3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened% -tk -wininst" 11,845 KiB
[ebuild  rR    ] sys-devel/bc-1.06.95-r2::gentoo  USE="readline -libedit -static" 284 KiB
[ebuild  rR    ] dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo  USE="gmp -binary -doc -ghcbootstrap -ghcmakebinary" 0 KiB
[ebuild  r  U  ] gnome-extra/libgda-5.2.4-r1:5/4::gentoo [5.2.4:5/4::gentoo] USE="berkdb gtk introspection* java ssl -canvas -debug (-firebird) -gnome-keyring -graphviz -http -json -ldap -mdb -mysql -oci8 -postgres -reports -sourceview -vala" PYTHON_TARGETS="python2_7" 12,032 KiB
[ebuild  rR    ] sci-mathematics/octave-4.0.0:0/4.0.0::gentoo  USE="X glpk imagemagick java opengl qhull qrupdate readline sparse zlib -curl -doc -fftw -gnuplot -gui -hdf5 -jit -postscript -static-libs" 15,390 KiB
[ebuild  r  U  ] sys-devel/llvm-3.7.1:0/3.7.1::gentoo [3.6.2:0/3.6::gentoo] USE="clang libffi ncurses python static-analyzer xml -debug -doc -gold -libedit -lldb% -multitarget -ocaml {-test}" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7 (-pypy%)" VIDEO_CARDS="radeon" 24,610 KiB
[ebuild     U  ] sys-devel/clang-3.7.1-r100:0/3.7::gentoo [3.6.2-r100:0/3.6::gentoo] USE="python static-analyzer -debug -multitarget" ABI_X86="32* (64) (-x32)" 0 KiB
[blocks B      ] <=sys-devel/clang-3.7.1-r99 ("<=sys-devel/clang-3.7.1-r99" is blocking sys-devel/llvm-3.7.1)
[blocks B      ] >=sys-devel/llvm-3.7 (">=sys-devel/llvm-3.7" is blocking media-libs/mesa-10.5.2)

Total: 22 packages (9 upgrades, 3 downgrades, 10 reinstalls), Size of downloads: 119,325 KiB
Conflict: 2 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/ncurses:0

  (sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, installed) pulled in by
    sys-libs/ncurses:0/5= required by (app-crypt/pinentry-0.9.6:0/0::gentoo, installed)
                    ^^^^^                                                                                                  
    sys-libs/ncurses:0/5[ada?,cxx?,gpm?,static-libs?,tinfo?,unicode?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/ncurses-5.9-r99:5/5::gentoo, installed)
                    ^^^^                                                                                                                                                                                                                                                                                                              
    (and 6 more with the same problems)

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                          

  (dev-libs/icu-55.1:0/55::gentoo, installed) pulled in by
    dev-libs/icu:0/55=[abi_x86_64(-)] required by (dev-qt/qtwebkit-4.8.7:4/4::gentoo, installed)
                ^^^^^^                                                                                                              
    (and 18 more with the same problem)

sys-devel/clang:0

  (sys-devel/clang-3.7.1-r100:0/3.7::gentoo, ebuild scheduled for merge) pulled in by
    =sys-devel/clang-3.7.1-r100 required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
    ^                ^^^^^^^^^^                                                                                                                                      

  (sys-devel/clang-3.6.2-r100:0/3.6::gentoo, installed) pulled in by
    =sys-devel/clang-3.6.2-r100 required by (sys-devel/llvm-3.6.2:0/3.6::gentoo, installed)
    ^                ^^^^^^^^^^                                                                                                                   
    <sys-devel/clang-3.7 required by (dev-libs/libclc-0.1.0_pre20150305:0/0::gentoo, installed)
    ^                ^^^                                                                                                                              

sys-devel/llvm:0

  (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge) pulled in by
    ~sys-devel/llvm-3.7.1[clang(-),debug=,multitarget?,python?,static-analyzer?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/clang-3.7.1-r100:0/3.7::gentoo, ebuild scheduled for merge)
    ^               ^^^^^                                                                                                                                                                                                                                                                                                                                                                

  (sys-devel/llvm-3.6.2:0/3.6::gentoo, installed) pulled in by
    <sys-devel/llvm-3.7:0/3.6=[abi_x86_64(-)] required by (media-libs/mesa-10.5.2:0/0::gentoo, installed)
    ^               ^^^^^^^^^^                                                                                                                                                     
    ~sys-devel/llvm-3.6.2[clang(-),debug=,multitarget?,python?,static-analyzer,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/clang-3.6.2-r100:0/3.6::gentoo, installed)
    ^               ^^^^^                                                                                                                                                                                                                                                                                                                                              
    (and 1 more with the same problems)

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.3:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2[python,python_targets_python2_7(-)?,-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_jython2_7(-),python_single_target_python2_7(+)] required by (dev-util/itstool-2.0.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                 
    >=dev-libs/libxml2-2.6.12[python,python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (app-text/gnome-doc-utils-0.20.10-r1:0/0::gentoo, installed)
                                                                                                                                                                                               
    dev-libs/libxml2:2=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/llvm-3.7.1:0/3.7.1::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                       

  (dev-libs/libxml2-2.9.2-r1001:2/2::gentoo, installed) pulled in by
    >=dev-libs/libxml2-2.8.0:2[python,python_abis_2.7] required by (dev-libs/libxslt-1.1.28-r1002:0/0::gentoo, installed)
                                      ^^^^^^^^^^^^^^^                                                                                                        


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/mesa-10.5.2:0/0::gentoo, installed) pulled in by
    media-libs/mesa[egl] required by (net-libs/webkit-gtk-2.4.9:3/25::gentoo, installed)
    media-libs/mesa required by @selected
    >=media-libs/mesa-9.1.6[opencl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[opencl,abi_x86_64(-)]) required by (virtual/opencl-0-r4:0/0::gentoo, installed)
    >=media-libs/mesa-10.3.4-r1[egl,gbm] required by (x11-base/xorg-server-1.16.4-r1:0/1.16.1::gentoo, installed)
    >=media-libs/mesa-10.2:* required by (www-client/firefox-41.0-r1:0/0::gentoo, installed)
    >=media-libs/mesa-9.1.6[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[egl,abi_x86_64(-)]) required by (x11-libs/cairo-1.14.2:0/0::gentoo, installed)
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[abi_x86_64(-)]) required by (virtual/opengl-7.0-r1:0/0::gentoo, installed)
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[abi_x86_64(-)]) required by (media-libs/gst-plugins-bad-1.4.5:1.0/1.0::gentoo, installed)
    >=media-libs/mesa-10.3.4-r1[nptl] required by (x11-base/xorg-server-1.16.4-r1:0/1.16.1::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, ebuild scheduled for merge)

Share this post


Link to post
Share on other sites
  • 0

Post #100

@Sandro Thx. :)

@storkk
sys-devel/ llvm has -clang use flag disabled on my system is the reason why I have no clang installed.

[ebuild   R    ] sys-devel/llvm-3.7.1:0/3.7.1::gentoo  USE="libffi ncurses python static-analyzer xml -clang -debug -doc -gold -libedit -lldb -multitarget -ocaml {-test}" PYTHON_TARGETS="python2_7" VIDEO_CARDS="radeon" 0 KiB

sys-devel/llvm has clang use flag enabled on your system.

[ebuild  r  U  ] sys-devel/llvm-3.7.1:0/3.7.1::gentoo [3.6.2:0/3.6::gentoo] USE="clang libffi ncurses python static-analyzer xml -debug -doc -gold -libedit -lldb% -multitarget -ocaml {-test}" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7 (-pypy%)" VIDEO_CARDS="radeon" 24,610 KiB

See what effect it has if you remove the clang use flag from llvm.
If you enabled it in /etc/portage/package.use remove the configuration.
If not add  "sys-devel/llvm   -clang" without the quotes to your package.use configuration.
Try again:

# emerge -pv1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2

Share this post


Link to post
Share on other sites
  • 0

@cardinal Congrats on 100 posts, and thanks for using your hundredth to help me!

 

I've added sys-devel/llvm -clang to package.use, which now looks like https://bpaste.net/show/8cdf2f2d9d5a

# emerge -pNv1 --backtrack=200 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] dev-lang/python-2.7.10-r1:2.7::gentoo [2.7.10-r1000:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened% -tk -wininst" 11,964 KiB
[ebuild     UD ] dev-lang/python-3.3.5-r2:3.3::gentoo [3.3.6-r1000:3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened% -tk -wininst" 11,845 KiB

Total: 2 packages (2 downgrades), Size of downloads: 23,809 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-libs/ncurses:0

  (sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) conflicts with
    sys-libs/ncurses:0/5= required by (games-roguelike/nethack-3.4.3-r5:0/0::gentoo, installed)
                    ^^^^^
    >=sys-libs/ncurses-5.7-r7:0/5= required by (x11-terms/xterm-320:0/0::gentoo, installed)
                             ^^^^^
    sys-libs/ncurses:0/5=[unicode] required by (media-video/vlc-2.2.1:0/5-8::gentoo, installed)
                    ^^^^^         
    sys-libs/ncurses:0/5[cxx,gpm,unicode,abi_x86_64(-)] required by (sys-libs/ncurses-5.9-r99:5/5::gentoo, installed)
                    ^^^^                               
    sys-libs/ncurses:0/5= required by (media-video/mplayer-1.2_pre20150730:0/0::gentoo, installed)
                    ^^^^^
    sys-libs/ncurses:0/5= required by (dev-python/pypy-2.6.0:0/2.6::gentoo, installed)
                    ^^^^^
    sys-libs/ncurses:0/5= required by (app-crypt/pinentry-0.9.6:0/0::gentoo, installed)
                    ^^^^^
    sys-libs/ncurses:0/5=[unicode] required by (sys-process/htop-1.0.3-r1:0/0::gentoo, installed)
                    ^^^^^         


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

sys-libs/ncurses:5

!!! The following installed packages are masked:
- media-libs/fontconfig-2.11.94::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask/funtoo-fixes:
# FL-2803, also note FL-2885 - a pango rebuild may be required after downgrade

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

(edited to fix stupid mistake)

Share this post


Link to post
Share on other sites
  • 0

@storkk

You changed the command I requested the output from by adding N and --backtrack=200
If you feel it is helpful for me to see the output from your altered command provide it in addition to the output from the command I request.
Please provide the output from this command:

# emerge -pv1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2

Share this post


Link to post
Share on other sites
  • 0

@cardinal sorry, I had run your original command before noticing a mistake I had made with package.use , then tried a couple of other things and pasted the last command I performed. Here is the output:

# emerge -pv1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-arch/bzip2-1.0.6-r7::gentoo  USE="-static -static-libs" ABI_X86="32* (64) (-x32)" 764 KiB
[ebuild   R    ] dev-libs/expat-2.1.0-r5::gentoo  USE="unicode -examples -static-libs" ABI_X86="32* (64) (-x32)" 550 KiB
[ebuild     U  ] dev-libs/gmp-6.1.0:0/10.4::gentoo [6.0.0a:0/0::gentoo] USE="asm%* cxx -doc -pgo -static-libs" ABI_X86="(64) -32 (-x32)" 1,905 KiB
[ebuild   R    ] sys-libs/zlib-1.2.8-r1::gentoo  USE="minizip -static-libs" ABI_X86="32* (64) (-x32)" 558 KiB
[ebuild     U  ] media-libs/libpng-1.6.21:0/16::gentoo [1.6.18:0/16::gentoo] USE="apng (-neon) -static-libs" ABI_X86="32* (64) (-x32)" 932 KiB
[ebuild     U  ] media-libs/freetype-2.6.2:2::gentoo [2.6:2::gentoo] USE="X adobe-cff bzip2 png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32* (64) (-x32)" 1,727 KiB
[ebuild     UD ] media-libs/fontconfig-2.11.1-r2:1.0::gentoo [2.11.94:1.0::gentoo] USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 1,481 KiB
[ebuild   R    ] app-eselect/eselect-python-20140125::gentoo  71 KiB
[ebuild   R    ] sys-libs/gpm-1.20.7-r2::gentoo  USE="(-selinux) -static-libs" ABI_X86="32* (64) (-x32)" 772 KiB
[ebuild     U  ] sys-libs/ncurses-6.0-r1:0/6::gentoo [5.9-r5:0/5::gentoo] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs {-test%} -threads% -tinfo -trace" ABI_X86="32* (64) (-x32)" 3,059 KiB
[ebuild     UD ] dev-lang/python-2.7.10-r1:2.7::gentoo [2.7.10-r1000:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened% -tk -wininst" 11,964 KiB
[ebuild     UD ] dev-lang/python-3.3.5-r2:3.3::gentoo [3.3.6-r1000:3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened% -tk -wininst" 11,845 KiB
[ebuild  rR    ] sys-devel/bc-1.06.95-r2::gentoo  USE="readline -libedit -static" 284 KiB
[ebuild  rR    ] dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo  USE="gmp -binary -doc -ghcbootstrap -ghcmakebinary" 0 KiB
[ebuild  r  U  ] gnome-extra/libgda-5.2.4-r1:5/4::gentoo [5.2.4:5/4::gentoo] USE="berkdb gtk introspection* java ssl -canvas -debug (-firebird) -gnome-keyring -graphviz -http -json -ldap -mdb -mysql -oci8 -postgres -reports -sourceview -vala" PYTHON_TARGETS="python2_7" 12,032 KiB
[ebuild  rR    ] sci-mathematics/octave-4.0.0:0/4.0.0::gentoo  USE="X glpk imagemagick java opengl qhull qrupdate readline sparse zlib -curl -doc -fftw -gnuplot -gui -hdf5 -jit -postscript -static-libs" 15,390 KiB

Total: 16 packages (5 upgrades, 3 downgrades, 8 reinstalls), Size of downloads: 63,328 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/ncurses:0

  (sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, installed) pulled in by
    sys-libs/ncurses:0/5[ada?,cxx?,gpm?,static-libs?,tinfo?,unicode?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/ncurses-5.9-r99:5/5::gentoo, installed)
                    ^^^^                                                                                                                                                                                                                                                                                                              
    sys-libs/ncurses:0/5= required by (dev-python/pypy-2.6.0:0/2.6::gentoo, installed)
                    ^^^^^                                                                                                 
    (and 5 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, ebuild scheduled for merge)

Share this post


Link to post
Share on other sites
  • 0

Let's try to eliminate slot conflict by installing sys-libs/ncurses-6.0-r1:0/6 into a New Slot.

This should leave existing sys-libs/ncurses-5.9-r5:0/5 on your system to satisfy currently installed packages.

# emerge -av1 sys-libs/ncurses:0/6

Post output:

# emerge -pv1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2

 

Share this post


Link to post
Share on other sites
  • 0

# emerge -av1 sys-libs/ncurses:0/6

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] app-arch/bzip2-1.0.6-r7::gentoo USE="-static -static-libs" ABI_X86="32* (64) (-x32)" 764 KiB
[ebuild R ] dev-libs/expat-2.1.0-r5::gentoo USE="unicode -examples -static-libs" ABI_X86="32* (64) (-x32)" 550 KiB
[ebuild U ] dev-libs/gmp-6.1.0:0/10.4::gentoo [6.0.0a:0/0::gentoo] USE="asm%* cxx -doc -pgo -static-libs" ABI_X86="(64) -32 (-x32)" 1,905 KiB
[ebuild R ] sys-libs/zlib-1.2.8-r1::gentoo USE="minizip -static-libs" ABI_X86="32* (64) (-x32)" 558 KiB
[ebuild U ] media-libs/libpng-1.6.21:0/16::gentoo [1.6.18:0/16::gentoo] USE="apng (-neon) -static-libs" ABI_X86="32* (64) (-x32)" 932 KiB
[ebuild U ] media-libs/freetype-2.6.2:2::gentoo [2.6:2::gentoo] USE="X adobe-cff bzip2 png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32* (64) (-x32)" 1,727 KiB
[ebuild UD ] media-libs/fontconfig-2.11.1-r2:1.0::gentoo [2.11.94:1.0::gentoo] USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 1,481 KiB
[ebuild R ] sys-libs/gpm-1.20.7-r2::gentoo USE="(-selinux) -static-libs" ABI_X86="32* (64) (-x32)" 772 KiB
[ebuild U ] sys-libs/ncurses-6.0-r1:0/6::gentoo [5.9-r5:0/5::gentoo] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs {-test%} -threads% -tinfo -trace" ABI_X86="32* (64) (-x32)" 3,059 KiB
[ebuild rR ] sys-devel/bc-1.06.95-r2::gentoo USE="readline -libedit -static" 284 KiB
[ebuild rR ] dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo USE="gmp -binary -doc -ghcbootstrap -ghcmakebinary" 0 KiB
[ebuild r U ] gnome-extra/libgda-5.2.4-r1:5/4::gentoo [5.2.4:5/4::gentoo] USE="berkdb gtk introspection* java ssl -canvas -debug (-firebird) -gnome-keyring -graphviz -http -json -ldap -mdb -mysql -oci8 -postgres -reports -sourceview -vala" PYTHON_TARGETS="python2_7" 12,032 KiB
[ebuild rR ] sci-mathematics/octave-4.0.0:0/4.0.0::gentoo USE="X glpk imagemagick java opengl qhull qrupdate readline sparse zlib -curl -doc -fftw -gnuplot -gui -hdf5 -jit -postscript -static-libs" 15,390 KiB

Total: 13 packages (5 upgrades, 1 downgrade, 7 reinstalls), Size of downloads: 39,449 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/ncurses:0

(sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
sys-libs/ncurses:0/6 (Argument)

(sys-libs/ncurses-5.9-r5:0/5::gentoo, installed) pulled in by
sys-libs/ncurses:0/5[ada?,cxx?,gpm?,static-libs?,tinfo?,unicode?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/ncurses-5.9-r99:5/5::gentoo, installed)
^^^^
sys-libs/ncurses:0/5= required by (dev-python/pypy-2.6.0:0/2.6::gentoo, installed)
^^^^^
(and 5 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

(dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) causes rebuilds for:
(dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, ebuild scheduled for merge)

!!! The following installed packages are masked:
- dev-lang/python-3.3.6-r1000::gentoo (masked by: package.mask)
- dev-lang/python-2.7.10-r1000::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Share this post


Link to post
Share on other sites
  • 0

Try this command that combines new versions of python, new version slot install ncurses, reinstall of existing eselect-python and ncurses :

 # emerge -av1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2 sys-libs/ncurses:5/5 sys-libs/ncurses:0/6

Share this post


Link to post
Share on other sites
  • 0
# emerge -av1 =app-eselect/eselect-python-20140125 =dev-lang/python-2.7.10-r1 =dev-lang/python-3.3.5-r2 sys-libs/ncurses:5/5 sys-libs/ncurses:0/6

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-arch/bzip2-1.0.6-r7::gentoo  USE="-static -static-libs" ABI_X86="32* (64) (-x32)" 764 KiB
[ebuild   R    ] dev-libs/expat-2.1.0-r5::gentoo  USE="unicode -examples -static-libs" ABI_X86="32* (64) (-x32)" 550 KiB
[ebuild   R    ] sys-libs/zlib-1.2.8-r1::gentoo  USE="minizip -static-libs" ABI_X86="32* (64) (-x32)" 558 KiB
[ebuild     U  ] media-libs/libpng-1.6.21:0/16::gentoo [1.6.18:0/16::gentoo] USE="apng (-neon) -static-libs" ABI_X86="32* (64) (-x32)" 932 KiB
[ebuild     U  ] media-libs/freetype-2.6.2:2::gentoo [2.6:2::gentoo] USE="X adobe-cff bzip2 png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32* (64) (-x32)" 1,727 KiB
[ebuild     UD ] media-libs/fontconfig-2.11.1-r2:1.0::gentoo [2.11.94:1.0::gentoo] USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 1,481 KiB
[ebuild   R    ] app-eselect/eselect-python-20140125::gentoo  71 KiB
[ebuild   R    ] sys-libs/gpm-1.20.7-r2::gentoo  USE="(-selinux) -static-libs" ABI_X86="32* (64) (-x32)" 772 KiB
[ebuild  r  U  ] sys-libs/ncurses-6.0-r1:0/6::gentoo [5.9-r5:0/5::gentoo] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs {-test%} -threads% -tinfo -trace" ABI_X86="32* (64) (-x32)" 3,059 KiB
[ebuild     UD ] dev-lang/python-2.7.10-r1:2.7::gentoo [2.7.10-r1000:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened% -tk -wininst" 11,964 KiB
[ebuild     UD ] dev-lang/python-3.3.5-r2:3.3::gentoo [3.3.6-r1000:3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened% -tk -wininst" 11,845 KiB
[ebuild     U  ] sys-libs/ncurses-5.9-r101:5::gentoo [5.9-r99:5::gentoo] USE="gpm unicode -tinfo (-ada%) (-cxx%*) (-static-libs%)" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild  r  U  ] x11-terms/xterm-322::gentoo [320::gentoo] USE="openpty truetype unicode -Xaw3d -toolbar" 1,199 KiB
[ebuild  rR    ] sys-process/htop-1.0.3-r1::gentoo  USE="unicode -oom -openvz -vserver" 0 KiB
[ebuild  r  U  ] media-libs/x265-1.9:0/79::gentoo [1.7:0/59::gentoo] USE="10bit 12bit%* -numa% -pic% {-test}" ABI_X86="(64) -32 (-x32)" 934 KiB
[ebuild  r  U  ] dev-python/pypy-4.0.1:0/4.0::gentoo [2.6.0:0/2.6::gentoo] USE="bzip2 gdbm jit ncurses shadowstack* -doc -low-memory (-sandbox) -sqlite {-test} -tk" CPU_FLAGS_X86="(-sse2)" 16,771 KiB
[ebuild  r  U  ] app-crypt/pinentry-0.9.7::gentoo [0.9.6::gentoo] USE="gtk ncurses qt5%* -caps -emacs -gnome-keyring -qt4 -static (-clipboard%)" 423 KiB
[ebuild  r  U  ] media-video/ffmpeg-2.8.5:0/54.56.56::gentoo [2.8:0/54.56.56::gentoo] USE="X aac alsa bluray bzip2 cdio encode faac gpl hardcoded-tables iconv ieee1394 jpeg2k libass mp3 network opengl opus postproc pulseaudio theora threads truetype twolame v4l vorbis vpx wavpack webp x264 x265 xvid zlib -aacplus (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bs2b -celt -cpudetection -debug -doc -examples -fdk -flite -fontconfig -frei0r -fribidi -gme -gnutls -gsm -iec61883 -jack -ladspa -libcaca -libressl% -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -oss -pic -quvi -samba -schroedinger -sdl -snappy -speex -ssh -static-libs {-test} -vaapi -vdpau -xcb -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="avx mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 -3dnow -3dnowext -avx2 -fma3 -fma4 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" 8,380 KiB
[ebuild  r  U  ] media-video/mplayer-1.2.1::gentoo [1.2_pre20150730::gentoo] USE="X a52 alsa bluray cddb cdio dts dvd dvdnav enca encode faac faad gif iconv ipv6 jpeg jpeg2k libass libmpeg2 mad mp3 network opengl osdmenu png pulseaudio rtmp shm theora truetype twolame unicode v4l vorbis x264 xinerama xscreensaver xv xvid -aalib (-altivec) (-aqua) -bidi -bl -bs2b -cdparanoia -cpudetection -debug -dga -directfb -doc -dv -dvb -fbcon -ftp -ggi -gsm -jack -joystick -ladspa -libcaca -lirc -live -lzo -md5sum -mng -nas -nut -openal -oss -pnm -pvr -radio -rar -rtc -samba -sdl (-selinux) -speex -tga -toolame -tremor -vdpau (-vidix) -xanim -xvmc -zoran" CPU_FLAGS_X86="mmx mmxext sse sse2 ssse3 -3dnow -3dnowext" VIDEO_CARDS="-mga -s3virge -tdfx" 12,725 KiB
[ebuild  r  U  ] media-video/vlc-2.2.1-r1:0/5-8::gentoo [2.2.1:0/5-8::gentoo] USE="X a52 alsa avcodec avformat bluray cdda cddb dbus dts dvbpsi dvd encode faad ffmpeg flac gcrypt ieee1394 jpeg libass libnotify libsamplerate matroska mp3 mpeg mtp ncurses ogg opengl png postproc pulseaudio qt5 svg swscale taglib theora truetype twolame udev v4l vorbis vpx x264 x265 xcb xml -aalib (-altivec) -atmo (-audioqueue) -bidi -chromaprint -dc1394 -debug -directfb (-directx) -dvb (-dxva2) -fdk -fluidsynth -fontconfig -gme -gnome -gnutls -growl -httpd -jack -kate -kde (-libav) -libcaca -libtar -libtiger -linsys -lirc -live -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-media-library) -modplug -musepack (-neon) -omxil -opencv -optimisememory -opus -projectm -qt4 (-rdp) -rtsp -run-as-root -samba -schroedinger -sdl -sdl-image -sftp -shout -sid -skins -speex {-test} -tremor -upnp -vaapi -vcdx -vdpau -vlm -vnc -wma-fixed -xv -zeroconf% -zvbi (-avahi%) (-oss%)" CPU_FLAGS_X86="mmx sse" 0 KiB

Total: 20 packages (11 upgrades, 3 downgrades, 6 reinstalls), Size of downloads: 74,149 KiB

The following packages are causing rebuilds:

  (sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-crypt/pinentry-0.9.7:0/0::gentoo, ebuild scheduled for merge)
    (x11-terms/xterm-322:0/0::gentoo, ebuild scheduled for merge)
    (sys-process/htop-1.0.3-r1:0/0::gentoo, ebuild scheduled for merge)
    (media-video/vlc-2.2.1-r1:0/5-8::gentoo, ebuild scheduled for merge)
    (media-video/mplayer-1.2.1:0/0::gentoo, ebuild scheduled for merge)
    (dev-python/pypy-4.0.1:0/4.0::gentoo, ebuild scheduled for merge)
  (media-libs/x265-1.9:0/79::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-video/vlc-2.2.1-r1:0/5-8::gentoo, ebuild scheduled for merge)
    (media-video/ffmpeg-2.8.5:0/54.56.56::gentoo, ebuild scheduled for merge)

!!! All ebuilds that could satisfy "app-text/libwpg:0.3" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/libwpg-0.3.1::gentoo (masked by: )
- app-text/libwpg-0.3.0::gentoo (masked by: )

(dependency required by "app-office/libreoffice-5.0.2.2::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Would you like to merge these packages? [Yes/No] 

woohoo! first successful emerges :-) it's on pypy now... I'll update tonight when I get home. Thank you @cardinal for your help so far!

Share this post


Link to post
Share on other sites
  • 0

After successfully emerging (yay!) the above, I now have:

# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=200 @system

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.56.0= required by (dev-util/mdds-0.12.1:0/0.12.1::gentoo, installed)
                  ^^^^^^^^^^                                                                                                   
    (and 3 more with the same problem)

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/55= required by (media-libs/libfreehand-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                                                      


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-office/libreoffice-5.0.4.2:0/0::gentoo, ebuild scheduled for merge)
  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    (app-office/libreoffice-5.0.4.2:0/0::gentoo, ebuild scheduled for merge)
  (app-text/poppler-0.40.0-r1:0/58::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-office/libreoffice-5.0.4.2:0/0::gentoo, ebuild scheduled for merge)
    (net-print/cups-filters-1.8.1:0/0::gentoo, ebuild scheduled for merge)
  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-lang/ghc-7.10.2-r1:0/7.10.2::gentoo, ebuild scheduled for merge)

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/clang-3.7.1-r100::gentoo
# required by dev-libs/libclc-0.2.0_pre20151006::gentoo
# required by media-libs/mesa-11.1.1::gentoo[opencl]
# required by media-libs/libepoxy-1.3.1::gentoo
# required by x11-libs/gtk+-3.16.7::gentoo
# required by app-office/libreoffice-5.0.4.2::gentoo[gtk3]
# required by @__auto_slot_operator_replace_installed__ (argument)
>=sys-devel/llvm-3.7.1 clang

Should I re-add clang to package.use?

Share this post


Link to post
Share on other sites
  • 0

These are the packages that would be merged, in order:
There are no packages listed that it would update due to  --backtrack=200
Output lists 2 slot conflicts,what would be rebuilt if packages in conflict were updated,and clang use flag.

--backtrack=COUNT
              Specifies  an integer number of times to backtrack if dependency
              calculation fails due to a conflict or an unsatisfied dependency
              (default: ?3?).

I have no experience with backtrack so I need to compare output without --backtrack= and with --backtrack= using lower settings.
Please post the links from wgetpaste to output from these commands:

# emerge --ask --update --newuse --deep --with-bdeps=y @system | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=10 @system | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=20 @system | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=30 @system | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=50 @system | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=75 @system | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=100 @system | wgetpaste

Share this post


Link to post
Share on other sites
  • 0

I believe backtrack simply decreases the probability of encountering "phantom" dependency conflicts by increasing the amount of the tree it will walk, 200 is just an arbitrarily large number, but the below is not what I expected.

 

Anyway, I needed to replace --ask by --pretend to avoid a hang because I can't see when the prompt to install comes:

# emerge --pretend --update --newuse --deep --with-bdeps=y @system | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.56.0= required by (dev-util/mdds-0.12.1:0/0.12.1::gentoo, installed)
                  ^^^^^^^^^^                                                                
    (and 3 more with the same problem)

dev-util/boost-build:0

  (dev-util/boost-build-1.58.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.58* required by (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

  (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/55= required by (media-libs/libfreehand-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/clang-3.7.1-r100::gentoo
# required by media-libs/mesa-11.1.1::gentoo[opencl]
# required by net-libs/webkit-gtk-2.4.9::gentoo[egl]
# required by @__auto_slot_operator_replace_installed__ (argument)
>=sys-devel/llvm-3.7.1 clang

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:0/0=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "media-gfx/uniconvertor-2.0_pre379-r1::gentoo" [installed])
(dependency required by "media-gfx/inkscape-0.91-r1::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])

Your paste can be seen here: https://bpaste.net/show/97502b4cd697

# emerge --pretend --update --newuse --deep --with-bdeps=y --backtrack=10 @system | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/giflib:0

  (media-libs/giflib-5.1.2:0/7::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/giflib-4.2.3-r1:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.4.2:0/5::gentoo, installed)
                     ^^^^^                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "media-gfx/uniconvertor-2.0_pre379-r1::gentoo" [installed])
(dependency required by "media-gfx/inkscape-0.91-r1::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])

Your paste can be seen here: https://bpaste.net/show/edcb7138f7ce

# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=20 @system | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/55= required by (media-libs/libfreehand-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                   

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.56.0= required by (dev-cpp/libcmis-0.5.0-r1:0.5/0.5::gentoo, installed)
                  ^^^^^^^^^^                                                                   
    (and 3 more with the same problem)

dev-util/boost-build:0

  (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

  (dev-util/boost-build-1.58.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.58* required by (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/clang-3.7.1-r100::gentoo
# required by dev-libs/libclc-0.2.0_pre20151006::gentoo
# required by media-libs/mesa-11.1.1::gentoo[opencl]
# required by net-libs/webkit-gtk-2.4.9::gentoo[egl]
# required by @__auto_slot_operator_replace_installed__ (argument)
>=sys-devel/llvm-3.7.1 clang
n  #<-this is me because I forgot to change --ask to --pretend

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "app-text/calibre-2.47.0::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])

Your paste can be seen here: https://bpaste.net/show/763b515f9925

# emerge --pretend --update --newuse --deep --with-bdeps=y --backtrack=30 @system | wgetpaste

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:0/0=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "media-gfx/uniconvertor-2.0_pre379-r1::gentoo" [installed])
(dependency required by "media-gfx/inkscape-0.91-r1::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])


Your paste can be seen here: https://bpaste.net/show/40dcae8b382c

# emerge --pretend --update --newuse --deep --with-bdeps=y --backtrack=50 @system | wgetpaste

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "media-gfx/uniconvertor-2.0_pre379-r1::gentoo" [installed])
(dependency required by "media-gfx/inkscape-0.91-r1::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])

Your paste can be seen here: https://bpaste.net/show/5a0b5e62359f

# emerge --pretend --update --newuse --deep --with-bdeps=y --backtrack=75 @system | wgetpaste

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/boost-1.51.0:0/1.56.0= required by (dev-libs/liborcus-0.7.1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                              
    (and 3 more with the same problem)

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/55= required by (media-libs/libfreehand-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                   

dev-util/boost-build:0

  (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

  (dev-util/boost-build-1.58.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.58* required by (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                     

media-libs/giflib:0

  (media-libs/giflib-5.1.2:0/7::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/giflib-4.2.3-r1:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.4.2:0/5::gentoo, installed)
                     ^^^^^                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/clang-3.7.1-r100::gentoo
# required by media-libs/mesa-11.1.1::gentoo[opencl]
# required by net-libs/webkit-gtk-2.4.9::gentoo[egl]
# required by @__auto_slot_operator_replace_installed__ (argument)
>=sys-devel/llvm-3.7.1 clang

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:0/0=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "media-gfx/uniconvertor-2.0_pre379-r1::gentoo" [installed])
(dependency required by "media-gfx/inkscape-0.91-r1::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])

Your paste can be seen here: https://bpaste.net/show/a5ec5c6c5271
 
# emerge --pretend --update --newuse --deep --with-bdeps=y --backtrack=100 @system | wgetpaste

!!! The ebuild selected to satisfy ">=media-libs/lensfun-0.2.5:=" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "media-gfx/ufraw-0.22::gentoo" [installed])
(dependency required by "media-gfx/imagemagick-6.9.2.10::gentoo[raw]" [ebuild])
(dependency required by "media-gfx/uniconvertor-2.0_pre379-r1::gentoo" [installed])
(dependency required by "media-gfx/inkscape-0.91-r1::gentoo" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])


Your paste can be seen here: https://bpaste.net/show/1665cac692d4

 

 

Thanks again for your time and expertise!

Share this post


Link to post
Share on other sites
  • 0

Your welcome,

I appreciate the opportunity to figure this out.   

It doesn't appear lack of output about installing updated packages was due to --backtrack setting.

Maybe I'm at a dead end with @system so lets look @world

Please post the links from wgetpaste to output from these commands:

# emerge --ask --update --newuse --deep --with-bdeps=y @world | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=10 @world | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=20 @world | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=30 @world | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=50 @world | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=75 @world | wgetpaste
# emerge --ask --update --newuse --deep --with-bdeps=y --backtrack=100 @world | wgetpaste

Share this post


Link to post
Share on other sites
  • 0
EDIT: this post should probably be ignored. There was a boot-update line in package.use , making package.use conflict with make.conf

# emerge --pretend --update --newuse --deep --with-bdeps=y @world | wgetpaste


!!! Problem resolving dependencies for sys-boot/boot-update from @selected

!!! The ebuild selected to satisfy "sys-boot/boot-update" has unmet requirements.
- sys-boot/boot-update-1.7.3-r1::gentoo USE="" PYTHON_SINGLE_TARGET="python2_7 python3_3" PYTHON_TARGETS="python2_7 python3_3"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python2_7 python_single_target_python3_3 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python2_7 python_single_target_python3_3 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_3? ( python_targets_python3_3 )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Your paste can be seen here: https://bpaste.net/show/6f0f15682076

 

This is causing emerge to abort rather quickly, and the other outputs are all identical except for the pattern of dots in the ellipsis before "done!" (e.g. https://bpaste.net/show/2405912062b9 )... stdout is identical.

 

I believe this is why I had the python stuff in my make.conf in the first place.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...