Jump to content

Search the Community

Showing results for tags 'python'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

  • drobbins' Blog
  • It's a Bear's life
  • haxmeister's Blog
  • psychopatch's Blog
  • 666threesixes666's Blog
  • decision theory
  • Chris Kurlinski's Blog
  • Sandro's Blog
  • danielv's Blog
  • Not So Stupid Admin Tricks
  • maldoror's Blog
  • andreawilson's Blog
  • Simple Step-by-Step Server Setup
  • saraedward's Blog
  • eusanpe
  • Linux Container Club - LXD/LXC's Blog
  • Funtoo Perl Hackers's Perl on Funtoo

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 7 results

  1. Hello when I emerge world update and I get warning WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-python/numpy:0 (dev-python/numpy-1.17.0_rc1:0/0::python-modules-kit, ebuild scheduled for merge) conflicts with dev-python/numpy[python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),python_single_target_python2_7(+)] required by (media-gfx/inkscape-0.92.4:0/0::media
  2. Hallo. I got an error during the installation of gimp with emerge -atv gimp. Output: - media-libs/gexiv2-0.10.6::media-kit USE="python -introspection -static-libs -test" PYTHON_TARGETS="python2_7 python3_4 -python3_5" The following REQUIRED_USE flag constraints are unsatisfied: python? ( introspection ) The above constraints are a subset of the following complete expression: python? ( introspection any-of ( python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 ) ) test? ( python ) (dependency required by "media-gfx/gimp-2.9.6::
  3. Hallo. emerge -atv scipy failed with the following message: >>> Failed to emerge sci-libs/scipy-0.19.1-r1, Log file: >>> '/var/tmp/portage/sci-libs/scipy-0.19.1-r1/temp/build.log' * Messages for package sci-libs/scipy-0.19.1-r1: * ERROR: sci-libs/scipy-0.19.1-r1::science-kit failed (compile phase): * (no error message) * * Call stack: * ebuild.sh, line 92: Called src_compile * environment, line 4389: Called distutils-r1_src_compile * environment, line 1317: Called _distutils-r1_run_foreach_impl 'python_compile'
  4. Good morning after a bit of a rocky transition to the new kit setup, I've noticed that eselect set python X doesn't seem to be working: mediaserver ~ # eselect python list Available Python interpreters, in order of preference: [1] python3.4 [2] python3.6 [3] python2.7 (fallback) mediaserver ~ # eselect python set 1 mediaserver ~ # eselect python list Available Python interpreters, in order of preference: [1] python3.4 [2] python3.6 [3] python2.7 (fallback) No asterisk after python3.4 However eselect kernel seems to be working appropriately: mediaserver ~
  5. Last time I updated @world was probably 6 months ago... and now I'm running into issues I don't seem to be able to solve, possibly partly python-related: # emerge -v --info | wgetpaste Your paste can be seen here: https://bpaste.net/show/4dcc37d656ac # emerge --ask --update --newuse --deep --with-bdeps=y @world | wgetpaste .... std err is at https://bpaste.net/show/3b353d5588b6 ... Your paste can be seen here: https://bpaste.net/show/4deeb418e791 # python-updater | wgetpaste emerge: there are no ebuilds to satisfy "dev-python/PyQt4:0/QtCore-1". Your paste can be seen here: https:/
  6. Hello, I am installing funtoo and I copied my make.conf, package.use, etc. files over since I liked that use flags I'm using and I got a messsage while updating world that there are no ebuilds for dev-python/python-docs needed by dev-lang/python-3.3.6-r1000 with the doc use flag enabled. I'm not sure if this is a bug in the ebuild or what.
  7. Warning: This is probably a noob question, I just replaced Debian on my Desktop with Funtoo... Now I try to allow Python 2 and 3 to coexist peacefully. The main problem are the python_single_target_pythonX_X use flags. A lot of packages need exactly one of them specified. But some require Python 2 and some Python 3. In /etc/portage/make.conf I specified PYTHON_TARGETS="python2_7 python3_4" PYTHON_SINGLE_TARGET="python3_4" If I add python2_7 as single target, some ebuilds start complaining about needing exacly one of the two but not both specified. But if I don't add python2_7, ebui
×
×
  • Create New...