Jump to content
funtoo forums
  • 0
bronislav

Kernel panic - not syncing: Fatal exception in interrupt

Question

I need help with fixing 100% reproducible kernel panic on my laptop. This occurs either if I boot my laptop without connected power cord or if I disconnect power cord from already booted laptop. Because of this I think that issue somehow related to the power management system.

 

My kernel is gentoo-sources-3.15.1:

Linux localhost 3.15.1-gentoo #1 SMP Wed Jun 25 21:29:18 EEST 2014 x86_64 Intel(R) Core(TM) i3-3110M CPU @ 2.40GHz GenuineIntel GNU/Linux 

But this issue reproducible with older kernels as well.

 

In boot time panic accours when "populationg udev events". I'm using eudev:

[I] sys-fs/eudev
     Available versions:  1.4 1.5.3 1.5.3-r1 1.5.3-r2 {doc +gudev +hwdb introspection +keymap +kmod +modutils +openrc +rule-generator selinux +static-libs test ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
     Installed versions:  1.5.3-r2(08:34:33 PM 06/25/2014)(gudev hwdb introspection keymap kmod modutils openrc rule-generator static-libs -doc -selinux -test ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32")
     Homepage:            https://github.com/gentoo/eudev
     Description:         Linux dynamic and persistent device naming support (aka userspace devfs)

If someone could help me in fixing this problem? What additional info necessary to investigate issue?

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

I figure it can't hurt to share my experiences. I once had a kernel panic problem, but all I had to do was avoid a specific single kernel version.

 

I have had problems with drivers related to X11-base/xorg-11. I don't think it caused a kernel panic, but it would completely freeze or whatever. There is a thing called ABI, and if the kernel has one binary interface and the apps or drivers have another, it won't work. I found the command 'emerge @x11-module-rebuild' to be useful to get everything on the same ABI, at least for my problems. Useful set targets are listed by 'emerge --list-sets'.

 

Did you see this in your dmesg: [Firmware Bug]: ACPI(DGFX) defines _DOD but not _DOS

Since you are guessing power stuff, I guess so.

 

I suppose you tried without ACPI and the power stuff; tried downgrading power management stuff. Maybe your hardware is not supported, bad luck, hard to reproduce if hardware specific. Related to new sys-apps/hwids? "[    3.583284] hp_accel: laptop model unknown, using default axes configuration &  [ 2.229867]   No soundcards found. & [    2.294729] ata1.00: ACPI cmd 00/00:00:00:00:00:a0 (NOP) rejected by device (Stat=0x51 Err=0x04)" Seems you should be able to roll something back, but guessing what is hard to do sometimes.

 

You could look at your config stuff for acpi config and try without laptop mode or whatever: /etc/laptop-mode/laptop-mode.conf

 

Maybe the problem will get fixed upstream with an update in a week or two. :)

Share this post


Link to post
Share on other sites
  • 0

This is link to the picture of kernel panic: link

 

I don't use genkernel. I build kernel usnig menuconfig, everything works fine until a few days ago. My kernel config is here: http://pastebin.com/VKp7WBQx

 

This is dmesg: http://pastebin.com/YB63PbBr

 

And this /var/log/everything/current (i am using metalog): http://pastebin.com/j6j7uDQn

 

I have cleared logs, reboot laptop, and then disconnect power cord. This logs from pressing power button and up to kernel panic. I didn't see there any info about crash or so.

 

What else I may do to investigate issue?

Share this post


Link to post
Share on other sites
  • 0
I know that for example, /usr can not  reside in a separate partition without using initramfs. 

I do not know if this is your case. 

I'd give it a try using genkernel (just to experiment and to better understand the degree to which exclusion is the specific problem).

Share this post


Link to post
Share on other sites
  • 0

I don't think that the problem in kernel. I have booted with kernel which I use month ago, when there are no such problem. And kernel panic still occurs in the same conditions. I have separate portion only for /home. /usr on the same partition with root.

 

By the way, may be problem some how related to the udev? I think so, because when I boot without power cord connected, panic occurs when 'waiting for udev events'.

Share this post


Link to post
Share on other sites
  • 0

according to screenshot: kernel panic caused by drm KMS module. also, in logs ext4 spitting errors. 

1. boot sysrescue cd and run fsck on that disk.

2. maybe good idea to hunt for some bad sectors, drive errors, etc.

3. try to downgrade to LTS kernel releases to fix DRM issues.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...