Jump to content
  • 0
bttr

Font Rendering Problems with Applications Which Use Pango [Solved]

Question

After a recent world update some libraries were updated and it brought me some serious problems. Well, I will start with the first problem I noted: the font of some programs just got weird.

1574451909.thumb.png.9564807f4200d87374e68803d7a67cf5.png

So after I noted that not all programs were updated properly which was the case of PyGTK 2. So I tried to update it but I got error messages as shown in the following image.

image.thumb.png.00ed74f085759a8c22de7e6fc1865793.png

I am not an expert in e-builds but seems that some libs requires a newer version of pango although PyGTK requires an older one.

Can anybody help me to fix this problem? As you could see before I am unable to understand the text of some programs and it is very very bad.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

I think portage wants you to set the introspection USEFLAG for x11-libs/pango in /etc/portage/package.use, and then (most likely) you will have to add it for number of other gtk related packages as well.

I have run into something similar with both LXDE and virt-manager.  TBH, I don't really know what the introspection USEFLAG does or why it wants it.

 

I hope that helps.

Share this post


Link to post
Share on other sites
  • 0
On 11/23/2019 at 2:57 AM, lazlo.vii said:

I think portage wants you to set the introspection USEFLAG for x11-libs/pango in /etc/portage/package.use, and then (most likely) you will have to add it for number of other gtk related packages as well.

I have run into something similar with both LXDE and virt-manager.  TBH, I don't really know what the introspection USEFLAG does or why it wants it.

 

I hope that helps.

I have already set the introspection useflag for pango and I have already unmerged pygtk but I am still with the same problem. Am I the only suffering with this bug?

Share this post


Link to post
Share on other sites
  • 0

@bttr

If rectangles appearing instead of fonts is a problem then set the fonts to liberation, cantarell, or another non-bitmap font.

Go into the preferences/configuration font section and scroll until a font displays and choose it.

Pango-1.44.7 switched from fontconfig to harfbuzz which doesn't support displaying bitmap fonts.

Reference:

https://gitlab.gnome.org/GNOME/pango/issues/386

Share this post


Link to post
Share on other sites
  • 0

@cardinal

I tried to change the GIMP font but I could not find the right section because I can only read squares, although I could change the font of SpaceFM (my file manager) to a ttf font as you can see below.

1574829228.thumb.png.e9185dfbee13a4e692bd8fd491ebacd3.png

But ...

image.png.e6bb7c7da0ce235627a22125e888b29b.png

... nothing changed.

I also have tried other fonts, inclusive another non-bitmap fonts but none worked.

Share this post


Link to post
Share on other sites
  • 0

@cardinal

I also suspect that when I did the world update that brought me this problem I was not able to update all packages that were supposed to be, because I did "emerge -auDN @world" but I left my notebook emerging all things and I went to college. When I got back I did not noticed at first but after I reboot my note, I realized that may some packages were not updated as supposed to be (as the case of PyGTK). Can this problem be caused by some package that were not installed properly on that world update?

Well, I do not know if it makes much sense but I am trying to figure out something that may caused this problem to me. Also, I do not know if it is relevant, but I do not use GNOME or LXDE and others stuffs like these, I use dwm.

Share this post


Link to post
Share on other sites
  • 0

I found the solution for this case. I was using bitmap fonts for my terminal and other applications so I have set 'eselect fontconfig enable 70-yes-bitmaps.conf'. But after the newest update of Pango, some applications that depends on it started not showing fonts correctly. So I had the idea of change the fontconfig and I did 'eselect fontconfig disable 70-yes-bitmaps.conf' and  'eselect fontconfig enable 70-no-bitmaps.conf'. After that I could see the applications showing the fonts correctly. Thanks to everyone that tried to help me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...