Jump to content

bcowan

Members
  • Content Count

    68
  • Joined

  • Last visited

  • Days Won

    6

Everything posted by bcowan

  1. Funtoo dropped multilib support not 32 bit, that's a big difference, 32 bit is still supported with new stages as recently as 02/04/2020, and you're trying to remove debian-sources when you should be removing debian-sources-lts 🙂
  2. Because those ebuilds need fixed to add support for python 3.7. Bugs need filed or pull requests added 🙂
  3. Most likely a very simple fix of adding python 3.7 to to python_compat in the ebuild if you could file a bug on bugs.funtoo.org or fix and make a pull request to code.funtoo.org it would be appreciated. Thanks 🙂
  4. It shouldn't care, allot of us use /var/tmp on tmpfs. Is your /var/tmp/portage full of failed builds causing less than 8 gigs of space? Or something else filling /var/tmp?
  5. Could you please report this on bugs.funtoo.org so we can further investigate? Thanks 🙂
  6. Do you actually use and need python 3.6? The default in Funtoo 1.4 is python 3.7 and the install guide has you emerge -C =dev-lang/python-3.6* and eselect python cleanup. These steps should have corrected allot of your issues.
  7. I can reproduce this, can you please report on bugs.funtoo.org? Thanks
  8. Feel free to file bugs on bugs.funtoo.org also that way we can track and other users can benefit/search.
  9. @upc0d3 can you try emerge -1 =net-libs/gssdp-1.0.3 and emerge -1 =net-libs/gupnp-1.0.3 then emerge -1 gupnp-igd the versions are slotted so they will install side by side...or both versions will be installed, however you wish to say it 🙂
  10. @jhan the above seems to be the answer here, needs to dep on older version. If you want to test and PR I have to go out to eat. I can do later if not 🙂
  11. @jhan already checking, looks like it needs to dep on older 1.0.3 sth like, =net-libs/gssdp-1.0.3:= =net-libs/gupnp-1.0.3:= seeing if it will rebuild with both installed now 🙂
  12. Could you file a bug at bugs.funtoo.org please so we can get this taken care of? At least get libaccounts-glib updated to the latest version, hopefully will fix the issue. Thank You 🙂
  13. Thanks for this report also, this too is part of the pending PR. sushi needed an added dep on gtksourceview:4
  14. Thanks for the report! I made a PR last night pending on this...fix will be in the tree eventually 🙂
  15. emerge -C pygtk it is unmaintained for a very long time. @drobbins has made several fixes to the tree to workaround this that should help after that. 🙂
  16. We need to see an actual build log to see what is causing the problem, all you have shown is pictures of packages saying they have failed with no info whatsoever 🙂 but my guess is you have edited your CFLAGS by hand and they are not right.
  17. @cardinal yes, I just worded it weird and confusing I guess. I'm saying that when he runs X it should use i965 for ivybridge gen procs, if not there is an issue 🙂
  18. @cardinal Hmm, yes you answered everything exactly right, but that should default to i965 and not use gallium. Just build out the old gallium i915 and intel driver. Won't know until you start an X session and check logs to see if its using i965 or not.
  19. I reported it to @drobbins last night, it was stuck in Russian. Should be fixed, if not please file a bug 🙂
  20. as noted earlier and by drobbins.... eselect python set python3.7 eselect python cleanup these steps were in the upgrade guide, someone has edited out the selection of the new default interpreter...eselect python set python3.7
  21. Thats exactly how I had fixed mine, with login.defs. Just change the SUB_UID_MAX and SUB_GID_MAX UID_MIN 1000 UID_MAX 60000 # System accounts SYS_UID_MIN 101 SYS_UID_MAX 999 # Extra per user uids SUB_UID_MIN 100000 SUB_UID_MAX 2000000000 SUB_UID_COUNT 65536 # # Min/max values for automatic gid selection in groupadd(8) # GID_MIN 1000 GID_MAX 60000 # System accounts SYS_GID_MIN 101 SYS_GID_MAX 999 # Extra per user group ids SUB_GID_MIN 100000 SUB_GID_MAX 20000000000 SUB_GID_COUNT 65536
  22. @quantum that wiki page mentions the nvidia-kernel-modules in the Introduction and the 1.4 Funtoo upgrade guide explicitly mentions needing the nvidia-kernel-modules package. The wiki page is editable by anyone if you wish to add please go ahead, it would be appreciated 🙂 Also, debian-sources-lts is the default and preferred sources for Funtoo. They are much more thoroughly tested/vetted. Debian-sources are more of a courtesy as they are latest testing of new kernel additions before a mainline LTS kernel is released.
  23. nvidia-kernel-modules needs to be installed separately, this is by design for container use cases. VIDEO_CARDS can safely be removed, please do not set to VIDEO_CARDS="" as that is means something different altogether and will cause breakage.
×
×
  • Create New...