Jump to content
Sign in to follow this  
engineer

voip stuff fails to build

Recommended Posts

Latest problem is 

net-voip/telepathy-gabble-0.18.4 and net-voip/telepathy-salute-0.8.1-r1 which are pulled in by net-in/telepathy-connection-managers-2-r2

I suspect openssl 1.1+ is messing them up, or some Apple defines that are messing up the structures.

Anyone else running into this?

 

Share this post


Link to post
Share on other sites

The openssl patches for building those programs are in the next release branch of their respective kits.

To build the programs now you have to temporarily add them to local patches. 

Click link, File/Save page as:

telepathy-gabble-0.18.4-openssl-1.1.patch 

telepathy-salut-0.8.1-openssl-1.1.patch

 

# mkdir -p /etc/portage/patches/net-voip/telepathy-{gabble,salut}
# cp telepathy-gabble-0.18.4-openssl-1.1.patch /etc/portage/patches/net-voip/telepathy-gabble/
# cp telepathy-salut-0.8.1-openssl-1.1.patch /etc/portage/patches/net-voip/telepathy-salut/
# emerge -av telepathy-connection-managers

 

Share this post


Link to post
Share on other sites

That worked great! Thanks for the detailed instructions, they worked first time, flawlessly.

This has inspired me to try an --empty-tree which may take a couple of days on my Core i5 with 1800+ packages. I'm sure something will break and I'll be back. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...