Jump to content
funtoo forums
  • 0
Sign in to follow this  
mrlogick

[SOLVED] Which PYTHON_TARGETS?

Question

I'm not very expert with Gentoo/Funtoo. I just want to install qutebrowser.

$ emerge -pv qutebrowser

These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for www-client/qutebrowser
... done!

!!! The ebuild selected to satisfy "qutebrowser" has unmet requirements.
- www-client/qutebrowser-1.2.0::net-kit USE="-test" PYTHON_TARGETS="-python3_5 -python3_6"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( python_targets_python3_5 python_targets_python3_6 )

What should I do? Should I set python_targets_python3_6 in package.use for qutebrowser?

Or something in make.conf? This is my /etc/portage/make.conf :

L10N="en-US it-IT"
LINGUAS="en_US it_IT"

CFLAGS="-march=ivybridge -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j4"

VIDEO_CARDS="intel i965 nvidia"

Is it better python 3.5 or 3.6? But they are unstable, so, do I need to unmask something?

Now I have python only python 2.7 and 3.4 installed (which are necessary for other packages)

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 1

ego kit list

ego config set kits python-kit <branch>

there are other useful modules in ego such as ego profile, query, doc ... sync.

What Oleg is probably suggesting is to switch to 3.6-prime branch.

 

Share this post


Link to post
Share on other sites
  • 0

How can I see which versions are stable and which not? On Gentoo i went to the website https://packages.gentoo.org/packages/dev-lang/python. Is there a command line tool for funtoo?

Anyway, I put:

www-client/qutebrowser python_targets_python3_6

into /etc/portage/package.use

Now, portage complains even more:

$ emerge -pv qutebrowser


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=dev-python/PyQt5-5.7.1[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-),declarative,gui,network,opengl,printsupport,sql,webengine,widgets]" has unmet requirements.
- dev-python/PyQt5-5.8.2::python-kit USE="dbus opengl svg -bluetooth -debug -declarative -designer -doc -examples -gles2 -gui -help -location -multimedia -network -positioning -printsupport -sensors -serialport -sql -testlib -webchannel -webengine -webkit -websockets -widgets -x11extras -xmlpatterns" PYTHON_TARGETS="python2_7 python3_4 python3_6 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    webengine? ( widgets? ( webchannel ) )

  The above constraints are a subset of the following complete expression:
    any-of ( python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 ) bluetooth? ( gui ) declarative? ( gui network ) designer? ( widgets ) help? ( gui widgets ) location? ( positioning ) multimedia? ( gui network ) opengl? ( gui widgets ) positioning? ( gui ) printsupport? ( gui widgets ) sensors? ( gui ) serialport? ( gui ) sql? ( widgets ) svg? ( gui widgets ) testlib? ( gui widgets ) webchannel? ( network ) webengine? ( network widgets? ( webchannel ) ) webkit? ( gui network printsupport widgets ) websockets? ( network ) widgets? ( gui ) xmlpatterns? ( network )

(dependency required by "www-client/qutebrowser-1.2.0::net-kit" [ebuild])
(dependency required by "qutebrowser" [argument])

 

Share this post


Link to post
Share on other sites
  • 0

python-kit/3.6-prime breaks ego {query,doc,kit}

rj@funtoo ~ $ emerge -pv qutebrowser

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=dev-python/PyQt5-5.7.1[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-),declarative,gui,network,opengl,printsupport,sql,webengine,widgets]" has unmet requirements.
- dev-python/PyQt5-5.8.2::python-kit USE="dbus opengl svg -bluetooth -debug -declarative -designer -doc -examples -gles2 -gui -help -location -multimedia -network -positioning -printsupport -sensors -serialport -sql -testlib -webchannel -webengine -webkit -websockets -widgets -x11extras -xmlpatterns" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    webengine? ( widgets? ( webchannel ) )

  The above constraints are a subset of the following complete expression:
    any-of ( python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 ) bluetooth? ( gui ) declarative? ( gui network ) designer? ( widgets ) help? ( gui widgets ) location? ( positioning ) multimedia? ( gui network ) opengl? ( gui widgets ) positioning? ( gui ) printsupport? ( gui widgets ) sensors? ( gui ) serialport? ( gui ) sql? ( widgets ) svg? ( gui widgets ) testlib? ( gui widgets ) webchannel? ( network ) webengine? ( network widgets? ( webchannel ) ) webkit? ( gui network printsupport widgets ) websockets? ( network ) widgets? ( gui ) xmlpatterns? ( network )

(dependency required by "www-client/qutebrowser-1.2.0::net-kit" [ebuild])
(dependency required by "qutebrowser" [argument])

 

 

Share this post


Link to post
Share on other sites
  • 0

Yes, my fault ego stopped working because I didn't review the https://www.funtoo.org/News:Python_Updater_Deprecation /Changing the Python Active Version.

I failed to set the python interpreter from python-3.4 to python-3.6

funtoo /home/rj # eselect python list
Available Python interpreters, in order of preference:
[1] python3.4
[2] python3.6 (fallback)
[3] python2.7 (fallback)
funtoo /home/rj # eselect python set 2
funtoo /home/rj # eselect python list
Available Python interpreters, in order of preference:
[1] python3.6
[2] python3.4
[3] python2.7 (fallback)

All functions of ego now work as expected.

Thanks for your help Oleg.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...