Jump to content
funtoo forums

mrlogick

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. mrlogick

    [SOLVED] Blocked Packages because of me

    Oh, very well! I'll wait for a solution. Thanks!
  2. Hi, I installed xorg-x11. (because i wanted x11-wm/i3). xorg-x11 depends on xbacklight. My problem was that xbacklight didn't work because of an error: $ xbacklight -get No outputs have backlight property So, searching on the internet, I found this package: sys-power/acpilight, which works perfectly. From https://github.com/wavexx/acpilight : So, in the end, all I did was: $ emerge --unmerge xbacklight $ emerge acpilight Now, I can perfectly use my i3 WM, change brightness... without any issues. The only problem is that i can't update my system anymore. Since xorg-x11 (which is still installed) depends on xbacklight, when I try to update the system I got: $ sudo emerge -auvDN @world These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] x11-apps/xbacklight-1.2.1-r1::xorg-kit 0 KiB [blocks B ] x11-apps/xbacklight ("x11-apps/xbacklight" is blocking sys-power/acpilight-1.0-r1) Total: 1 package (1 new), Size of downloads: 0 KiB Conflict: 1 block (1 unsatisfied) * Error: The above package list contains packages which cannot be * installed at the same time on the same system. x11-apps/xbacklight-1.2.1-r1:0/0::xorg-kit, ebuild scheduled for merge pulled in by x11-apps/xbacklight required by x11-base/xorg-x11-7.4-r2:0/0::xorg-kit, installed sys-power/acpilight-1.0-r1:0/0::nokit, installed pulled in by sys-power/acpilight required by @selected Is there a way to keep xorg-x11 and acpilight, maybe masking xbacklight ? What is the right way to do it?
  3. mrlogick

    [SOLVED] Which PYTHON_TARGETS?

    Ok, I decommented "python-kit = 3.6-prime" in /etc/ego.conf
  4. mrlogick

    [SOLVED] Which PYTHON_TARGETS?

    How can I see which versions are stable and which not? On Gentoo i went to the website https://packages.gentoo.org/packages/dev-lang/python. Is there a command line tool for funtoo? Anyway, I put: www-client/qutebrowser python_targets_python3_6 into /etc/portage/package.use Now, portage complains even more: $ emerge -pv qutebrowser These are the packages that would be merged, in order: Calculating dependencies... done! !!! The ebuild selected to satisfy ">=dev-python/PyQt5-5.7.1[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-),declarative,gui,network,opengl,printsupport,sql,webengine,widgets]" has unmet requirements. - dev-python/PyQt5-5.8.2::python-kit USE="dbus opengl svg -bluetooth -debug -declarative -designer -doc -examples -gles2 -gui -help -location -multimedia -network -positioning -printsupport -sensors -serialport -sql -testlib -webchannel -webengine -webkit -websockets -widgets -x11extras -xmlpatterns" PYTHON_TARGETS="python2_7 python3_4 python3_6 -python3_5" The following REQUIRED_USE flag constraints are unsatisfied: webengine? ( widgets? ( webchannel ) ) The above constraints are a subset of the following complete expression: any-of ( python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 ) bluetooth? ( gui ) declarative? ( gui network ) designer? ( widgets ) help? ( gui widgets ) location? ( positioning ) multimedia? ( gui network ) opengl? ( gui widgets ) positioning? ( gui ) printsupport? ( gui widgets ) sensors? ( gui ) serialport? ( gui ) sql? ( widgets ) svg? ( gui widgets ) testlib? ( gui widgets ) webchannel? ( network ) webengine? ( network widgets? ( webchannel ) ) webkit? ( gui network printsupport widgets ) websockets? ( network ) widgets? ( gui ) xmlpatterns? ( network ) (dependency required by "www-client/qutebrowser-1.2.0::net-kit" [ebuild]) (dependency required by "qutebrowser" [argument])
  5. mrlogick

    [SOLVED] Which PYTHON_TARGETS?

    I'm not very expert with Gentoo/Funtoo. I just want to install qutebrowser. $ emerge -pv qutebrowser These are the packages that would be merged, in order: Calculating dependencies / !!! Problem resolving dependencies for www-client/qutebrowser ... done! !!! The ebuild selected to satisfy "qutebrowser" has unmet requirements. - www-client/qutebrowser-1.2.0::net-kit USE="-test" PYTHON_TARGETS="-python3_5 -python3_6" The following REQUIRED_USE flag constraints are unsatisfied: any-of ( python_targets_python3_5 python_targets_python3_6 ) What should I do? Should I set python_targets_python3_6 in package.use for qutebrowser? Or something in make.conf? This is my /etc/portage/make.conf : L10N="en-US it-IT" LINGUAS="en_US it_IT" CFLAGS="-march=ivybridge -O2 -pipe" CXXFLAGS="${CFLAGS}" MAKEOPTS="-j4" VIDEO_CARDS="intel i965 nvidia" Is it better python 3.5 or 3.6? But they are unstable, so, do I need to unmask something? Now I have python only python 2.7 and 3.4 installed (which are necessary for other packages)
×