Jump to content
funtoo forums
  • 0
da.ferri

Realtek r8168 module install

Question

14 answers to this question

Recommended Posts

  • 1

The user must recompile their kernel with CONFIG_R8169 disabled so in-tree  r8169.ko  is not on system.

There would be a conflict if in-tree r8169 and out-of-tree realtek r8169 modules were both installed on same system.

How the user configures and recompiles the kernel depends on what kernel  sources are used, how they are installed, if genkernel  is used,etc...

rj@funtoo ~ $ less /var/git/meta-repo/kits/net-kit/net-misc/r8168/r8168-8.044.02.ebuild 
CONFIG_CHECK="!R8169"
ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"

 

Share this post


Link to post
Share on other sites
  • 1

well, this is not entirely 100% true about necessity of disabling module in kernel. Because it can be blacklisted at runtime.  but it's correct that debian-sources has the r8169 enabled as module. This ebuild maybe need correction

Share this post


Link to post
Share on other sites
  • 1

perhaps firmware is whats needed r8169.c refers to r8168 multiple times... I am no programmer but my r8169 is using

r8169 0000:01:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-2.fw

PS also looked I am using

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

if it matters at all.

OP if you could give output of  ' sudo lspci -k |grep Ethernet '

Share this post


Link to post
Share on other sites
  • 1

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 68:f7:28:aa:4d:f7 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.203/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0 <<<<<<<< shows you have IP address does it work?

ok should of been ' lsmod | grep r8169 ' but ok

 

Share this post


Link to post
Share on other sites
  • 0
Quote

well, this is not entirely 100% true about necessity of disabling module in kernel. Because it can be blacklisted at runtime.  but it's correct that debian-sources has the r8169 enabled as module. This ebuild maybe need correction

As said in the first post the r8169 module has been blacklisted and in the emerge --info that I've posted there isn't a voice about the kernel, that is the debian-sources installed when i put the command emerge -auvDN @world.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, dhudson said:

perhaps firmware is whats needed r8169.c refers to r8168 multiple times... I am no programmer but my r8169 is using

r8169 0000:01:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-2.fw

PS also looked I am using

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

if it matters at all.

OP if you could give output of  ' sudo lspci -k |grep Ethernet '

davide@Funtoo ~ $ sudo lspci -k | grep Ethernet

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
    Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    Kernel modules: r8169

 

Share this post


Link to post
Share on other sites
  • 0

I've whitelisted r8169 because I need LAN just right now.

So here it's the output with r8169 enabled:

Funtoo davide # lsmod r8169
Usage: lsmod
Funtoo davide # dmesg | grep r8169
[   14.734630] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   14.734640] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[   14.744984] r8169 0000:02:00.0 eth0: RTL8168g/8111g at 0xffffa55980cfd000, 68:f7:28:aa:4d:f7, XID 10900800 IRQ 48
[   14.744987] r8169 0000:02:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   17.037973] r8169 0000:02:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-3.fw
[   17.054149] r8169 0000:02:00.0 eth0: link down
[   17.054149] r8169 0000:02:00.0 eth0: link down
[   19.864899] r8169 0000:02:00.0 eth0: link up
Funtoo davide # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 68:f7:28:aa:4d:f7 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.203/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
       valid_lft 86134sec preferred_lft 86134sec
    inet6 fe80::bf4f:f610:4421:7a0d/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 92:20:ac:da:61:28 brd ff:ff:ff:ff:ff:ff

 

 

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, dhudson said:

inet 192.168.1.203/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0 <<<<<<<< shows you have IP address does it work?

Yes, it works... seems to be resolved and the connection is stable.

Funtoo davide # ls -al /etc/init.d/netif.eth0
ls: impossibile accedere a /etc/init.d/netif.eth0: File o directory non esistente

Funtoo davide # cat /etc/conf.d/netif.eth0
cat: /etc/conf.d/netif.eth0: File o directory non esistente

Funtoo davide # lsmod | grep r8169
r8169                  90112  0
mii                    16384  1 r8169

netif.eth0 -> no file or directory(maybe I've missed something during configuration?)

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, da.ferri said:

Yes, it works... seems to be resolved and the connection is stable.


Funtoo davide # ls -al /etc/init.d/netif.eth0
ls: impossibile accedere a /etc/init.d/netif.eth0: File o directory non esistente

Funtoo davide # cat /etc/conf.d/netif.eth0
cat: /etc/conf.d/netif.eth0: File o directory non esistente

Funtoo davide # lsmod | grep r8169
r8169                  90112  0
mii                    16384  1 r8169

netif.eth0 -> no file or directory(maybe I've missed something during configuration?)

what exact guide used for this configuration?

Share this post


Link to post
Share on other sites
  • 0
48 minutes ago, dhudson said:

just courious , I have static ip set with those files. if you use

dhcpcd or other variants you wont need them

glad you got it sorted out.

Yes, I use dhcpcd as default because I have many problems to connect at my university network.

 

41 minutes ago, Oleg Vinichenko said:

what exact guide used for this configuration?

Funtoo's installation guide

 

.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×