Jump to content
funtoo forums
  • 0
dkg

Getting eix to work with kits

Question

I'm confused what I need to do to get eix to work on a current funtoo system.  People say it should work.  There's an old forum thread that talks about it, but nothing in the thread has helped with my issues.  Worse, I am getting different results on different systems (but never the right results).  Problem one, I get warnings like this...

[root@chopin portage]# eix eix                                                                            
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/build/current of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/corei7 of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/flavor/desktop of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/lxqt of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/no-systemd of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/kde-plasma-5 of file /etc/portage/make.profile/parent

Then notice the results on this system...

[?] app-portage/eix                                                                                     
     Available versions:  0.32.4 ~0.32.5 ~0.32.5-r1 ~0.32.9 {debug doc linguas_de linguas_ru nls sqlite}   
     Installed versions:  0.32.9-r1[?](02:00:06 PM 10/19/2017)(-debug -doc -linguas_de -linguas_ru -nls -sqlite)
     Homepage:            https://github.com/vaeth/eix/                                                    
     Description:         Search and query ebuilds

The Available versions are outdated.  I believe what it is updating based on the old /usr/portage tree.  On another system where I removed /usr/portage, eix just always returns no results.  Running 'eix-update' or 'eix-sync -u' do not correct the situation.  In fact, if I remove /usr/portage, then it will complain about missing /usr/portage files...

[root@chopin portage]# eix-update                                                                                                                                                            
Reading Portage settings...
[... Warnings removed ...]
Building database (/var/cache/eix/portage.eix)...                                                           
cannot open /usr/portage/profiles/categories: No such file or directory                                           
[0] "" /usr/portage/ (cache: metadata-md5-or-flat)                                                                  
     Reading category 0|0 (100) EMPTY!                                                                        
Applying masks...                                                                                          
Calculating hash tables...                                                                                
Writing database file /var/cache/eix/portage.eix...                                                        
Database contains 0 packages in 0 categories

On another system, eix simply returns old results, but I may have done something to nuke it's cache.  I'm not sure.  I'm using default branches for all kits on these systems.  One system does have a local overlay, but I don't think that's the problem.  What else do I need to do to get eix working?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1
On 11/29/2017 at 2:53 PM, dkg said:

Where on your system is this PORTDIR set?

Eix determines the path from  location attribute in /etc/portage/repos.conf/funtoo/core-kit

rj@funtoo ~ $ cat /etc/portage/repos.conf/funtoo/default 
[DEFAULT]
main-repo = core-kit
rj@funtoo ~ $ cat /etc/portage/repos.conf/funtoo/core-kit 
[core-kit]
location = /var/git/meta-repo/kits/core-kit
auto-sync = no
priority = 1

Using ports-2012 location attribute was /usr/portage

rj@funtoo ~ $ cat /etc/portage/repos.conf.bak/gentoo
[DEFAULT]
main-repo = gentoo

[gentoo]
location = /usr/portage
sync-type = git
sync-uri = git://github.com/funtoo/ports-2012.git
auto-sync = yes

strace shows file paths scanned by eix

strace -o eix.open.txt -e open eix --print PORTDIR

strace -o eix.txt eix --print PORTDIR

Share this post


Link to post
Share on other sites
  • 0

There seems to be something wrong on your system, as eix still reports old versions of eix as available. When I look at my portage tree on my system, there is only an ebuild for version 0.32.9-r1.

Also the warning messages about your parent file suggest that the content of your parent file is not correct. Could you post the parent file?

Share this post


Link to post
Share on other sites
  • 0
On 11/22/2017 at 10:57 PM, jhan said:

There seems to be something wrong on your system, as eix still reports old versions of eix as available. When I look at my portage tree on my system, there is only an ebuild for version 0.32.9-r1.

Also the warning messages about your parent file suggest that the content of your parent file is not correct. Could you post the parent file?

Because eix's database is out-of-date.  Those are not actually the ebuilds available.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, palica said:

Paste your


/etc/portage/make.profile/parent

Paste what is in your /etc/portage/repos.conf direcotry

[root@chopin ~]# cat /etc/portage/make.profile/parent
core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit
core-kit:funtoo/1.0/linux-gnu/build/current
core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/corei7
core-kit:funtoo/1.0/linux-gnu/flavor/desktop
core-kit:funtoo/1.0/linux-gnu/mix-ins/lxqt
core-kit:funtoo/1.0/linux-gnu/mix-ins/no-systemd
core-kit:funtoo/1.0/linux-gnu/mix-ins/kde-plasma-5
editors-kit:funtoo/kits/python-kit/3.4-prime
text-kit:funtoo/kits/python-kit/3.4-prime
dev-kit:funtoo/kits/python-kit/3.4-prime
perl-kit:funtoo/kits/python-kit/3.4-prime
games-kit:funtoo/kits/python-kit/3.4-prime
lisp-scheme-kit:funtoo/kits/python-kit/3.4-prime
desktop-kit:funtoo/kits/python-kit/3.4-prime
net-kit:funtoo/kits/python-kit/3.4-prime
xorg-kit:funtoo/kits/python-kit/3.4-prime
media-kit:funtoo/kits/python-kit/3.4-prime
ml-lang-kit:funtoo/kits/python-kit/3.4-prime
security-kit:funtoo/kits/python-kit/3.4-prime
haskell-kit:funtoo/kits/python-kit/3.4-prime
nokit:funtoo/kits/python-kit/3.4-prime
java-kit:funtoo/kits/python-kit/3.4-prime
core-hw-kit:funtoo/kits/python-kit/3.4-prime
core-kit:funtoo/kits/python-kit/3.4-prime
php-kit:funtoo/kits/python-kit/3.4-prime
gnome-kit:funtoo/kits/python-kit/3.4-prime
ruby-kit:funtoo/kits/python-kit/3.4-prime
kde-kit:funtoo/kits/python-kit/3.4-prime
python-kit:funtoo/kits/python-kit/3.4-prime
xfce-kit:funtoo/kits/python-kit/3.4-prime
science-kit:funtoo/kits/python-kit/3.4-prime
lang-kit:funtoo/kits/python-kit/3.4-prime
[root@chopin ~]# ls -l /etc/portage/repos.conf
total 8
drwx------ 2 root root 4096 Oct 19 21:13 ./
drwxr-xr-x 9 root root 4096 Oct 19 21:12 ../
lrwxrwxrwx 1 root root   30 Oct 19 21:13 funtoo -> /var/git/meta-repo/repos.conf//
[root@chopin ~]#

 

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, palica said:

What your ego version?

You probably have to run emerge -avuDN @world --new-repo

[root@chopin ~]# ego query versions ego
 app-admin/ego| slot|               repo
--------------+-----+-------------------
         2.0.9|    0| core-kit/1.0-prime
        2.0.10|     | core-kit/1.0-prime
        2.0.14|     | core-kit/1.0-prime
         2.1.1|     | core-kit/1.0-prime
         2.2.0|     | core-kit/1.0-prime
         2.2.1|     | core-kit/1.0-prime
       * 2.3.1|     | core-kit/1.0-prime
         2.3.2|     | core-kit/1.0-prime
          9999|     | core-kit/1.0-prime

What is '--new-repo' supposed to do?  As far as I can see, that is not a valid argument to emerge.

Share this post


Link to post
Share on other sites
  • 0
27 minutes ago, dkg said:

What is '--new-repo' supposed to do?  As far as I can see, that is not a valid argument to emerge.

The parameter is actually called "--newrepo" and recompiles a package if it is now pulled from a different repository.

 

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, Oleg Vinichenko said:

sorry, --newrepo, it was typo with --new-repo

WOW!  That is going to rebuild the whole system (922 packages).  That's what I need to do to fix eix?

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, dkg said:

WOW!  That is going to rebuild the whole system (922 packages).  That's what I need to do to fix eix?

Probably yes, as eix sees the package in the different repository than stored in its database and complains about it.

Share this post


Link to post
Share on other sites
  • 0

i cannot say about eix as i don't use it, but yes it can be indirectly good for eix. As jhan pointed, when ebuild installed , there are may various metadata about ebuild installed into /var/db/* including special file repository, which has all information about what repo ebuild installed from. --newrepo will rebuild those ebuilds that now changed it's origin, for example 

sys-libs/ncurses::gentoo will be sys-libs/ncruses::core-kit, so gentoo was a name of repository (and which was in /usr/portage). With rebuild you will get your /var/db correctly set. Which might fix eix (i can't tell)

Share this post


Link to post
Share on other sites
  • 0

Your funtoo symlink  ends with //

Review the directions for installing meta-repo.

[root@chopin ~]# ls -l /etc/portage/repos.conf
total 8
drwx------ 2 root root 4096 Oct 19 21:13 ./
drwxr-xr-x 9 root root 4096 Oct 19 21:12 ../
lrwxrwxrwx 1 root root   30 Oct 19 21:13 funtoo -> /var/git/meta-repo/repos.conf//

On my system :

rj@funtoo ~ $ ls -la /etc/portage/repos.conf
total 12
drwxr-xr-x  2 root root 4096 Nov  4 12:47 .
drwxr-xr-x 16 root root 4096 Nov  4 12:45 ..
lrwxrwxrwx  1 root root   30 Nov  4 12:45 funtoo -> /var/git/meta-repo/repos.conf/
-rw-r--r--  1 root root   83 Nov  4 12:48 local.conf
rj@funtoo ~ $ ls -la /etc/portage/repos.conf/funtoo/
total 112
drwxr-xr-x 2 portage portage 4096 Nov  4 12:54 .
drwxr-xr-x 6 portage portage 4096 Nov 25 04:15 ..
-rw-r--r-- 1 portage portage   89 Jul 23 02:04 core-hw-kit
-rw-r--r-- 1 portage portage   83 Aug 19 14:31 core-kit
-rw-r--r-- 1 portage portage   31 Jul 23 02:04 default
-rw-r--r-- 1 portage portage   89 Jul 23 02:04 desktop-kit
-rw-r--r-- 1 portage portage   81 Jul 23 02:04 dev-kit
-rw-r--r-- 1 portage portage   89 Jul 23 02:04 editors-kit
-rw-r--r-- 1 portage portage   85 Jul 25 12:43 games-kit
-rw-r--r-- 1 portage portage   86 Jul 23 02:04 gnome-kit
-rw-r--r-- 1 portage portage   89 Oct 23 04:26 haskell-kit
-rw-r--r-- 1 portage portage   83 Jul 23 02:04 java-kit
-rw-r--r-- 1 portage portage   81 Jul 23 02:04 kde-kit
-rw-r--r-- 1 portage portage   83 Oct 27 00:56 lang-kit
-rw-r--r-- 1 portage portage   97 Oct 23 04:26 lisp-scheme-kit
-rw-r--r-- 1 portage portage   85 Jul 23 02:04 media-kit
-rw-r--r-- 1 portage portage   89 Oct 23 04:26 ml-lang-kit
-rw-r--r-- 1 portage portage   81 Jul 23 02:04 net-kit
-rw-r--r-- 1 portage portage   81 Jul 23 02:04 nokit
-rw-r--r-- 1 portage portage   83 Jul 23 02:04 perl-kit
-rw-r--r-- 1 portage portage   81 Jul 29 22:33 php-kit
-rw-r--r-- 1 portage portage   87 Jul 23 02:04 python-kit
-rw-r--r-- 1 portage portage   83 Oct 23 04:26 ruby-kit
-rw-r--r-- 1 portage portage   90 Jul 23 02:04 science-kit
-rw-r--r-- 1 portage portage   91 Jul 23 02:04 security-kit
-rw-r--r-- 1 portage portage   83 Jul 23 02:04 text-kit
-rw-r--r-- 1 portage portage   83 Oct 23 04:26 xfce-kit
-rw-r--r-- 1 portage portage   83 Jul 23 02:04 xorg-kit

Check your eix PORTDIR and PORTDIR_OVERLAY variables after you fix the symlink. If they don't match mine with the exception of my "/usr/local/portage" personal overlay you may have a PORTDIR = "/usr/portage" defined in /etc/portage/make.conf  that has to be removed.

rj@funtoo ~ $ eix --print PORTDIR
/var/git/meta-repo/kits/core-kit/
rj@funtoo ~ $ eix --print PORTDIR_OVERLAY
/var/git/meta-repo/kits/core-hw-kit
/var/git/meta-repo/kits/desktop-kit
/var/git/meta-repo/kits/dev-kit
/var/git/meta-repo/kits/editors-kit
/var/git/meta-repo/kits/games-kit
/var/git/meta-repo/kits/gnome-kit
/var/git/meta-repo/kits/haskell-kit
/var/git/meta-repo/kits/java-kit
/var/git/meta-repo/kits/kde-kit
/var/git/meta-repo/kits/lang-kit
/var/git/meta-repo/kits/lisp-scheme-kit
/var/git/meta-repo/kits/media-kit
/var/git/meta-repo/kits/ml-lang-kit
/var/git/meta-repo/kits/net-kit
/var/git/meta-repo/kits/nokit
/var/git/meta-repo/kits/perl-kit
/var/git/meta-repo/kits/php-kit
/var/git/meta-repo/kits/python-kit
/usr/local/portage
/var/git/meta-repo/kits/ruby-kit
/var/git/meta-repo/kits/science-kit
/var/git/meta-repo/kits/security-kit
/var/git/meta-repo/kits/text-kit
/var/git/meta-repo/kits/xfce-kit
/var/git/meta-repo/kits/xorg-kit

I use this script to sync and check for updated ebuilds :

#!/bin/sh

ego sync &&
if [[ -e /var/cache/eix/portage.eix ]] ; then 
    cp -a /var/cache/eix/portage.eix /var/cache/eix/previous.eix; 
fi
eix-update
if [[ -e /var/cache/eix/previous.eix ]] ; then 
    eix-diff; 
fi

 

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, palica said:

sorry. my bad about new-repo. But should help you with packages being displayed as not installed in eix output.

can you list


/var/git/meta-repo/repos.conf

I do not have an issue with eix displaying incorrect information about what is installed.  It is reporting incorrect information about what is available to install.  Really, it doesn't seem logical that rebuilding the system will fix that issue, or the other issue described above (warning: ignoring parent).

[root@chopin ~]# ls -l /var/git/meta-repo/repos.conf
total 116
drwx------ 2 portage portage 4096 Oct 28 14:14 ./
drwx------ 6 portage portage 4096 Nov 22 16:36 ../
-rw------- 1 portage portage   92 Oct 19 08:41 chopin.conf
-rw------- 1 portage portage   89 Sep 17 11:38 core-hw-kit
-rw------- 1 portage portage   83 Sep 17 11:38 core-kit
-rw------- 1 portage portage   31 Sep 17 11:38 default
-rw------- 1 portage portage   89 Sep 17 11:38 desktop-kit
-rw------- 1 portage portage   81 Sep 17 11:38 dev-kit
-rw------- 1 portage portage   89 Sep 17 11:38 editors-kit
-rw------- 1 portage portage   85 Sep 17 11:38 games-kit
-rw------- 1 portage portage   86 Sep 17 11:38 gnome-kit
-rw------- 1 portage portage   89 Oct 28 14:14 haskell-kit
-rw------- 1 portage portage   83 Sep 17 11:38 java-kit
-rw------- 1 portage portage   81 Sep 17 11:38 kde-kit
-rw------- 1 portage portage   83 Oct 28 14:14 lang-kit
-rw------- 1 portage portage   97 Oct 28 14:14 lisp-scheme-kit
-rw------- 1 portage portage   85 Sep 17 11:38 media-kit
-rw------- 1 portage portage   89 Oct 28 14:14 ml-lang-kit
-rw------- 1 portage portage   81 Sep 17 11:38 net-kit
-rw------- 1 portage portage   81 Sep 17 11:38 nokit
-rw------- 1 portage portage   83 Sep 17 11:38 perl-kit
-rw------- 1 portage portage   81 Sep 17 11:38 php-kit
-rw------- 1 portage portage   87 Sep 17 11:38 python-kit
-rw------- 1 portage portage   83 Oct 28 14:14 ruby-kit
-rw------- 1 portage portage   90 Sep 17 11:38 science-kit
-rw------- 1 portage portage   91 Sep 17 11:38 security-kit
-rw------- 1 portage portage   83 Sep 17 11:38 text-kit
-rw------- 1 portage portage   83 Oct 28 14:14 xfce-kit
-rw------- 1 portage portage   83 Sep 17 11:38 xorg-kit

The chopin.conf file is for a local overlay on this system.  The other system where I have eix issues does not have a local overlay.  If eix is working for you, please describe any steps taken beyond those in the meta-repo migration guide.

Share this post


Link to post
Share on other sites
  • 0

so I would recommend you to do it this way:

/etc/portage/repos.conf/ will contain:

  • copy all the kits and prepend them with ego-
    • so you will have ego-core-kit linking to /var/git/meta-repo/repos.conf/core-kit and so on for other kits
    • don't copy default
    • put stuff from default into core-kit
  • put your chopin.conf in here too

This is going to be the new layout coming with ego-2.3.2

Paste your chopin.conf

eix-sync works without problems no need to write custom scripts

 

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, cardinal said:

Your funtoo symlink  ends with //

I have never seen that cause an issue with a directory symlink, but I have changed it.  In addition, the symlink on the other system with eix issues did not have this "issue".

15 minutes ago, cardinal said:

Check your eix PORTDIR and PORTDIR_OVERLAY variables after you fix the symlink. If they don't match mine with the exception of my "/usr/local/portage" personal overlay you may have a PORTDIR = "/usr/portage" defined in /etc/portage/make.conf  that has to be removed.

I have neither PORTDIR nor PORTDIR_OVERLAY defined in make.conf.

[root@chopin portage]# cat /etc/portage/make.conf
# These settings were set by the metro build script that automatically built this stage.
# Please consult /etc/portage/make.conf.example for a more detailed example.

MAKEOPTS="-j9"
# For darktable
#CPU_FLAGS_X86="sse3"
#CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --ask --quiet-build=y --autounmask=n"
FETCHCOMMAND="/usr/bin/wget --limit-rate=200k --timeout=60 --tries=3 --passive-ftp -O \"\${DISTDIR}/\${FILE}\" \"\${URI}\""
RESUMECOMMAND="/usr/bin/wget -c --limit-rate=200k --timeout=60 --tries=3 --passive-ftp -O \"\${DISTDIR}/\${FILE}\" \"\${URI}\""
PORTAGE_ELOG_SYSTEM="save_summary:log,warn,error mail_summary:log,warn,error echo"
PORTAGE_ELOG_MAILURI="dave@gasaway.org /usr/bin/sendmail"
PORTAGE_ELOG_MAILFROM="portage@nymph.dakega.info"
FEATURES="clean-logs"
USE="consolekit gif jpeg png tiff flac ogg vorbis mp3 opus -iptables -networkmanager -upower -ldap -nls -pulseaudio -handbook -ppp"
VIDEO_CARDS="radeon radeonsi"
#VIDEO_CARDS="fglrx"
LINGUAS="en en_US en_DK de_AT"
ABI_X86="64 32"
INPUT_DEVICES="evdev roccat_konepure"

 

Share this post


Link to post
Share on other sites
  • 0

you want probably

L10N="${LINGUAS}" in your make.conf

for the useflags I would suggest to remove them from make.conf and use profiles instead

for example

gif jpeg png tiff flac ogg vorbis mp3

are all in audio and media mix-ins which are part of workstation flavor which is part of desktop flavor

so selecting desktop flavor has you covered with most of them

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, cardinal said:

@dkg

Post output:


eix --print PORTDIR

eix --print PORTDIR_OVERLAY

 

Sorry.  Here they are.

[root@chopin repos.conf]# eix --print PORTDIR                                                                                                                                                        
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit of file /etc/portage/make.profile/parent                                                                                       
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/build/current of file /etc/portage/make.profile/parent                                                                                        
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/corei7 of file /etc/portage/make.profile/parent                                                                        
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/flavor/desktop of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/lxqt of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/no-systemd of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/kde-plasma-5 of file /etc/portage/make.profile/parent
warning: ignoring parent editors-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent text-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent dev-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent perl-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent games-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent lisp-scheme-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent desktop-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent net-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent xorg-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent media-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent ml-lang-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent security-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent haskell-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent nokit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent java-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent core-hw-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent php-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent gnome-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent ruby-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent kde-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent python-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent xfce-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent science-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent lang-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
/usr/portage/
[root@chopin repos.conf]# eix --print PORTDIROVERLAY
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/build/current of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/corei7 of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/flavor/desktop of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/lxqt of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/no-systemd of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/1.0/linux-gnu/mix-ins/kde-plasma-5 of file /etc/portage/make.profile/parent
warning: ignoring parent editors-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent text-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent dev-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent perl-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent games-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent lisp-scheme-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent desktop-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent net-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent xorg-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent media-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent ml-lang-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent security-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent haskell-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent nokit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent java-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent core-hw-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent core-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent php-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent gnome-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent ruby-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent kde-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent python-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent xfce-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent science-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent
warning: ignoring parent lang-kit:funtoo/kits/python-kit/3.4-prime of file /etc/portage/make.profile/parent

 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, palica said:

you want probably

L10N="${LINGUAS}" in your make.conf

for the useflags I would suggest to remove them from make.conf and use profiles instead

for example


gif jpeg png tiff flac ogg vorbis mp3

are all in audio and media mix-ins which are part of workstation flavor which is part of desktop flavor

so selecting desktop flavor has you covered with most of them

It's likely those USE flags predate funtoo profiles.  This system has been in operation since early 2014.  Surely, that is not the cause of my eix troubles.

Share this post


Link to post
Share on other sites
  • 0

Another point.  Earlier I said this...

On 11/22/2017 at 5:19 PM, dkg said:

On another system, eix simply returns old results, but I may have done something to nuke it's cache.  I'm not sure.

I figured out that difference.  On the other system I had deleted /usr/portage, as it did not have space for both trees.  If I do 'mv /usr/portage /usr/portage.old && eix-update' on this system, then I get the same empty results as the other system.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, palica said:

so I would recommend you to do it this way:

/etc/portage/repos.conf/ will contain:

  • copy all the kits and prepend them with ego-
    • so you will have ego-core-kit linking to /var/git/meta-repo/repos.conf/core-kit and so on for other kits
    • don't copy default
    • put stuff from default into core-kit
  • put your chopin.conf in here too

This is going to be the new layout coming with ego-2.3.2

Paste your chopin.conf

eix-sync works without problems no need to write custom scripts

 

I'm having trouble understanding your instructions.  You say to "copy all the kits".  Copy them from where?  Are you saying to copy the files in /var/git/meta-repo/repos.conf/?  Then you say that I will have 'ego-core-kit linking to...'.  Um.  If I copy files, then they will be files, not links.  Unless you are talking about the locations in those files.  If so, then I would have to change all the locations in the files, no?

[root@chopin ~]# cat /var/git/meta-repo/repos.conf/core-kit
[core-kit]
location = /var/git/meta-repo/kits/core-kit
auto-sync = no
priority = 1
[root@chopin ~]# cat /var/git/meta-repo/repos.conf/chopin.conf
[chopin]
location = /var/git/overlay/chopin
masters = core-kit
auto-sync = no
priority = 10

 

Share this post


Link to post
Share on other sites
  • 0

USE flag - you are right not the cause of your problems with eix

Iinstructions - yes you are right it says copy in one and link in other. my fault

copy all the kits from /var/git/meta-repo/repos.conf/ to /etc/portage/repos.conf/ (prepend them with ego-)

add stuff from default to ego-core-kit

add your chopin.conf to /etc/portage/repos.conf/

rm /usr/share/portage/config/repos.conf

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, palica said:

USE flag - you are right not the cause of your problems with eix

Iinstructions - yes you are right it says copy in one and link in other. my fault

copy all the kits from /var/git/meta-repo/repos.conf/ to /etc/portage/repos.conf/ (prepend them with ego-)

add stuff from default to ego-core-kit

add your chopin.conf to /etc/portage/repos.conf/


rm /usr/share/portage/config/repos.conf

I'm sorry.  I fail to see how this will get eix to stop looking for /usr/portage.  Will it fix the warnings?  Is this what you have done to get eix to work?

(I have no /usr/share/portage/config/repos.conf file, by the way.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×