Jump to content
funtoo forums
  • 0
More_Piffle

Help a N00B with chroot

Question

Hello all,

I am rusty enough with Unix/Linux to call myself a Newbie, I know enough to get myself in trouble.

So I need to chroot into my funtoo installation so I can run: rc-update del xdm default    However when looking at the commands for chroot on the install instructions and I try to run: mount /mnt/funtoo/ I get no such directory. So I am thinking it is because I am booted to "rescue" and then I try to run: mount /dev/sdb3/ /mnt/funtoo/ and I also got no such directory. I ran: mount /dev/sdb3/ / and it seemed to work but when I changed to / and looked around at some of the files and directories I found that I was looking at directories and files on the "rescue" Linux.

I looked back in the instructions and they say:

   mkdir /mnt/funtoo

   mount /dev/sdb3 /mnt/funtoo

However I do not want to create a new directory I want to mount what is already there, so I did not do that.

As you can see I somewhat understand the commands and what I am doing but not really (my linux install is on sdb). I could use some help - even if it is "Hey you need to read this" - I will learn and want to learn.

 

What got me here:  Installing xfce4 after testing xwindows - the instructions say to edit /etc/conf.d/xdm and make these entries:

   DISPLAYMANAGER="<LightDM>"

   # rc-update add xdm default

   # rc-update add dbus default

   # rc

Finished up with the other instructions - created power group and added root to it etc. rebooted and did not get my xfce session as expected so not knowing what I was doing, and I seem to remember from somewhere years ago that # in a config file = a comment, I ran the rc-update commands at the command prompt and rebooted now I am presented with a login screen and can get no where and cannot get a command prompt.

 

 

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1

@More_Piffle With the mkdir /mnt/funtoo, you are making a dir on the live disk so you can mount the directories that are on your root partition "/dev/sdb3." Then when you "mount /dev/sdb3 /mnt/funtoo" you will then have access to the files that you need to edit in "/etc/conf.d/xdm". Thus you are not making another dir on your installation /dev/sdb3. https://wiki.gentoo.org/wiki/Chroot

This video should be helpful as well https://www.youtube.com/watch?v=VrJvqdD4Kkg

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Oleg Vinichenko said:

what instruction you followed, so we know?

Oleg forgive me it is not a fault with any instruction, I figured out this morning, it is the fact that I used reader view with firefox and printed from there and so it looked like the rc-update commands belonged in the /etc/conf.d/xdm  config file. - I am learning by leaps and bounds ... Woohoo gonna get stuck in a corner again! Maybe not now, maybe not tomorrow, but I can feel it coming :)

The instruction that i followed that lead me to put # in my /etc/conf.d/xdm file is: funtoo.org/package:Xfce4-meta (it was because I printed from firefox reader view)

@tefreem34 Thank you for clearing that up for me, and thank you for the further instructions.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×