Jump to content
Funtoo Linux
  • 0
Sandro

About /var/mail/root

Question

Hi ... reading the mails for root, i can see this error

Date: Thu, 22 Sep 2016 21:00:01 +0200 (CEST) 

usage: egencache [options] <action> ... [atom] ...
egencache: error: --repo option is required

From root@ci74771ht.localdomain  Fri Sep 23 21:00:01 2016
Return-Path: <root@ci74771ht.localdomain>
X-Original-To: root
Delivered-To: root@ci74771ht.localdomain
Received: by ci74771ht.localdomain (Postfix, from userid 0)
       id D984F100821; Fri, 23 Sep 2016 21:00:01 +0200 (CEST)
From: root@ci74771ht.localdomain (Cron Daemon)
To: root@ci74771ht.localdomain
Subject: Cron <root@ci74771ht> /usr/bin/egencache --update-use-local-desc
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>
X-Cron-Env: <USER=root>
Message-Id: <20160923190001.D984F100821@ci74771ht.localdomain>
Date: Fri, 23 Sep 2016 21:00:01 +0200 (CEST)

usage: egencache [options] <action> ... [atom] ...
egencache: error: --repo option is required

It is related to vixie-cron & anacron.

 

My crontab :

ci74771ht ~ # crontab -l 
# DO NOT EDIT THIS FILE - edit the master and reinstall.
# (/home/sandro/Funtoo/crons.cron installed on Sat Jul 30 23:39:51 2016)
# (Cron version V5.0 -- $Id: crontab.c,v 1.12 2004/01/23 18:56:42 vixie Exp $)
00      23      1       *       *       /sbin/fstrim -v -a >> /var/log/fstrim.lo
g
00      22      *       *       *       /usr/bin/updatedb
00      21      *       *       *       /usr/bin/egencache --update-use-local-desc

Thanks for any suggestion ^^

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

The error message in your first post:

egencache: error: --repo option is required

Your existing crontab has no --repo option:

00      21      *       *       *       /usr/bin/egencache --update-use-local-desc

you don't need to run update of use-local-desc. it's in included in portage tree. But real problem in your case was missing --repo=gentoo

Replace --update-use-local-desc with --repo=gentoo

00      21      *       *       *       /usr/bin/egencache --repo=gentoo

Share this post


Link to post
Share on other sites
  • 0

why do you run egencache --update-use-local-desc?

Cause I sincerely don't know if it must be "refreshed" (similar mlocate/updatedb for example)

 

If mi thought is incorrect ... i will remove the instruction from crontab :)

Share this post


Link to post
Share on other sites
  • 0

you don't need to run update of use-local-desc. it's in included in portage tree. But real problem in your case was missing --repo=gentoo

 

Excuse me i've not understood ..... where i must add "--repo=gentoo" ?

 

excuse my ignorance :|

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×