Jump to content
funtoo forums
  • 0
ajohnl

Any way to have both GNOME and KDE installed at the same time?

Question

My profile:

sudo epro show

=== Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: amd64-piledriver
      flavor: desktop
     mix-ins: gnome
     mix-ins: xfce
     mix-ins: kde-plasma-5


=== All inherited flavors from desktop flavor: ===

                     workstation (from desktop flavor)
                            core (from workstation flavor)
                         minimal (from core flavor)

=== All inherited mix-ins from desktop flavor: ===

                               X (from workstation flavor)
                           audio (from workstation flavor)
                             dvd (from workstation flavor)
                           media (from workstation flavor)
      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)
                  console-extras (from workstation flavor)
                           print (from desktop flavor)

When I try updating world and installing kde at the same time:

emerge -auvDN --with-bdeps=y @world kde-apps/kde-meta:5

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=kde-plasma/plasma-desktop-5.5.5:5" has unmet requirements.
- kde-plasma/plasma-desktop-5.5.5-r1::gentoo USE="evdev fontconfig gtk3 handbook pulseaudio qt4 -debug -gtk2 -legacy-systray -test -touchpad"

  The following REQUIRED_USE flag constraints are unsatisfied:
    gtk3? ( legacy-systray )

  The above constraints are a subset of the following complete expression:
    legacy-systray? ( any-of ( gtk2 gtk3 qt4 ) ) gtk2? ( legacy-systray ) gtk3? ( legacy-systray )

(dependency required by "kde-plasma/plasma-meta-5.5.5::gentoo" [ebuild])
(dependency required by "kde-apps/kde-meta-15.08.3::gentoo" [ebuild])
(dependency required by "kde-apps/kde-meta:5" [argument])

Does anyone know a way to have both? And if not, can I just remove the gnome and xfce mix-ins and it'll work? Or is additional configuration needed?

 

Thanks.

 

 

 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

 

Try :

# egencache --update-use-local-desc
# euse -P qt4 gtk2
# euse -E qt5 gtk3
# emerge -DNupv world kde-apps/kde-meta:5

I tried the commands, got some errors:

egencache --update-use-local-desc
usage: egencache [options] <action> ... [atom] ...
egencache: error: --repo option is required

As for the 3rd command:

euse -E qt5 gtk3
Adding flag "qt5" to make.conf
ERROR: Use flag "gtk3" is not defined in use.desc and should not be added
to make.conf.

I tried manually editing my make.conf with USE="qt5 gtk3" but I still get errors.

emerge -DNupv @world kde-apps/kde-meta:5
These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for media-video/vlc from @selected
... done!

!!! The ebuild selected to satisfy "media-video/vlc" has unmet requirements.
- media-video/vlc-2.2.2::gentoo USE="X a52 alsa avcodec avformat bluray cdda cddb dbus dts dvbpsi dvd encode faad ffmpeg flac gcrypt gnome ieee1394 jpeg libass libnotify libsamplerate matroska mp3 mpeg mtp ncurses ogg opengl png postproc pulseaudio qt4 qt5 svg swscale taglib theora truetype twolame udev v4l vorbis vpx x264 x265 xcb xml -aalib (-altivec) -atmo (-audioqueue) -bidi -chromaprint -dc1394 -debug -directfb (-directx) -dvb (-dxva2) -fdk -fluidsynth -fontconfig -gme -gnutls -growl -httpd -jack -kate -kde (-libav) -libcaca -libtar -libtiger -linsys -lirc -live -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-media-library) -modplug -musepack (-neon) -omxil -opencv -optimisememory -opus -projectm (-rdp) -rtsp -run-as-root -samba -schroedinger -sdl -sdl-image -sftp -shout -sid -skins -speex -test -tremor -upnp -vaapi -vcdx -vdpau -vlm -vnc -wma-fixed -xv -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse"

  The following REQUIRED_USE flag constraints are unsatisfied:
    qt4? ( !qt5 ) qt5? ( !qt4 )

  The above constraints are a subset of the following complete expression:
    aalib? ( X ) bidi? ( truetype ) cddb? ( cdda ) dvb? ( dvbpsi ) dxva2? ( avcodec ) ffmpeg? ( avcodec avformat swscale ) fontconfig? ( truetype ) gnutls? ( gcrypt ) httpd? ( lua ) libcaca? ( X ) libtar? ( skins ) libtiger? ( kate ) qt4? ( X !qt5 ) qt5? ( X !qt4 ) sdl? ( X ) skins? ( truetype X xml exactly-one-of ( qt4 qt5 ) ) vaapi? ( avcodec X ) vdpau? ( xcb ) vlm? ( encode ) xv? ( xcb )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Thanks for your help btw :)

Share this post


Link to post
Share on other sites
  • 0

I'm using kde4 (then with qt4 and "-qt5");

 

To emerge vlc try with

 

# euse -D qt5 media-video/vlc
# euse -E qt4 media-video/vlc
# emerge -DNu vlc

 

However, in my system (but i use Funtoo Stable), about vlc:

 

 

[ebuild   R    ] media-video/vlc-2.2.1-r1:0/5-8::gentoo  USE="X a52 aalib alsa avcodec avformat bidi bluray cdda cddb dbus dts dvb dvbpsi dvd encode ffmpeg flac fontconfig gcrypt gnutls ieee1394 jack jpeg kde libass libcaca libnotify libsamplerate lirc lua matroska modplug mp3 mpeg mtp musepack ncurses ogg opengl png pulseaudio qt4 sdl speex svg swscale theora truetype udev v4l vaapi vnc vorbis x264 xcb xml xv (-altivec) -atmo (-audioqueue) -chromaprint -dc1394 -debug -directfb (-directx) (-dxva2) -faad -fdk -fluidsynth -gme -gnome -growl -httpd -kate (-libav) -libtar -libtiger -linsys -live (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-media-library) (-neon) -omxil -opencv -optimisememory -opus -postproc -projectm -qt5 (-rdp) -rtsp -run-as-root -samba -schroedinger -sdl-image -sftp -shout -sid -skins -taglib {-test} -tremor -twolame -upnp -vcdx -vdpau -vlm -vpx -wma-fixed -x265 -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse" 20450 KiB

Total: 1 package (1 reinstall), Size of downloads: 20450 KiB

 

(It will require others dependencies) :|

Share this post


Link to post
Share on other sites
  • 0

@ajohnl
Undo changes to get back to the output in post #1.
If you have  gtk2 gtk3 qt4 qt5 in /etc/portage/make.conf USE= remove them.
Avoid adding USE flags to make.conf , it effects all packages and overrides the profile configuration.
The conflict is due to gnome mix-in make.default sets USE gtk3 and kde-plasma-5 make.default sets USE qt4 and qt5.
Plasma-desktop can only be built using either gtk2 or gtk3 or qt4.
The above constraints are a subset of the following complete expression:
    legacy-systray? ( any-of ( gtk2 gtk3 qt4 ) ) gtk2? ( legacy-systray ) gtk3? ( legacy-systray )
The gnome profile enables gtk3 and kde-plasma-5 enables qt4 which causes the error.
One solution is to disable gtk3 for plasma-desktop in /etc/portage/package.use so it builds with qt4.

"echo kde-plasma/plasma-desktop -gtk3" >> /etc/portage/package.use/plasma-desktop

Don't override vlc use flags, mix-ins/kde-plasma-5/package.use has "media-video/vlc -qt4", vlc builds with qt5.
There is no conflict between lxde and kde-plasma-5 mix-ins on my system.
The output from line 500 emerge -auvDN --with-bdeps=y @world kde-apps/kde-meta:5 :

[ebuild  N     ] kde-plasma/plasma-desktop-5.5.5-r1:5::gentoo  USE="evdev fontconfig handbook qt4 -debug -gtk2 -gtk3 -legacy-systray -pulseaudio {-test} -touchpad" 6,158 KiB

Share this post


Link to post
Share on other sites
  • 0

 

@ajohnl

Undo changes to get back to the output in post #1.

If you have  gtk2 gtk3 qt4 qt5 in /etc/portage/make.conf USE= remove them.

Avoid adding USE flags to make.conf , it effects all packages and overrides the profile configuration.

The conflict is due to gnome mix-in make.default sets USE gtk3 and kde-plasma-5 make.default sets USE qt4 and qt5.

Plasma-desktop can only be built using either gtk2 or gtk3 or qt4.

The above constraints are a subset of the following complete expression:

    legacy-systray? ( any-of ( gtk2 gtk3 qt4 ) ) gtk2? ( legacy-systray ) gtk3? ( legacy-systray )

The gnome profile enables gtk3 and kde-plasma-5 enables qt4 which causes the error.

One solution is to disable gtk3 for plasma-desktop in /etc/portage/package.use so it builds with qt4.

"echo kde-plasma/plasma-desktop -gtk3" >> /etc/portage/package.use/plasma-desktop

Don't override vlc use flags, mix-ins/kde-plasma-5/package.use has "media-video/vlc -qt4", vlc builds with qt5.

There is no conflict between lxde and kde-plasma-5 mix-ins on my system.

The output from line 500 emerge -auvDN --with-bdeps=y @world kde-apps/kde-meta:5 :

[ebuild  N     ] kde-plasma/plasma-desktop-5.5.5-r1:5::gentoo  USE="evdev fontconfig handbook qt4 -debug -gtk2 -gtk3 -legacy-systray -pulseaudio {-test} -touchpad" 6,158 KiB

It asked me to install old nvidia drivers (which wouldn't compile) so I masked them, other than that everything works, thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...