Jump to content
funtoo forums

ajohnl

Members
  • Content Count

    8
  • Joined

  • Last visited

  • Days Won

    1

ajohnl last won the day on April 6 2016

ajohnl had the most liked content!

About ajohnl

  • Rank
    Newbie

Recent Profile Visitors

231 profile views
  1. I use Funtoo for gaming and love it but I'm having problems getting my steam controller to work with controller supported games. I installed steam following this: http://www.funtoo.org/Steam And I followed this for additional setup: https://wiki.gentoo.org/wiki/Steam_Controller My current udev rules set in /etc/udev/rules.d/99-steam-controller-perms.rules # This rule is needed for basic functionality of the controller in Steam SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0666" # This rule is necessary for gamepad emulation KERNEL=="uinput", MODE="0660", GROUP="input", OPTIONS+="static_node=uinput" And gamepad emulation still doesn't work, but keyboard and mouse emulation works perfectly. Has anyone here got it working? Thanks in advance.
  2. Solved by adding abi_x86_64/32 to the corresponding packages.
  3. Hi, I appear to have some problems with dependencies when doing emerge -auvDNU @world http://pastebin.com/bnjTSMBE My package.use and .mask don't have anything unusual, and my epro is amd64 piledriver desktop with gnome and xfce mix-ins. This happened after I tried using kde, then reverted because of some driver issues, the weird thing is that when I try to install some of them manually I get for example: Calculating dependencies... done! [ebuild R ] media-video/ffmpeg-2.8.6:0/54.56.56::gentoo USE="X aac alsa bluray bzip2 cdio encode faac gpl hardcoded-tables iconv ieee1394 jpeg2k libass mp3 network opengl postproc pulseaudio theora threads truetype twolame v4l vorbis vpx wavpack webp x264 x265 xvid zlib -aacplus (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bs2b -celt -cpudetection -debug -doc -examples -fdk -flite -fontconfig* -frei0r -fribidi -gme -gnutls -gsm -iec61883 -jack -ladspa -libcaca -libressl -librtmp -libsoxr -libv4l -lzma* (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -opus -oss -pic -quvi -samba -schroedinger -sdl* -snappy -speex -ssh -static-libs {-test} -vaapi -vdpau -xcb -zvbi" ABI_X86="(64) -32* (-x32)" CPU_FLAGS_X86="avx fma3 fma4 mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 xop -3dnow -3dnowext -avx2" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" 0 KiB Total: 1 package (1 reinstall), Size of downloads: 0 KiB !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: media-video/ffmpeg:0 (media-video/ffmpeg-2.8.6:0/54.56.56::gentoo, ebuild scheduled for merge) pulled in by media-video/ffmpeg (Argument) (media-video/ffmpeg-2.8.6:0/54.56.56::gentoo, installed) pulled in by >=media-video/ffmpeg-2.8.5:0/54.56.56=[abi_x86_32(-),abi_x86_64(-)] required by (media-plugins/gst-plugins-libav-1.6.3:1.0/1.0::gentoo, installed) >=media-video/ffmpeg-2.8.5:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-plugins/gst-plugins-libav-1.6.3:1.0/1.0::gentoo, installed) It appears I already have the latest packages yet they conflict, any idea what this might be? Thanks in advance.
  4. It's fine, all is working right now. Now how do I make this [solved]?
  5. It asked me to install old nvidia drivers (which wouldn't compile) so I masked them, other than that everything works, thanks.
  6. My profile: sudo epro show === Enabled Profiles: === arch: x86-64bit build: current subarch: amd64-piledriver flavor: desktop mix-ins: gnome mix-ins: xfce mix-ins: kde-plasma-5 === All inherited flavors from desktop flavor: === workstation (from desktop flavor) core (from workstation flavor) minimal (from core flavor) === All inherited mix-ins from desktop flavor: === X (from workstation flavor) audio (from workstation flavor) dvd (from workstation flavor) media (from workstation flavor) mediadevice-audio-consumer (from media mix-in) mediadevice-base (from mediadevice-audio-consumer mix-in) mediadevice-video-consumer (from media mix-in) mediadevice-base (from mediadevice-video-consumer mix-in) mediaformat-audio-common (from media mix-in) mediaformat-gfx-common (from media mix-in) mediaformat-video-common (from media mix-in) console-extras (from workstation flavor) print (from desktop flavor) When I try updating world and installing kde at the same time: emerge -auvDN --with-bdeps=y @world kde-apps/kde-meta:5 These are the packages that would be merged, in order: Calculating dependencies... done! !!! The ebuild selected to satisfy ">=kde-plasma/plasma-desktop-5.5.5:5" has unmet requirements. - kde-plasma/plasma-desktop-5.5.5-r1::gentoo USE="evdev fontconfig gtk3 handbook pulseaudio qt4 -debug -gtk2 -legacy-systray -test -touchpad" The following REQUIRED_USE flag constraints are unsatisfied: gtk3? ( legacy-systray ) The above constraints are a subset of the following complete expression: legacy-systray? ( any-of ( gtk2 gtk3 qt4 ) ) gtk2? ( legacy-systray ) gtk3? ( legacy-systray ) (dependency required by "kde-plasma/plasma-meta-5.5.5::gentoo" [ebuild]) (dependency required by "kde-apps/kde-meta-15.08.3::gentoo" [ebuild]) (dependency required by "kde-apps/kde-meta:5" [argument]) Does anyone know a way to have both? And if not, can I just remove the gnome and xfce mix-ins and it'll work? Or is additional configuration needed? Thanks.
×
×
  • Create New...