Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

Boost blocking ncmpcpp, also gnome keyring is trying to weasle it's way in... please help



Hello,  I went to update my system last night and am getting some weird errors.

# emerge -auDN @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U  ] app-portage/layman-2.3.0-r1 [2.3.0] PYTHON_TARGETS="-python3_5%"
[ebuild     U  ] sys-apps/util-linux-2.27.1 [2.27]
[ebuild     U  ] dev-vcs/git-2.6.3 [2.6.2]
[nomerge       ] sys-fs/sshfs-fuse-2.5
[ebuild     U  ]  net-misc/openssh-7.1_p1-r2 [7.1_p1-r1]
[ebuild     U  ] www-client/google-chrome-beta-47.0.2526.58_p1 [47.0.2526.49_p1]
[ebuild     U  ] www-plugins/adobe-flash- []
[nomerge       ] virtual/jdk-1.8.0-r1
[ebuild     U  ]  dev-java/oracle-jdk-bin- [] USE="awt%* cups%* -examples% -javafx%"
[ebuild     U  ] media-tv/plex-media-server- []
[nomerge       ] dev-vcs/git-2.6.3 [2.6.2]
[ebuild  N     ]  app-crypt/gnupg-2.0.28  USE="bzip2 mta nls readline usb -doc -ldap (-selinux) -smartcard -static -tools"
[ebuild     U  ]   app-crypt/pinentry-0.9.6-r6 [0.9.6-r5]
[nomerge       ] sys-process/glances-2.4.2
[ebuild     U  ]  dev-python/psutil-3.2.2 [3.1.1] PYTHON_TARGETS="-python3_5%"
[nomerge       ] media-plugins/gst-plugins-meta-1.6
[nomerge       ]  media-plugins/gst-plugins-mad-1.6.0
[nomerge       ]   media-libs/gst-plugins-ugly-1.6.0
[nomerge       ]    media-libs/gst-plugins-base-1.6.0
[ebuild     U  ]     app-text/iso-codes-3.63 [3.61]
[ebuild     U  ] app-portage/eix-0.31.3 [0.31.1]
[ebuild     U  ] www-plugins/chrome-binary-plugins-47.0.2526.58_beta1 [47.0.2526.49_beta1]
[ebuild     U  ] media-sound/ncmpcpp-0.7_beta1 [0.6.7]
[ebuild     U  ] sys-process/procps-3.3.11-r2 [3.3.10-r1]
[ebuild     U  ] sys-apps/grep-2.22 [2.21-r1]
[nomerge       ] app-portage/layman-2.3.0-r1 [2.3.0] PYTHON_TARGETS="-python3_5%"
[nomerge       ]  dev-python/ssl-fetch-0.3
[nomerge       ]   dev-python/requests-2.8.1
[nomerge       ]    dev-python/pyopenssl-0.15.1
[nomerge       ]     dev-python/cryptography-1.1
[ebuild  N     ]      virtual/python-ipaddress-1.0  PYTHON_TARGETS="python2_7 python3_3 -pypy -pypy3 -python3_4 -python3_5"
[ebuild     U  ]       dev-python/ipaddress-1.0.15 [1.0.14]
[nomerge       ] dev-java/oracle-jdk-bin- [] USE="awt%* cups%* -examples% -javafx%"
[nomerge       ]  dev-java/java-config-2.2.0
[nomerge       ]   sys-apps/portage-2.4.0
[ebuild     U  ]    app-misc/pax-utils-1.1.4 [1.1.3]
[nomerge       ] media-gfx/gimp-2.8.14-r1
[ebuild     U  ]  dev-libs/libxslt-1.1.28-r5 [1.1.28-r4] USE="-examples%"
[ebuild     U  ]   dev-libs/libxml2-2.9.2-r4 [2.9.2-r1]
[nomerge       ] app-portage/layman-2.3.0-r1 [2.3.0] PYTHON_TARGETS="-python3_5%"
[ebuild     U  ]  dev-vcs/mercurial-3.6.1 [3.6]
[nomerge       ] gnome-base/gvfs-1.24.2
[nomerge       ]  net-libs/libsoup-2.50.0
[ebuild     U  ]   dev-db/sqlite-3.9.2 [3.9.1]
[nomerge       ] dev-java/oracle-jdk-bin- [] USE="awt%* cups%* -examples% -javafx%"
[nomerge       ]  net-print/cups-2.0.4
[nomerge       ]   net-libs/gnutls-3.3.18
[ebuild     U  ]    dev-libs/gmp-6.1.0 [6.0.0a] USE="asm%*"
[blocks B      ] dev-libs/boost:0/1.57.0 ("dev-libs/boost:0/1.57.0" is blocking media-sound/ncmpcpp-0.7_beta1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gmp-6.0.0a:0/0::gentoo, installed) pulled in by
    dev-libs/gmp:0/0= required by (dev-scheme/guile-2.0.11-r1:0/2.0.11::gentoo, installed)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-sound/ncmpcpp-0.7_beta1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    media-sound/ncmpcpp required by @selected

  (dev-libs/boost-1.57.0:0/1.57.0::gentoo, installed) pulled in by
    dev-libs/boost:=[python,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] (dev-libs/boost:=[python,python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)]) required by (net-libs/rb_libtorrent-1.0.6:0/0::gentoo, installed)
    dev-libs/boost:0/1.57.0=[python,python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (net-libs/rb_libtorrent-1.0.6:0/0::gentoo, installed)
    >=dev-libs/boost-1.53:=[threads] required by (net-libs/rb_libtorrent-1.0.6:0/0::gentoo, installed)
    >=dev-libs/boost-1.53:0/1.57.0=[threads] required by (net-libs/rb_libtorrent-1.0.6:0/0::gentoo, installed)
    dev-libs/boost:=[nls,threads] required by (media-sound/ncmpcpp-0.7_beta1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/boost:=[icu] required by (media-sound/ncmpcpp-0.7_beta1:0/0::gentoo, ebuild scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by gnome-base/gnome-keyring-3.16.0-r1::gentoo
# required by gnome-base/libgnome-keyring-3.12.0::gentoo
# required by dev-vcs/git-2.6.3::gentoo[gnome-keyring]
# required by app-portage/layman-2.3.0-r1::gentoo[git]
# required by @selected
# required by @world (argument)
>=app-crypt/pinentry-0.9.6-r6 gnome-keyring

Would you like to add these changes to your config files? [Yes/No]

could someone explain why portage is trying to do this?


Thank you for your time.

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Have you tried for example:


# emerge --sync && emerge -1u ncmpcpp && emerge -DNupv world ?


Or try to mask temporarely with

# echo ">=media-sound/ncmpcpp-0.6.9">>/etc/portage/package.mask

# emerge -DNu world --with-bdeps=y -pv

Link to comment
Share on other sites

  • 0

@Cardinal: Thank You Cardinal: I'm trying some experiment: for example with Funtoo "Stable" on my system the 0.6.8 is correctly compiled.

Now I try with "Stable" if also the 0.7_beta_! compiles or not on Stable.




Ok ..... with Stable also the last 0.7_? compiled succesfully ...... 


Now I must terminate the compilation of Chromium .... then I make experiemnts also in "current".


I wish my little feedback can be utile :)

Link to comment
Share on other sites

  • 0

In current, only the last ebuild creates also for me troubles.


# echo "=media-sound/ncmpcpp-0.7_beta1">>/etc/portage/package.mask"

Can give temporarely for You a solution.


Excuse me Cardinal ... hope not to have bored You :|

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...