Jump to content
  • 0
Sign in to follow this  
linuxbigot

emerge -a www-client/firefox-bin...

Question

(chroot) sysresccd / # emerge -a www-client/firefox-bin

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/lzo-2.08-r1  USE="-examples -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] media-fonts/liberation-fonts-2.00.1-r1  USE="-X -fontforge" 
[ebuild  N     ] dev-perl/XML-NamespaceSupport-1.110.0-r1 
[ebuild  N     ] media-libs/libpng-1.6.17  USE="-apng (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] media-libs/alsa-lib-1.0.29  USE="python -alisp -debug -doc" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 
[ebuild  N     ] dev-libs/gobject-introspection-common-1.42.0 
[ebuild  N     ] virtual/ttf-fonts-1 
[ebuild  N     ] x11-themes/hicolor-icon-theme-0.15 
[ebuild  N     ] dev-perl/XML-SAX-Base-1.80.0-r1 
[ebuild  N     ] virtual/perl-Storable-2.490.100-r1 
[ebuild  N     ] x11-proto/xproto-7.0.27  USE="-doc" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-proto/xextproto-7.3.0  USE="-doc" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] media-libs/freetype-2.5.5  USE="adobe-cff bzip2 -X -auto-hinter -bindist -debug -doc -fontforge -harfbuzz -infinality -png -static-libs -utils" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/xtrans-1.3.5  USE="-doc" 
[ebuild  N     ] x11-proto/inputproto-2.3.1  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-proto/renderproto-0.11.1-r1  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] dev-libs/atk-2.14.0  USE="nls -introspection {-test}" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] media-fonts/font-util-1.3.1 
[ebuild  N     ] x11-proto/kbproto-1.0.6-r1  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-misc/util-macros-1.19.0 
[ebuild  N     ] x11-proto/damageproto-1.2.1-r1  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] dev-perl/XML-SAX-0.990.0-r1 
[ebuild  N     ] x11-proto/xf86bigfontproto-1.2.0-r1  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] dev-libs/libpthread-stubs-0.3-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-proto/compositeproto-0.4.2-r1  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] app-arch/libarchive-3.1.2-r1  USE="acl bzip2 e2fsprogs iconv lzma xattr zlib -expat -lzo -nettle -static-libs" 
[ebuild  N     ] x11-libs/pixman-0.32.6  USE="(-altivec) (-iwmmxt) (-loongson2f) (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmxext sse2 ssse3" 
[ebuild  N     ] x11-proto/randrproto-1.4.1  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-proto/xcb-proto-1.11-r1000  ABI_X86="(64) -32 (-x32)" PYTHON_ABIS="2.7 3.3 -2.6 -3.1 -3.2 -3.4 (-3.5)" 
[ebuild  N     ] x11-libs/libICE-1.0.9  USE="ipv6 -doc -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXau-1.0.8  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXdmcp-1.1.2  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] dev-util/cmake-3.2.1  USE="ncurses -doc -emacs -qt4 -qt5 {-test}" 
[ebuild  N     ] x11-proto/fixesproto-5.0-r1  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] dev-perl/XML-LibXML-2.1.400-r1  USE="{-test}" 
[ebuild  N     ] x11-libs/libxcb-1.11-r1  USE="-doc (-selinux) -static-libs {-test} -xkb" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] media-gfx/graphite2-1.2.4-r1  USE="-perl {-test}" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libSM-1.2.2-r1  USE="ipv6 uuid -doc -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] dev-perl/XML-Simple-2.200.0-r1 
[ebuild  N     ] x11-libs/libX11-1.6.3  USE="ipv6 -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-misc/icon-naming-utils-0.8.90 
[ebuild  N     ] x11-libs/libXfixes-5.0.1  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXrender-0.9.8  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXext-1.3.3  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/gdk-pixbuf-2.31.1  USE="X -debug -introspection -jpeg -jpeg2k {-test} -tiff" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXt-1.1.4  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-themes/gnome-icon-theme-3.12.0  USE="-branding" 
[ebuild  N     ] x11-libs/libXcomposite-0.4.4-r1  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXdamage-1.1.4-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXcursor-1.1.14  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXrandr-1.4.2  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/libXi-1.7.4  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] virtual/freedesktop-icon-theme-0 
[ebuild  N     ] media-libs/fontconfig-2.11.93  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] app-eselect/eselect-fontconfig-1.1 
[ebuild  N     ] x11-libs/cairo-1.14.2  USE="X glib svg (-aqua) -debug (-directfb) (-gles2) -opengl -static-libs -valgrind -xcb -xlib-xcb" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] media-libs/harfbuzz-0.9.35  USE="cairo glib graphite icu truetype -introspection -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/pango-1.36.8  USE="-X -debug -introspection" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-libs/gtk+-2.24.27  USE="(-aqua) -cups -debug -examples -introspection {-test} -vim-syntax -xinerama" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] www-client/firefox-bin-38.0.1  USE="(-selinux) -startup-notification" LINGUAS="-af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -kn -ko -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -te -tr -uk -vi -zh_CN -zh_TW" 

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-libs/gtk+-2.24.27
# required by www-client/firefox-bin-38.0.1
# required by www-client/firefox-bin (argument)
=x11-libs/cairo-1.14.2 X
# required by x11-libs/gtk+-2.24.27
# required by www-client/firefox-bin-38.0.1
# required by www-client/firefox-bin (argument)
>=x11-libs/gdk-pixbuf-2.31.1 X

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

As always TIA !!!

 

how to solve it ??? 

 

asap

 

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

The following USE changes are necessary to proceed:

(see "package.use" in the portage(5) man page for more details)

# required by x11-libs/gtk+-2.24.27

# required by www-client/firefox-bin-38.0.1

# required by www-client/firefox-bin (argument)

=x11-libs/cairo-1.14.2 X

# required by x11-libs/gtk+-2.24.27

# required by www-client/firefox-bin-38.0.1

# required by www-client/firefox-bin (argument)

>=x11-libs/gdk-pixbuf-2.31.1 X

 

ie add to /etc/portage/make.conf

USE="X"

 

or

 

mkdir -p /etc/portage/package.use

echo "x11-libs/cairo X" >> /etc/portage/package.use/cairo

echo "x11-libs/gdk-pixbuf X" >> /etc/portage/package.use/gdk-pixbuf

 

 

for this it's better to set a desktop profile, it will resolve most of USE flags problems. I suspect only core profile used here.

epro flavor desktop

 

You ROCK homies !!!

 

I'm writin from fireshit-bin on ICEWM

 

:emobounce:

Share this post


Link to post
Share on other sites
  • 0

As spectromas said, all you have to do is explained at the end of the output, and it points you to man 5 portage as well.

 

However, I think you should first set your flavor and mix-ins: http://www.funtoo.org/Funtoo_Linux_Installation#ProfilesEspecially, setting the X mix-in would be a good idea.

 

Did you solve your chroot issue?

 

PS : I see you are still on sysresccd, probably firefox is not the priority for now. Get a working environnment before installing software you need. Otherwise, you'll just get into more troubles.

Share this post


Link to post
Share on other sites
  • 0

The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by x11-libs/gtk+-2.24.27
# required by www-client/firefox-bin-38.0.1
# required by www-client/firefox-bin (argument)
=x11-libs/cairo-1.14.2 X
# required by x11-libs/gtk+-2.24.27
# required by www-client/firefox-bin-38.0.1
# required by www-client/firefox-bin (argument)
>=x11-libs/gdk-pixbuf-2.31.1 X

 

ie add to /etc/portage/make.conf

USE="X"

 

or

 

mkdir -p /etc/portage/package.use

echo "x11-libs/cairo X" >> /etc/portage/package.use/cairo

echo "x11-libs/gdk-pixbuf X" >> /etc/portage/package.use/gdk-pixbuf

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...