Jump to content
  • 0
dkg

1.4 upgrade and Python 3.6

Question

I'm confused by the way that the 1.4 upgrade instructions state, unconditionally, "Remove python-3.6 as it will no longer be used."  There are at least a couple of ebuilds in the tree that do not have a Python 3.7 target, e.g., net-fs/s3ql and dev-python/pycrypto.  What am I missing?

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 1

@dkg you may find that some of the 'left over' things depending on 3.6 are actually 'old'/deprecated and can be removed. For example, pycrypto is old, and should be deleted, and pycryptodome is now being used in its place.

Share this post


Link to post
Share on other sites
  • 0

True.  But until that work is done, advising people to execute 'emerge -C =dev-lang/python-3.6*' without checking if they are using it seems silly.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, drobbins said:

@dkg you may find that some of the 'left over' things depending on 3.6 are actually 'old'/deprecated and can be removed. For example, pycrypto is old, and should be deleted, and pycryptodome is now being used in its place.

See the bug I filed at gentoo yesterday 🙂

https://bugs.gentoo.org/707878

Share this post


Link to post
Share on other sites
  • 0

@dkg you should really not file Funtoo bugs on the Gentoo bug tracker. It is an issue in Funtoo, not Gentoo. Please close the bug as invalid on Gentoo's bug tracker and file it on Funtoo's bug tracker.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, drobbins said:

@dkg you should really not file Funtoo bugs on the Gentoo bug tracker. It is an issue in Funtoo, not Gentoo. Please close the bug as invalid on Gentoo's bug tracker and file it on Funtoo's bug tracker.

I am both a Gentoo user and a Funtoo user.  Would you like me to open a bug on both trackers?

Share this post


Link to post
Share on other sites
  • 0

@dkg I am assuming you are experiencing the bug under Funtoo since you are posting on the Funtoo forums. In that case, open the bug on the Funtoo bug tracker. You should not open bugs for issues you experience under Funtoo on the Gentoo bug tracker. So yes, if my assumptions are correct, then close the bug as invalid on the Gentoo bug tracker and open one on the Funtoo bug tracker.

If you are experiencing the identical issue on a Gentoo box, then yes, you report the issue you are experiencing on Gentoo to the Gentoo bug tracker.

But since you are posting here about a Funtoo issue, and you opened a bug on the Gentoo bug tracker, this is wrong. Just because you also use Gentoo does not entitle you to report Funtoo bugs to the Gentoo bug tracker. This is not helpful at all since I don't see the issue, so the issue will NOT get fixed in Funtoo.

I hope that makes sense.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, drobbins said:

I hope that makes sense.

Sure, it makes sense, but it is a problem that I am experiencing in both.  I am happy to open a Funtoo bug, too, if that is the proper etiquette in my situation.

Share this post


Link to post
Share on other sites
  • 0

And there you have it.  🙂

https://bugs.funtoo.org/browse/FL-6963

Honestly, I feel this discussion has gotten a little off track, though.  It was supposed to be about my concern with the upgrade instructions.  I guess the answer is, "Don't blindly follow the steps."  Good advice, that.  I only pointed out the s3ql problem because pycrypto vs. pycryptodome came up.  A workaround is there if anybody needs it.

Share this post


Link to post
Share on other sites
  • 0

From an install instructions perspective, they are correct. You should remove python-3.6 as Funtoo Linux 1.4 does not have python-3.6 and instead has python-3.7. So if you are upgrading your system to 1.4 and want your system to be set up that way, it is necessary to remove python-3.6.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, drobbins said:

From an install instructions perspective, they are correct. You should remove python-3.6 as Funtoo Linux 1.4 does not have python-3.6 and instead has python-3.7. So if you are upgrading your system to 1.4 and want your system to be set up that way, it is necessary to remove python-3.6.

Umm.  Okay.  I suppose this all makes sense to people with deep insight into Funtoo, but it's awful confusing to this user.  Python 3.6 is in the tree, but it's not part of Funtoo 1.4.  Software which I find critical is in the tree, but does not have a Python 3.7 target (only 3.5 and 3.6).  So I keep Python 3.6 and therefore I'm deviating from Funtoo 1.4, I guess.  I did not know that what I did was not supported.  Seems the correct thing to do was to remove 3.6, and break that critical software.  It needed to be fixed for 3.7, but I had no idea about this when I started the upgrade.  I'm not sure how I would know that there are packages without 3.7 targets before I get to the part of the upgrade where I sync the new tree.  Even after, unless I'm actively looking for for these problems, I don't think any red flags would get raised before the step where Python 3.6 is removed.  If there was warning about this potential problem area, I must have missed it.  I guess I'm saying I don't know where I went wrong in this process.  What should I have done differently?

Share this post


Link to post
Share on other sites
  • 0

@dkg I agree it's confusing. I recommend a clean reinstall rather than an upgrade if at all possible. Gentoo doesn't handle upgrades well and thus Funtoo inherits these problems. I hope to address them in the future but the first step was to attempt to document the upgrade instructions.

Share this post


Link to post
Share on other sites
  • 0

Funny thing, I had the opposite problem. My upgrade failed because lack of support for python 3.6 so I had to remove it ahead of the instructions :)

 

Cheers,

Erik

 

Share this post


Link to post
Share on other sites
  • 0

And just a note, there have been improvements to Funtoo's python eclasses which should have fixed a lot of bugs related to python3.7 compatibility missing from our ebuilds.  This happened in the last week. Our snapshot of Gentoo was taken at a time when Gentoo was not really converted over to 3.7 yet, and this is reflected in the state of the ebuilds in the Funtoo tree. While we have made fixes here and there, the recent Funtoo enhancements I made to the eclasses basically fix this throughout the whole Funtoo tree and also make python ebuilds more maintainable and auto-gennable on Funtoo going forward.

So just wanted to let everyone know that we have had major improvements here, and these are just the initial steps. We plan to be ahead of Gentoo in regards to Python support very soon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...