Jump to content
kratsy-tony

Bumblebee on nvidia-steam-launcher

Recommended Posts

The approach to installing steam as described here: https://www.funtoo.org/Steam is very clever. 

However, it doesn't describe how it applies to Optimus laptops. 

Or am I missing something? Can the guide for Steam be used for gaming (Optimus) laptops?

Sorry, but I'm just a mere mortal trying to figure out how I can use my gaming laptop given that Funtoo is now fully 64-bit.

Other things in mind: Lutris, Wine, DXVK, Vulkan, Steam proton.

Share this post


Link to post
Share on other sites

Some update:

After tinkering a bit. It seems that you don't need bumblebee at all!??? I'm not really sure because glxinfo returns "Intel" as its renderer. I.e., it returns the following:

root@4f82889627cf:/# glxinfo |grep -i renderer
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel(R) UHD Graphics 630 (Coffeelake 3x8 GT2) x86/MMX/SSE2

This is a bit confusing because the command nvidia-container-cli info returns this (for an unitiated like me I take this as an indication that the Nvidia card is in use):

NVRM version:   440.44
CUDA version:   10.2

Device Index:   0
Device Minor:   0
Model:          GeForce GTX 1660 Ti
Brand:          GeForce
GPU UUID:       GPU-142cff67-ea5c-3410-82cd-cc262a1afc18
Bus Location:   00000000:01:00.0
Architecture:   7.5

I was able to install Witcher using Steam Proton (good), however there is no audio at all (this is the deal breaker for me). From video previews in steam games to the actual game that's running - no audio.

I hope some Funtoo gods would shed some light on this. I'm definitely missing a lot.

Thank you guys for the great work.

Share this post


Link to post
Share on other sites

Hmmm... I'm already using steam-nvidia-launcher-1.6, but the file described in the bug remains having an extra "unix:" prepended to the pulse server line. How does one edit that file inside the docker container? It seems to be immutable. Basically I still don't have audio, and I'm not even sure if the nvidia card is used instead of the intel one as glxinfo indicates that its renderer is intel.

Share this post


Link to post
Share on other sites

@kratsy-tony you can "steam-nvidia-launcher attach" to attach to a running container and edit /root/steam.sh. But I think I know why the container didn't update ... keep reading below.

BTW, that's really cool that you were able to use the steam-nvidia-launcher under Optimus -- I hadn't tested that.

The audio issue *should* be fixed with 1.6, but you *may* need to "blow away" your old container to fix the audio issue, now that I think about it. I don't think the launcher is checking to make sure the container is 1.6 so it's running your existing 1.5 container. Do a "docker ps -a", grab the container ID, then do "docker rm <container-id>". When you use steam-nvidia-launcher the next time, the container will be recreated and you'll have a 1.6 container.

Edit: also note your existing downloads should be preserved since they are bind-mounted into the ~/SteamData directory in your home dir on your host.

Share this post


Link to post
Share on other sites

Hello @drobbins, thanks for the help - I appreciate it. Now I can play Steam games with sound. 

Quote

BTW, that's really cool that you were able to use the steam-nvidia-launcher under Optimus -- I hadn't tested that.

I'm unsure if the Nvidia GPU is being used - if my deduction is correct, I don't think it does. If I run a game (Windows - Witcher 1) through Steam's Proton and switch to a terminal attached to the container, then run nvidia-smi, it returns the following:

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.64       Driver Version: 440.44       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 166...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   52C    P0     7W /  N/A |      0MiB /  5944MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+

As you can see, it indicates that the GPU is off. I haven't tried native titles yet (e.g., DoTA or Witcher 2). I'll let you guys know as soon as I do.

Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...