Jump to content
  • 1

Screen Freezing


bitterbitbasher
 Share

Question

I've recently installed Funtoo 1.4 (I did a zero fill on my HD early, instead updating from Funtoo 1.3), and now after I've installed all (or almost all) programs I want, I'm experiencing a very bad bug that makes my screen freeze when I open certain progs. It has first occurred when I opened the Youtube page on surf browser. The screen just got frozen although the mouse still be changing accordingly with the application. To bribe this situation I have to quit dwm (which is the window manager that I use) and then open it again by doing startx. It also occurs everytime I try to open Vivaldi browser. Immediately when the program opens the screen freezes.

My notebook wich Funtoo 1.4 is installed has 4Gb of RAM, Intel Core I3 processor and Intel HD Graphics 3000. I have set gfxcard-intel on epro profile and intel i965 on make.conf. While I've been doing this topic my screen just got frozen 2 times on surf, both when I tried to search something on Google and it had Youtube content involved; and I realized that the X log (that shows up in the terminal when I do startx) sometimes shows errors related to GDK. The last one reported an IO problem from GDK.

Please, can anybody help me with this issue? I also have experienced other issues with this new update of Funtoo and I'll make other topics to report them, wich I think it's the best I can do at this moment.

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0
6 minutes ago, bcowan said:

Can you check /etc/boot.conf and make sure that if nomodeset is there you remove it and re-run ego boot update, then reboot.

My boot.conf:

Quote

 

boot {
    generate grub
    default "Funtoo Linux genkernel"
    timeout 3
}

"Funtoo Linux" {
    kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
    kernel kernel[-v]
    initrd initramfs[-v]
    params += real_root=auto rootfstype=auto
}

As you can see there is no nomodeset, I removed it, as suggested in the Funtoo installation guide.

Link to comment
Share on other sites

  • 0
11 hours ago, vchipk985 said:

You can try 2 things:

Install a non gtk browser, ex: falkon (qt), maybe its gtk related.

Or

Install debian-sources, probably you have installed debian-sources-lts. We can see if its kernel related.

Can you upload the X log and show the errors?

About the browser, I think Vivaldi is not based on GTK. About installing debian-sources, I installed it but it did not solve the freeze problem. And about the log, there is a xkbcomp error about keycode above 255. Also seems that occurred an AL lib error; "pulse_load: Failed to load libpulse.so.0". It's important to say that I have experienced another errors related to AL lib; and it occurs everytime when I try do open dwarf-fortress and due to that I can't run the game. The error message reports "Sound devices available:

OpenAL Soft

Picking OpenAL Soft. If your desired device was missing, make sure you have the appropriate 32-bit libraries installed. If you wanted a different device, configure ~/.openalrc appropriately.

AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead

Perfect OpenAL context attributes GET

Loading binding from data/init/interface.txt

Segmentation fault".

That's all.

Link to comment
Share on other sites

  • 0
3 hours ago, bitterbitbasher said:

About installing debian-sources, I installed it but it did not solve the freeze problem.

If you did everything right, it is not kernel related. As I said before: upload the Xorg full log. Without it we can only guess what is happening.

3 hours ago, bitterbitbasher said:

Picking OpenAL Soft. If your desired device was missing, make sure you have the appropriate 32-bit libraries installed.

Since 1.3 update, funtoo doesn't use multilib. And the error is telling you to use 32-bits libraries.

But you were using funtoo 1.3 before and it was working, which is strange.

 

Link to comment
Share on other sites

  • 0
1 hour ago, vchipk985 said:

If you did everything right, it is not kernel related. As I said before: upload the Xorg full log. Without it we can only guess what is happening.

Since 1.3 update, funtoo doesn't use multilib. And the error is telling you to use 32-bits libraries.

But you were using funtoo 1.3 before and it was working, which is strange.

 

Sorry about the log, I don't know how to export to a file. I usually copy de log through st (simple terminal) wich allows me to select the text and copy them to clipboard. But the xorg log is shown in the "native" terminal, which doesn't allow me to copy the text. If you know how can I do it, I would send the full xorg log.

Link to comment
Share on other sites

  • 0

Line 57:

[ 46346.003] (II) LoadModule: "intel"
[ 46346.003] (WW) Warning, couldn't open module intel
[ 46346.003] (EE) Failed to load module "intel" (module does not exist, 0)
[ 46346.003] (II) LoadModule: "modesetting"
[ 46346.003] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 46346.004] (II) Module modesetting: vendor="X.Org Foundation"
[ 46346.004]     compiled for 1.20.5, module version = 1.20.5
[ 46346.004]     Module class: X.Org Video Driver
[ 46346.004]     ABI class: X.Org Video Driver, version 24.0
[ 46346.004] (II) LoadModule: "fbdev"
[ 46346.004] (WW) Warning, couldn't open module fbdev
[ 46346.004] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 46346.004] (II) LoadModule: "vesa"
[ 46346.004] (WW) Warning, couldn't open module vesa
[ 46346.004] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 46346.004] (II) modesetting: Driver for Modesetting Kernel Drivers: kms

Its loading on kms modeset instead on intel module (module does not exist on your output)

See if fbdev, intel, i915 and i965 are enabled on VIDEO_CARDS with emerge --info. Also, see if they are enabled on xorg-drivers: emerge -pv xorg-drivers.

The log didn't show the freeze, but it can be related to the missing intel module.

Link to comment
Share on other sites

  • 0
5 hours ago, vchipk985 said:

Line 57:

[ 46346.003] (II) LoadModule: "intel"
[ 46346.003] (WW) Warning, couldn't open module intel
[ 46346.003] (EE) Failed to load module "intel" (module does not exist, 0)
[ 46346.003] (II) LoadModule: "modesetting"
[ 46346.003] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 46346.004] (II) Module modesetting: vendor="X.Org Foundation"
[ 46346.004]     compiled for 1.20.5, module version = 1.20.5
[ 46346.004]     Module class: X.Org Video Driver
[ 46346.004]     ABI class: X.Org Video Driver, version 24.0
[ 46346.004] (II) LoadModule: "fbdev"
[ 46346.004] (WW) Warning, couldn't open module fbdev
[ 46346.004] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 46346.004] (II) LoadModule: "vesa"
[ 46346.004] (WW) Warning, couldn't open module vesa
[ 46346.004] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 46346.004] (II) modesetting: Driver for Modesetting Kernel Drivers: kms

Its loading on kms modeset instead on intel module (module does not exist on your output)

See if fbdev, intel, i915 and i965 are enabled on VIDEO_CARDS with emerge --info. Also, see if they are enabled on xorg-drivers: emerge -pv xorg-drivers.

The log didn't show the freeze, but it can be related to the missing intel module.

Really really really thanks to you!! :><3333 It solved my problem.

I had only "intel" and "i965" flags set for VIDEO_CARDS, but I added "dri3", "i915" and "fbdev", as you suggested, and after I did emerge -auDN @world, I finally could be able to open Vivaldi Browser.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...