Jump to content
funtoo forums
  • 0
Sign in to follow this  
synteejol

Error while syncing

Question

4 answers to this question

Recommended Posts

  • 0

Running  "ego sync" I have no errors.

The output is here.

When I have issues with a specific kit I rename it's folder, then I run "ego sync" and it clones a fresh copy of the kit.

After successful clone I delete the renamed old copy of the kit.

Share this post


Link to post
Share on other sites
  • 0

If you're in a jam and really have to emerge a package in this situation you can run

ego sync --config-only

so profiles and everything is in alignment to allow emerges, but best practice is please wait and allow time for tree to be fixed.

USE AT YOUR OWN RISK

Share this post


Link to post
Share on other sites
  • 0

Thank u for your kind reply. This morning I did "ego sync" again with no error.  the updating of world gave me this error:

 * ERROR: x11-base/xorg-server-1.20.1-r1::xorg-kit failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *               ebuild.sh, line   92:  Called src_configure
 *             environment, line 3602:  Called xorg-2_src_configure
 *             environment, line 4655:  Called autotools-utils_src_configure
 *             environment, line  990:  Called econf '--docdir=/usr/share/doc/xorg-server-1.20.1-r1' '--enable-shared' '--disable-static' '--disable-selective-werror' '--enable-ipv6' '--disable-debug' '--disable-dmx' '--enable-glamor' '--enable-kdrive' '--disable-libunwind' '--enable-xwayland' '--enable-record' '--enable-xfree86-utils' '--enable-dri' '--enable-dri2' '--enable-glx' '--disable-xcsecurity' '--disable-xephyr' '--disable-xnest' '--enable-xorg' '--disable-xvfb' '--enable-config-udev' '--without-doxygen' '--without-xmlto' '--without-systemd-daemon' '--disable-systemd-logind' '--disable-suid-wrapper' '--enable-install-setuid' '--enable-libdrm' '--sysconfdir=/etc/X11' '--localstatedir=/var' '--with-fontrootdir=/usr/share/fonts' '--with-xkb-output=/var/lib/xkb' '--disable-config-hal' '--disable-linux-acpi' '--without-dtrace' '--without-fop' '--with-os-vendor=Gentoo' '--with-sha1=libcrypto'
 *        phase-helpers.sh, line  718:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  121:  Called die
 * The specific snippet of code:
 *              die "$@"
 * 
 * If you need support, post the output of `emerge --info '=x11-base/xorg-server-1.20.1-r1::xorg-kit'`,
 * the complete build log and the output of `emerge -pqv '=x11-base/xorg-server-1.20.1-r1::xorg-kit'`.
 * The complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.20.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.20.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-base/xorg-server-1.20.1-r1/work/xorg-server-1.20.1_build'
 * S: '/var/tmp/portage/x11-base/xorg-server-1.20.1-r1/work/xorg-server-1.20.1'

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...