Jump to content
funtoo forums
  • 0
erikr

[Canceled] Only 1/4 of installed memory with EFI-boot

Question

After many many considerations I went for EFI-boot in faovour of good old BIOS-boot using syslinux. The fall back solution is still BIOS-boot using extlinux.

Problem is that with the very same (carefully verified) initramfs and kernel all my 16GB ram shows up in BIOS boot while only 4GB (well, 3.5) shows up booting from EFI.

Any hint on the reason to this? My world does not depend on EFI-boot, the BOIS boot works very well and will be my primary until this is sorted out, but it would be good to understand.

Some facts;

Motherboard is ASUSTeK SABERTOOTH 990FX R2.0 Rev 1.xx

BIOS is dated Date: 05/04/2016 and version 2901 that seems to be the latest version.

# uname -a                                                                                                                                                                         
Linux kalle 4.13.12-gentoo #6 SMP PREEMPT Thu Dec 14 07:42:52 CET 2017 x86_64 AMD FX(tm)-9590 Eight-Core Processor AuthenticAMD GNU/Linux

I have tried several combinations of legacy modes including no legacy support (CSM disabled).

 

Edited by erikr
Edit header to cancel topic.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Well, thanks for the help in this thread. I started to test combinations of my 4 memory modules and found out that something is wrong and it is possible that there is a problem with the motherboard. I have moved on to greener pastures and are now installing on my brand new I7-8700K setup instead. It is fabulous.

After I managed to boot on debian-sources I also had to rebuild webkit-gtk that would actually freeze the computer after 20 minutes. That is what I used to test the memory modules.

Eventually I will return to that motherboard and try to find the problem, it is intended to be a server taking backups. If I decide to trust it.

 

Regards,

Erik

 

 

 

Share this post


Link to post
Share on other sites
  • 0

I don't think so. I have tried with the exactly same kernel and initrd and lines for both BIOS and EFI  (named it memory-test and copied the files between the two boot partitions) so I guess should have the very same problem when booting in BIOS.

/etc/motd tells me I used stage3-amd64-piledriver-funtoo-current-2017-10-18 as a starting point, I would not be able to do anything if I booted with a 32 bit kernel. Right? I recall I tried that during transition; nothing works and that is how you can tell it went wrong.

 

Share this post


Link to post
Share on other sites
  • 0

I forgot to mention; I am booting the very same linux root and home partitions from BOIS and EFI, using the very same kernel-file and initramfs-file and get different results. 16GB if I boot using BOIS and 4 if I boot using EFI.

 

 

Share this post


Link to post
Share on other sites
  • 0

I am using crucial, forgot the exact module right now. I am not overclocking. I did build the PC my self. I have suspected memory problems at some stage (some 6 month ago) and tested to remove them in pair. I think they are purchased as a set of 4x4 modules.

There is a lot of BIOS settings, any particular of interest, and I have tried quite some combinations.

I have verified the problem in UEFI Only mode as well as combined Legacy/UEFI. UEFI only mode used my DIsplayPort as main output while  legacy enabled uses the DVI-port.

I (think) I have disabled secure boot, it is only used when instaölling kubuntu and is disabled directly when the nvidia drivers is installed so there is little point.

 

I am currently installing debian-sources but that will take quite some hours so I know more later tonight :)

 

// Erik

 

 

Share this post


Link to post
Share on other sites
  • 0

I managed to boot with UEFI and debian-sources. All 16GB of memory are there but keyboard wont work during boot so I cannot enter password for encrypted disks, thus the time delay.

 

Seems like I have some miss-configuration in my kernel config but on the other hand it has been around for some time and are based on the one for my previous hardware that is based on the hardware before that.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×