Jump to content
funtoo forums
  • 0
Sandro

[Solved] VLC doesn't run very well

Question

It's been a while since VLC does not work well: from time to time it "flashes" ... or there are "black" frames in an almost random way.
The compilation is successful, I also tried the different options related to video output. I'm using an nVidia 660 GTX; I think the output of the active and inactive USE can be useful:

>
	sandro@ci74771ht ~ $ emerge -pqv --nodeps vlc 
[ebuild   R   ] media-video/vlc-2.2.4-r1  USE="X a52 aalib alsa avcodec avformat bidi bl
uray cdda cddb dbus dc1394 dts dvb dvbpsi dvd encode faad ffmpeg flac fluidsynth fontcon
fig gcrypt gme gnutls gstreamer ieee1394 jack jpeg kate kde libass libnotify libsamplera
te libtiger lirc live lua matroska modplug mp3 mpeg mtp musepack ncurses ogg opengl opus
png postproc pulseaudio qt4 qt5 rtsp schroedinger sdl sid speex svg swscale taglib theo
ra truetype twolame udev v4l vdpau vnc vorbis vpx x264 x265 xcb xml xv (-altivec) -atmo 
(-audioqueue) -chromaprint -debug -directfb (-directx) (-dxva2) -fdk -gnome -growl -http
d (-libav) -libcaca -libtar -linsys (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-q
tkit) (-macosx-quartztext) (-neon) -omxil -opencv -optimisememory -projectm (-rdp) -run-
as-root -samba -sdl-image -sftp -shout -skins {-test} -tremor -upnp -vaapi -vcdx -vlm -w
ma-fixed -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse" 

Personally I have no idea how to deal with the problem. (I also wonder if the same thing happens to others).
Thanks for any answers.
(with other movie players I have no problem (xine, kaffeine, smplayer, dragon etc)
Thanks for the attention :)

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 1

@Sandro, I would like to redirect you here -

The topic title should be edited from "VLC doesn't run very well" to something more concrete like: Random flashes or black frames in VLC while playing movies in fullscreen

Try to add more information, that you think could be relevant to the problem. Like driver used, kernel version, is it only for certain videos or for all, fullscreen/windowed...

Also try to update to media-kit:1.1-prime by issuing these commands

Quote

ego config set kits media-kit 1.1-prime

ego sync

emerge -av vlc

 

Share this post


Link to post
Share on other sites
  • 0

Ok .... your idea to upgrade to the top version of the kit "media-kit" was decisive ....
I did some tests and for now it seems to me that the behavior is correct !!!!
Thank you so much :)

Allow me to dedicate this piece to you: "https://www.youtube.com/watch?v=iahhYHy7lDo"
I hope you like it :)

Thanks for everything :)

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Oleg Vinichenko said:

notice, that media-kit 1.1-prime branch is the default for couple of days.

Ok Oleg; Anyway i use the xorg-kit 1.19-prime instead 1.17-prime (1.17 gave some litle troubles in my system)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...