Jump to content
funtoo forums
  • 0
tefrem34

[Solved] Two ebuilds that keep failing

Question

Hello to the forum and funtoo devs.

 

I just started using funtoo and am still learning how it all works. But I am having troubles updating my system because of two ebuilds and installing mypaint.

These two keep failing on the build (broken):

dev-libs/appstream
de-perl/LWP-Protocol-https

The LWP-Protocol-https gives a message 404 error, not found. I had pasted the error in the list, but for some reason it didn't stay.

and mypaint has this loop I can not get past:

media-gfx/mypaint
>>> media-gfx/mypaint-1.2.1:0/0::media-kit, ebuild scheduled for merge, wants dev-libs/protobuf[python]
>>> dev-qt/qtwebengine-5.9.2:5/5.9::kde-kit, installed, wants dev-libs/protobuf:0/14=
>>> dev-python/protobuf-python-3.4.1:0/14::python-kit, ebuild scheduled for merge, wants ~dev-libs/protobuf-3.4.1

My candidates are:

>>> dev-libs/protobuf-3.3.0:0/13::dev-kit, ebuild scheduled for merge has SLOT 0/13
>>> dev-libs/protobuf-3.4.1:0/14::dev-kit, installed has SLOT 0/14

So I am still not sure if I need to do, change the versions or what not, so I can finish getting my system built.

Thanks

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1

Hi, tefrem34!

Welcome to the world Funtoo, I hope you like!

I also have problems with dev-libs/appstream-0.11.5, so I blocked it in '/etc/portage/package.mask/appstream-0.11.5' and I'm using dev-libs/appstream-0.10.6-r1.

I found the source code of dev-perl/LWP-Protocol-https-6.60.0 here: https://ftp.mirrorservice.org/sites/download.salixos.org/x86_64/extra-14.2/source/perl/perl-LWP-Protocol-https/LWP-Protocol-https-6.06.tar.gz , just download and move to '/var/cache/portage/distfiles/'.

About the error in installing media-gfx/mypaint, I believe it is a bug.

I think you should create a bug in https://bugs.funtoo.org/ about the error in dev-libs/appstream-0.11.5 and to install the program media-gfx/mypaint, are nice people working there and they will like to help you.

I hope I've helped!

Share this post


Link to post
Share on other sites
  • 0

@cafaia

Thanks for the response.

I forgot about being able to mask the version and thank you for the link to the source  and the dir to where to put it. I am going to give this a go.

I can't seem to log into the bugs.funtoo it says to use my log in for the funtoo forums but it tells me the usr/paswd is wrong.

Masking the broken version worked a treat.

Okay, so I downloaded the LWP-Protocol-https- tar.gz and put it in the dir you said to. I did and "emerge -avuND @world" but it is still using the broken one. How do I get it to install from the "/var/cashe/portage/distfiles/"?

Share this post


Link to post
Share on other sites
  • 0

Hi, tefrem34!

You tried to create another user for bugs.funtoo.org? Maybe this will solve the problem.

I thought you were having trouble downloading the source code (404 error, not found), so I said to download from another location and move to '/var/cache/portage/distfiles/'. If the error is in the compilation you will have to register a bug (I have installed the version dev-perl/LWP-Protocol-https-6.60.0, and you?).

I hope I've helped!

Share this post


Link to post
Share on other sites
  • 0
Quote

I thought you were having trouble downloading the source code (404 error, not found)

Yes, that is what it said.

>>> Downloading 'https://dev.gentoo.org/~tove/distfiles/dev-perl/LWP-Protocol-https/LWP-Protocol-https_ca-cert-r1.patch.gz'
--2017-11-14 15:26:41--  https://dev.gentoo.org/~tove/distfiles/dev-perl/LWP-Protocol-https/LWP-Protocol-https_ca-cert-r1.patch.gz
Resolving dev.gentoo.org... 2001:470:ea4a:1:5054:ff:fec7:86e4, 140.211.166.183
Connecting to dev.gentoo.org|2001:470:ea4a:1:5054:ff:fec7:86e4|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-11-14 15:26:41 ERROR 404: Not Found.

!!! Couldn't download 'LWP-Protocol-https_ca-cert-r1.patch.gz'. Aborting.
 * Fetch failed for 'dev-perl/LWP-Protocol-https-6.60.0', Log file:
 *  '/var/tmp/portage/dev-perl/LWP-Protocol-https-6.60.0/temp/build.log'

So, something is going on with it.

It is strange that it will not install for me and it worked for you. It looks like it is the same version "dev-perl/LWP-Protocol-https-6.60.0::perl-kit".

I am going to try to log into the funtoo bug and report these two issues.

I appreciate your help. :)

Share this post


Link to post
Share on other sites
  • 0

Hi, tefrem34!

Sorry, I had not seen that had it too 'LWP-Protocol-https_ca-cert-r1.patch.gz'. You can download from here http://portages.ifcem.if.ua/distfiles/LWP-Protocol-https_ca-cert-r1.patch.gz and move to '/var/cache/portage/distfiles', then you will be able to install LWP-Protocol-https-6.60.0.

I hope I've helped!

P.S.: I am attaching the missing file LWP-Protocol-https_ca-cert-r1.patch.gz.

LWP-Protocol-https_ca-cert-r1.patch.gz

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, tefrem34 said:

Thank you so much!! :)

That was the ticket.

You are a life saver, well at least sanity :).

Hi, tefrem34!

I'm happy to help, we are here to help each other!

Big hug!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×