Jump to content
funtoo forums

cafaia

Members
  • Content Count

    83
  • Joined

  • Last visited

  • Days Won

    7

Everything posted by cafaia

  1. Hi, Walterw! I removed the 'ro' option but the error is still there. I'm sending my initramfs, I hope you can help me. Best regards. Here is the link to the initramfs file: https://mega.nz/#!ZYNVGKBQ!hryGEXRWUmIkiTcyNOyP4VwuAxerNMNTY61LgQopl4w
  2. Hi, Walterw! I did not modify my initramfs, I created it with the genkernel command. And I have this in my grub.cfg file: linux /vmlinuz-4.15.17-1 root=/dev/mapper/swsyho-system ro domdadm dolvm rootfstype=ext4 scandelay resume=/dev/mapper/swsyho-swap initrd /initramfs-genkernel-x86_64-4.15.17-1 Best regards!
  3. Hi, Walterw! Thank you for your attention and tip! I made three changes, with scandelay, no scandelay and with this spelling 'scandelay=3', but the 'sh: bad number' continues... Best regards!
  4. Hi, Palica! Thank you for your attention and for the tip! I have this message about three lines before starting openrc, in the boot process before openrc starts. My fstab: /dev/md1 /boot ext2 defaults,noatime 1 2 /dev/mapper/swsyho-swap none swap sw 0 0 /dev/mapper/swsyho-system / ext4 noatime 0 1 /dev/mapper/swsyho-home /home ext4 defaults,noatime 0 2 tmpfs /var/tmp/portage tmpfs uid=portage,gid=portage,mode=775,size=16384M,noatime 0 0 /dev/sdc1 /hd ext4 defaults,noatime 0 2 I start the kernel with the following command line (from dmesg): Command line: BOOT_IMAGE=/vmlinuz-4.15.17-1 root=/dev/mapper/swsyho-system ro domdadm dolvm rootfstype=ext4 scandelay resume=/dev/mapper/swsyho-swap I start the kernel with the grub2 program and I have debian-sources but wihtout USE 'binary'.
  5. Hello, everyone! In all installations made of Funtoo, I have this message: Using mount -t ext4 -o ro sh: bad number This message always appears before starting the openrc program. I believe it is harmless, but someone would know how to fix it? I thank you in advance for your help!
  6. Hi, Mauricev! I'm glad to hear that you found the mistake. Best regards!
  7. Hi, Mauricev! After you create the local repository, did you do that: # ebuild /var/git/overlay/local-overlay/cat/pkg/autossh-version.ebuild digest I hope this is what is missing. Best regards!
  8. Hi, Donjames! I believe that is what you are looking for: I hope I've helped! Best regards!
  9. Hi, Biocyberman! Did you add this repository with layman? If so, you can use eix, look: https://www.funtoo.org/Package:Eix If not, you can use the file '/etc/portage/repos.conf/myoverlay.conf', look: https://www.funtoo.org/Local_Overlay , you should look at the variable 'auto-sync'. Hope this helps! Best regards!
  10. Hi, Safulkin! There is already an open bug about it ( https://bugs.funtoo.org/browse/FL-5127 ), if you want you can start seeing this bug. Best regards!
  11. Hi, Belenar! Ops, the thing is complicated then, because you do not have the current version of ego and the gitmodules file has been removed, look: https://github.com/funtoo/meta-repo/commit/85a413af847d9b0fd9e73b7f7a601a4101dd7e05#diff-8903239df476d7401cf9e76af0252622 Then you should do this to have a functional repository: # install -d /var/git # cd /var/git # git clone https://github.com/funtoo/meta-repo.git # cd meta-repo # wget https://raw.githubusercontent.com/funtoo/meta-repo/aadee00606e39b63cb0f21b48a7780dc5bc33b08/.gitmodules # git submodule init # cd kits # git clone https://github.com/funtoo/python-modules-kit.git # cd /var/git/meta-repo # git submodule update # rm /usr/share/portage/config/repos.conf # mv /etc/portage/repos.conf /etc/portage/repos.conf.bak # mkdir /etc/portage/repos.conf # ln -s /var/git/meta-repo/repos.conf /etc/portage/repos.conf/funtoo # chown -R portage:portage /var/git/meta-repo # my_pyver="$(eselect python show --python3)" # USE="python_targets_${my_pyver/./_} python_single_target_${my_pyver/./_}" emerge -1 --nodeps ego # hash -r # epro update # emerge -1 portage # ego sync I hope this works!
  12. Hi, Belenar! I believe the page https://github.com/funtoo/meta-repo information is outdated, I advise you to use the instructions here: Downloading the Portage tree Now it's time to install a copy of the Portage repository, which contains package scripts (ebuilds) that tell portage how to build and install thousands of different software packages. To create the Portage repository, simply run ego sync from within the chroot. This will automatically clone the portage tree from GitHub and all kit submodules: (chroot) # ego sync from https://www.funtoo.org/Install#Downloading_the_Portage_tree I hope this helps! Best regards!
  13. Hi, Delyas! Unfortunately I can not help with these two problems in specific, but the language problem I registered two bugs ( https://bugs.funtoo.org/browse/FL-5084 https://bugs.funtoo.org/browse/FL-5037 ), if you can help me by talking about your problem, I thank you. With best regards!
  14. Hi, dear Silvio! Well, now who does not know, it's me. Unfortunately I give up... I suggest you do a new installation of Funtoo, in the face of all this seems to be the most correct thing to do. Big hug, Eduardo
  15. Hi, Silvio! Yes, the "emerge grub" command should be with chroot and if you get error while running the "boot-update" command you should do this "emerge boot-update" and follow these steps: https://www.funtoo.org/Package:Boot-Update Big hug, Eduardo
  16. Hi, Silvio! The first command is the correct command, the error is because you have not installed in Funtoo the Grub program. Then you will have to do these steps: # mkdir /mnt/funtoo # mount /dev/sdb3 /mnt/funtoo # mount /dev/sda2 /mnt/funtoo/boot/efi # cd /mnt/funtoo # mount -t proc none proc # mount --rbind /sys sys # mount --rbind /dev dev # cp /etc/resolv.conf /mnt/funtoo/etc/ # env -i HOME=/root TERM=$TERM /bin/chroot . bash -l # export PS1="(chroot) $PS1" (chroot) # ego sync (chroot) # emerge debian-sources (chroot) # emerge grub (chroot) # emerge @module-rebuild (chroot) # grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id="Funtoo Linux [GRUB]" --recheck /dev/sdc (chroot) # boot-update (chroot) # exit # cd /mnt # umount -lR funtoo # reboot I put it more: "emerge grub". I believe that if you follow this you will have a bootable system. Big hug, Eduardo
  17. Hi, Silvio! Yes, we'll have to make Funtoo bootable again and for that we will use a pendrive. After you boot with SystemRescueCD you should connect the pendrive (/dev/sdc) and follow these steps, assuming you only have two disks (/dev/sda and /dev/sdb) on your PC: # mkdir /mnt/funtoo # mount /dev/sdb3 /mnt/funtoo # mount /dev/sda2 /mnt/funtoo/boot/efi # cd /mnt/funtoo # mount -t proc none proc # mount --rbind /sys sys # mount --rbind /dev dev # cp /etc/resolv.conf /mnt/funtoo/etc/ # env -i HOME=/root TERM=$TERM /bin/chroot . bash -l # export PS1="(chroot) $PS1" (chroot) # ego sync (chroot) # emerge debian-sources (chroot) # emerge @module-rebuild (chroot) # grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id="Funtoo Linux [GRUB]" --recheck /dev/sdc (chroot) # boot-update (chroot) # exit # cd /mnt # umount -lR funtoo # reboot After these steps you should start the PC by the pendrive that should not be disconnected. Try this and tell me the result, please. I'm happy to help and I would love to make everything work again! Big hug, Eduardo
  18. Hi, Silvio! I believe you did not see my message because she is on page two of the forum. Did you find her now? In my opinion it would be very important to reinstall grub, for this I'll explain the output lsblk. This is the output of the lsblk command here without the attached pendrive: NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 465,8G 0 disk ├─sda1 8:1 0 2M 0 part ├─sda2 8:2 0 2G 0 part │ └─md1 9:1 0 2G 0 raid1 /boot └─sda3 8:3 0 463G 0 part └─md2 9:2 0 925,8G 0 raid0 ├─swsyho-swap 253:0 0 32G 0 lvm [SWAP] ├─swsyho-system 253:1 0 250G 0 lvm / └─swsyho-home 253:2 0 643,8G 0 lvm /home sdb 8:16 0 465,8G 0 disk ├─sdb1 8:17 0 2M 0 part ├─sdb2 8:18 0 2G 0 part │ └─md1 9:1 0 2G 0 raid1 /boot └─sdb3 8:19 0 463G 0 part └─md2 9:2 0 925,8G 0 raid0 ├─swsyho-swap 253:0 0 32G 0 lvm [SWAP] ├─swsyho-system 253:1 0 250G 0 lvm / └─swsyho-home 253:2 0 643,8G 0 lvm /home sdc 8:32 0 2,7T 0 disk └─sdc1 8:33 0 2,7T 0 part /hd sr0 11:0 1 1024M 0 rom sr1 11:1 1 1024M 0 rom And this is the output with the pendrive connected: NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 465,8G 0 disk ├─sda1 8:1 0 2M 0 part ├─sda2 8:2 0 2G 0 part │ └─md1 9:1 0 2G 0 raid1 /boot └─sda3 8:3 0 463G 0 part └─md2 9:2 0 925,8G 0 raid0 ├─swsyho-swap 253:0 0 32G 0 lvm [SWAP] ├─swsyho-system 253:1 0 250G 0 lvm / └─swsyho-home 253:2 0 643,8G 0 lvm /home sdb 8:16 0 465,8G 0 disk ├─sdb1 8:17 0 2M 0 part ├─sdb2 8:18 0 2G 0 part │ └─md1 9:1 0 2G 0 raid1 /boot └─sdb3 8:19 0 463G 0 part └─md2 9:2 0 925,8G 0 raid0 ├─swsyho-swap 253:0 0 32G 0 lvm [SWAP] ├─swsyho-system 253:1 0 250G 0 lvm / └─swsyho-home 253:2 0 643,8G 0 lvm /home sdc 8:32 0 2,7T 0 disk └─sdc1 8:33 0 2,7T 0 part /hd sdh 8:112 1 14,9G 0 disk └─sdh1 8:113 1 14,9G 0 part sr0 11:0 1 1024M 0 rom sr1 11:1 1 1024M 0 rom So the pendrive is what is different between one and another, in this case the device /dev/sdh. So in my case I would have to do "grub-install (parameters for the UEFI system) /dev/sdh", can you do this? Then you should choose the boot by the pendrive in bios... I'm rooting for you and I hope we can get it working again! Big hug, Eduardo
  19. Hi, Silvio! I thought that SystemRescueCD had the driver nvidia, then we'll have to do something else, let's make Funtoo bootable again. For this you should do a chroot and reinstall the kernel and the necessary drivers with the commands: # emerge debian-sources # emerge @module-rebuild I do not use the UEFI system, but you should follow the steps in the Grub Funtoo installation manual, but this time we will install Grub on a USB drive, so you should connect one and see what device it is with the 'lsblk' command, and at the time of installing Grub you should replace the value of /dev/sda with the pendrive. You should then leave the pendrive connected to the PC and reboot, and choose this device (pen drive) as bootable. So you do not lose the installation of grub that accesses your other operating systems. Let's see if that works, because chroot is more for working only in text mode. Big hug, Eduardo
  20. Hi, Silvio! Funtoo manuals are very well written and are slightly different from Gentoo, you did right to follow the Funtoo manual. We'll try to solve this mouse problem first. I believe it would be good for you to create an xorg.conf file with these commands: # Xorg -configure :5 # mv /root/xorg.conf.new /etc/X11/xorg.conf # nvidia-xconfig To test this setting file: # X -config /etc/X11/xorg.conf Try this and tell me how it went. Big hug, Eduardo
  21. Hi, Silvio! Wow, the photo is very beautiful, it's a city I want to meet! This, if you encounter any problems when following the manual, here insert the error that I will be happy to help. One more question: do you have the services "dbus" and "consolekit" running? Maybe it is that... Anything is just calling, because the Funtoo community is here to help and welcome to the Funtoo community! Big hug, Eduardo
  22. Hi, Bourbon! Now who does not know what to do is me, because the settings seem to be correct... I hope you find help in the manuals I sent you because I no longer have any idea what can be. You should try to follow the manual and if something goes wrong contact. I'm sorry but at the moment I do not know what to do. Big hug, Eduardo
  23. Hi, Bourbon! I'm sorry you're in trouble. Your problems seem to be for lack of this command: # emerge -av --update --deep --newuse --changed-use --with-bdeps=y @world Because in funtoo the programs most of the time are dependencies of correct FLAGS/USES in master programs. For example: you should not install xf86-input-evdev with the command emerge, because this program must be installed with the parameter INPUT_DEVICES="evdev" in master program xorg-drivers. Could you send me the output of the command "emerge --info"? I advise you to read this, for me it helped: https://wiki.gentoo.org/wiki/Xorg https://wiki.gentoo.org/wiki/KDE I hope this helps you. Big hug, Eduardo
  24. Hi, Bourbon! Well, to install again the kernel does not have much difficulty, is a process similar to the first steps of the installation. I advise you to use the Live CD SystemRescueCD and do this: # mkdir /mnt/funtoo # mount /dev/sda3 /mnt/funtoo # mkdir /mnt/funtoo/boot # mount /dev/sda1 /mnt/funtoo/boot # cd /mnt/funtoo # mount -t proc none proc # mount --rbind /sys sys # mount --rbind /dev dev # cp /etc/resolv.conf /mnt/funtoo/etc/ # env -i HOME=/root TERM=$TERM /bin/chroot . bash -l # export PS1="(chroot) $PS1" (chroot) # ego sync (chroot) # emerge debian-sources (chroot) # exit # cd /mnt # umount -lR funtoo # reboot I do not have UEFI so I do not know for sure how you should proceed, but the above commands I believe arrive. I read that the new debian kernel will have what is missing for you (CONFIG_SND_HDA_PREALLOC_SIZE=2048). I also love Brazil and my Italian blood. I'm glad you've visited my country. I have not yet visited Rio de Janeiro and neither Salvador, but I have great interest to visit these two cities. The Italian corals of Rio Grande do Sul are famous, because Rio Grande do Sul is the Brazilian state with the largest number of Italian immigrants. Big hug, Eduardo Coutinho Scalabrin P. S.: Excuses, but I do not have Facebook, but if I create one I'll look for you, okay?
  25. Hi, bourbon! I'm glad I'm helping you and it's a pleasure to help you! But after you have put on /etc/portage/make.conf this: L10N="en-US it" LINGUAS="en_US it" did you run the command below as root? emerge -av --update --deep --newuse --changed-use --with-bdeps=y @world About your network, you should follow these commands: # cd /etc/init.d # ln -s netif.tmpl net.eth0 # rc-update add net.eth0 default # echo template=dhcpcd > /etc/conf.d/net.eth0 # echo 'rc_need="net.eth0"' >> /etc/conf.d/ntp-client # rc-update add ntpd default And you should disable the dhcpcd boot service, thus: # rc-update del dhcpcd default You edited the wrong files, the correct one is edit '/etc/conf.d/ntp-client' and not '/etc/init.d/ntp-client'. To cancel the old user, you must give this command: # userdel -f -r LOGIN It is not correct to edit the file '/etc/init.d/udev' because the error saying to user run script is harmless. I am from Brazil of the state of Rio Grande do Sul of the city of Frederico Westphalen. My great grandfather was Italian, he was from the Vicenza state of the city of Schio, my last name is Scalabrin. Big hug!
×
×
  • Create New...