Jump to content
funtoo forums
  • 0
bug

Killer NIC e2200 not getting DHCP

Question

After doing a sucessful

emerge -auvDN @world

for the first time since the switch to ego (which involved a LOT of pain and masking/unmasking/oneshots due to version differences), my NIC is not working.  Due to the very large number of packages updated, I have no idea which one could have caused the malfunction.I'm having to tether my desktop to my phone through USB.

I have tried every possible relevant genkernel config, and I even tried patching the atl1c driver by hand to support my card (details below)

03:00.0 Ethernet controller: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller (rev 13)
        Subsystem: Micro-Star International Co., Ltd. [MSI] Killer E220x Gigabit Ethernet Controller
        Flags: bus master, fast devsel, latency 0, IRQ 46
        Memory at fe800000 (64-bit, non-prefetchable) [size=256K]
        I/O ports at d000 [size=128]
        Capabilities: [40] Power Management version 3
        Capabilities: [58] Express Endpoint, MSI 00
        Capabilities: [c0] MSI: Enable+ Count=1/16 Maskable+ 64bit+
        Capabilities: [d8] MSI-X: Enable- Count=16 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [180] Device Serial Number ff-85-2b-be-44-8a-5b-ff
        Kernel driver in use: alx
        Kernel modules: alx

As you can see, the alx network driver recognizes the card, but it provides no connection.  NetworkManager shows eth0 going through a loop of trying to connect, failing to get an IP address from DHCP, and pausing for a minute.

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

I have tested three different kernels from recent history, making sure the alx driver module is enabled, in an attempt to determine whether it was a kernel/driver issue, and I think I can rule that out.  eth0 fails to connect on all three.

sys-kernel/debian-sources-4.8.15

sys-kernel/gentoo-sources-4.13.9

sys-kernel/gentoo-sources-4.4.94

However, I did notice that the alx driver was disabled by default on 4.13.9, which probably means it is viewed as unstable.  I suppose that should not be surprising.  The Killer NIC series is not very well supported by anybody, not even the OEM anymore.  I'm just about ready to give up on this NIC and find a board with a more "standard" one...

 

Share this post


Link to post
Share on other sites
  • 0

Yes, as mentioned, I tested both debian-sources and gentoo-sources.

I used genkernel, making sure CONFIG_ALX is enabled (alx is the only known driver that supports my card).

LAN does not work in any case.  The module loads, and detects my card, but does not complete DHCP with my router.

The router works with other devices.  All of this was working until last week.

Share this post


Link to post
Share on other sites
  • 0

NetworkManager, but it fails with dhcpcd and dhclient too.  Here's dhcpcd output:

DUID 00:01:00:01:21:7a:8f:c1:44:8a:5b:85:2b:be
eth0: IAID 5b:85:2b:be
eth0: adding address fe80::77fd:da5a:d9ab:e830
ipv6_addaddr1: Permission denied
eth0: soliciting an IPv6 router
eth0: soliciting a DHCP lease
eth0: probing for an IPv4LL address
eth0: carrier lost
eth0: carrier acquired
eth0: IAID 5b:85:2b:be
eth0: soliciting a DHCP lease
eth0: soliciting an IPv6 router
eth0: probing for an IPv4LL address
eth0: carrier lost
eth0: carrier acquired
eth0: IAID 5b:85:2b:be
eth0: soliciting an IPv6 router
eth0: soliciting a DHCP lease
eth0: probing for an IPv4LL address
eth0: carrier lost
eth0: carrier acquired
eth0: IAID 5b:85:2b:be
eth0: soliciting a DHCP lease
eth0: soliciting an IPv6 router
timed out
dhcpcd exited

 

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, dhudson said:

curious  try 'lsmod | grep alx'

I think module mdio should also load with alx

 

formicarium bug # lsmod | grep alx
alx                    40960  0
mdio                   16384  1 alx

you are correct.

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, dhudson said:

how about 'ifconfig -a'?

possible clue is


ipv6_addaddr1: Permission denied

 is your router giving ipv6 or ipv4?

It should be giving both, but so far, I am receiving neither.

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 44:8a:5b:85:2b:be  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 37

 Other devices on the same LAN are receiving both IPv4 and IPv6 addresses.

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, dhudson said:

ok probably configuration problem


contents of '/etc/conf.d/net.eth0' ?

or mabe is /etc/conf.d/netif.eth0

no such file.  nothing has been changed from the defaults since install.

Share this post


Link to post
Share on other sites
  • 0

if your using network-manager there should be no configuration from my understanding the docs.

or for dhcpcd you do

# cd /etc/init.d
# ln -s netif.tmpl net.eth0
# rc-update add net.eth0 default
# echo template=dhcpcd > /etc/conf.d/net.eth0
# rc

Share this post


Link to post
Share on other sites
  • 0

just to add I myself do a static ip its a desktop but dhcpcd is also default runlevel as is netif.eth0

~$ cat /etc/conf.d/netif.eth0
template="interface"
ipaddr="192.168.0.101/24"
gateway="192.168.0.1"
nameservers="192.168.0.1"
domain=""


but if your on a notebook the dhcpcd above should do.

Edited by dhudson
typo

Share this post


Link to post
Share on other sites
  • 0

Setting a static IP (192.168.1.123 in this case, because the subnet is 192.168.1.1/24) results in nothing.  eth0 reports as connected but receives no traffic.

Out of curiosity, I also looked into what "ipv6_addaddr1: Permission denied" might mean, and it seems that it has to do with NetworkManager disabling ipv6 temporarily while it tries to set up the connection.  However, enabling it doesn't let dhcpcd get any further, it just removes the "ipv6_addaddr1: Permission denied" error, and fails in the exact same way (timeout).

Thank you all for running me through the basic diagnostics, but I think I am probably going to opt for replacing the hardware.  I was planning on upgrading the motherboard and CPU regardless.

Share this post


Link to post
Share on other sites
  • 0

No internet due to killer e2200 after windows 10 update. So now you need to download Killer E2200 Gigabit Ethernet Controller driver to away from any kind of interruption while using internet. There are multiple sources available on internet which offer download facility. But make sure this driver should be scan or virus free.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×