Jump to content

Photo

GPT encrypted boot problem

grub efi failed boot flashing capslock gpt

3 replies to this topic

#1
infectiousoma

infectiousoma

    Newbie

  • Members
  • Pip
  • 2 posts

I am attempting to install Funtoo to my HP 17-e016dx. http://h10025.www1.h...product=6521424

My system loads Grub 2 and then when I select my funtoo OS it goes on to a black screen with my caps lock blinking. My logical conclusion is that my grub isn't proceding to decrypt my cryptcontainer.

In my grub I press e to edit and it loads this up.

setparams 'Funtoo Linux -bzImage-3.1.fapp'

  insmod part_gpt

  insmod ext2

  set root=(hostdisk//dev/sda,gpt1)

  search --no-floppy --fs-uuid --set 7ccfb22-7ccfb622-7846-4387-8168-12ffd784a2e5

  linux /bzImage-3.1.fapp video=vesafb rootfstype=ext4 root=/dev/mapper/vg-root

  set gfxpayload=1600x900

 

After installing using this guide, http://www.funtoo.or...partition_table

I set it up with this partition table

1       200Mb    0700

2       512Kb    EF02

3       695Gb    0700

Then after 32 hours of encrypting my drive and securing it with my pass I created my logic valumes. And then my filesystem.

Then I mounted the filesystem as directed. I used the AMD64 piledriver package for my OS.

After chrooting the system I set a few values like the MAKEOPTS-"j5"

Of course it took me a few days to configure my kernel.

I modified my boot.conf as directed.

This is where I guess it went wrong, but i don't truely know. But the system doesn't seem to want to decrpyt.

The grub file doesn't mention the slashbeast, busybox, crytpsetup, or lvm. IDK if it is supposed to though.

From there I simply continued to follow the tutorial. Any help would be greatly appreciated. Thank you.

 



#2
infectiousoma

infectiousoma

    Newbie

  • Members
  • Pip
  • 2 posts

Oh yeah, I have tried remounting everything from my live usb, but none of my filesystem seems to be present. Only the empty system on the live usb.



#3
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 345 posts

looks like you do not use initramfs with encryption support. This is required for decrypting the dirves


  • csmk likes this
www.funtoo.org

#4
csmk

csmk

    Newbie

  • Members
  • Pip
  • 3 posts

I don't know if you already figured out, but I'll leave here my boot.conf

boot {
    generate grub
    default "Funtoo Linux Hardened"
    timeout 3
}
 
"Funtoo Linux Hardened" {
    params root=/dev/mapper/root
    params += crypt_root=/dev/vda3
    params += rootfstype=ext4
    params += ro
    params += quiet
    kernel /vmlinuz-3.17.7-hardened-r1
    initrd /initramfs-genkernel-x86_64-3.17.7-hardened-r1
}

After I compile the kernel (and make "modules_install"/"install"), I run "genkernel --luks --install initramfs" to build the initramfs.

 


  • Otakku likes this



Reply to this topic



  



Also tagged with one or more of these keywords: grub, efi, failed boot, flashing, capslock, gpt

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users