Jump to content

Photo

HELP!! How to correctly install the Mate environment??

installation first steps desktop graphic environment portage ebuild package sets

Best Answer 666threesixes666 , 14 November 2014 - 05:31 AM

you need to emerge -1 networkmanager nm-applet

 

much past that i suggest you give gnome 3.14 a whirl, its classic modes very gnome 2y.

 

personally i abandoned ship to xfce4 which has been a strong running light weight desktop for me for YEARS...  i was running xfce before i figured out gnome2 was a viable solution.

 

gnome 2 / mate / gnome 3 / cinnamon use pulse audio...  i run pulse audio on my xfce4 setup.

Go to the full post »


6 replies to this topic

#1
--->yoalli<---

--->yoalli<---

    Member

  • Members
  • PipPip
  • 15 posts

Hello everybody! after six years using Linux distributions like fedora and sabayon , finally i decided to move to a really serious distro. I was researching on what kind of meta-distro must be installed on my computer and i really really liked the funtoo way for linux since the first time i meet the welcome page in funtoo.org, ,,, anyway, i was wondering on how to install the Mate environment over my new stage 3 tarball and brand new compiled kernel already installed on my hard drive. First i take a look to http://www.funtoo.org/MATE_Desktop, but when i needed to do the following step:

cp /usr/portage/sets/mate /etc/portage/sets

suddenly the things went very dark... the '/usr/portage/sets/mate' doesn't exist on my installation, i decided to install Mate following the little guide provided by the gentoo wiki (http://wiki.gentoo.org/wiki/MATE), after that, finally i can run the mate desktop by 'startx' , but to be honest, the desktop really sucks balls, it lack a lot of things that usally i need: doesn't mount any kind of media, doesn't have network manager, there are no sound, even i don't know how to set up the time. So, how to correctly install the Mate environment?? or how to complete the installation of the very minimal 'mate-base/mate' desktop. I really appreciate any information or any help . Thanks!
 


  • cuchumino likes this

#2
666threesixes666

666threesixes666

    Advanced Member

  • Members
  • PipPipPip
  • 129 posts
✓  Best Answer

you need to emerge -1 networkmanager nm-applet

 

much past that i suggest you give gnome 3.14 a whirl, its classic modes very gnome 2y.

 

personally i abandoned ship to xfce4 which has been a strong running light weight desktop for me for YEARS...  i was running xfce before i figured out gnome2 was a viable solution.

 

gnome 2 / mate / gnome 3 / cinnamon use pulse audio...  i run pulse audio on my xfce4 setup.


  • --->yoalli<--- likes this

Duke: No more of that talk or I'll put the f*cking leeches on you, understand?

 

Paul: [about Percy] The man is mean and careless and stupid, and that's a bad combination in a place like this.


#3
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 345 posts

i'll correct Mate Guide, set is no longer needed. Installing mate is quite simple:

 

#  eselect profile add funtoo/1.0/linux-gnu/mix-ins/mate

# emerge mate 


  • --->yoalli<--- likes this
www.funtoo.org

#4
--->yoalli<---

--->yoalli<---

    Member

  • Members
  • PipPip
  • 15 posts

you need to emerge -1 networkmanager nm-applet

 

much past that i suggest you give gnome 3.14 a whirl, its classic modes very gnome 2y.

 

personally i abandoned ship to xfce4 which has been a strong running light weight desktop for me for YEARS...  i was running xfce before i figured out gnome2 was a viable solution.

 

gnome 2 / mate / gnome 3 / cinnamon use pulse audio...  i run pulse audio on my xfce4 setup.

 

thanks!! the reason i don't want to install gnome is because of the package 'net-libs/webkit-gtk' , it takes too long on the compile phase. I already installed pulseaudio (media-sound/pulseaudio) but when i try to launch it , it give me this message:


E: [pulseaudio] core-util.c: Failed to connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: no such file or directory
E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
E: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="0" name="pci-0000_00_05.0" card_name="alsa_card.pci-0000_00_05.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
E: [pulseaudio] module-console-kit.c: Unable to contact D-Bus system bus: org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /var/run/dbus/system_bus_socket: no such file or directory
E: [pulseaudio] module.c: Failed to load module "module-console-kit" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

maybe i need to update world...



#5
--->yoalli<---

--->yoalli<---

    Member

  • Members
  • PipPip
  • 15 posts

i'll correct Mate Guide, set is no longer needed. Installing mate is quite simple:

 

#  eselect profile add funtoo/1.0/linux-gnu/mix-ins/mate

# emerge mate 

 

first of all: thanks very much for the reply. It works, but only installs 'mate-base/mate' , my desktop is still incomplete (no network, no sound), no extras at all, any suggestion to install the complete overlay??



#6
666threesixes666

666threesixes666

    Advanced Member

  • Members
  • PipPipPip
  • 129 posts

do 1 thing at a time.  yeah webkit-gtk makes me want to punch babies....  takes my quad core an hour to compile....

 

the emerge networkmanager didnt work?


Duke: No more of that talk or I'll put the f*cking leeches on you, understand?

 

Paul: [about Percy] The man is mean and careless and stupid, and that's a bad combination in a place like this.


#7
--->yoalli<---

--->yoalli<---

    Member

  • Members
  • PipPip
  • 15 posts

do 1 thing at a time.  yeah webkit-gtk makes me want to punch babies....  takes my quad core an hour to compile....

 

the emerge networkmanager didnt work?

 

after updating world the things are working better, installing pulse-audio and updating world solved a lot of issues. I already moved to gnome, sound is working in both environments (mate and gnome) the network is working, but i don't see any network icon or applet in gnome... thats is a minor problem i guess. by the way, thankyou so much, your reply helped a lot! (installing webkit-gtk made to murder a little girl...)





Reply to this topic



  



Also tagged with one or more of these keywords: installation, first steps, desktop, graphic environment, portage, ebuild, package sets

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users