Jump to content
funtoo forums
  • 0
angus71

Installation, lost at "chroot"

Question

Hi there!

I'm new to funtoo - to linux too to be honest... :-)

I tried an installation according to the section "install" at the website.

Everything worked until i came to the headline "chroot into Funtoo"; actualy in this part it's NOT

mentioned how to chroot in the new system EXACTLY.

I tried several approachses like "chroot /dev/sdc" because there would be my root directory, according

to the previous steps.. But it doesn't work a bit. I searched the net but found nothing that helped me.

Any suggestions?

Thanks for your help

angus71

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hi cardinal!

Thank you again for your suggestion! It worked flawlessly!

Now the system is set up and rebooted. Next step will be - when i will be able to

spare time again - to install and setup xorg. Maybe you will find there a new post from me.... :P

Greetings

Share this post


Link to post
Share on other sites
  • 0

Following the install instructions to the letter.

Your target install partition /dev/sdc should be mounted to the working directory which is /mnt/funtoo

The period . after chroot is a shortcut for the working directory.

# env -i HOME=/root TERM=$TERM chroot . bash -l
Find your working directory with print working directory command:

pwd
If pwd outputs /mnt/funtoo then:

# env -i HOME=/root TERM=$TERM chroot . bash -l
is the same as

# env -i HOME=/root TERM=$TERM chroot /mnt/funtoo bash -l

Share this post


Link to post
Share on other sites
  • 0

I tried  install Funtoo according tutorial from official website  http://www.funtoo.org/Install

and this tutorial : 

and everything went very well , ... until chrooting 

i got answer : ... can not run ... bin bash, .. any error  ... ( ? )

and even appear change (before #) on (chroot) but later i couldn't do nothing

I also tried  apply above advanced commands ( # env ...  ... bash -1 )

and without succes too :-( 

I can join screens

Share this post


Link to post
Share on other sites
  • 0

What I did for my chroot is more in line with the Gentoo style.

mount -t proc /proc /mnt/funtoo/proc

mount --rbind /dev /mnt/funtoo/dev

mount --make-rslave /mnt/funtoo/dev

mount --rbind /sys /mnt/funtoo/sys

mount --make-rslave /mnt/funtoo/sys

chroot /mnt/funtoo /bin/bash

This works fine for me; doing it in accordance with the docs didn't maintain my network connection for some reason. Maybe this is a bad way to chroot, but I hope this helps someone.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...