Jump to content
  • 0
fanfoue

mate 1.12/gtk3

Question

Hello,

 

Yesterday update attempt leads to a series of messages about mate-base/mate-panel-1.12.2-r3 wanting gtk3 then rejecting it, then wanting it, then rejecting it... :

 

# emerge -auDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by mate-base/mate-1.12-r1::gentoo
# required by @selected
# required by @world (argument)
>=mate-base/mate-panel-1.12.2-r3 gtk3

 

so I modify /etc/portage/package.use accordingly, but :

 

# emerge -auDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by mate-extra/mate-power-manager-1.12.1-r2::gentoo
# required by mate-base/mate-1.12-r1::gentoo[extras]
# required by @selected
# required by @world (argument)
>=mate-base/mate-panel-1.12.2-r3 -gtk3

 

And so on...

I'm new to funtoo, please help me getting out of this mess.

Thanks !

 

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Thanks for the answer.

 

I guess yes :

 

$ epro show

=== Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: core2_64
      flavor: desktop
     mix-ins: no-systemd
     mix-ins: X
     mix-ins: audio
     mix-ins: mate


=== All inherited flavors from desktop flavor: ===

                     workstation (from desktop flavor)
                            core (from workstation flavor)
                         minimal (from core flavor)

=== All inherited mix-ins from desktop flavor: ===

                               X (from workstation flavor)
                           audio (from workstation flavor)
                             dvd (from workstation flavor)
                           media (from workstation flavor)
      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)
                  console-extras (from workstation flavor)
                           print (from desktop flavor)

 

What should I do then ? What informations/files do you need ?

(I updated 3 minutes ago, and still the same problem)

Thanks

Share this post


Link to post
Share on other sites
  • 0

I add mate mix-in:

funtoo rj # epro mix-ins +mate

=== Enabled Profiles: ===

        arch: pure64
       build: current
     subarch: native_64-pure64
      flavor: desktop
     mix-ins: lxde
     mix-ins: mate

>>> Added mate mix-in.
funtoo rj # emerge -av mate | tee mate.emerge.txt

mate.emerge.txt

 
No USE changes are necessary.
All 28 packages with gtk3 use flag have it  disabled "-gtk3"

Share this post


Link to post
Share on other sites
  • 0

Thanks.

I already had the mate mix-in (that's what the epro output shows). So epro mix-ins +mate has no effect...

What 28 packages are you refering to ?

The 28 packages with -gtk3 listed here: https://bpaste.net/show/b10cb931b1f2

You have a configuration on your system that is causing the gtk3 conflict.

Maybe if you provide this information the conflict can be resolved to allow the update.

 

Post the paste links:

# emerge -vv --info | wgetpaste

# emerge -avuDN @world | wgetpaste

Share this post


Link to post
Share on other sites
  • 0

Sorry the output didn't work properly, here is it :

# emerge -avuDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by mate-extra/mate-power-manager-1.12.1-r2::gentoo
# required by mate-base/mate-1.12-r1::gentoo[extras]
# required by @selected
# required by @world (argument)
>=mate-base/mate-panel-1.12.2-r3 -gtk3

Would you like to add these changes to your config files? [Yes/No]

Autounmask changes successfully written.

 * IMPORTANT: config file '/etc/portage/package.use' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

if I modify package.use (adding -gtk3 to mate-panel), I get the same loop as described in my 1st post.

Share this post


Link to post
Share on other sites
  • 0

 grep -r gtk /etc/portage :

/etc/portage/package.use
1:x11misc/lightdm gtk -introspection -gnome -kde -qt4 -qt5
4:media-sound/audacious chardet -gtk gtk3
5:media-plugins/audacious-plugins -gtk gtk3 http
8:www-client/firefox gmp-autoupdate gtk3 hwaccel system-sqlite startup-notification
140:x11-libs/gtk+ abi_x86_32
171:#>=mate-base/mate-1.14.0 -gtk3
195:# required by app-editors/bluefish-2.2.9::gentoo[-gucharmap,gtk3]

/etc/portage/make.conf
7:#USE="-gnome -gtk -kde -kdeenablefinal -ldap nls -qt3 -qt3support -qt4 userlocales -systemd -pulseaudio"
8:USE="php threads usb gstreamer xcb gtk3 nls userlocales -gnome -kde -kdeenablefinal -ldap -qt3 -qt3support -qt4 -qt5 -systemd -pulseaudio"

/etc/portage/package.unmask
5:# mate-themes upstream now releasing support per each gtk3 version. i.e for 3.16, 3.18. masking a release that is built for 3.18 until we have gtk-3.18.

I have tried to modify make.conf and set -gtk3 for USE :

...
[ebuild     U  ] mate-base/mate-control-center-1.12.1-r1::gentoo [1.10.2::gentoo] USE="-appindicator% -debug -gtk3%" 1 275 KiB
[ebuild     U  ] mate-base/mate-applets-meta-1.12::gentoo [1.10::gentoo] USE="-appindicator -gtk3% -netspeed% -sensors" 0 KiB
[ebuild     U  ] app-arch/engrampa-1.12.0::gentoo [1.10.2::gentoo] USE="caja -gtk3% -magic (-packagekit) (-debug%)" 1 348 KiB
[ebuild     U  ] app-cdr/brasero-3.12.1-r1:0/3.1::gentoo [3.12.1:0/3.1::gentoo] USE="css introspection libburn mp3 -nautilus (-packagekit) -playlist {-test} -tracker" 0 KiB
[ebuild     U  ] app-emulation/wine-1.9.16::gentoo [1.9.15::gentoo] USE="X alsa cups fontconfig gecko gstreamer jpeg lcms mono mp3 ncurses nls opengl osmesa perl png realtime run-exes s3tc ssl staging themes%* threads truetype udisks v4l xcomposite xml -capi -custom-cflags -d3d9 -dos -gphoto2 -gsm -ldap -netapi -odbc -openal -opencl -oss -pcap -pipelight -prelink -pulseaudio -samba -scanner (-selinux) {-test} -vaapi -xinerama" ABI_X86="32 (64) (-x32)" LINGUAS="en fr -ar -bg -ca -cs -da -de -el -en_US -eo -es -fa -fi -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW" 32 558 KiB
[ebuild     U  ] mate-extra/mate-screensaver-1.12.0-r1::gentoo [1.10.2-r2::gentoo] USE="X consolekit libnotify opengl pam -debug -gtk3% (-systemd)" 4 755 KiB
[ebuild     U  ] mate-extra/caja-extensions-1.12.0-r1::gentoo [1.10.1-r2::gentoo] USE="cdr mail open-terminal wallpaper -gajim -gksu -gtk3% -image-converter -pidgin -share -upnp (-debug%)" 362 KiB
[ebuild     U  ] mate-base/mate-1.12-r1::gentoo [1.10.0-r2::gentoo] USE="base extras notification themes (-bluetooth) -gtk3% -help%" 0 KiB
[blocks B      ] >=x11-libs/gtk+-3.17:3 (">=x11-libs/gtk+-3.17:3" is blocking x11-themes/mate-themes-3.16.3)

Total: 93 packages (86 upgrades, 3 new, 4 reinstalls), Size of downloads: 262 860 KiB
Conflict: 2 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/gtk+:3

  (x11-libs/gtk+-3.20.8:3/3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-3.19.6:3[introspection?] required by (x11-libs/gtksourceview-3.20.4:3.0/3::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^                                                                                                                                                                                
    (and 1 more with the same problem)

  (x11-libs/gtk+-3.16.7:3/3::gentoo, installed) pulled in by
    =x11-libs/gtk+-3.16*:3 required by (x11-themes/mate-themes-meta-3:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...