Jump to content
  • 0
Sign in to follow this  
linuxbigot

Impossible to use new kernel...

Question

hi folks!

 

I followed all the tutos (kernel upgrade,etc) but it is impossible to run the new compiled kernel  4.4.1

 grub2-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/kernel-genkernel-x86_64-4.0.5-gentoo
Found initrd image: /boot/initramfs-genkernel-x86_64-4.0.5-gentoo
Found linux image: /boot/vmlinuz-4.0.5-gentoo
Found initrd image: /boot/initramfs-genkernel-x86_64-4.0.5-gentoo
Found linux image: /boot/vmlinuz-4.0.5-gentoo.old
Found initrd image: /boot/initramfs-genkernel-x86_64-4.0.5-gentoo
done

grub cant find it , what else to do ?

 

tia !

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Did you copy the new kernel into /boot?  Try:

# ls /boot

If that returns nothing you may need to mount /boot and then look at it:

$ sudo mount /boot
$ ls /boot

I suspect you probably compiled the kernel and never copied it to /boot, or potentially copied it to /boot, but the actually boot partition was not mounted.  Both are pretty easy mistakes to make and not entirely obvious to a new Linux user.

Share this post


Link to post
Share on other sites
  • 0


# ls /boot
System.map-4.0.5-gentoo initramfs-genkernel-x86_64-4.0.5-gentoo
System.map-4.0.5-gentoo.old initramfs-genkernel-x86_64-4.4.1-gentoo
System.map-genkernel-x86_64-4.0.5-gentoo kernel-genkernel-x86_64-4.0.5-gentoo
config-4.0.5-gentoo vmlinuz-4.0.5-gentoo
config-4.0.5-gentoo.old vmlinuz-4.0.5-gentoo.old
grub


# mount /boot
mount: can't find /boot in /etc/fstab

Share this post


Link to post
Share on other sites
  • 0

There's no kernel 4.4.1 there, just the initramfs.  You likely missed a step somewhere, though it's hard to tell where since you haven't told us what tutorial you're following or what method (manual, genkernel, etc) you're using to build your kernel.

 

Also, no /boot entry in /etc/fstab?  I might  just be old school, but that strikes me as something odd.  

Share this post


Link to post
Share on other sites
  • 0

 GRUB2 is controlled by Debian [sda3] ...

# cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't 
# needed); notail increases performance of ReiserFS (at the expense of storage 
# efficiency).  It's safe to drop the noatime options if you want and to 
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#/dev/BOOT              /boot           ext2            noauto,noatime  1 2
/dev/sda5               /               btrfs           noatime         0 1
#/dev/SWAP              none            swap            sw              0 0
#/dev/cdrom             /mnt/cdrom      auto            noauto,ro       0 0
#/dev/fd0               /mnt/floppy     auto            noauto          0 0

************************************************************************************************
# gdisk -l /dev/sda
GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 625142448 sectors, 298.1 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 2789EE95-F428-4A47-B29D-A6D54DB6605C
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 625142414
Partitions will be aligned on 2048-sector boundaries
Total free space is 205161069 sectors (97.8 GiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048           43007   20.0 MiB    0700  
   2           43008          555007   250.0 MiB   0700  
   3          555008       105412607   50.0 GiB    8300  
   4       105412608       210268159   50.0 GiB    0700  
   5       210270208       315127807   50.0 GiB    8300

tia !

 

 

Share this post


Link to post
Share on other sites
  • 0

See, that's an important detail that needs to be said first.  Your initial post makes it look like this is a single boot system, not multiboot.

 

How are you going from Debian's GRUB2 to Funtoo?  Are you chainloading?  Or are you just maintaining one GRUB configuration (in Debian)?  This is definitely a non-standard setup, but it should be doable.

Share this post


Link to post
Share on other sites
  • 0

So if you're maintaining the GRUB configuration in Debian what makes you think the Funtoo tools will "just work" there?  It's really a good way for your GRUB configuration to get out of sync and into some weird state.

 

If you want to add a new Funtoo kernel to a Debian managed GRUB2 you'll need to build the kernel in Funtoo, manually mount your /boot partition (/dev/sda2?), copy the kernel and any other important bits over (probably just an initrd/initramfs, but maybe your kernel config if you like keeping that there too), and then boot into Debian and manually edit your Debian GRUB files to include your Funtoo kernel.  I'm not familiar with Debian's use of GRUB2, but I know it's not quite the same as Funtoo, so all I can say is Google is your friend here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...